Bitcoin Forum
December 03, 2016, 06:01:38 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Error compiling from Githead  (Read 848 times)
TehZomB
Sr. Member
****
Offline Offline

Activity: 294


WTB NHL Expansion team in Baltimore


View Profile WWW
June 06, 2012, 12:33:09 AM
 #1

Help would be appreciated Smiley
I am running Debian Squeeze x64. Dependencies are installed.

Code:
    In file included from main.h:10,
                     from checkpoints.cpp:10:
    net.h: In member function 'void CNode::EndMessage()':
    net.h:354: warning: invalid access to non-static data member 'CMessageHeader::nMessageSize'  of NULL object
    net.h:354: warning: (perhaps the 'offsetof' macro was used incorrectly)
    net.h:360: warning: invalid access to non-static data member 'CMessageHeader::nChecksum'  of NULL object
    net.h:360: warning: (perhaps the 'offsetof' macro was used incorrectly)
    net.h:361: warning: invalid access to non-static data member 'CMessageHeader::nChecksum'  of NULL object
    net.h:361: warning: (perhaps the 'offsetof' macro was used incorrectly)

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480788098
Hero Member
*
Offline Offline

Posts: 1480788098

View Profile Personal Message (Offline)

Ignore
1480788098
Reply with quote  #2

1480788098
Report to moderator
1480788098
Hero Member
*
Offline Offline

Posts: 1480788098

View Profile Personal Message (Offline)

Ignore
1480788098
Reply with quote  #2

1480788098
Report to moderator
Pieter Wuille
Legendary
*
Offline Offline

Activity: 1036


View Profile WWW
June 06, 2012, 10:11:13 AM
 #2

I see no error.

aka sipa, core dev team

Tips and donations: 1KwDYMJMS4xq3ZEWYfdBRwYG2fHwhZsipa
someguy123
Sr. Member
****
Offline Offline

Activity: 335


PHP Coder, Bitcoin enthusiast, Litecointalk admin


View Profile WWW
June 08, 2012, 04:36:04 AM
 #3

That's not an error, that's just a few warnings, if you run ls -l in the src dir, you'll see bitcoind is there, you can then just sudo cp bitcoind /usr/bin/bitcoind to "install" it.

1SoMGuYknDgyYypJPVVKE2teHBN4HDAh3
Administrator/owner of LTC Forum | LTC Block Explorer | Someguy123 Web Development
TehZomB
Sr. Member
****
Offline Offline

Activity: 294


WTB NHL Expansion team in Baltimore


View Profile WWW
June 08, 2012, 10:20:25 AM
 #4

Oh...

Thanks.

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!