Bitcoin Forum
November 24, 2017, 12:22:11 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Armory, Bitcoin QT, and Tor for Mac OS  (Read 1718 times)
NewBTCGuy
Newbie
*
Offline Offline

Activity: 15


View Profile
November 20, 2014, 01:42:19 AM
 #1

So, obviously I'm a newb.  Please forgive that.
I've searched both here and elsewhere on the web and not found a clear answer to the following.  Please forgive that.

How the heck does one get Armory into Online mode via Tor in the Mac OS (in clear, easy-to-understand terms)?  I have my crayons ready!

The only fixes I've seen somewhat clearly delineated pertain to setting "listen=1" in the bitcoin.conf file, which I can't find in the Mac version.

I (finally) have Bitcoin Core v0.9.3.0 synched and set up to run via the Tor Browser proxy and it actively connects to the network and syncs the latest blocks.  I have Armory 0.92.3 setup with Enable settings for Proxies/Tor checked and I have tried it with Skip online check on startup enabled and disabled but the result is the same, all Offline Mode all the time.

I've seen posts where others ask this question, but only one where the user asked specifically about the Mac OS fix, and it basically went unanswered.

Could use some help here...

Thanks,
NBTCG

 
Join ICO Now Coinlancer is Disrupting the Freelance marketplace!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1511482931
Hero Member
*
Offline Offline

Posts: 1511482931

View Profile Personal Message (Offline)

Ignore
1511482931
Reply with quote  #2

1511482931
Report to moderator
NewBTCGuy
Newbie
*
Offline Offline

Activity: 15


View Profile
November 20, 2014, 01:52:12 AM
 #2

So, obviously I'm a newb.  Please forgive that.
I've searched both here and elsewhere on the web and not found a clear answer to the following.  Please forgive that.

How the heck does one get Armory into Online mode via Tor in the Mac OS (in clear, easy-to-understand terms)?  I have my crayons ready!

The only fixes I've seen somewhat clearly delineated pertain to setting "listen=1" in the bitcoin.conf file, which I can't find in the Mac version.

I (finally) have Bitcoin Core v0.9.3.0 synched and set up to run via the Tor Browser proxy and it actively connects to the network and syncs the latest blocks.  I have Armory 0.92.3 setup with Enable settings for Proxies/Tor checked and I have tried it with Skip online check on startup enabled and disabled but the result is the same, all Offline Mode all the time.

I've seen posts where others ask this question, but only one where the user asked specifically about the Mac OS fix, and it basically went unanswered.

Could use some help here...

Thanks,
NBTCG

 

Oh yeah, I forgot to mention that Amory was connecting fine before I routed Bitcoin Core through the Tor proxy, which is now 9150 BTW.

 
picobit
Hero Member
*****
Offline Offline

Activity: 547


Decor in numeris


View Profile
November 20, 2014, 04:02:07 PM
 #3

I do not know about Tor, but the bitcoin.conf  file would be in

Library/Application Support/Bitcoin

To open the hidden Library folder, click on Finder's Go menu while pressing Alt.
NewBTCGuy
Newbie
*
Offline Offline

Activity: 15


View Profile
November 20, 2014, 08:00:52 PM
 #4

I do not know about Tor, but the bitcoin.conf  file would be in

Library/Application Support/Bitcoin

To open the hidden Library folder, click on Finder's Go menu while pressing Alt.


Thanks for the tip picobit, but my Library isn't hidden (I unhid it a while ago) and having used the bootstrap.dat method of downloading the blockchain, I had already discovered HardDrive/Users/Username/Library/Application Support/Bitcoin, but there was no bitcoin.conf file there (or in any of the sub-folders).  I created one anyway using Text Edit and included a few versions of the recommended settings (including listen=1).  And I made sure to kill the .txt extension on the filename so that the extension actually was .conf.  None of that worked, it just left me with the following error message when opening Bitcoin Core:

"Cannot parse configuration file: the options configuration file contains an invalid line '{\rtf\ansi\ansicpg1252\cocoartf1343\cocoasubrtf160'.Only use key=value syntax"

...and then quits out of the launch process.

I'm running 10.10.1.

Thanks,
NBTCG
picobit
Hero Member
*****
Offline Offline

Activity: 547


Decor in numeris


View Profile
November 21, 2014, 11:37:46 AM
 #5

"Cannot parse configuration file: the options configuration file contains an invalid line '{\rtf\ansi\ansicpg1252\cocoartf1343\cocoasubrtf160'.Only use key=value syntax"

...and then quits out of the launch process.

I'm running 10.10.1.

I really don't know, I am just guessing here.  But the \rtf part makes me think of "rich text format".  Are you 100% sure that you have saved the file as an ASCII text file, and not as a rich text file or something like that?  Open a Terminal, go to the directory, and check the file type with "file":

Quote
~$ cd 'Library/Application Support/Bitcoin'
Bitcoin$ file bitcoin.conf
bitcoin.conf: ASCII text
(the bold marks what I typed)

NewBTCGuy
Newbie
*
Offline Offline

Activity: 15


View Profile
November 21, 2014, 03:23:20 PM
 #6

"Cannot parse configuration file: the options configuration file contains an invalid line '{\rtf\ansi\ansicpg1252\cocoartf1343\cocoasubrtf160'.Only use key=value syntax"

...and then quits out of the launch process.

I'm running 10.10.1.

I really don't know, I am just guessing here.  But the \rtf part makes me think of "rich text format".  Are you 100% sure that you have saved the file as an ASCII text file, and not as a rich text file or something like that?  Open a Terminal, go to the directory, and check the file type with "file":

Quote
~$ cd 'Library/Application Support/Bitcoin'
Bitcoin$ file bitcoin.conf
bitcoin.conf: ASCII text
(the bold marks what I typed)



You, sir, are correct.  Thanks for the guidance.  For all other Newb Mac guys the solution is as follows...

The Mac OS text editor is setup to operate with rich text and if one changes the bitcoin file extension to .conf from .rtf it won't change the format of the content, thus generating the above reported error.  Thus one must:

1.  Set TextEdit for plain text in the New Document pane of TextEdit preferences AND...
2.  Open the Save dialog, choose Customize Encoding List from the drop-down menu for Plain-Text Encoding, add Western (ASCII) as an option, and choose that option for saving the bitcoin.conf file in Users/<Username>/Library/Application Support/Bitcoin

The bitcoin.conf file you create/edit with TextEdit should contain the (ASCII) text suggested by BookLover in the first post of https://bitcointalk.org/index.php?topic=623868.new#new.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!