Bitcoin Forum
December 04, 2016, 10:29:38 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: heterogeneous ati system  (Read 920 times)
johanatan
Member
**
Offline Offline

Activity: 84


View Profile
May 19, 2011, 04:22:27 AM
 #1

Has anyone tried mixing 5XXX and 6XXX cards on the same system?  Both Linux and Windows recognize the cards just fine, but CLInfo. ati-config and other OpenCL programs (including the miners) do not.

1GjRUzZfDCBHeCyJk6av3pXYS9VKjCvQTQ
1480847378
Hero Member
*
Offline Offline

Posts: 1480847378

View Profile Personal Message (Offline)

Ignore
1480847378
Reply with quote  #2

1480847378
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480847378
Hero Member
*
Offline Offline

Posts: 1480847378

View Profile Personal Message (Offline)

Ignore
1480847378
Reply with quote  #2

1480847378
Report to moderator
1480847378
Hero Member
*
Offline Offline

Posts: 1480847378

View Profile Personal Message (Offline)

Ignore
1480847378
Reply with quote  #2

1480847378
Report to moderator
Dr. Arnold
Newbie
*
Offline Offline

Activity: 17


View Profile
May 19, 2011, 04:36:38 AM
 #2

Yep running a 6950 and a 5850 in my pc right now  Grin
jsidhu
Newbie
*
Offline Offline

Activity: 9


View Profile
May 19, 2011, 04:38:13 AM
 #3

yeah, I just got it running today. 2x5970 + 1 6870 on Linux.

The 6870 will not work with ati stream sdk 2.1, you need to upgrade it to the latest AMD APP SDK2.4 .

So far i've had the best performance from 2.1.  So i'd recommend using 2.1 for everything that it works for, and use 2.4 for the newer 6X cards.

To use both 2.1/2.4 you add both paths to your LD_LIBRARY_PATH, i.e. make sure you have the path to 2.1 and 2.4 libs in there. If you do this, the miner, ex phoenix, will see this as a second platform. SO you can use 2.1 for your older 5XXX cards and 2.4 for the newer 6XXX cards. 2.1 was the fastest for me for my 5970s, so I'd recommend 2.1 for everything, and if that doesn't work, use the 2.4.

export LD_LIBRARY_PATH=/opt/ati-stream-sdk-v2.1-lnx64/lib/x86_64/:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH=/opt/AMD-APP-SDK-v2.4-lnx64/lib/x86_64/:$LD_LIBRARY_PATH

make sure u specify the PLATFORM=0 or PLATFORM=1 when accessing the different versions of the sdk.


nster
Full Member
***
Offline Offline

Activity: 126



View Profile
May 19, 2011, 04:38:36 AM
 #4

make sure to use the device=1 device=2 or device=0 depending on what is right for you

167q1CHgVjzLCwQwQvJ3tRMUCrjfqvSznd Donations are welcome Smiley Please be kind if I helped
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!