Bitcoin Forum
October 24, 2017, 04:35:46 AM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Python QT-4 Dependency Error Help  (Read 675 times)
binar
Newbie
*
Offline Offline

Activity: 2


View Profile
January 17, 2015, 05:14:43 PM
 #1

Fellow Forum Members,
I downloaded from the Ubuntu download page a bittorrent for "Ubuntu 12.04.5 alternate (64-bit)" and I had no problem installing it to a clean hard drive.

I then downloaded "0.92.3 [Offline Bundle] for Ubuntu 12.04 exact (64bit)" from the Armory download page and I'm getting this error in the Ubuntu Software Center when I try to install Armory 0.92.3 to my new Ubuntu OS:

"Dependency is not satisfiable: Python - QT4"

What am I doing wrong?  Isn't Armory 0.92.3 suppose to be compatible with Ubuntu 12.04.5?  In other words, does it really matter I have installed Ubuntu 12.04.5 when Armory is specifying Ubuntu 12.04?  The only difference seems to be a ".5" difference.  

I have turned off the LAN feature from my motherboard bios because this Ubuntu PC is not suppose to connect to the internet. I would appreciate it a lot if anyone could post for me a link where I could download the "Python QT4" dependency I am missing so that I can download it to a USB stick and then install it to my Ubuntu 12.04.5 installation without having to connect it to the internet.  

Any help will be greatly appreciated.  Thanks in advance.
1508819746
Hero Member
*
Offline Offline

Posts: 1508819746

View Profile Personal Message (Offline)

Ignore
1508819746
Reply with quote  #2

1508819746
Report to moderator
1508819746
Hero Member
*
Offline Offline

Posts: 1508819746

View Profile Personal Message (Offline)

Ignore
1508819746
Reply with quote  #2

1508819746
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508819746
Hero Member
*
Offline Offline

Posts: 1508819746

View Profile Personal Message (Offline)

Ignore
1508819746
Reply with quote  #2

1508819746
Report to moderator
etotheipi
Legendary
*
Offline Offline

Activity: 1428


Core Armory Developer


View Profile WWW
January 17, 2015, 06:19:17 PM
 #2

Ugh, I thought we had it on the website.  Yes it needs to be 12.04.5.  There didn't used to be such a requirement... But I think they changed the packages in 12.04.3.

I'm not even sure if the alternate CD works, since it likely has different packages.

(Edit: sorry misread and thought you said you weren't installing 12.04.5.  Nonetheless my last statement still holds... Probably the alt CD)

Founder and CEO of Armory Technologies, Inc.
Armory Bitcoin Wallet: Bringing cold storage to the average user!
Only use Armory software signed by the Armory Offline Signing Key (0x98832223)

Please donate to the Armory project by clicking here!    (or donate directly via 1QBDLYTDFHHZAABYSKGKPWKLSXZWCCJQBX -- yes, it's a real address!)
binar
Newbie
*
Offline Offline

Activity: 2


View Profile
January 17, 2015, 06:46:12 PM
 #3

Etotheipi,
Thank you very much for your post.  Just to clarify. There is an "Ubuntu 12.04.5 Desktop (64-bit)"  and there is also an "Ubuntu 12.04.5 Alternate (64-bit)" available for download on the Ubuntu download website.

I installed the "Desktop" version and not the "Alternate" version (sorry I got the two confused in my original post). However, with the Desktop version installed I am getting a Python QT4 dependency error.  

Below is the link of the Armory version I downloaded:

https://s3.amazonaws.com/bitcoinarmory-releases/armory_0.92.3_offline_ubuntu_12.04-64.tar.gz


Which of the two download links below is the correct Ubuntu OS match for the Armory version I downloaded that is currently posted in the Armory download page:


http://releases.ubuntu.com/12.04/ubuntu-12.04.5-alternate-amd64.iso.torrent   ?


http://releases.ubuntu.com/12.04/ubuntu-12.04.5-desktop-amd64.iso.torrent   ?


I would be very grateful if anyone can post a link to the correct Ubuntu OS that is compatible with the 64bit offline Ubuntu version of armory_0.92.3.  I'm currently getting the Python QT4 dependency error with the Desktop Ubuntu version installed.  Any help will be greatly appreciated. THanks
etotheipi
Legendary
*
Offline Offline

Activity: 1428


Core Armory Developer


View Profile WWW
January 17, 2015, 08:03:38 PM
 #4

The desktop version is correct.  Did you use the bundled install script (Install_DblClick_RunInTerminal.sh)?  You should be able to double-click that in the unpacked folder and then type your password.  It will do the rest for you.

I had a freshly installed 12.04.5 virtual machine and did exactly that with the 0.92.3 offline bundle and it worked.  Did you maybe grab the 32-bit bundle instead?  Did you try installing the packages individually?

Founder and CEO of Armory Technologies, Inc.
Armory Bitcoin Wallet: Bringing cold storage to the average user!
Only use Armory software signed by the Armory Offline Signing Key (0x98832223)

Please donate to the Armory project by clicking here!    (or donate directly via 1QBDLYTDFHHZAABYSKGKPWKLSXZWCCJQBX -- yes, it's a real address!)
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!