Bitcoin Forum
December 14, 2017, 06:33:22 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Bitcoin 6.0.3 linux Fatal Error  (Read 1365 times)
Luddite Savant
Newbie
*
Offline Offline

Activity: 11


View Profile
July 28, 2012, 07:53:07 PM
 #1

Hi,

I would've posted this on the tech support forum but as I've just joined I can't so hopefully someone can help me. I ran bitcoin under Windows but have just switched to Linux Ubunto 12.04. I've installed bitcoin-0.6.3-linux and I replaced the linux wallet.dat file with my file from windows. When running bin/32/bitcoin-qt I got the following error:

"A fatal error occured. Bitcoin can no longer continue safely and will quit.

EXCEPTION: 22DbRunRecoveryException       
DbEnv::open: DB_RUNRECOVERY: Fatal error, run database recovery       
bitcoin in Runaway exception  "

When running bitcoind, or the 64 versions (just to test, I'm not on 64bit), nothing happens. I've deleted everything & reinstalled to try bitcoin-qt without my existing wallet.dat but I get the same error.

Can anyone tell me what the problem is & how I can resolve it?
1513233202
Hero Member
*
Offline Offline

Posts: 1513233202

View Profile Personal Message (Offline)

Ignore
1513233202
Reply with quote  #2

1513233202
Report to moderator
1513233202
Hero Member
*
Offline Offline

Posts: 1513233202

View Profile Personal Message (Offline)

Ignore
1513233202
Reply with quote  #2

1513233202
Report to moderator
1513233202
Hero Member
*
Offline Offline

Posts: 1513233202

View Profile Personal Message (Offline)

Ignore
1513233202
Reply with quote  #2

1513233202
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
SunnyKing
Newbie
*
Offline Offline

Activity: 2


View Profile
July 29, 2012, 06:21:59 PM
 #2

Could you post the last few pages of your db.log (in the same directory of your wallet.dat file, ~/.bitcoin)? That would help identify what the problem was.
Luddite Savant
Newbie
*
Offline Offline

Activity: 11


View Profile
July 29, 2012, 09:31:02 PM
 #3

Ok, here it is:

Quote
Unacceptable log file /home/anonymous/.bitcoin/database/log.0000000405: unsupported log version 16
Invalid log file: log.0000000405: Invalid argument
PANIC: Invalid argument
unable to join the environment
Unacceptable log file /home/anonymous/.bitcoin/database/log.0000000405: unsupported log version 16
Invalid log file: log.0000000405: Invalid argument
PANIC: Invalid argument
unable to join the environment
Unacceptable log file /home/anonymous/.bitcoin/database/log.0000000405: unsupported log version 16
Invalid log file: log.0000000405: Invalid argument
PANIC: Invalid argument
unable to join the environment
Unacceptable log file /home/anonymous/.bitcoin/database/log.0000000405: unsupported log version 16
Invalid log file: log.0000000405: Invalid argument
PANIC: Invalid argument
unable to join the environment
Unacceptable log file /home/anonymous/.bitcoin/database/log.0000000405: unsupported log version 16
Invalid log file: log.0000000405: Invalid argument
PANIC: Invalid argument
unable to join the environment
Unacceptable log file /home/anonymous/.bitcoin/database/log.0000000405: unsupported log version 16
Invalid log file: log.0000000405: Invalid argument
PANIC: Invalid argument
unable to join the environment
Unacceptable log file /home/anonymous/.bitcoin/database/log.0000000405: unsupported log version 16
Invalid log file: log.0000000405: Invalid argument
PANIC: Invalid argument
unable to join the environment
Unacceptable log file /home/anonymous/.bitcoin/database/log.0000000405: unsupported log version 16
Invalid log file: log.0000000405: Invalid argument
PANIC: Invalid argument
unable to join the environment
Unacceptable log file /home/anonymous/.bitcoin/database/log.0000000405: unsupported log version 16
Invalid log file: log.0000000405: Invalid argument
PANIC: Invalid argument
unable to join the environment
Unacceptable log file /home/anonymous/.bitcoin/database/log.0000000405: unsupported log version 16
Invalid log file: log.0000000405: Invalid argument
PANIC: Invalid argument
unable to join the environment
Unacceptable log file /home/anonymous/.bitcoin/database/log.0000000405: unsupported log version 16
Invalid log file: log.0000000405: Invalid argument
PANIC: Invalid argument
unable to join the environment
Program version 4.8 doesn't match environment version 5.1
Unacceptable log file /home/anonymous/.bitcoin/database/log.0000000406: unsupported log version 17
Invalid log file: log.0000000406: Invalid argument
PANIC: Invalid argument
unable to join the environment
Luddite Savant
Newbie
*
Offline Offline

Activity: 11


View Profile
July 30, 2012, 05:32:18 PM
 #4

Any ideas?
SunnyKing
Newbie
*
Offline Offline

Activity: 2


View Profile
July 30, 2012, 06:00:13 PM
 #5

How did you install your bitcoin client?
This error message seems to indicate that there was a mismatched berkeleydb versions.
Bitcoin currently uses BerkeleyDB 4.8 version.
Luddite Savant
Newbie
*
Offline Offline

Activity: 11


View Profile
July 31, 2012, 11:54:12 AM
 #6

I installed it by extracting the .gz folder into a seperate folder using archive manager.

If its got mismatched versions how do I go about fixing this, I've already deleted the new folder and reinstalled. Thinking about it I'm not sure if I deleted the hidden folder too. I'll give that a try when I get home.
Failing that any other suggestions?
Luddite Savant
Newbie
*
Offline Offline

Activity: 11


View Profile
July 31, 2012, 06:04:16 PM
 #7

That's done the trick, I hadn't deleted the .bitcoin hidden file so that's where the version differences must've been coming in. I've now managed to open bitcoin & it's syncing with the network - only about 170,000 blocks to go.

Cheers for your help SunnyKing
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!