Bitcoin Forum
December 16, 2017, 02:22:45 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: P2Pool and general mining questions...  (Read 2012 times)
BitCoiner2012
Sr. Member
****
Offline Offline

Activity: 364



View Profile
August 01, 2012, 08:45:06 PM
 #1

Hi !

A 560 ti nVidia, using GUIMiner -cuda, and p2pool.

Went through all the setups listed at the Wiki page here:

https://en.bitcoin.it/wiki/P2Pool

And everything seemed to be in working order. I get around 70-80 MHash a second says the GUIMiner, p2Pool seems to confirm this or did earlier when it was working. AFter some hours I noticed it telling me that the connection had been lost for several minutes. Over the hours I had collected some "shares" according to the miner, though I don't recall if the shares listed in p2pool were reflected. The speed seems to be about the same (P2Pool ranges from 60-200 mhash it claims). However when I restarted the programs I noticed there is no indication of previous shares. How does this work exactly? P2Pool claims "Shares: 0 (0 Orphan, 0 dead).

Suddenly and with no change of settings, my failure rate seems to be around 30-45% (DoA), this was not occuring a few hours ago. I tried restarting, but with no luck or change.

Here is an image of my command prompt.

http://i.imgur.com/YrPZf.png

Thanks!

BTC Long.
1513390965
Hero Member
*
Offline Offline

Posts: 1513390965

View Profile Personal Message (Offline)

Ignore
1513390965
Reply with quote  #2

1513390965
Report to moderator
1513390965
Hero Member
*
Offline Offline

Posts: 1513390965

View Profile Personal Message (Offline)

Ignore
1513390965
Reply with quote  #2

1513390965
Report to moderator
1513390965
Hero Member
*
Offline Offline

Posts: 1513390965

View Profile Personal Message (Offline)

Ignore
1513390965
Reply with quote  #2

1513390965
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Merrick
Member
**
Offline Offline

Activity: 113


View Profile
August 02, 2012, 07:13:33 AM
 #2

You are still paid properly for any applicable share value even though they get reset to zero if you restart it. Watch the "Current Payout" as that's the number that really matters. If current payout is > 0 and you stop submitting shares, it starts dropping until it reaches zero. If it is > 0 when the pool finds a block, you get paid. I'm not sure on the high DoA rate.
BitCoiner2012
Sr. Member
****
Offline Offline

Activity: 364



View Profile
August 02, 2012, 01:06:30 PM
 #3

You are still paid properly for any applicable share value even though they get reset to zero if you restart it. Watch the "Current Payout" as that's the number that really matters. If current payout is > 0 and you stop submitting shares, it starts dropping until it reaches zero. If it is > 0 when the pool finds a block, you get paid. I'm not sure on the high DoA rate.

Thanks, this was very helpful in adding to my basic understanding.

I have let it run some more time now thinking that perhaps I was unlucky for the first share. I was right in that my % of DoA seems to be leveling out to a lower area, however both shares I have thus received are still dead. I don't have any orphan or viable share it seems, so even when this next block is found I will have nothing. Which is fine, once I understand why that is.

Here is a new image after running all night:

http://i.imgur.com/gBnz0.png

My % DoA seems to have fallen, so that is good. But any ideas anyone?

Appreciated.

Edit: Also, does anyone conceivably know a manner in which to stop the instant updating in p2pool cmd prompt and alter it to update much slower so I can actually pay attention to some data? Thanks so much again.

And when I try to use CGMiner, I get no pools active and it closes.

Edit 2:

I also know that, for example, when I go to http://p2pool.info/ and check the statistics (I've been mining since about 1PM 8/1 in this "manner" that "seems" like it connects) I notice that my payment address is not available. It begins with "1cvp" and I search for it in active payout, in current workers, once blocks are completed (I have been mining since the completion of 2 or 3 blocks in said time). Does this mean I was not "part" of those blocks when they were mined and my mines were just not relevant? Despite my "shares" none were actually "accepted" by p2pool? Is that how it works? Is that why my only shares (2) were "dead"? Will, perhaps, today during the solving of 2-4 blocks I perhaps will be part of it?

Edit 3:

Finally seemed to have it connect. Before I could not pull up any query at 127.0.0.1 for information. Now I receive this:

http://i.imgur.com/cLeSO.png

Which is also what my GUIMINER and P2Pool looks like. Things seem okay, but I notice my DoA rate ranges from 20-50%. I did have a connection error earlier in the hour and thought that may have something to do with the statistic, but I'm not so sure anymore. Is my high DoA rate (for example, the only two previous shares acquired were dead shares) causing about half of my effort to be useless?

BTC Long.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!