Bitcoin Forum
December 08, 2016, 06:18:37 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: unable to downclock memory on 6870  (Read 2213 times)
perryh
Newbie
*
Offline Offline

Activity: 3


View Profile
May 25, 2011, 12:18:19 PM
 #1

Hi

I have a ref board 6870 and I can't downclock it in linux (ubuntu)


I am using AMDOverDriveCtrl and I have successfully adjusted the 3 profiles to run the memory at 400mhz, but the info tab still displays that the memory is running at 1050mhz under load. Before I run the miner, it successfully changes my memory's clock to 400mhz... but it goes up to 1050 right after.

Any ideas?

Thanks
-perry
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481221117
Hero Member
*
Offline Offline

Posts: 1481221117

View Profile Personal Message (Offline)

Ignore
1481221117
Reply with quote  #2

1481221117
Report to moderator
1481221117
Hero Member
*
Offline Offline

Posts: 1481221117

View Profile Personal Message (Offline)

Ignore
1481221117
Reply with quote  #2

1481221117
Report to moderator
perryh
Newbie
*
Offline Offline

Activity: 3


View Profile
May 25, 2011, 06:32:10 PM
 #2

up
a7thson
Newbie
*
Offline Offline

Activity: 7


View Profile
May 25, 2011, 06:53:08 PM
 #3


Before I run the miner, it successfully changes my memory's clock to 400mhz... but it goes up to 1050 right after.

Sapphire 6870 here -- Same issue and same behavior.  I had hoped there was a way to avoid using the Radeon BIOS editor but that's probably the next step.  Sadly, my setup is a linux box, so I'll have to dig up an XP boot cd or try FreeDOS, I suppose, to do the deed.

find something useful in my  post? 13FMjxBshHfrRPLzz41t5UcWyKXWwpoTTt
a7thson
Newbie
*
Offline Offline

Activity: 7


View Profile
May 25, 2011, 11:09:29 PM
 #4


Any ideas?


This seems to somewhat address the issues.  Unfortunately I don't have an MS Windows setup so the recommendation to use MSI's Afterburner is probably next to useless for me.
http://forum.bitcoin.org/index.php?topic=9652.0

This longer thread also addresses underclocking more generally, though again everything is Windows-centric
 Angry

http://forum.bitcoin.org/index.php?topic=4292.0

Maybe they'll help you... I seem to be out of options.

aticonfig --adapter=0 --odsc 0,350

fails with:
ERROR - Set clocks failed for Adapter 0 - AMD Radeon HD 6800 Series
        Please check that input values were valid

But succeeds if that application (AMDOverdriveCtrl) is running.  However, even though the "peak" values can then be changed accordingly, the actual clock speeds never move, even if all the profiles are set with the lower clock speed.  Moreover, once I exit AMDOverdriveCtrl, it restores my old settings with the default 1050Mhz memory clock.  It's beyond annoying.

find something useful in my  post? 13FMjxBshHfrRPLzz41t5UcWyKXWwpoTTt
Pygy
Jr. Member
*
Offline Offline

Activity: 47


View Profile
May 26, 2011, 02:08:09 PM
 #5

Save the profile, and edit it by hand in a text editor (mine is called mem300.ovdr)
Code: ("$ nano mem300.ovdr ")
<?xml version="1.0" encoding="utf-8"?>
<OVERDRIVE_PROFILE>
  <PERFORMANCE_LEVEL level="2" gpu="75000" mem="100000" voltage="1050"/>
  <PERFORMANCE_LEVEL level="1" gpu="55000" mem="100000" voltage="1038"/>
  <PERFORMANCE_LEVEL level="0" gpu="15700" mem="30000" voltage="950"/>
  <FAN_SETTING percentage="AUTO"/>
  <FAN_CTRL enabled="no"/>
  <FAN_CTRL_CURVE type="0"/>
  <FAN_CTRL_POINT nr="0" temperature="2000" percentage="0"/>
  <FAN_CTRL_POINT nr="1" temperature="4000" percentage="2500"/>
  <FAN_CTRL_POINT nr="2" temperature="6000" percentage="5000"/>
  <FAN_CTRL_POINT nr="3" temperature="8000" percentage="7500"/>
  <FAN_CTRL_POINT nr="4" temperature="10000" percentage="10000"/>
  <MONITOR_SAMPLE_TIME interval="10"/>
  <COLOR_PROFILE enabled="no" longitude="-13.000000" latitude="52.000000" color_temp_day="6500" color_temp_night="4000" transition="30"/>
  <POWERTUNE percentage="0"/>
</OVERDRIVE_PROFILE>

You must change the mem param of the performance levels 1 and 2 to 30000.
Then you can load the profile from the command line with
Code:
$ AMDOverdriveCtrl -i N -b mem300.ovdr
Where N is the id number reported by
Code:
$ AMDOverdriveCtrl -h

However, I don't know (yet) how to adapt the voltage for these lower memory clock rates...


Amazingly, lowering the memory clock increased the hash rate from ~320 to ~325 MH/s
TurdHurdur
Full Member
***
Offline Offline

Activity: 217


View Profile
May 26, 2011, 02:12:51 PM
 #6

There's always 100 less than the core clock, at least.
Pygy
Jr. Member
*
Offline Offline

Activity: 47


View Profile
May 26, 2011, 02:36:21 PM
 #7

There's always 100 less than the core clock, at least.

I'm sorry, but I don't understand your reply...
TurdHurdur
Full Member
***
Offline Offline

Activity: 217


View Profile
May 26, 2011, 03:09:14 PM
 #8

There's always 100 less than the core clock, at least.

I'm sorry, but I don't understand your reply...
I could never lower the mem clocks below 100 less than the core clock. So, I put it in my Windows box and used Afterburner to.
picollo7
Newbie
*
Offline Offline

Activity: 25


View Profile
May 26, 2011, 05:07:58 PM
 #9

Same issue here.  The lowest I can downclock it to is 850.  I think it has something to do with the voltages.  If you look at the voltages, it the mem clock speed is 300 at 1, and then goes to like 950 at 1.17.  So I think it is just a limitation of the card due to the voltage changes.  850 is the lowest I can go at 1.17.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!