Bitcoin Forum
October 01, 2016, 06:55:46 PM *
News: Latest stable version of Bitcoin Core: 0.13.0 (New!) [Torrent]. Make sure you verify it.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Crashing (solved)  (Read 1958 times)
ender_x
Newbie
*
Offline Offline

Activity: 10


View Profile
April 13, 2010, 05:26:08 PM
 #1

Unfortunately I've experienced crashing while I send transfers.. its happened twice so far.. both times it was after having been idle for many hours.. then I attempted to use the client to transfer. The first transfer was for 0.01.. it failed. but has removed from my total.  and sits in a perpetual state of 0/unconfirmed.
After it had crashed.. I brought the cilent back up.. and it showed -0.01.. and the recipient had not received it. so I immediately sent a second transfer just to make sure it was reproducible.. The second I made for 0.02 as to make it easily identifiable.. it succeeded.  I left the client alone for a day or so.. and had it "generating".
Then I made another transfer.. unfortunately I tried to transfer all of the funds.. and now they're all lost :-) awesome huh. It crashed in the same mannor. it Does display a message.. but I have not captured it. sorry.. When I get more funds I'll try and reproduce it, and capture the dialog.

I'm running Mandriva 2010.0 x86_64. all other transfers have gone great.. both offline recipients vs online.

$ ldd bitcoin
./bitcoin: /usr/lib/libcrypto.so.0.9.8: no version information available (required by ./bitcoin)                                                                    
        linux-gate.so.1 =>  (0xffffe000)                                          
        libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0xf7585000)            
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xf7177000)          
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xf7171000)          
        libSM.so.6 => /usr/lib/libSM.so.6 (0xf7167000)                            
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xf7076000)                    
        libm.so.6 => /lib/libm.so.6 (0xf704e000)                                  
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xf7031000)                          
        libc.so.6 => /lib/libc.so.6 (0xf6ed0000)                                  
        libdl.so.2 => /lib/libdl.so.2 (0xf6ecb000)                                
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xf6e29000)          
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xf6e24000)                
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xf6e09000)    
        libX11.so.6 => /usr/lib/libX11.so.6 (0xf6cd7000)                          
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xf6c8f000)              
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xf6c4d000)          
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xf6b88000)                
        libpthread.so.0 => /lib/libpthread.so.0 (0xf6b6e000)                      
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0xf6b43000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xf6b37000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xf6b31000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xf6b13000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0xf6a93000)
        libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xf69eb000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xf69c1000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xf698d000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xf6988000)
        librt.so.1 => /lib/librt.so.1 (0xf697d000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0xf6963000)
        /lib/ld-linux.so.2 (0xf7738000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0xf6958000)
        libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xf694f000)
        libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xf6944000)
        libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xf693f000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xf692d000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xf6929000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xf691f000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf6901000)
        libpcre.so.0 => /lib/libpcre.so.0 (0xf68d1000)
        libz.so.1 => /lib/libz.so.1 (0xf68be000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xf683c000)
        libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xf67d3000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xf67bd000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xf667b000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xf6677000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xf6670000)

Any ideas on capturing my limbo coins? Also ideas on preventing failed transfers in the future?
Thanks
Sam.
1475348146
Hero Member
*
Offline Offline

Posts: 1475348146

View Profile Personal Message (Offline)

Ignore
1475348146
Reply with quote  #2

1475348146
Report to moderator
1475348146
Hero Member
*
Offline Offline

Posts: 1475348146

View Profile Personal Message (Offline)

Ignore
1475348146
Reply with quote  #2

1475348146
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1475348146
Hero Member
*
Offline Offline

Posts: 1475348146

View Profile Personal Message (Offline)

Ignore
1475348146
Reply with quote  #2

1475348146
Report to moderator
1475348146
Hero Member
*
Offline Offline

Posts: 1475348146

View Profile Personal Message (Offline)

Ignore
1475348146
Reply with quote  #2

1475348146
Report to moderator
1475348146
Hero Member
*
Offline Offline

Posts: 1475348146

View Profile Personal Message (Offline)

Ignore
1475348146
Reply with quote  #2

1475348146
Report to moderator
Link2VoIP
Newbie
*
Offline Offline

Activity: 21


Superior network = superior results


View Profile WWW
April 13, 2010, 06:11:58 PM
 #2

Which version are you running? 0.2 or a snapshot?

Oh, and "libcrypto.so.0.9.8: no version information available (required by ./bitcoin)" is worrisome.
ender_x
Newbie
*
Offline Offline

Activity: 10


View Profile
April 13, 2010, 07:03:51 PM
 #3

I'm running 0.2.0 binarys.
I was unable to compile svn trunk with my distro.

Anyways looks like I didnt search for my question in the forums.. Sorry!!

For those who are interested: http://bitcointalk.org/index.php?topic=27.0
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!