Bitcoin Forum
December 09, 2016, 12:27:33 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: [SOLVED] Need help to maximize the gpu usage on a 5970 with Linux Ubuntu 11.04  (Read 3047 times)
SicKk
Jr. Member
*
Offline Offline

Activity: 34


View Profile
May 30, 2011, 11:21:12 AM
 #1

as the subject says I need help....

o.k. long story short :

System :

Linux Ubuntu 11.04 amd64
AMD Phenom x4 9850 Black Edition 4x2.5Ghz
2GB Ram
XFX ATI Radeon HD 5970 XFX Black Edition 4GB

aticonfig --odgc --odgt --adapter=all

Quote
Adapter 0 - ATI Radeon HD 5900 Series
                            Core (MHz)    Memory (MHz)
           Current Clocks :    950           300
             Current Peak :    950           300
  Configurable Peak Range : [550-1000]     [210-1500]
                 GPU load :    82%

Adapter 1 - ATI Radeon HD 5900 Series
                            Core (MHz)    Memory (MHz)
           Current Clocks :    850           1200
             Current Peak :    850           1200
  Configurable Peak Range : [550-1000]     [1000-1500]
                 GPU load :    57%

Adapter 0 - ATI Radeon HD 5900 Series
            Sensor 0: Temperature - 77.00 C

Adapter 1 - ATI Radeon HD 5900 Series
            Sensor 0: Temperature - 68.00 C

I've downclocked the first GPU memory to 300Mhz with AMD Overdrive Ctrl and got a good power saving. can't figure out how to downclock the second GPU.
when i run a miner only on the first GPU, i get up to 415 Mhash/s with a GPU load of 99% and a core temperature 78°-82° celsius. if i run an another miner on the second GPU, well you see the result above.

could soneone please give some advice how to downcloak the memory and overclock the GPU. or how i could set the second GPU to be default, and maybe be able to make the setting with AMD Overdrive Ctrl.

thanks for your help in advance
1481243253
Hero Member
*
Offline Offline

Posts: 1481243253

View Profile Personal Message (Offline)

Ignore
1481243253
Reply with quote  #2

1481243253
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481243253
Hero Member
*
Offline Offline

Posts: 1481243253

View Profile Personal Message (Offline)

Ignore
1481243253
Reply with quote  #2

1481243253
Report to moderator
1481243253
Hero Member
*
Offline Offline

Posts: 1481243253

View Profile Personal Message (Offline)

Ignore
1481243253
Reply with quote  #2

1481243253
Report to moderator
SicKk
Jr. Member
*
Offline Offline

Activity: 34


View Profile
May 30, 2011, 01:46:19 PM
 #2

o.k. another problem, I cant disable CrossFire.

aticonfig --lscs

Code:
Candidate Combination:
    Master: 3:0:0
    Slave: 4:0:0
    CrossFire is enabled on current device
    CrossFire Diagnostics:
    There is CrossFire Side port connection between GPUs
    CrossFire can work with P2P write through peer aperture
    Dongle Capabilities: support PASSTHROUGH |INTERLINK_SW_AFR | INTERLINK_AUTO_AFR | INTERLINK_BLACKING | INTERLINK_SUPERAA

aticonfig --lsch

Code:
CrossFire chain for adapter 0, status: enabled
  0. 03:00.0 ATI Radeon HD 5900 Series
  1. 04:00.0 ATI Radeon HD 5900 Series

aticonfig --help |grep crossfire

Code:
  --lscc, --list-crossfire-candidates
  --lscs, --list-crossfire-status
  --lsch, --list-crossfire-chains
  --cfa, --add-crossfire-chain
  --cfd, --delete-crossfire-chain
  --cf, --crossfire={on|off}
  --cfl, --crossfire-logo={on|off}

aticonfig --lsch

Code:
CrossFire chain for adapter 0, status: enabled
  0. 03:00.0 ATI Radeon HD 5900 Series
  1. 04:00.0 ATI Radeon HD 5900 Series

aticonfig --cf=off --adapter=all

Code:
CrossFire chain(s) disabled
Warning: X needs to be restarted before CrossFire changes take effect.

aticonfig --cfd --adapter=all

Code:
CrossFire chain(s) disabled
Warning: X needs to be restarted before CrossFire changes take effect.

and after reboot the crossfire link is enabled again. does anyone has a clue why this is happening ?
SicKk
Jr. Member
*
Offline Offline

Activity: 34


View Profile
May 30, 2011, 04:04:47 PM
 #3

solved, started mining jobs over ssh and everything went fine, got peaks of over 800 Mhash/s with two GPU'S on two different pools.
sunbird
Newbie
*
Offline Offline

Activity: 23


View Profile
September 14, 2011, 04:11:35 AM
 #4

Hi there,

I stumbled upon this thread because I've got an 11.04 rig with a 5970, but I can't seem to get both cores working efficiently. When I start the first core, I can get just over 300 M/hash, but when I start the second one, the first one drops in half.

I've followed these instructions to disable crossfire, but now after I start the first device, I get this error after starting the second device:

Code:
Kernel error: Unusual behavior from OpenCL. Hardware problem?

I tried https://bitcointalk.org/index.php?topic=14340.20 these instructions for plugging and unplugging the monitor before starting each device, but I'm still only getting about 300 M/hash, which is obviously way low for a 5970.

Ideas?
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!