Bitcoin Forum
August 16, 2018, 02:39:25 PM *
News: Latest stable version of Bitcoin Core: 0.16.2  [Torrent].
   Home   Help Search Donate Login Register  
Pages: [1]
Author Topic: Found a bug in V1.6.1 / 1.6.2: ValueError: No JSON object could be decoded  (Read 2008 times)
Jr. Member
Offline Offline

Activity: 33
Merit: 0

View Profile
March 08, 2013, 08:06:34 PM

Hi there,

since today, electrum has some strange output on the console when I start it:

$ electrum -w wallet.dat
Exception in thread Thread-4:
Traceback (most recent call last):
  File "/usr/lib/python2.7/", line 551, in __bootstrap_inner
  File "/usr/local/lib/python2.7/dist-packages/electrum/", line 28, in run
  File "/usr/local/lib/python2.7/dist-packages/electrum/", line 39, in discovery
    response = json.loads(
  File "/usr/lib/python2.7/json/", line 326, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python2.7/json/", line 366, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.7/json/", line 384, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded

I used V1.6.1 and saw this, then I updated to 1.6.2. The error still occurs. I tried starting electrum with my usual wallet (without arguments). I also tried to start with no wallet or other data at all (renamed the .electrum directory in case some of the data in there got corrupted) and then, the error appears right after the creation of the new wallet. Everything else seems OK. If I start electrum with my usual wallet, the transactions and addresses are displayed normally. I didn't try to make any transaction because I'm kind of sceptical what will happen (don't want to lose any of my hardly earned bitcoins...).

I use Ubuntu Linux 12.04 as operating system. Has anybody seen this message and/or knows what's it all about or how to get rid of it?
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Hero Member
Offline Offline

Activity: 717
Merit: 500

Bitcoin Venezuela

View Profile WWW
March 10, 2013, 02:34:40 AM

Same here, have been trying to solve this since 7th morning. In my case I see this in Terminal in Mountain Lion. I thought it was the latest Java update which messed up the OS

Also I can't open the binary App. It fail to open, still trying things and asking in the Apple forums to see if it was an update or something else.

Admin: rdymac (PGP) | | @cafebitcoin | Electrum, lightweight bitcoin client
If I've been helpful tip me a coffee! Cheesy1rdymachKZpA9pTYHYHMYZjfjnoBW6B3k Bitrated user: rdymac.
Offline Offline

Activity: 1899
Merit: 1017

View Profile WWW
March 13, 2013, 06:38:16 AM

that bug is fixed.
for bug reports, better use github

Electrum: the convenience of a web wallet, without the risks
Pages: [1]
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!