Bitcoin Forum
April 20, 2018, 01:53:18 AM *
News: Latest stable version of Bitcoin Core: 0.16.0  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Solo mining, 0 accepted  (Read 2726 times)
xanadu
Member
**
Offline Offline

Activity: 62
Merit: 10


View Profile
April 09, 2013, 03:09:46 PM
 #1

Dorking around with solo mining on a spare rig and it never accepts any hashes even though it is running full tilt.



Ignore the low hash rate, I haven't optimized the client with flags yet.  Yes I know that that'd likely take years to find a block solo these days.

Running a Phoenix 2.0 client and connected to Bitcoin-qt v0.8.1-beta running in -server mode that has downloaded the full blockchain.

Where have I gone wrong?
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
MashRinx
Sr. Member
****
Offline Offline

Activity: 390
Merit: 250



View Profile
April 09, 2013, 03:42:27 PM
 #2

do you have a bitcoin.conf file in your bitcoin data folder with a RPC password set?

something like (this may not be exactly correct):

server=1
rpcuser=username
rpcpassword=password
rpcallowip=127.0.0.1
rpcport=8332
grue
Global Moderator
Legendary
*
Offline Offline

Activity: 2100
Merit: 1136



View Profile
April 09, 2013, 03:47:05 PM
 #3

solo mining = hashes accepted only if it matches the network difficulty, which will take forever.

It is pitch black. You are likely to be eaten by a grue.

Adblock for annoying signature ads | Enhanced Merit UI
xanadu
Member
**
Offline Offline

Activity: 62
Merit: 10


View Profile
April 09, 2013, 03:50:49 PM
 #4

do you have a bitcoin.conf file in your bitcoin data folder with a RPC password set?

something like (this may not be exactly correct):

server=1
rpcuser=username
rpcpassword=password
rpcallowip=127.0.0.1
rpcport=8332

Yes, the bitcoin.conf file is configured, otherwise the client wouldn't connect to the server, right?

Here is the bitcoin.conf file:
Quote
server=1
rpcuser=bits
rpcpassword=*****
rpcallowip=192.168.0.*
rcpport=8332
paytxfee=0.00

I enabled verbose mode, here is the output:


Thanks!
xanadu
Member
**
Offline Offline

Activity: 62
Merit: 10


View Profile
April 09, 2013, 03:52:17 PM
 #5

solo mining = hashes accepted only if it matches the network difficulty, which will take forever.

Ah, that makes sense... going to be a long while before I see an "Accepted" then Smiley
grue
Global Moderator
Legendary
*
Offline Offline

Activity: 2100
Merit: 1136



View Profile
April 09, 2013, 09:56:02 PM
 #6

solo mining = hashes accepted only if it matches the network difficulty, which will take forever.

Ah, that makes sense... going to be a long while before I see an "Accepted" then Smiley
it might be smart to verify your configuration is correct by mining a few testnet blocks.

It is pitch black. You are likely to be eaten by a grue.

Adblock for annoying signature ads | Enhanced Merit UI
MashRinx
Sr. Member
****
Offline Offline

Activity: 390
Merit: 250



View Profile
April 11, 2013, 03:20:04 AM
 #7

sorry, missed the "Connected to server" line.  Good luck!
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2492
Merit: 1047


Ruu \o/


View Profile WWW
April 11, 2013, 03:23:16 AM
 #8

solo mining = hashes accepted only if it matches the network difficulty, which will take forever.

Ah, that makes sense... going to be a long while never before I see an "Accepted" then Smiley
There, FTFY.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!