Bitcoin Forum
November 20, 2017, 04:52:58 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: trouble installing PyQT4 in windows  (Read 293 times)
jonald_fyookball
Legendary
*
Offline Offline

Activity: 1246


Core dev leaves me neg feedback #abuse #political


View Profile
May 13, 2017, 01:43:38 PM
 #1

(If you're not a developer, you can safely ignore this thread, you can simply run Electrum as an .exe)

I want to install PyQt4, which is required to run electrum in windows from python.

I get this error:

C:\Users\Owner\Anaconda2>python PyQt4/configure-ng.py
Querying qmake about your Qt installation...
Determining the details of your Qt installation...
Error: Failed to determine the detail of your Qt installation. Try again using
the --verbose flag to see more detail about the problem.

1511153578
Hero Member
*
Offline Offline

Posts: 1511153578

View Profile Personal Message (Offline)

Ignore
1511153578
Reply with quote  #2

1511153578
Report to moderator
Join ICO Now Coinlancer is Disrupting the Freelance marketplace!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
kolloh
Legendary
*
Offline Offline

Activity: 1148


View Profile
May 13, 2017, 10:32:30 PM
 #2

Do you have SIP installed? ( https://www.riverbankcomputing.com/software/sip/download )

This looks to be a prerequisite and if you don't have it installed, it could be causing the issue.
jonald_fyookball
Legendary
*
Offline Offline

Activity: 1246


Core dev leaves me neg feedback #abuse #political


View Profile
May 13, 2017, 10:39:23 PM
 #3

Do you have SIP installed? ( https://www.riverbankcomputing.com/software/sip/download )

This looks to be a prerequisite and if you don't have it installed, it could be causing the issue.

Yes I do have it. SIP

maybe found a clue though:  I read on a forum it may be 32bit vs 64bit incompatibility... i will check this. thanks for looking!

jonald_fyookball
Legendary
*
Offline Offline

Activity: 1246


Core dev leaves me neg feedback #abuse #political


View Profile
May 14, 2017, 03:54:08 AM
 #4

I think its installed by i keep getting this when running electrum


C:\Users\Owner\Anaconda2>python Electrum/electrum
Traceback (most recent call last):
  File "Electrum/electrum", line 379, in <module>
    d.init_gui(config, plugins)
  File "C:\Users\Owner\Anaconda2\Electrum\lib\daemon.py", line 281, in init_gui
    gui = __import__('electrum_gui.' + gui_name, fromlist=['electrum_gui'])
  File "C:\Users\Owner\Anaconda2\Electrum\gui\qt\__init__.py", line 35, in <module>
    from PyQt4.QtGui import *
ImportError: No module named QtGui


Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!