Bitcoin Forum
August 17, 2017, 12:02:14 AM *
News: Latest stable version of Bitcoin Core: 0.14.2  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 [3] 4 5 6 7 8 9 10 11 12 13 »  All
  Print  
Author Topic: [Sell][in stock] HashBuster ASIC Miners  (Read 70332 times)
gades
Sr. Member
****
Offline Offline

Activity: 416



View Profile WWW
October 10, 2013, 05:17:29 AM
 #41

The Hashbuster runs fine with the Virtualbox image on Windows 7

works fine, just had to put together your fork to get rid of the error segfault, as well as in the code driver-birfury.c one error about which he wrote needbmw. is currently working steadily.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1502928134
Hero Member
*
Offline Offline

Posts: 1502928134

View Profile Personal Message (Offline)

Ignore
1502928134
Reply with quote  #2

1502928134
Report to moderator
1502928134
Hero Member
*
Offline Offline

Posts: 1502928134

View Profile Personal Message (Offline)

Ignore
1502928134
Reply with quote  #2

1502928134
Report to moderator
XBOCT
Member
**
Offline Offline

Activity: 80


View Profile
October 11, 2013, 07:55:03 AM
 #42

slightly modified version of cgminer with automatic clockbit selection: https://www.dropbox.com/s/mwdfp9lv9ey1umh/cgminer_hid-autoclock.tgz
PS I run cgminer under FreeBSD, so if you have problems with building it under Linux look sources (link posted by wttbs) and revese some def/undef...
newminer7950
Full Member
***
Offline Offline

Activity: 130


View Profile
October 11, 2013, 10:55:56 AM
 #43

I have the error when start cgminer_hid from last post:

error while loading shared libraries: libhidapi-hidraw.so.0: cannot open shared object file: No such file or directory

library libhidapi-hidraw.so.0 is present in /usr/local/lib/
when i build from sources i recieve error:
 Electric Fence bug

Donations: 1BKA3FsvrZzznSJueXbx3qokHYqmwe9QQC
gades
Sr. Member
****
Offline Offline

Activity: 416



View Profile WWW
October 11, 2013, 08:52:33 PM
 #44

slightly modified version of cgminer with automatic clockbit selection: https://www.dropbox.com/s/mwdfp9lv9ey1umh/cgminer_hid-autoclock.tgz
PS I run cgminer under FreeBSD, so if you have problems with building it under Linux look sources (link posted by wttbs) and revese some def/undef...

version cgminer 3.5.0 (based on you changes) https://www.dropbox.com/s/1dn02frgz9sj2no/cgminer_hid_hades.tar.bz2

XBOCT
Member
**
Offline Offline

Activity: 80


View Profile
October 11, 2013, 11:57:50 PM
 #45

version cgminer 3.5.0 (based on you changes) https://www.dropbox.com/s/1dn02frgz9sj2no/cgminer_hid_hades.tar.bz2
Thanks! It works under FreeBSD with  minimal include/lib adaptation. But instead of normal shutdown it crashes... Something strange in bitfury_shutdown()... But who want to stop miner ? Wink

Do you have any changes in hashrate  ?
gades
Sr. Member
****
Offline Offline

Activity: 416



View Profile WWW
October 12, 2013, 05:58:00 AM
 #46

version cgminer 3.5.0 (based on you changes) https://www.dropbox.com/s/1dn02frgz9sj2no/cgminer_hid_hades.tar.bz2
Thanks! It works under FreeBSD with  minimal include/lib adaptation. But instead of normal shutdown it crashes... Something strange in bitfury_shutdown()... But who want to stop miner ? Wink

Do you have any changes in hashrate  ?

I made one change which was due to segfault (can you download the previous version?)

line 1302
Code:
                                /* //SEGFAULT
                                 tailsprintf (strbuf, "%lld@%d ",
                                               cgpu->
                                               hashrate_by_clockbits[cgpu->
                                                                     chip]
                                               [clockdiff],
                                               cgpu->clockbits_nominal[cgpu->
                                                                       chip] +
                                               clockdiff +
                                               CLOCKBIT_SWIPE_MIN);
                                */
                                }


your version of the driver-bitfury.c achieved an increase in the rate of +1 Ghash, but there are two problem:
- Sometimes when determining the device is not all (you have to restart cgminer);
- Falling speed <1Ghash reset_chip function does not work as it is turned off (if (0 && total_secs> 60 && cgpu-> rolling <1000), and thus the algorithm does not take any action on the chip output from this mode.

p.s./ Вы случайно русский не знаете? (Do you speak Russian?)

HashBuster.com
Jr. Member
*
Offline Offline

Activity: 33


View Profile
October 12, 2013, 07:14:16 AM
 #47

Price drop.
gades
Sr. Member
****
Offline Offline

Activity: 416



View Profile WWW
October 12, 2013, 07:46:27 AM
 #48

New version https://www.dropbox.com/s/1pc58s0b7jqxjdn/v0.6_update_to_3.5.1.tar.bz2

XBOCT
Member
**
Offline Offline

Activity: 80


View Profile
October 12, 2013, 10:24:07 AM
 #49


I made one change which was due to segfault (can you download the previous version?)

tailsprintf(buf, "format ...") should be changed to tailsprintf(buf, BUFSIZE, "format ...")


Quote
your version of the driver-bitfury.c achieved an increase in the rate of +1 Ghash
+1Gh/s per single chip ?? way!

Quote
- Sometimes when determining the device is not all (you have to restart cgminer);
Detection time  (BITFURY_DETECT_TRIES) was reduced. It may be too low now... Now i think that it should be at least 4.2/Mhash_rate.

Quote
- Falling speed <1Ghash reset_chip function does not work as it is turned off (if (0 && total_secs> 60 && cgpu-> rolling <1000), and thus the algorithm does not take any action on the chip output from this mode.
Ohh... My fault. I deactivated it during debug.

Quote
p.s./ Вы случайно русский не знаете? (Do you speak Russian?)
Yes. We can continue here or in here
gades
Sr. Member
****
Offline Offline

Activity: 416



View Profile WWW
October 12, 2013, 11:08:24 AM
 #50

Quote
your version of the driver-bitfury.c achieved an increase in the rate of +1 Ghash
+1Gh/s per single chip ?? way!

is a speedup in 1Ghash / s to 5 devices hashbuster nano



gades
Sr. Member
****
Offline Offline

Activity: 416



View Profile WWW
October 12, 2013, 01:54:45 PM
 #51

New version https://www.dropbox.com/s/d91e7e64r5zfujt/v0.7_fix_resetchip_chipdetect.tar.bz2

wttbs
Legendary
*
Offline Offline

Activity: 1428



View Profile WWW
October 12, 2013, 02:11:13 PM
 #52


I downloaded the new version, when I run ./configure I get this error:

checking for pthread_create in -lpthread... no
configure: error: Could not find pthread library - please install libpthread

library is installed:

sudo apt-get install libpthread-stubs0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libpthread-stubs0 is already the newest version.

can you please help me. I just started with Linux so I am not an expert  Grin I run Ubuntu 13.04 64-bit

Signature
XBOCT
Member
**
Offline Offline

Activity: 80


View Profile
October 12, 2013, 03:03:07 PM
 #53

checking for pthread_create in -lpthread... no
configure: error: Could not find pthread library - please install libpthread

can you please help me. I just started with Linux so I am not an expert  Grin I run Ubuntu 13.04 64-bit

Check presence of hidapi (hidapi-hidraw)  library.
wttbs
Legendary
*
Offline Offline

Activity: 1428



View Profile WWW
October 12, 2013, 03:52:34 PM
 #54

checking for pthread_create in -lpthread... no
configure: error: Could not find pthread library - please install libpthread

can you please help me. I just started with Linux so I am not an expert  Grin I run Ubuntu 13.04 64-bit

Check presence of hidapi (hidapi-hidraw)  library.

cloned hidapi with git but didn't compile it  Grin ./configure and make etc succesful, hidapi installed

Now I did run a configure for the cgminer-dir

./configure --disable-opencl --disable-adl --disable-bitforce --disable-icarus --disable-modminer --disable-ztex --disable-scrypt --enable-bitfury

Code:
------------------------------------------------------------------------
cgminer 3.5.1
------------------------------------------------------------------------


Configuration Options Summary:

  libcurl(GBT+getwork).: Enabled: -lcurl 
  curses.TUI...........: FOUND: -lncurses
  OpenCL...............: Detection overrided. GPU mining support DISABLED
  scrypt...............: Disabled (needs OpenCL)
  ADL..................: Detection overrided. GPU monitoring support DISABLED

  Avalon.ASICs.........: Disabled
  BFL.ASICs............: Disabled
  BitForce.FPGAs.......: Disabled
  BitFury.ASICs........: Enabled
  Icarus.FPGAs.........: Disabled
  Klondike.ASICs.......: Disabled
  ModMiner.FPGAs.......: Disabled

Compilation............: make (or gmake)
  CPPFLAGS.............:
  CFLAGS...............: -g -O2
  LDFLAGS..............:  -lpthread
  LDADD................:  -lcurl   compat/jansson/libjansson.a -lpthread     -lm compat/libusb-1.0/libusb/.libs/libusb-1.0.a -ludev -lrt

Installation...........: make install (as root if needed, with 'su' or 'sudo')
  prefix...............: /usr/local

then I did : sudo make install

Code:
petje@smurver:~/cgminer-hb/cgminer-hb06$ sudo make install
Making install in lib
make[1]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/lib'
  GEN    signal.h
  GEN    string.h
make  install-recursive
make[2]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/lib'
make[3]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/lib'
make[4]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/lib'
make[4]: Nothing to be done for `install-exec-am'.
make[4]: Nothing to be done for `install-data-am'.
make[4]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/lib'
make[3]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/lib'
make[2]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/lib'
make[1]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/lib'
Making install in compat
make[1]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/compat'
Making install in jansson
make[2]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/compat/jansson'
make[3]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/compat/jansson'
make[3]: Nothing to be done for `install-exec-am'.
 /bin/mkdir -p '/usr/local/include'
 /usr/bin/install -c -m 644 jansson.h jansson_config.h '/usr/local/include'
make[3]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/compat/jansson'
make[2]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/compat/jansson'
Making install in libusb-1.0
make[2]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/compat/libusb-1.0'
Making install in libusb
make[3]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/compat/libusb-1.0/libusb'
make[4]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/compat/libusb-1.0/libusb'
 /bin/mkdir -p '/usr/local/lib'
 /bin/bash ../libtool   --mode=install /usr/bin/install -c   libusb-1.0.la '/usr/local/lib'
libtool: install: /usr/bin/install -c .libs/libusb-1.0.so.2.0.0 /usr/local/lib/libusb-1.0.so.2.0.0
libtool: install: (cd /usr/local/lib && { ln -s -f libusb-1.0.so.2.0.0 libusb-1.0.so.2 || { rm -f libusb-1.0.so.2 && ln -s libusb-1.0.so.2.0.0 libusb-1.0.so.2; }; })
libtool: install: (cd /usr/local/lib && { ln -s -f libusb-1.0.so.2.0.0 libusb-1.0.so || { rm -f libusb-1.0.so && ln -s libusb-1.0.so.2.0.0 libusb-1.0.so; }; })
libtool: install: /usr/bin/install -c .libs/libusb-1.0.lai /usr/local/lib/libusb-1.0.la
libtool: install: /usr/bin/install -c .libs/libusb-1.0.a /usr/local/lib/libusb-1.0.a
libtool: install: chmod 644 /usr/local/lib/libusb-1.0.a
libtool: install: ranlib /usr/local/lib/libusb-1.0.a
libtool: finish: PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/sbin" ldconfig -n /usr/local/lib
----------------------------------------------------------------------
Libraries have been installed in:
   /usr/local/lib

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - add LIBDIR to the `LD_RUN_PATH' environment variable
     during linking
   - use the `-Wl,-rpath -Wl,LIBDIR' linker flag
   - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
 /bin/mkdir -p '/usr/local/include/libusb-1.0'
 /usr/bin/install -c -m 644 libusb.h '/usr/local/include/libusb-1.0'
make[4]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/compat/libusb-1.0/libusb'
make[3]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/compat/libusb-1.0/libusb'
make[3]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/compat/libusb-1.0'
make[4]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/compat/libusb-1.0'
make[4]: Nothing to be done for `install-exec-am'.
 /bin/mkdir -p '/usr/local/lib/pkgconfig'
 /usr/bin/install -c -m 644 libusb-1.0.pc '/usr/local/lib/pkgconfig'
make[4]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/compat/libusb-1.0'
make[3]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/compat/libusb-1.0'
make[2]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/compat/libusb-1.0'
make[2]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/compat'
make[3]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/compat'
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
make[3]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/compat'
make[2]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/compat'
make[1]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/compat'
Making install in ccan
make[1]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/ccan'
make[2]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06/ccan'
make[2]: Nothing to be done for `install-exec-am'.
make[2]: Nothing to be done for `install-data-am'.
make[2]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/ccan'
make[1]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06/ccan'
make[1]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06'
  CC     cgminer-cgminer.o
  CC     cgminer-util.o
  CC     cgminer-sha2.o
  CC     cgminer-sha2_old.o
  CC     cgminer-api.o
  CC     cgminer-logging.o
  CC     cgminer-driver-opencl.o
  CC     cgminer-usbutils.o
  CC     cgminer-driver-bitfury.o
driver-bitfury.c: In function ‘spi_txrx’:
driver-bitfury.c:152:5: warning: format ‘%d’ expects a matching ‘int’ argument [-Wformat]
driver-bitfury.c: In function ‘libbitfury_sendHashData’:
driver-bitfury.c:785:5: warning: format ‘%x’ expects argument of type ‘unsigned int’, but argument 9 has type ‘unsigned int’ [-Wformat]
driver-bitfury.c:785:5: warning: format ‘%x’ expects argument of type ‘unsigned int’, but argument 9 has type ‘unsigned int’ [-Wformat]
driver-bitfury.c:797:4: warning: format ‘%x’ expects argument of type ‘unsigned int’, but argument 9 has type ‘unsigned int’ [-Wformat]
driver-bitfury.c:797:4: warning: format ‘%x’ expects argument of type ‘unsigned int’, but argument 9 has type ‘unsigned int’ [-Wformat]
driver-bitfury.c:835:8: warning: format ‘%x’ expects argument of type ‘unsigned int’, but argument 9 has type ‘unsigned int’ [-Wformat]
driver-bitfury.c:835:8: warning: format ‘%x’ expects argument of type ‘unsigned int’, but argument 9 has type ‘unsigned int’ [-Wformat]
driver-bitfury.c: At top level:
driver-bitfury.c:878:8: warning: conflicting types for ‘nmsleep’ [enabled by default]
driver-bitfury.c:593:7: note: previous implicit declaration of ‘nmsleep’ was here
driver-bitfury.c: In function ‘bitfury_detect’:
driver-bitfury.c:1011:8: warning: format ‘%d’ expects argument of type ‘int’, but argument 6 has type ‘double’ [-Wformat]
driver-bitfury.c:1011:8: warning: format ‘%d’ expects argument of type ‘int’, but argument 6 has type ‘double’ [-Wformat]
driver-bitfury.c: At top level:
driver-bitfury.c:1683:3: warning: initialization from incompatible pointer type [enabled by default]
driver-bitfury.c:1683:3: warning: (near initialization for ‘bitfury_drv.drv_detect’) [enabled by default]
driver-bitfury.c:1685:3: warning: initialization from incompatible pointer type [enabled by default]
driver-bitfury.c:1685:3: warning: (near initialization for ‘bitfury_drv.get_statline_before’) [enabled by default]
  CC     cgminer-libbitfury.o
  CC     cgminer-spidevc.o
In file included from spidevc.c:1:0:
spidevc.h:26:64: warning: ‘struct cgpu_info’ declared inside parameter list [enabled by default]
spidevc.h:26:64: warning: its scope is only this definition or declaration, which is probably not what you want [enabled by default]
spidevc.h:29:27: warning: ‘struct cgpu_info’ declared inside parameter list [enabled by default]
spidevc.h:30:36: warning: ‘struct cgpu_info’ declared inside parameter list [enabled by default]
spidevc.h:31:36: warning: ‘struct cgpu_info’ declared inside parameter list [enabled by default]
spidevc.h:32:30: warning: ‘struct cgpu_info’ declared inside parameter list [enabled by default]
spidevc.h:34:64: warning: ‘struct cgpu_info’ declared inside parameter list [enabled by default]
In file included from spidevc.c:1:0:
spidevc.h:35:56: warning: ‘struct cgpu_info’ declared inside parameter list [enabled by default]
spidevc.h:37:28: warning: ‘struct cgpu_info’ declared inside parameter list [enabled by default]
spidevc.h:38:28: warning: ‘struct cgpu_info’ declared inside parameter list [enabled by default]
spidevc.h:39:36: warning: ‘struct cgpu_info’ declared inside parameter list [enabled by default]
spidevc.h:47:73: warning: ‘struct cgpu_info’ declared inside parameter list [enabled by default]
  CCLD   cgminer
make[2]: Entering directory `/home/petje/cgminer-hb/cgminer-hb06'
 /bin/mkdir -p '/usr/local/bin'
  /bin/bash ./libtool   --mode=install /usr/bin/install -c cgminer '/usr/local/bin'
libtool: install: /usr/bin/install -c cgminer /usr/local/bin/cgminer
 /bin/mkdir -p '/usr/local/bin'
 /usr/bin/install -c ./diablo130302.cl ./diakgcn121016.cl ./phatk121016.cl ./poclbm130302.cl ./scrypt130511.cl '/usr/local/bin'
make[2]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06'
make[1]: Leaving directory `/home/petje/cgminer-hb/cgminer-hb06'

when I try to start cgminer I get this:

cgminer

cgminer: error while loading shared libraries: libhidapi-hidraw.so.0: cannot open shared object file: No such file or directory

Signature
gades
Sr. Member
****
Offline Offline

Activity: 416



View Profile WWW
October 12, 2013, 04:26:07 PM
 #55

cgminer: error while loading shared libraries: libhidapi-hidraw.so.0: cannot open shared object file: No such file or directory

if you install libhid - run ldconfig

To compile you need to:
1. install package: sudo apt-get install electric-fence dh-autoreconf
2. install hidapi library:
clone git from: https://github.com/signal11/hidapi
run ./bootstrap then ./configure, make, make install

wttbs
Legendary
*
Offline Offline

Activity: 1428



View Profile WWW
October 12, 2013, 05:48:27 PM
 #56

cgminer: error while loading shared libraries: libhidapi-hidraw.so.0: cannot open shared object file: No such file or directory

if you install libhid - run ldconfig

To compile you need to:
1. install package: sudo apt-get install electric-fence dh-autoreconf
2. install hidapi library:
clone git from: https://github.com/signal11/hidapi
run ./bootstrap then ./configure, make, make install

Thanks, ldconfig did the job, I forgot that. Compile succesfull, no error with hidapi

did a configure and make for cgminer again. No I get this message running cgminer  Sad


 [2013-10-12 19:46:37] Started cgminer 3.5.1
 [2013-10-12 19:46:37] Device Found
  type: fa04 0011
  path: /dev/hidraw2
  serial_number:Segmentation fault (core dumped)

Signature
gades
Sr. Member
****
Offline Offline

Activity: 416



View Profile WWW
October 12, 2013, 06:10:52 PM
 #57

Thanks, ldconfig did the job, I forgot that. Compile succesfull, no error with hidapi

did a configure and make for cgminer again. No I get this message running cgminer  Sad


 [2013-10-12 19:46:37] Started cgminer 3.5.1
 [2013-10-12 19:46:37] Device Found
  type: fa04 0011
  path: /dev/hidraw2
  serial_number:Segmentation fault (core dumped)


gdb /path_to_cgminer/bin/cgminer
run
backtrace

p.s./ I see you have more than one device, try to reload the board of power (molex connector) before starting cgminer

wttbs
Legendary
*
Offline Offline

Activity: 1428



View Profile WWW
October 12, 2013, 06:29:01 PM
 #58

Thanks, ldconfig did the job, I forgot that. Compile succesfull, no error with hidapi

did a configure and make for cgminer again. No I get this message running cgminer  Sad


 [2013-10-12 19:46:37] Started cgminer 3.5.1
 [2013-10-12 19:46:37] Device Found
  type: fa04 0011
  path: /dev/hidraw2
  serial_number:Segmentation fault (core dumped)


gdb /path_to_cgminer/bin/cgminer
run
backtrace

p.s./ I see you have more than one device, try to reload the board of power (molex connector) before starting cgminer

disconnected molex from boards, waited 30 seconds, reconnected molex

Code:
[2013-10-12 20:25:27] Started cgminer 3.5.1[New Thread 0x7ffff1b72700 (LWP 4477)]

 [2013-10-12 20:25:27] Device Found
  type: fa04 0011
  path: /dev/hidraw2
  serial_number:
Program received signal SIGSEGV, Segmentation fault.
get_device_string (key=key@entry=DEVICE_STRING_MANUFACTURER,
    string=string@entry=0xf44800 <wstr> L"", maxlen=maxlen@entry=255, dev=<optimized out>)
    at hid.c:256
256 fstat(dev->device_handle, &s);
(gdb) backtrace
#0  get_device_string (key=key@entry=DEVICE_STRING_MANUFACTURER,
    string=string@entry=0xf44800 <wstr> L"", maxlen=maxlen@entry=255, dev=<optimized out>)
    at hid.c:256
#1  0x00007ffff6bfb65d in hid_get_manufacturer_string (dev=<optimized out>,
    string=string@entry=0xf44800 <wstr> L"", maxlen=maxlen@entry=255) at hid.c:764
#2  0x000000000043fe6b in bitfury_detect () at driver-bitfury.c:985
#3  0x000000000040653d in main (argc=1, argv=0x7fffffffdff8) at cgminer.c:7950
(gdb)

I have 3 hashbuster connected via an USB HUB

lsusb
Code:
lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 058: ID fa04:0011  
Bus 001 Device 059: ID fa04:0011  
Bus 001 Device 060: ID fa04:0011  
Bus 001 Device 004: ID 1a40:0201 Terminus Technology Inc. FE 2.1 7-port Hub
Bus 001 Device 005: ID 045e:00cb Microsoft Corp. Basic Optical Mouse v2.0
Bus 001 Device 006: ID 413c:2003 Dell Computer Corp. Keyboard
Bus 001 Device 010: ID 0bda:0151 Realtek Semiconductor Corp. Mass Storage Device (Multicard Reader)
Bus 001 Device 011: ID 1a40:0101 Terminus Technology Inc. 4-Port HUB

Connected 1 hashbuster directly to usbport, disconnect other 2, same error

Signature
gades
Sr. Member
****
Offline Offline

Activity: 416



View Profile WWW
October 12, 2013, 07:02:46 PM
 #59

Code:
[2013-10-12 20:25:27] Started cgminer 3.5.1[New Thread 0x7ffff1b72700 (LWP 4477)]

 [2013-10-12 20:25:27] Device Found
  type: fa04 0011
  path: /dev/hidraw2
  serial_number:
Program received signal SIGSEGV, Segmentation fault.
get_device_string (key=key@entry=DEVICE_STRING_MANUFACTURER,
    string=string@entry=0xf44800 <wstr> L"", maxlen=maxlen@entry=255, dev=<optimized out>)
    at hid.c:256
256 fstat(dev->device_handle, &s);
(gdb) backtrace
#0  get_device_string (key=key@entry=DEVICE_STRING_MANUFACTURER,
    string=string@entry=0xf44800 <wstr> L"", maxlen=maxlen@entry=255, dev=<optimized out>)
    at hid.c:256
#1  0x00007ffff6bfb65d in hid_get_manufacturer_string (dev=<optimized out>,
    string=string@entry=0xf44800 <wstr> L"", maxlen=maxlen@entry=255) at hid.c:764
#2  0x000000000043fe6b in bitfury_detect () at driver-bitfury.c:985
#3  0x000000000040653d in main (argc=1, argv=0x7fffffffdff8) at cgminer.c:7950
(gdb)
Judging by mistake, the driver can not read the manufacturer: (Try to turn off the power and usb cord from all devices, and then turn back. then the error should abyss.


wttbs
Legendary
*
Offline Offline

Activity: 1428



View Profile WWW
October 12, 2013, 07:30:31 PM
 #60

disconnect power and usb, waited 30 sec, connected power, waited for led to stop blinking, connected usb: same error

The weird thing is, when I run the VirtualBox machine they work in cgminer ! When I do a lsub in a terminal in the virtual machine it shows the same as on the ubuntu machine, no manufacturer

lsusb on the virtualbox machine

Code:
hashbuster@hashbuster-VirtualBox:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 80ee:0021 VirtualBox USB Tablet
Bus 002 Device 003: ID fa04:0011 
Bus 002 Device 004: ID fa04:0011 
Bus 002 Device 005: ID fa04:0011 
hashbuster@hashbuster-VirtualBox:~$

This is what cgminer displays during startup in the Virtualbox machine
Code:
2013-10-12 15:34:04] BITFURY chip #1 detected
 [2013-10-12 15:34:08] BITFURY: 1 chips detected!
 [2013-10-12 15:34:08] Device Found
  type: fa04 0011
  path: /dev/hidraw3
  serial_number:
 [2013-10-12 15:34:08] Manufacturer: StarFury Laboratories

 [2013-10-12 15:34:08] Product: HashBuster.nano Project

 [2013-10-12 15:34:09] BITFURY chip #1 detected
 [2013-10-12 15:34:13] BITFURY: 1 chips detected!




Signature
Pages: « 1 2 [3] 4 5 6 7 8 9 10 11 12 13 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!