Bitcoin Forum
September 24, 2018, 03:07:46 AM *
News: ♦♦ New info! Bitcoin Core users absolutely must upgrade to previously-announced 0.16.3 [Torrent]. All Bitcoin users should temporarily trust confirmations slightly less. More info.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Standard Bitcoin-Qt client is burning up my CPU on OSX 10.8.5  (Read 3327 times)
manuel
Member
**
Offline Offline

Activity: 70
Merit: 10


View Profile
October 20, 2013, 10:15:09 AM
 #1

[looks like I should have posted this here and not in technical discussion but I cannot delete the topic there: "You cannot delete your own topics in this board."]

With a late model MacBook Pro.  I asked about this in the newbie forum and was told this was "normal" but I can't see how it is.  It is using 90-95% of all four cores on an i7.

When I first noticed this problem I noticed that my client was out of date so I upgraded.  The problem went away for about 2 or 3 hours while it ran quietly using only 5-10% of CPU capacity then all of a sudden it returned.  I tried closing and reopening the client, no luck.  I tried restarting, no luck.

I do not believe this can be "normal".  I've run bit-coin qt on all kinds of much less powerful machines and you would hardly know it's running - it certainly didn't monopolize 95%+ of the the CPU.

What can I do here?

Thanks.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
cshelswell
Hero Member
*****
Offline Offline

Activity: 611
Merit: 500


View Profile WWW
October 20, 2013, 10:17:21 AM
 #2

it does eventually get through it. Just try turning it off then back on again. It's just the initial downloading of the block chain. Unless you're coding with it or solo mining try something like multibit it works great on OSX

manuel
Member
**
Offline Offline

Activity: 70
Merit: 10


View Profile
October 20, 2013, 10:48:26 AM
 #3

it does eventually get through it. Just try turning it off then back on again. It's just the initial downloading of the block chain. Unless you're coding with it or solo mining try something like multibit it works great on OSX

Nope not coding or doing anything.   Here is something to prove my point.  I had an idea.  I opened up a virtual machine on windows 7 on virtual box.  It downloads the block chain at at least the same speed but I'd say even faster really.  It did more than 30 weeks of data in just the time I was testing and making screen shots.  And note, I have only given the virtual machine access to 1/4 cores and 2/8 GB memory...




Compare that to the native OSX client.



Makes no sense.  Something is drastically wrong here.  Can anyone help?
HellDiverUK
Hero Member
*****
Offline Offline

Activity: 938
Merit: 501



View Profile
October 20, 2013, 02:56:58 PM
 #4

I can't help, other than saying I didn't see the same here (rMBP, i5, 10.8.5, Bitcoin-qt 0.8.5).

deepceleron
Legendary
*
Offline Offline

Activity: 1512
Merit: 1000



View Profile WWW
October 20, 2013, 03:13:02 PM
 #5

There is a lot of CPU work to do, syncing is not simply downloading. About 50,000 transactions per day have to be verified, with multiple txins each. That's about 350 transactions per block on average, about 100000 SHA256 tree hashes and probably ~200000 ECDSA signatures per day to calculate.

Bitcoin is single-threaded while downloading the blockchain until it passes the last checkpoint. After that, signature checking of transactions is enabled which is multithreaded, using as much CPU as you give it. Ideally Bitcoin would use 100% CPU all the time while it needs it.
manuel
Member
**
Offline Offline

Activity: 70
Merit: 10


View Profile
October 20, 2013, 03:21:05 PM
 #6

I can't help, other than saying I didn't see the same here (rMBP, i5, 10.8.5, Bitcoin-qt 0.8.5).


Don't you mean i7?  I thought all rMBP were i7?

I tried running it on a MacBook Air with a much less powerful 1.3 GHz dual core i5 and it's not taking up more than 25% of the CPU and the computer stays cool and operates normally.  Now it did behave that way for a couple hours on my MBP when I upgraded to the latest version but then it went right back to normal.

Can anyone help? .
gmaxwell
Staff
Legendary
*
Offline Offline

Activity: 2506
Merit: 1502



View Profile
October 20, 2013, 03:30:50 PM
 #7

I do not believe this can be "normal".  I've run bit-coin qt on all kinds of much less powerful machines and you would hardly know it's running - it certainly didn't monopolize 95%+ of the the CPU.
It's normal and necessary when its syncing up with the blockchain.  Are you fully synced up yet or not?

Bitcoin will not be compromised
manuel
Member
**
Offline Offline

Activity: 70
Merit: 10


View Profile
October 20, 2013, 03:47:32 PM
 #8

There is a lot of CPU work to do, syncing is not simply downloading. About 50,000 transactions per day have to be verified, with multiple txins each. That's about 350 transactions per block on average, about 100000 SHA256 tree hashes and probably ~200000 ECDSA signatures per day to calculate.

Bitcoin is single-threaded while downloading the blockchain until it passes the last checkpoint. After that, signature checking of transactions is enabled which is multithreaded, using as much CPU as you give it. Ideally Bitcoin would use 100% CPU all the time while it needs it.

But this is not the experience of actually using the client on multiple platforms.  Have you not seen the screen shots I posted above?

I just ran it on a MacBook Air with a much less powerful CPU, it only used 25% of available resources and downloaded the block chain much faster.

Can anyone shed some light on this?
grue
Legendary
*
Offline Offline

Activity: 2100
Merit: 1140



View Profile
October 20, 2013, 03:56:56 PM
 #9

But this is not the experience of actually using the client on multiple platforms.  Have you not seen the screen shots I posted above?

I just ran it on a MacBook Air with a much less powerful CPU, it only used 25% of available resources and downloaded the block chain much faster.

Can anyone shed some light on this?
Windows 7 in VM screenshot: you were connected to a slow peer or were otherwise IO bound. Your cpu was waiting for data, therefore it wasn't at 100% utilization.
Mac OSX screenshot: you passed the last block checkpoint, so multithreading verifications are enabled. therefore bitcoin can use all cpu resources.

to see if you passed the checkpoint (and if multithreading is enabled), go to help->debug window. if "current number of blocks" is greater than 250000, then you passed the last checkpoint.

It is pitch black. You are likely to be eaten by a grue.

Adblock for annoying signature ads | Enhanced Merit UI
manuel
Member
**
Offline Offline

Activity: 70
Merit: 10


View Profile
October 20, 2013, 04:16:44 PM
 #10

But this is not the experience of actually using the client on multiple platforms.  Have you not seen the screen shots I posted above?

I just ran it on a MacBook Air with a much less powerful CPU, it only used 25% of available resources and downloaded the block chain much faster.

Can anyone shed some light on this?
Windows 7 in VM screenshot: you were connected to a slow peer or were otherwise IO bound. Your cpu was waiting for data, therefore it wasn't at 100% utilization.
Mac OSX screenshot: you passed the last block checkpoint, so multithreading verifications are enabled. therefore bitcoin can use all cpu resources.

to see if you passed the checkpoint (and if multithreading is enabled), go to help->debug window. if "current number of blocks" is greater than 250000, then you passed the last checkpoint.

Alright but I still don't understand why it didn't do the same with the MacBook Air on the same internet connection.

Is there any way to limit it so it doesn't monopolize my whole system?  It also makes the computer frighteningly hot.

I'm at 252,141.  Anything else I should look for?

grue
Legendary
*
Offline Offline

Activity: 2100
Merit: 1140



View Profile
October 20, 2013, 09:28:34 PM
 #11

Alright but I still don't understand why it didn't do the same with the MacBook Air on the same internet connection.

Is there any way to limit it so it doesn't monopolize my whole system?  It also makes the computer frighteningly hot.

I'm at 252,141.  Anything else I should look for?
go to bitcoin.conf and put in the following:
Code:
par=2
this will limit the verification threads to 2. you can also use other values if you wish.

It is pitch black. You are likely to be eaten by a grue.

Adblock for annoying signature ads | Enhanced Merit UI
manuel
Member
**
Offline Offline

Activity: 70
Merit: 10


View Profile
October 21, 2013, 02:37:22 AM
 #12

Thanks that helps!
HellDiverUK
Hero Member
*****
Offline Offline

Activity: 938
Merit: 501



View Profile
October 21, 2013, 08:42:48 AM
 #13

I can't help, other than saying I didn't see the same here (rMBP, i5, 10.8.5, Bitcoin-qt 0.8.5).


Don't you mean i7?  I thought all rMBP were i7?


No, it's a 2.5GHz i5.  See: http://www.apple.com/uk/macbook-pro/specs-retina/ - mine's the base spec 13"

manuel
Member
**
Offline Offline

Activity: 70
Merit: 10


View Profile
October 21, 2013, 12:27:50 PM
 #14

Alright but I still don't understand why it didn't do the same with the MacBook Air on the same internet connection.

Is there any way to limit it so it doesn't monopolize my whole system?  It also makes the computer frighteningly hot.

I'm at 252,141.  Anything else I should look for?
go to bitcoin.conf and put in the following:
Code:
par=2
this will limit the verification threads to 2. you can also use other values if you wish.

I still think something is out of whack here.  When I limit to 3 threads it advances as fast (and I would say perhaps even faster) as when I let it use up all 8 threads to 95-98% of CPU capacity.

Finally I am up to date though.

It takes forever.

How long is it supposed to take to catch up a couple of months?

BookLover
Hero Member
*****
Offline Offline

Activity: 534
Merit: 500


^Bitcoin Library of Congress.


View Profile
October 23, 2013, 01:41:28 AM
 #15

The MacBook Pro has a solid state drive and the main limit on sync speed is the your hard drive and peer speed.  With flash storage and fast peers you can sync a whole lot faster and start stressing your other components.  This may be why be why your having trouble.  Undecided Of course without being there for all I know bitcoin-qt could have an issue with multithreading. Wink

manuel
Member
**
Offline Offline

Activity: 70
Merit: 10


View Profile
October 23, 2013, 06:58:24 AM
 #16

The MacBook Pro has a solid state drive and the main limit on sync speed is the your hard drive and peer speed.  With flash storage and fast peers you can sync a whole lot faster and start stressing your other components.  This may be why be why your having trouble.  Undecided Of course without being there for all I know bitcoin-qt could have an issue with multithreading. Wink

I think there must be something more to it than that because I would call the sync speed with or without 8 threads anything but fast.  Limiting it to 3 hardly changes the sync speed at all and I almost want to say it's faster that way (but still very slow). 

grue
Legendary
*
Offline Offline

Activity: 2100
Merit: 1140



View Profile
October 24, 2013, 02:09:16 PM
 #17

then it's most likely your peer's speed. bitcoin doesn't know who the fastest peer is, so it chooses at random. if bitcoin chose a slow peer, you get slow speed. also, it's worth mentioning that each block has a different size. blocks from when satoshi dice was popular, for example will take longer to verify. thus it might seem "slow" from a blocks/minute perspective.

It is pitch black. You are likely to be eaten by a grue.

Adblock for annoying signature ads | Enhanced Merit UI
manuel
Member
**
Offline Offline

Activity: 70
Merit: 10


View Profile
October 24, 2013, 03:30:40 PM
 #18

then it's most likely your peer's speed. bitcoin doesn't know who the fastest peer is, so it chooses at random. if bitcoin chose a slow peer, you get slow speed. also, it's worth mentioning that each block has a different size. blocks from when satoshi dice was popular, for example will take longer to verify. thus it might seem "slow" from a blocks/minute perspective.

But if the peer speed is low then why is it using tons of CPU?
grue
Legendary
*
Offline Offline

Activity: 2100
Merit: 1140



View Profile
October 24, 2013, 03:56:07 PM
 #19

then it's most likely your peer's speed. bitcoin doesn't know who the fastest peer is, so it chooses at random. if bitcoin chose a slow peer, you get slow speed. also, it's worth mentioning that each block has a different size. blocks from when satoshi dice was popular, for example will take longer to verify. thus it might seem "slow" from a blocks/minute perspective.

But if the peer speed is low then why is it using tons of CPU?
see the second explanation.

It is pitch black. You are likely to be eaten by a grue.

Adblock for annoying signature ads | Enhanced Merit UI
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!