Bitcoin Forum
November 22, 2017, 07:48:23 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 [12]  All
  Print  
Author Topic: The collective Mastercoin-explorer, Mastercoin-ruby and Mastercoin-wallet topic  (Read 19294 times)
Tachikoma
Hero Member
*****
Offline Offline

Activity: 938



View Profile WWW
December 09, 2013, 02:10:24 PM
 #221

I'm not involved with that. As far as I know that feature is not implemented at the moment.

Electrum: the convenience of a web wallet, without the risks | Bytesized Seedboxes BTC/LTC supported
1511336903
Hero Member
*
Offline Offline

Posts: 1511336903

View Profile Personal Message (Offline)

Ignore
1511336903
Reply with quote  #2

1511336903
Report to moderator
Join ICO Now A blockchain platform for effective freelancing
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1511336903
Hero Member
*
Offline Offline

Posts: 1511336903

View Profile Personal Message (Offline)

Ignore
1511336903
Reply with quote  #2

1511336903
Report to moderator
1511336903
Hero Member
*
Offline Offline

Posts: 1511336903

View Profile Personal Message (Offline)

Ignore
1511336903
Reply with quote  #2

1511336903
Report to moderator
1511336903
Hero Member
*
Offline Offline

Posts: 1511336903

View Profile Personal Message (Offline)

Ignore
1511336903
Reply with quote  #2

1511336903
Report to moderator
Herp
Sr. Member
****
Offline Offline

Activity: 294


View Profile
December 09, 2013, 02:19:30 PM
 #222

I'm not involved with that. As far as I know that feature is not implemented at the moment.

Thanks. Guess I have no choice but to wait for now.
 
Quote
Mastercoin-explorer is lagging behind because of a piece of recursive validation code I added.

This quote gave me the wrong idea. Was thinking these two, master-chest and mastercoin-explorer, are somewhat intertwined development wise.


███████████████████████████████████████
███████████████████████████████████████
█████████████████████████████
██████████████████████████
████████████████████████
███████████████████████
█████████████████▐████
███████████████████████
████████████████████████
██████████████████████████
█████████████████████████████
███████████████████████████████████████
███████████████████████████████████████
DECENT
FOUNDATION



██
██
██
██
██
██
██
██
██

██
██
██


[D]ecentralized application
[E]liminated third parties
[C]ontent distribution



██
██
██
██
██
██
██
██
██

██
██
██


[E]ncrypted & secure
[N]o borders
[T]imeless reputation



██
██
██
██
██
██
██
██
██

██
██
██



██
██
██
██
██
██
██
██
██

██
██
██

Exocyst
Sr. Member
****
Offline Offline

Activity: 266


Science!


View Profile
December 19, 2013, 05:33:13 PM
 #223

I'm on ubuntu 13.04, and I keep getting an issue with qtbinings when I try to run mastercoin-wallet:
Code:
$ mastercoin-wallet
/var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt4.rb:27:in `const_missing': uninitialized constant Qt::RubyThreadFix::Queue (NameError)
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt4.rb:27:in `<class:RubyThreadFix>'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt4.rb:23:in `<module:Qt>'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt4.rb:22:in `<top (required)>'
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt.rb:1:in `<top (required)>'
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /var/lib/gems/1.9.1/gems/mastercoin-wallet-0.0.11/lib/mastercoin-wallet.rb:1:in `<top (required)>'
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /var/lib/gems/1.9.1/gems/mastercoin-wallet-0.0.11/bin/mastercoin-wallet:3:in `<top (required)>'
from /usr/local/bin/mastercoin-wallet:23:in `load'
from /usr/local/bin/mastercoin-wallet:23:in `<main>'

I'm brand new to ruby, what did I screw up? I followed these directions verbatim:
Code:
sudo apt-get update
sudo apt-get install ruby ruby-dev gem
sudo apt-get install libqt4-gui libqt4-dev cmake
sudo gem install mastercoin-wallet
mastercoin-wallet

For clarity, this is not an issue specifically with mastercoin-wallet, as qtbindings are malfuntioning in general: a simple require "Qt" pops off the same error:
Code:
$ irb
irb(main):001:0> require "Qt"
NameError: uninitialized constant Qt::RubyThreadFix::Queue
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt4.rb:27:in `const_missing'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt4.rb:27:in `<class:RubyThreadFix>'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt4.rb:23:in `<module:Qt>'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt4.rb:22:in `<top (required)>'
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt.rb:1:in `<top (required)>'
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:60:in `require'
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:60:in `rescue in require'
from /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:35:in `require'
from (irb):1
from /usr/bin/irb:12:in `<main>'

I would, of course, still appreciate any help, though.

Exocyst
Sr. Member
****
Offline Offline

Activity: 266


Science!


View Profile
December 19, 2013, 06:53:25 PM
 #224

I figured it out with some help from ryanmelt of the qtbindings github (https://github.com/ryanmelt/qtbindings/issues/69)
Basically, I had to edit mastercoin-wallet.rb and call thread first:
Code:
require 'thread'
require 'Qt'
This should be fixed in the next version of qtbindings according to ryanmelt.

Exocyst
Sr. Member
****
Offline Offline

Activity: 266


Science!


View Profile
December 19, 2013, 07:44:52 PM
 #225

Do you need to populate the blockchain with bitcoin_node before running mastercoin-wallet?

I'm not seeing any offers and I get errors when I try to create a new purchase offer for TEST MSC:
Code:
/var/lib/gems/1.9.1/gems/mastercoin-wallet-0.0.11/lib/mastercoin-wallet/builder.rb:114:in `pick_outputs': undefined method `reject!' for nil:NilClass (NoMethodError)
from /var/lib/gems/1.9.1/gems/mastercoin-wallet-0.0.11/lib/mastercoin-wallet/builder.rb:151:in `create_transaction_with_keys'
from /var/lib/gems/1.9.1/gems/mastercoin-wallet-0.0.11/lib/mastercoin-wallet/gui/purchase_offer_window.rb:59:in `send_transaction'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt/qtruby4.rb:900:in `qt_metacall'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt/qtruby4.rb:900:in `method_missing'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt/qtruby4.rb:900:in `exec'
from /var/lib/gems/1.9.1/gems/mastercoin-wallet-0.0.11/lib/mastercoin-wallet/gui/main_window.rb:108:in `new_purchase_offer'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt/qtruby4.rb:900:in `qt_metacall'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt/qtruby4.rb:900:in `method_missing'
from /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/lib/Qt/qtruby4.rb:900:in `exec'
from /var/lib/gems/1.9.1/gems/mastercoin-wallet-0.0.11/bin/mastercoin-wallet:12:in `<top (required)>'
from /usr/local/bin/mastercoin-wallet:23:in `load'
from /usr/local/bin/mastercoin-wallet:23:in `<main>'

EDIT: I understand from more combing of early posts that this is an insufficient-balance issue. I guess it's time to learn ruby, I would like to contribute to this mastercoin-wallet client, is there a mailing list?

EDIT2: Learned a teensy bit of ruby, and threw up a patch: https://github.com/Exocyst/mastercoin-wallet/commit/c5ff31dcba49ccb2eda4e5e6273eded8604b0a8a

btcxyzzz
Legendary
*
Offline Offline

Activity: 882

Monero - secure, private and untraceable currency.


View Profile WWW
December 25, 2013, 11:49:30 PM
 #226

Someone help me installing it on Mint 14? Thanks...

CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:97 (MESSAGE):
  Could NOT find Ruby (missing: RUBY_INCLUDE_DIR RUBY_LIBRARY
  RUBY_CONFIG_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:288 (_FPHSA_FAILURE_MESSAGE)
  cmake/modules/FindRuby.cmake:249 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:18 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!
make: [build] Error 1 (ignored)
cd ext/build; make
make[1]: Entering directory `/var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/ext/build'
make[1]: *** No targets specified and no makefile found.  Stop.
make[1]: Leaving directory `/var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/ext/build'
make: *** [build] Error 2


Gem files will remain installed in /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1 for inspection.
Results logged to /var/lib/gems/1.9.1/gems/qtbindings-4.8.5.1/./gem_make.out

Bitshares - advanced decentralized exchange and asset platform.
Tachikoma
Hero Member
*****
Offline Offline

Activity: 938



View Profile WWW
December 30, 2013, 04:40:48 PM
 #227

Hey guys,

I've been mostly AFK these past two weeks but I'm back.

For those on (x/l/k)Ubuntu 13.10 (and perhaps 13.04) I made a script that should hopefully help you install the wallet but I require some testers.

Code:
sudo apt-get -y install curl
curl -L https://gist.github.com/maran/8182379/raw/7309391a1e2341ff9f0cb1ae6603e8006cb891cc/install.sh | bash

This should install the dependencies, install rvm, install ruby-2.1 and install the wallet software.

I developed it on a Xubuntu 13.10 version and it works there.

Please let me know.

 

Electrum: the convenience of a web wallet, without the risks | Bytesized Seedboxes BTC/LTC supported
superfluouso
Full Member
***
Offline Offline

Activity: 202


View Profile
December 31, 2013, 09:51:01 AM
 #228

Hey guys,

I've been mostly AFK these past two weeks but I'm back.

For those on (x/l/k)Ubuntu 13.10 (and perhaps 13.04) I made a script that should hopefully help you install the wallet but I require some testers.

Code:
sudo apt-get -y install curl
curl -L https://gist.github.com/maran/8182379/raw/7309391a1e2341ff9f0cb1ae6603e8006cb891cc/install.sh | bash

This should install the dependencies, install rvm, install ruby-2.1 and install the wallet software.

I developed it on a Xubuntu 13.10 version and it works there.

Please let me know.

 

Welcome back!  This is hands down the easiest method to install and works great!  It does take some time as expected - about 20 minutes or so but still much faster than manually doing everything yourself.  I had an ISO for Ubuntu 13.10 so tested with that. 

I'm surprised more people aren't jumping on this.  I recommend putting this in the OP and possibly cross posting in the main thread(s)

Thanks!  Still excited for what comes next  Cool
Tachikoma
Hero Member
*****
Offline Offline

Activity: 938



View Profile WWW
December 31, 2013, 10:00:15 AM
 #229

Awesome, thanks for testing it!

I will update the Github page and OP as this seems to work Smiley

Electrum: the convenience of a web wallet, without the risks | Bytesized Seedboxes BTC/LTC supported
ninjaboon
Legendary
*
Offline Offline

Activity: 1708



View Profile WWW
January 01, 2014, 03:37:05 AM
 #230

Hey guys,

I've been mostly AFK these past two weeks but I'm back.

For those on (x/l/k)Ubuntu 13.10 (and perhaps 13.04) I made a script that should hopefully help you install the wallet but I require some testers.

Code:
sudo apt-get -y install curl
curl -L https://gist.github.com/maran/8182379/raw/7309391a1e2341ff9f0cb1ae6603e8006cb891cc/install.sh | bash

This should install the dependencies, install rvm, install ruby-2.1 and install the wallet software.

I developed it on a Xubuntu 13.10 version and it works there.

Please let me know.

 

currently on Ubuntu 12.10, but will download the new ISO and test it out. thanks

iram5110
Newbie
*
Offline Offline

Activity: 17


View Profile WWW
January 03, 2014, 05:41:37 AM
 #231

buggy but interesting

 *Link Removed*
Tachikoma
Hero Member
*****
Offline Offline

Activity: 938



View Profile WWW
January 03, 2014, 09:46:00 AM
 #232

buggy but interesting

If you tell me more about the buggy part I might be able to make it just interesting Smiley

Electrum: the convenience of a web wallet, without the risks | Bytesized Seedboxes BTC/LTC supported
Tachikoma
Hero Member
*****
Offline Offline

Activity: 938



View Profile WWW
January 08, 2014, 09:11:06 PM
 #233

I took some time today to add Fedora (20) support to the automagic installer. As always it might work on earlier versions, if not give me a pm.

I've updated the README with the new script link; if you use the instructions there it should always be up-to-date. (I want to avoid pasting the link here since it might expire in the future and it's hard to go back and edit it everywhere Smiley

Edit: I created a fixed url for the installer. The latest version should always be on wallet.mastercoin-explorer.com, to install it:

Code:
curl -L http://wallet.mastercoin-explorer.com/ | bash

Electrum: the convenience of a web wallet, without the risks | Bytesized Seedboxes BTC/LTC supported
superfluouso
Full Member
***
Offline Offline

Activity: 202


View Profile
January 09, 2014, 07:59:57 AM
 #234

I took some time today to add Fedora (20) support to the automagic installer. As always it might work on earlier versions, if not give me a pm.

I've updated the README with the new script link; if you use the instructions there it should always be up-to-date. (I want to avoid pasting the link here since it might expire in the future and it's hard to go back and edit it everywhere Smiley

Edit: I created a fixed url for the installer. The latest version should always be on wallet.mastercoin-explorer.com, to install it:

Code:
curl -L http://wallet.mastercoin-explorer.com/ | bash

Very nice! I've got to get some sleep now but will look to test on few different distros over the next couple days.  Thanks!
Tachikoma
Hero Member
*****
Offline Offline

Activity: 938



View Profile WWW
January 09, 2014, 10:07:15 AM
 #235

Seems there might be a problem left with the Fedora installation; it runs but it might need a custom OpenSSL version with ECDSA support. I might have been too early saying it's fully supported! :/

Electrum: the convenience of a web wallet, without the risks | Bytesized Seedboxes BTC/LTC supported
Tachikoma
Hero Member
*****
Offline Offline

Activity: 938



View Profile WWW
January 09, 2014, 02:52:53 PM
 #236

The problem is the following: I don't really have the time to dive into this Fedora business too much especially since it's a problem others could probably be working on while I focus on more Mastercoin oriented things. The problem is that the OpenSSL version installed on Fedora does not have the secp256k1 curve enabled.

I will payout USD 250 in Mastercoin for the first person who can modify the install script on http://wallet.mastercoin-explorer.com/ to support Fedora and the likes.

Requirements:
  • It should use RVM if possible
  • Preferably install ruby 2.x
  • It should not touch the yum installed OpenSSL version
  • It should be able to run and configure my wallet client after running the installation script

Please note that the error only happens once you insert your private key in the first run dialog so make sure you test it before submitting. I will also give out a bounty if you can prove that what I want is impossible Smiley
 

Electrum: the convenience of a web wallet, without the risks | Bytesized Seedboxes BTC/LTC supported
Pages: « 1 2 3 4 5 6 7 8 9 10 11 [12]  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!