Bitcoin Forum
November 18, 2017, 04:43:27 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Trouble moving Bitcoin-qt wallet to external drive  (Read 952 times)
deltaqueue
Newbie
*
Offline Offline

Activity: 13


View Profile
November 22, 2013, 12:25:48 AM
 #1

Hi all,

My bitcoin folder (in Appdata/roaming) is 13.5GB. It's too big to keep on my SSD, so I need to move it to an external drive.

To do this, I tried first detaching the database, so I ran this code in the command prompt (using Windows 7 x64):

Code:
"C:\Program Files\Bitcoin\bitcoin-qt.exe" -detachdb=1

(bitcoin wallet opens, then I close it)

From there I copied the Bitcoin folder and put it on my E drive, then ran this in the command prompt:

Code:
"C:\Program Files\Bitcoin\bitcoin-qt.exe" -datadir=E:\Bitcoin

When that opens my Bitcoin wallet, it says my bitcoins are unverified, and nothing really happens. I left bitcoin-qt open for 12 hours and it still says I'm 254 weeks behind / not synced / have X unverified coins. When I finally closed bitcoin-qt and re-opened it using the shortcut, it used my original database destination and the wallet was synced in a short period of time.

Any ideas what I'm doing wrong and how I can successfully move this bitcoin data to an external drive?
1510980207
Hero Member
*
Offline Offline

Posts: 1510980207

View Profile Personal Message (Offline)

Ignore
1510980207
Reply with quote  #2

1510980207
Report to moderator
1510980207
Hero Member
*
Offline Offline

Posts: 1510980207

View Profile Personal Message (Offline)

Ignore
1510980207
Reply with quote  #2

1510980207
Report to moderator
A blockchain platform for effective freelancing
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
BookLover
Hero Member
*****
Offline Offline

Activity: 535


^Bitcoin Library of Congress.


View Profile
November 22, 2013, 01:36:07 AM
 #2

You don't need to run:
Code:
"C:\Program Files\Bitcoin\bitcoin-qt.exe" -detachdb=1
this command option has a different purpose.

You need to change the shortcut target to
Code:
"C:\Program Files\Bitcoin\bitcoin-qt.exe" -datadir=E:\Bitcoin
instead of just running this once from the command line.

I bet you got the target directory wrong, I would look at E:\Bitcoin and were you put your bitcoin directory and make sure they match up correctly.

Wild guess here if nothing else works try running:
Code:
"C:\Program Files\Bitcoin\bitcoin-qt.exe" -datadir=E:\Bitcoin\
if this works don't forget to change the shortcut appropriately.

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!