Bitcoin Forum
December 05, 2016, 12:38:08 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Port 8333 install problem, one solution  (Read 2184 times)
japhroaig
Newbie
*
Offline Offline

Activity: 1


View Profile
February 24, 2011, 11:43:34 PM
 #1

Looks like VMWare server for Win7 64 bit (at least this version) uses port 8333 by default, which is also the bitcoin port.   killing vmware-hostd.exe frees up that port and will allow bitcoin to function.
1480898288
Hero Member
*
Offline Offline

Posts: 1480898288

View Profile Personal Message (Offline)

Ignore
1480898288
Reply with quote  #2

1480898288
Report to moderator
1480898288
Hero Member
*
Offline Offline

Posts: 1480898288

View Profile Personal Message (Offline)

Ignore
1480898288
Reply with quote  #2

1480898288
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480898288
Hero Member
*
Offline Offline

Posts: 1480898288

View Profile Personal Message (Offline)

Ignore
1480898288
Reply with quote  #2

1480898288
Report to moderator
iav
Newbie
*
Offline Offline

Activity: 1


View Profile
May 15, 2011, 11:00:49 PM
 #2

It's not a solution.
SmokeTooMuch
Legendary
*
Offline Offline

Activity: 873


View Profile
May 16, 2011, 08:55:18 PM
 #3

It's not a solution.
It's not even a problem. Port 8333 does NOT have to be forwarded.

Date Registered: 2009-12-10 | I'm using GPG, pm me for my public key. | Bitcoin on Reddit: https://www.reddit.com/r/btc
You like what I'm doing? Why don't you send me a coin: 17Pj8jpUgY6qTaKgiopL5U48zxU4rTrkuB
raipat
Newbie
*
Offline Offline

Activity: 1


View Profile
June 01, 2011, 11:54:58 AM
 #4

It is a problem (even if the port does not need to be forwarded, the bitcoin process wants to bind to it on the machine which fails if VMWare already bound to it), and killing the hostd is not a solution as you need it for VMWare management.
So you either move VMWare to another port or bitcoin uses another port. I found no way to move bitcoin. You can specify rpcport but not the "main" listening port.
wumpus
Hero Member
*****
Offline Offline

Activity: 798

No Maps for These Territories


View Profile
June 01, 2011, 12:27:13 PM
 #5

Use -nolisten to not listen at all. In the most recent git version there is a flag (-port XXX) to use another port, but nolisten should be ok for most cases.


Bitcoin Core developer [PGP] Warning: For most, coin loss is a larger risk than coin theft. A disk can die any time. Regularly back up your wallet through FileBackup Wallet to an external storage or the (encrypted!) cloud. Use a separate offline wallet for storing larger amounts.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!