Bitcoin Forum
December 08, 2016, 06:33:21 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Problems with cgminer  (Read 7988 times)
yjacket
Full Member
***
Offline Offline

Activity: 202


View Profile
January 25, 2012, 06:32:37 AM
 #1

So i just started using cgminer.
I have 2 questions:

Why does guiminer consistently show higher m/h rates? i thought cgminer should be much better. Is this just a reporting issue i.e. cgminer is actually more accurate?

One of my cards will constantly die using cgminer but not with guiminer. Why is this?

1481222001
Hero Member
*
Offline Offline

Posts: 1481222001

View Profile Personal Message (Offline)

Ignore
1481222001
Reply with quote  #2

1481222001
Report to moderator
1481222001
Hero Member
*
Offline Offline

Posts: 1481222001

View Profile Personal Message (Offline)

Ignore
1481222001
Reply with quote  #2

1481222001
Report to moderator
1481222001
Hero Member
*
Offline Offline

Posts: 1481222001

View Profile Personal Message (Offline)

Ignore
1481222001
Reply with quote  #2

1481222001
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
jake262144
Full Member
***
Offline Offline

Activity: 210


View Profile
January 25, 2012, 07:00:33 AM
 #2

Firstly, most of the miners rely on the same CL kernels for the computations so any difference in achievable speeds should be minimal.

Secondly, the actual mining speed relies on a whole bunch of parameters being optimally set for your hardware and software.
What fine-tuning parameters are you using? work size? vector width? thread count?

Perhaps cgminer is just pushing the card harder than guiminer which results in it becoming unstable? What intensity value have you used?
What are the clocks and temperatures?

Perhaps you should start with what operating system, driver version and cards you are talking about? All of that matters you know.

Also, the value of cgminer doesn't lie in its superior speed. The value lies in its being able to do multi-pool mining, overclocking, and voltage- and temperature control all by itself.
yjacket
Full Member
***
Offline Offline

Activity: 202


View Profile
January 25, 2012, 07:15:15 AM
 #3

Firstly, most of the miners rely on the same CL kernels for the computations so any difference in achievable speeds should be minimal.

Secondly, the actual mining speed relies on a whole bunch of parameters being optimally set for your hardware and software.
What fine-tuning parameters are you using? work size? vector width? thread count?

Perhaps cgminer is just pushing the card harder than guiminer which results in it becoming unstable? What intensity value have you used?
What are the clocks and temperatures?

Perhaps you should start with what operating system, driver version and cards you are talking about? All of that matters you know.

Also, the value of cgminer doesn't lie in its superior speed. The value lies in its being able to do multi-pool mining, overclocking, and voltage- and temperature control all by itself.

I'm using windows 7, intensity is set to 8 for cg, no other settings changed. The card is a 5850 clock 750,
mem at 500. Settings for gui are v and w128. Guy shows about is showing a 10 percent advantage. I've changed worksize in cg but it hurts performance.
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2002


Ruu \o/


View Profile WWW
January 25, 2012, 07:24:12 AM
 #4

You didn't happen to change driver versions between moving from guiminer to cgminer?

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
yjacket
Full Member
***
Offline Offline

Activity: 202


View Profile
January 25, 2012, 07:25:30 AM
 #5

You didn't happen to change driver versions between moving from guiminer to cgminer?

Nope, using the latest, inefficient drivers.
jake262144
Full Member
***
Offline Offline

Activity: 210


View Profile
January 25, 2012, 11:24:00 AM
 #6

Most recent drivers with 2.6 SDK?
Try vectors = 4 and worksize = 64 in cgminer as suggested here.

If you're using 2.5 SDK, try vectors = 2 and worksize = either 128 or 256.
One of those should be the optimum setting.

Mind you, it's not only "vectors" in cgminer but also what vector width you want (1, 2, 4).

If you're editing the config file, the lines should look like that:
Code:
"vectors" : "2",
"worksize" : "256",

The default number of GPU threads is already optimal at 2, EDIT:: as is the default intensity of 9 but the intensity needs to be set to 9 manually.
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2002


Ruu \o/


View Profile WWW
January 25, 2012, 11:55:47 AM
 #7

Most recent drivers with 2.6 SDK?The default number of GPU threads is already optimal at 2, as is the default intensity of 9.
Default intensity is actually dynamic which is designed for regular desktop use, so the intensity needs to actually be set to -I 9.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
jake262144
Full Member
***
Offline Offline

Activity: 210


View Profile
January 25, 2012, 12:31:51 PM
 #8

My bad. Fixed.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!