Bitcoin Forum
December 08, 2016, 10:15:29 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: problem with radeon 5970  (Read 1663 times)
pollus
Newbie
*
Offline Offline

Activity: 11


View Profile
February 13, 2012, 08:10:28 PM
 #1

Good evening,

I have an issue on Ubuntu 11..04 that I am not able to pin point.

Here is the scenario:

I am running SDK 2.3
and ATI drivers 11.4

I have two graphic cards installed (Radeon 5970) both are recognized by the system:

btc@BTC:~/test$ aticonfig --list-adapters
* 0. 03:00.0 ATI Radeon HD 5900 Series
  1. 04:00.0 ATI Radeon HD 5900 Series
  2. 07:00.0 ATI Radeon HD 5900 Series
  3. 08:00.0 ATI Radeon HD 5900 Series

* - Default adapter

btc@BTC:/opt/ati-stream-sdk-v2.3-lnx64/samples/opencl/bin/x86_64$ ./CLInfo |grep CL_DEVICE_TYPE_GPU
  Device Type:                CL_DEVICE_TYPE_GPU
  Device Type:                CL_DEVICE_TYPE_GPU
  Device Type:                CL_DEVICE_TYPE_GPU
  Device Type:                CL_DEVICE_TYPE_GPU

As you can see above, all 4 cores seem to be ok.

When I start poclbm in order to start mining first session seems to be ok, second one devides the amount of mhash by 2 the rest just hangs the system.

So to be square on that: first core counts about 350 mhash per second if there is only one worker on.

After turning the second worker on both will be counting about 175 mhash/s even though a different device number is being used.


I double checked for crossfire binds, there is none,

I am sure I use different devices with my command:

First command:
./poclbm.py -d0 --worksize=128 .....

Second one:

./poclbm.py -d1 --worksize=128 .... etc

I ran out of ideas, I tried different versions of this miner, no luck there.

I double checked the configuration of the system and drivers and that seems ok as well.

I need a fresh "look" at the problem as it looks like I am in some kind of vicious circle.

The issue looks exactly the same as ones with crossfire enabled. The problem is that crossfire does not seem to be enabled.

confirmed with these commands:

sudo aticonfig --lscs
sudo aticonfig --lsch

Any help is appreciated.

Thanks lads.

Regards,

pollus
1481192129
Hero Member
*
Offline Offline

Posts: 1481192129

View Profile Personal Message (Offline)

Ignore
1481192129
Reply with quote  #2

1481192129
Report to moderator
1481192129
Hero Member
*
Offline Offline

Posts: 1481192129

View Profile Personal Message (Offline)

Ignore
1481192129
Reply with quote  #2

1481192129
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481192129
Hero Member
*
Offline Offline

Posts: 1481192129

View Profile Personal Message (Offline)

Ignore
1481192129
Reply with quote  #2

1481192129
Report to moderator
1481192129
Hero Member
*
Offline Offline

Posts: 1481192129

View Profile Personal Message (Offline)

Ignore
1481192129
Reply with quote  #2

1481192129
Report to moderator
jjiimm_64
Legendary
*
Offline Offline

Activity: 1680


View Profile
February 14, 2012, 06:23:11 PM
 #2


I guess a different miner would be a fresh look. 

see what cgminer has to say about the number of cards..

1jimbitm6hAKTjKX4qurCNQubbnk2YsFw
gnar1ta$
Donator
Hero Member
*
Offline Offline

Activity: 756


View Profile
February 14, 2012, 06:34:15 PM
 #3

Does linux use crossfire?  I have 2 5970's in a linux rig and have never done anything with crossfire.  And SDK 2.1 or 2.4 and ATI driver 11.6 seem to be the most stable.  Throw a BAMT usb on there and see what happens. Or try cgminer - with no OC's at first. Check CPU usage also.

Losing hundreds of Bitcoins with the best scammers in the business - BFL, Avalon, KNC, HashFast.
pollus
Newbie
*
Offline Offline

Activity: 11


View Profile
February 15, 2012, 03:10:17 PM
 #4

the whole thing is that I tried enabling crossfire then dissabling it.

The hardware is combined out of 2 5970s

Trying phoenix and poclbm miners bot hgive the same result.

Regardless which device I start the mhash /s will not exceed 300 if I start 2 that will device 300 in two if three the 300/3 if four then the system hangs.

I tried rebuilding the whole machine from the scratch same issue.

I tried different drivers 2.1 then 2.3 no luck either.

I double checked every possibility to see why this setup behaves like it had crossfire enabled but could not find any reasonable solution.

I am suspecting the mother board now it is ASUS_M4A77TD_PRO (http://www.asus.com/Motherboards/AMD_AM3/M4A77TD_PRO/)
It has something called ATI CrossFireX™ Technology Support i tried to find that option in BIOS in order to disable it but to no avail.

Any ideas? Anybody else had an issue with this motherboard?

Thanks for your replies lads.

Regards,

pollus
jjiimm_64
Legendary
*
Offline Offline

Activity: 1680


View Profile
February 15, 2012, 04:14:01 PM
 #5

the whole thing is that I tried enabling crossfire then dissabling it.

The hardware is combined out of 2 5970s

Trying phoenix and poclbm miners bot hgive the same result.

Regardless which device I start the mhash /s will not exceed 300 if I start 2 that will device 300 in two if three the 300/3 if four then the system hangs.

I tried rebuilding the whole machine from the scratch same issue.

I tried different drivers 2.1 then 2.3 no luck either.

I double checked every possibility to see why this setup behaves like it had crossfire enabled but could not find any reasonable solution.

I am suspecting the mother board now it is ASUS_M4A77TD_PRO (http://www.asus.com/Motherboards/AMD_AM3/M4A77TD_PRO/)
It has something called ATI CrossFireX™ Technology Support i tried to find that option in BIOS in order to disable it but to no avail.

Any ideas? Anybody else had an issue with this motherboard?

Thanks for your replies lads.

Regards,

pollus


if it is mobo,  reset mobo to all defaults. 

1jimbitm6hAKTjKX4qurCNQubbnk2YsFw
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2002


Ruu \o/


View Profile WWW
February 16, 2012, 01:59:43 AM
 #6

export DISPLAY=:0

Also you will get more overclocking ability with 11.6 instead of 11.4.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!