Bitcoin Forum
December 09, 2016, 05:40:13 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Problem: ubuntu 11.10 cgminer latest  (Read 1803 times)
Chefnet
Hero Member
*****
Offline Offline

Activity: 686


View Profile
March 14, 2012, 03:09:17 PM
 #1

hi,

sorry i have searched the forum but not found it.
I have a rig with various cards (5870, 2x5850, 5970). Just installed with the guide from cgminer. When I want to mine only with 1 gpu all is okay, if I wnt to do it with all my hasrate is about 350mh/s overall cards?? I could not find what's wrong.
SDK 2.4
AMD 11.8 (fglrx)
Sempron 140
MSI 890FXA-GD70
2 gb ram
usb stick with 11.10
cgminer 2.3.1-2

Thank you for your help or link to the discussion I have not found.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Chefnet
Hero Member
*****
Offline Offline

Activity: 686


View Profile
March 14, 2012, 04:52:07 PM
 #2

and when I want to use bamt 0.5c the after the startscreen nothing is shown??

vampire
Hero Member
*****
Offline Offline

Activity: 574



View Profile
March 14, 2012, 09:45:59 PM
 #3

Did you run?

sudo aticonfig --adapter=all --initial
smracer
Donator
Legendary
*
Offline Offline

Activity: 1022



View Profile
March 14, 2012, 11:21:13 PM
 #4

try using 11.04 instead.

1smracer15yDLhJG27fd7GV3tegcNjtg2
Chefnet
Hero Member
*****
Offline Offline

Activity: 686


View Profile
March 15, 2012, 04:28:54 AM
 #5

Did you run?

sudo aticonfig --adapter=all --initial


yes I have run.
And why should I use 11.04?

Is there no one with more ideas?

Chefnet
Hero Member
*****
Offline Offline

Activity: 686


View Profile
March 15, 2012, 10:32:12 AM
 #6

export  of display was done before.
No one else with such a problem, and why is bamt not running?

P4man
Hero Member
*****
Offline Offline

Activity: 504



View Profile
March 15, 2012, 12:41:45 PM
 #7

Did you run?

sudo aticonfig --adapter=all --initial


yes I have run.

run it again after you added (or removed) a card, then reboot, then try again. You may also try with -f

sudo aticonfig --adapter=all --initial -f

Chefnet
Hero Member
*****
Offline Offline

Activity: 686


View Profile
March 15, 2012, 07:52:27 PM
 #8

so I have tested all, but it is all time the same.
Now I see the cpu (Sempron 140) is at 100% while mining. Is this the bottleneck?

vampire
Hero Member
*****
Offline Offline

Activity: 574



View Profile
March 15, 2012, 09:10:52 PM
 #9

so I have tested all, but it is all time the same.
Now I see the cpu (Sempron 140) is at 100% while mining. Is this the bottleneck?

You got AMD 11.8 (fglrx)


Why don't you install 11.6?
P4man
Hero Member
*****
Offline Offline

Activity: 504



View Profile
March 15, 2012, 10:09:38 PM
 #10

so I have tested all, but it is all time the same.
Now I see the cpu (Sempron 140) is at 100% while mining. Is this the bottleneck?

Oh, so all cards do show up in cgminer? Then yes, you could be running in to the infamous cpu % bug.
Try this:

export GPU_USE_SYNC_OBJECTS=1

then run cgminer.  If that doesnt work, is there a reason you arent using BAMT?

Chefnet
Hero Member
*****
Offline Offline

Activity: 686


View Profile
March 16, 2012, 04:49:18 AM
 #11

thx I will try.
I want to use bamt like described, but it don't startup. After the choice screen (stat, fal, ...) my screen is blank and nothing is going on.

export GPU_USE_SYNC_OBJECTS=1 don't work

now I'm downloading 11.12

bye

-ck
Moderator
Legendary
*
Offline Offline

Activity: 2002


Ruu \o/


View Profile WWW
March 17, 2012, 04:04:24 AM
 #12

Driver versions 11.7 to 11.10 on linux have high CPU usage of their own. Use either 11.6 or 11.11+ but be aware of the performance loss that comes with upgrading to a 12.x driver and the new SDK that comes with it.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
echris1
Full Member
***
Offline Offline

Activity: 124


View Profile
March 17, 2012, 04:34:52 PM
 #13

Driver versions 11.7 to 11.10 on linux have high CPU usage of their own. Use either 11.6 or 11.11+ but be aware of the performance loss that comes with upgrading to a 12.x driver and the new SDK that comes with it.

You can sort of cancel out that loss by using the diablo kernel in cgminer, at least it worked for me with 12.2 in lubuntu 11.10.
Chefnet
Hero Member
*****
Offline Offline

Activity: 686


View Profile
March 17, 2012, 07:29:15 PM
 #14

hi,

thx for help i will test it with 11.6 again, 11.12 shot my ubuntu, so i try a new one :-).

echris1
Full Member
***
Offline Offline

Activity: 124


View Profile
March 18, 2012, 04:53:11 AM
 #15

I don't think 11.6 works with Ubuntu 11.10.  Something about the kernel being bumped to version 3 makes 11.6 not install properly.
Chefnet
Hero Member
*****
Offline Offline

Activity: 686


View Profile
March 21, 2012, 05:04:33 AM
 #16

thx at all, after bamt won't mine and 11.10 make some extratrouble i use now ubuntu 11.04+fglrx 11.6+ sdk 2.4+ cgminer 2.3.1 and all is running (except the 5970 i have to test the card in another pc)

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!