Bitcoin Forum
September 24, 2017, 08:57:41 AM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Why is my miner picking up 4 devices when i only have 2 cards?  (Read 2393 times)
aaa801
Member
**
Offline Offline

Activity: 95



View Profile
April 02, 2012, 07:44:07 PM
 #1

Code:
[02/04/12 17:30:47] Started
[02/04/12 17:30:47] Connecting to: http://216.231.138.132:8338/
[02/04/12 17:30:47] Using AMD Accelerated Parallel Processing OpenCL 1.1 AMD-APP (851.4)
[02/04/12 17:30:49] BFI_INT patching enabled, disabling hardware check errors
[02/04/12 17:30:49] Added Cypress (#1) (18 CU, local work size of 128)
[02/04/12 17:30:52] BFI_INT patching enabled, disabling hardware check errors
[02/04/12 17:30:52] Added Cypress (#2) (18 CU, local work size of 128)
[02/04/12 17:30:52] Using ATI Stream OpenCL 1.0 ATI-Stream-v2.1 (145)
[02/04/12 17:31:00] BFI_INT patching enabled, disabling hardware check errors
[02/04/12 17:31:00] Added Cypress (#3) (18 CU, local work size of 128)
[02/04/12 17:31:07] BFI_INT patching enabled, disabling hardware check errors
[02/04/12 17:31:07] Added Cypress (#4) (18 CU, local work size of 128)

#1 and #3 seem to take forever to actualy hash anything

this is with using 2 5850's and using diablo miner, alnough i have had something similar in cgminer

LTC: LUUikznZrvDb65ZCNQUNCiTaCB4CWGYRSZ
BTC: 1325TrScK8jkiPuMEMxNf1VXHHfnR1QtgN
          ▄█████▄
        ▄█████████▄
      ▄████▀   ▀████▄
    ▄████▀   ▄ ▄█▀████▄
  ▄████▀   ▄███▀   ▀████▄
▄████▀   ▄███▀   ▄   ▀████▄
█████   ███▀   ▄███   █████
▀████▄   ▀██▄▄███▀   ▄████▀
  ▀████▄   ▀███▀   ▄████▀
    ▀████▄       ▄████▀
      ▀████▄   ▄████▀
        ▀███  ████▀
          ▀█▄███▀
.
|
.
|
          ▄█████▄
        ▄█████████▄
      ▄████▀   ▀████▄
    ▄████▀   ▄ ▄█▀████▄
  ▄████▀   ▄███▀   ▀████▄
▄████▀   ▄███▀   ▄   ▀████▄
█████   ███▀   ▄███   █████
▀████▄   ▀██▄▄███▀   ▄████▀
  ▀████▄   ▀███▀   ▄████▀
    ▀████▄       ▄████▀
      ▀████▄   ▄████▀
        ▀███  ████▀
          ▀█▄███▀
unthy
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
ssateneth
Legendary
*
Offline Offline

Activity: 1302



View Profile
April 02, 2012, 08:33:26 PM
 #2

You have both 2.1 SDK and some other SDK installed. Looks like 2.6 SDK, which is bad for radeon 5xxx. You need to specify manually what "devices" you want to mine on. You will want to mine on 2.1 sdk though because it is the most efficient for 5xxx

-ck
Moderator
Legendary
*
Offline Offline

Activity: 2282


Ruu \o/


View Profile WWW
April 04, 2012, 04:04:06 AM
 #3

Each "display enabled" device, be that in a configuration explicitly, or just by attaching it to a monitor, is seen as an opencl device. OpenCL is too stupid to tell apart 2 physical devices from one physical device attached to 2 monitors.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
ssateneth
Legendary
*
Offline Offline

Activity: 1302



View Profile
April 04, 2012, 10:15:35 PM
 #4

Each "display enabled" device, be that in a configuration explicitly, or just by attaching it to a monitor, is seen as an opencl device. OpenCL is too stupid to tell apart 2 physical devices from one physical device attached to 2 monitors.

Naybe, but this is irrelevant to his situation.

[02/04/12 17:30:47] Using AMD Accelerated Parallel Processing OpenCL 1.1 AMD-APP (851.4)
[02/04/12 17:30:52] Using ATI Stream OpenCL 1.0 ATI-Stream-v2.1 (145)

This is clearly a case of 2 installed SDK's.

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!