Bitcoin Forum
December 03, 2016, 09:54:33 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1] 2 »  All
  Print  
Author Topic: 1BTC bounty -- increase 7970 hashrate on bamt/cgminer  (Read 20138 times)
hashalfahalve
Member
**
Offline Offline

Activity: 100

Support the bitcoin economy, use BTC merchants


View Profile
April 11, 2012, 02:48:58 AM
 #1

Hi All,

Looking at the hardware wiki I saw people getting great hashrates with the 7970 with the lowest being 550 running on a windoze box and the average being ~650+.

I just got a shiny 7970 in the mail, and plugged it into bamt, installed the latest drivers and have it using cgminer instead of phoenix (phoenix wouldn't start at all).

It's mining with consistency at ~480mh.

1BTC to someone who can send me a pretty config file with optimal settings or point out something obvious I'm missing to get the hashrate up.

Yes, I'm a n00b.

Thanks!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480802073
Hero Member
*
Offline Offline

Posts: 1480802073

View Profile Personal Message (Offline)

Ignore
1480802073
Reply with quote  #2

1480802073
Report to moderator
1480802073
Hero Member
*
Offline Offline

Posts: 1480802073

View Profile Personal Message (Offline)

Ignore
1480802073
Reply with quote  #2

1480802073
Report to moderator
af_newbie
Legendary
*
Offline Offline

Activity: 896



View Profile
April 11, 2012, 02:58:38 AM
 #2

Save (edit pool info) the following as cgm.conf file:

{
"pools" : [
   {
      "url" : "http://pool.ABCPool.co:8332",
      "user" : "your id",
      "pass" : "pwd"
   },
   {
      "url" : "http://mine2.btcguild.com:8332",
      "user" : "your id",
      "pass" : "pass"
   }
],

"intensity" : "9",
"gpu-engine" : "1125",
"gpu-fan" : "0-85",
"gpu-memclock" : "975",
"gpu-powertune" : "0",
"temp-cutoff" : "95",
"temp-overheat" : "85",
"temp-target" : "75",
"auto-fan" : true,
"auto-gpu" : true,
"api-listen" : true,
"expiry" : "120",
"failover-only" : true,
"gpu-threads" : "5",
"log" : "5",
"quiet" : true,
"retry-pause" : "5",
"scan-time" : "45",
"temp-hysteresis" : "3",
"vectors" : "1",
"worksize" : "64",
"kernel" : "poclbm"
}


and run

 cgminer -c cgm.conf

This should give you 670s Mh/s, then you can increase gpu-engine clock to 1180, maybe 1200 to get 720 Mh/s

hashalfahalve
Member
**
Offline Offline

Activity: 100

Support the bitcoin economy, use BTC merchants


View Profile
April 11, 2012, 05:25:04 AM
 #3

And the winner of the million dollar, er, 1btc prize is af_newbie! Thank you sir! I currently have 0.86btc in my account, with about .2 pending, as soon as it hits 1 I'll send it all to you.  Grin


With increasing gpu-engine, is my only concern maintaining adequate cooling? Or are there other dangers I should be looking out for with changing that number?

af_newbie
Legendary
*
Offline Offline

Activity: 896



View Profile
April 11, 2012, 05:40:04 AM
 #4

And the winner of the million dollar, er, 1btc prize is af_newbie! Thank you sir! I currently have 0.86btc in my account, with about .2 pending, as soon as it hits 1 I'll send it all to you.  Grin


With increasing gpu-engine, is my only concern maintaining adequate cooling? Or are there other dangers I should be looking out for with changing that number?



You don't have to worry about cooling with one card.  I run three 7970 in a CM HAF case, temperature stays at 73C and fan at 55% the highest.

If you keep memory clock below engine clock by 150 MHz you should not experience any issues, even with clocks at 1200/1050

Undervolting (saving power) and underclocking memory (lowering temperatures and power usage) is what will cause crashes and will require lots of babysitting.  If you ever move to Windows, you can try my cgminer-wdog to keep your cgminer running.

You have to play with your card to find that sweet spot in terms of Mh/W and stability.  Every card is different (ASIC quality) so finding that point is kinda hit and miss.

 
hashalfahalve
Member
**
Offline Offline

Activity: 100

Support the bitcoin economy, use BTC merchants


View Profile
April 11, 2012, 04:36:11 PM
 #5



 cgminer -c cgm.conf



Does this config work for multiple cards? When I try it with two 7970 GPUs the computer shuts off completely. I think it might be an underrated PSU, but want to make sure I'm not missing anything obvious besides that.

DeathAndTaxes
Donator
Legendary
*
Offline Offline

Activity: 1218


Gerald Davis


View Profile
April 11, 2012, 04:38:17 PM
 #6



 cgminer -c cgm.conf



Does this config work for multiple cards? When I try it with two 7970 GPUs the computer shuts off completely. I think it might be an underrated PSU, but want to make sure I'm not missing anything obvious besides that.

Yes you can specify per GPU values like this
Code:
"gpu-engine" : "1125, 1050, 1125, 1070",

With one value it applies that value to all cards.  

Either way works.

Rig powering off sounds like a power issue.
hashalfahalve
Member
**
Offline Offline

Activity: 100

Support the bitcoin economy, use BTC merchants


View Profile
April 11, 2012, 05:01:54 PM
 #7

For some reason it looks like GPU0 is using the 1125 setting from the conf file, but GPU1 is set at 925.
af_newbie
Legendary
*
Offline Offline

Activity: 896



View Profile
April 11, 2012, 05:37:32 PM
 #8

For some reason it looks like GPU0 is using the 1125 setting from the conf file, but GPU1 is set at 925.

Your card is defaulting to stock clocks. Nothing cgminer can do about it.  Sometimes you'll find that 7970s will get "stuck" on specific clocks
and cgminer will not be able to set them to other values.  Try to change them from within cgminer but make sure the diff between engine and memory is kept at 150 MHz  (memory lower by 150).  Bigger spread will not work as cgminer uses ADL APIs and those will not work with larger difference in engine to memory clocks.

On Windows, I use Afterburner to set clocks to whatever I want BEFORE running cgminer.
Use GPU-Z sensor page to see what the card is actually running at.
hashalfahalve
Member
**
Offline Offline

Activity: 100

Support the bitcoin economy, use BTC merchants


View Profile
April 11, 2012, 06:36:42 PM
 #9

Shoot, I rebooted and now they're both stuck at 925..

I'm on BAMT, is there a bamt/debian utility to manually change the clock?

af_newbie
Legendary
*
Offline Offline

Activity: 896



View Profile
April 11, 2012, 06:51:40 PM
 #10

aticonfig does not work?
hashalfahalve
Member
**
Offline Offline

Activity: 100

Support the bitcoin economy, use BTC merchants


View Profile
April 11, 2012, 07:35:50 PM
 #11

Thanks, yes it seems to work though it's not very consistent. I set the max allowed clock and memory to 1200,1050

then in cgm.conf I set them at 1180,975 and it's running at 1180,1375

When it does run at 1200,1050 it seems to freeze up.

I'll have to keep playing around with it.

BTW I just sent your bounty many thanks for your continued help!
DeathAndTaxes
Donator
Legendary
*
Offline Offline

Activity: 1218


Gerald Davis


View Profile
April 11, 2012, 07:43:35 PM
 #12

then in cgm.conf I set them at 1180,975 and it's running at 1180,1375

answer was already given

1180 - 150 = 1030.  975 is too low so it resets to stock.

Quote
Try to change them from within cgminer but make sure the diff between engine and memory is kept at 150 MHz  (memory lower by 150).  Bigger spread will not work as cgminer uses ADL APIs and those will not work with larger difference in engine to memory clocks.

cgminer also has a mem-diff parameter.  You can set it to 150, set no memclock and cgminer will always set memclock to core clock - memdiff.
I'll have to keep playing around with it.
af_newbie
Legendary
*
Offline Offline

Activity: 896



View Profile
April 12, 2012, 08:40:43 AM
 #13

BTW I just sent your bounty many thanks for your continued help!

Thank you.  Much appreciated.
hashalfahalve
Member
**
Offline Offline

Activity: 100

Support the bitcoin economy, use BTC merchants


View Profile
April 12, 2012, 12:56:57 PM
 #14

I'm having an issue with the core clock winding down back to 925, do you have any thoughts on that? It will start running at the speeds I set, the memory clock doesn't change, but after a few minutes the core clock drops down to 925. I thought it might be the auto-gpu but the card isn't overheating, it's right at 66 degrees, and even when I take out auto-gpu it still drops down after a bit.

af_newbie
Legendary
*
Offline Offline

Activity: 896



View Profile
April 12, 2012, 01:40:37 PM
 #15

I'm having an issue with the core clock winding down back to 925, do you have any thoughts on that? It will start running at the speeds I set, the memory clock doesn't change, but after a few minutes the core clock drops down to 925. I thought it might be the auto-gpu but the card isn't overheating, it's right at 66 degrees, and even when I take out auto-gpu it still drops down after a bit.

I'd lower the engine clock to 1150 and see what happens.  You are probably pushing your card too hard and cgminer gets failures from the card and lowers the speed, or the card does it by itself.  If both engine and memory are reset to stock clocks, it was probably the card's BIOS doing the reset.
hashalfahalve
Member
**
Offline Offline

Activity: 100

Support the bitcoin economy, use BTC merchants


View Profile
April 12, 2012, 07:24:25 PM
 #16

It's weird.

I have two cards, and one is running happily at 1200/1050 without issue.

The other one the max I can get it at is 1165/1015. If I push it to 1170 even, it works for a few minutes then the hash rate dials down and down then cgminer says it's "sick" and dies.

Same card same brand/company.


So you're saying even though they're identical cards, they have different OC properties?
af_newbie
Legendary
*
Offline Offline

Activity: 896



View Profile
April 12, 2012, 09:09:31 PM
 #17

It's weird.

I have two cards, and one is running happily at 1200/1050 without issue.

The other one the max I can get it at is 1165/1015. If I push it to 1170 even, it works for a few minutes then the hash rate dials down and down then cgminer says it's "sick" and dies.

Same card same brand/company.


So you're saying even though they're identical cards, they have different OC properties?

Download GPU-Z, right click on the title bar, select ASIC quality.

Every card is different.  I have three sapphires, they are all 7970, same BIOS but are different.

JWU42
Legendary
*
Offline Offline

Activity: 1484


View Profile
April 14, 2012, 09:27:21 PM
 #18

I need to try again - never did get it (bamt and 7970s) to work about 4 weeks ago so stuck with lubuntu.


GPG PubKey | THREEMA | OTC | HeatWare | 1JWU42QLGFESoQCC4iPzUDTRiC9nx5bi95
1l1l11ll1l
Hero Member
*****
Offline Offline

Activity: 711


TheMerchantShop.com


View Profile WWW
April 29, 2012, 05:10:44 AM
 #19

Running BAMT, how can I see what memory clock my cards are at? Reading this thread I thinking they're probably not running at the rate I tell them to...

High Volume and/or High Risk Credit Card Processing. TheMerchantShop.com
JWU42
Legendary
*
Offline Offline

Activity: 1484


View Profile
April 29, 2012, 01:25:49 PM
 #20

7970 can run as low as engine less 150.

1050 Eng = 900 Mem
1125 Eng = 975 Mem

etc...

Hitting "G" in cgminer (which will be running in screen -- 'screen -r' will attach you) will show you all the details.

GPG PubKey | THREEMA | OTC | HeatWare | 1JWU42QLGFESoQCC4iPzUDTRiC9nx5bi95
Pages: [1] 2 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!