Bitcoin Forum
December 02, 2016, 06:20:10 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1] 2 »  All
  Print  
Author Topic: got problem with 5 x 5870  (Read 2479 times)
fuxianhui888
Full Member
***
Offline Offline

Activity: 205



View Profile
June 01, 2012, 12:14:41 AM
 #1

I tried to run 5 5870 with BAMT,but after couple minutes,BAMT  crashed(mouse doesn't move,keyboard doesn't work,stop mining,no network),have to restart again,
anybody has any ideas?
1480702810
Hero Member
*
Offline Offline

Posts: 1480702810

View Profile Personal Message (Offline)

Ignore
1480702810
Reply with quote  #2

1480702810
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480702810
Hero Member
*
Offline Offline

Posts: 1480702810

View Profile Personal Message (Offline)

Ignore
1480702810
Reply with quote  #2

1480702810
Report to moderator
1480702810
Hero Member
*
Offline Offline

Posts: 1480702810

View Profile Personal Message (Offline)

Ignore
1480702810
Reply with quote  #2

1480702810
Report to moderator
TheHarbinger
Sr. Member
****
Offline Offline

Activity: 378


Why is it so damn hot in here?


View Profile
June 01, 2012, 12:52:57 AM
 #2

I tried to run 5 5870 with BAMT,but after couple minutes,BAMT  crashed(mouse doesn't move,keyboard doesn't work,stop mining,no network),have to restart again,
anybody has any ideas?


You set your setting up incorrectly.

12Um6jfDE7q6crm1s6tSksMvda8s1hZ3Vj
fuxianhui888
Full Member
***
Offline Offline

Activity: 205



View Profile
June 01, 2012, 01:07:53 AM
 #3

I tried to run 5 5870 with BAMT,but after couple minutes,BAMT  crashed(mouse doesn't move,keyboard doesn't work,stop mining,no network),have to restart again,
anybody has any ideas?


You set your setting up incorrectly.


but it  works in the first five minutes,
Dargo
Legendary
*
Offline Offline

Activity: 1554



View Profile
June 01, 2012, 01:12:50 AM
 #4

Haven't you been having trouble with this for a while? It's little hard to advise w/o reviewing what you have tried so far, but here are some basic suggestions. I got 5x5850 going on BAMT, but it was pretty unstable at first. You have probably already tried this, but if you have made *any* hardware configuration changes, even if they seem trivial, boot from a fresh copy of BAMT. At one point I swapped one 5850 for another, so the two were in different slots, and BAMT completely freaked out about this. I had to start over with a fresh copy. Also, you might try being uber anal about that fresh copy, as in write zeros to the usb drive to completely wipe it and then use dd in linux as opposed to win32diskimager to copy the image. Another thing to try is to get the cards going manually in phoenix - i.e. cd /opt/miners/phoenix - and start each card manually. If you can get all 5 going this way, this will at least tell you that the problem is specific to the process of starting automatically from the configuration script. Also, try starting your GPUs with *REALLY* moderate settings (like 600/500 core/clock at stock voltage). If they work this way, you know you are pushing the clocks of one or more GPUs too much. If they still don't work, lower the voltage - then if they work you know your PSU can't handle 5 cards at stock voltage.

I think BAMT is awesome, but for me it did a lot of really strange things. I know it's supposed to be essentially plug and play, but in my experience it was a bit less friendly than this. I've switched now to cgminer on a flavor of ubuntu 11.04 (Peppermint Two), and I'm liking this better. I definitely recommend cgminer if you can't get BAMT working.
fuxianhui888
Full Member
***
Offline Offline

Activity: 205



View Profile
June 01, 2012, 01:27:36 AM
 #5

here 's my setting

Code:
# Big A Miner Thing configuration
# /etc/bamt/bamt.conf
#
# When done editing, restart mining to make changes here take effect
# If you're just setting up BAMT, be sure to edit pools as well.
#
# As of 0.5, many less common options have been removed from this
# default config to make it easier on the noobs.
#
# You will find a complete example with all options described
# at /opt/bamt/examples/bamt.conf
#
# Note: This is a YAML file.  Indentation is significant.
#
# If you break things badly, a backup of this file in it's original
# form can be found at /opt/bamt/examples/bamt.conf.simple
#


---
settings:

  # miner_id is used to set hostname and identify this rig to munin and
  # other processes
  # IMPORTANT! miner_id must be a valid hostname: all lower case, no weird
  # characters, underscores, periods, or spaces. Dash and numbers are ok.

  miner_id: bamt-miner

  # loc is any additional string you wish to use to identify or group this rig

  miner_loc: unspecified location

  # should we monitor the cards? 1 = yes, 0 = no

  do_monitor: 0

  # if monitoring, how do we send email alerts?

  # these are required..

  # smtp_host: smtp.gmail.com
  # smtp_to: you@yourmail.com
 
  # these are optional..

  # smtp_from: somefrom@address
  # smtp_subject: I wanted a custom subject in my alerts...
  # smtp_port: 587
  # smtp_auth_user: user@where
  # smtp_auth_pass: secret
  # smtp_tls: 1
  # smtp_ssl: 1

 
 
# GPU Configurtation

# You'll need one gpuX: section per GPU installed.  Not sure what's installed,
# or the order?  Open a root shell and type:  aticonfig --list-adapters
#
# You can delete gpu sections if you don't have that many cards.. or add more
# if you find a way to run them



gpu0:

  # remove disabled: or set it to 0 to actually use this card..

  disabled: 0

 
  # overclocking.. all are optional 

  # optional command to execute prior to overclocking
  # any valid command (or the path to a script) is fine

  # pre_oc_cmd:


  # (core/mem)_X = the value to set for this profile (0-2)
  # Profile 2 is used while mining, but setting values
  # in profile 2 that are *lower* than the values in the other
  # profiles is not allowed on some GPUs, so you have to adjust
  # the other profiles as well.
  # For instance, to get 300Mhz mem clock on my 5830s, I have
  # to set all 3 profiles to 300.


  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  core_speed_2: 900
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000
  core_voltage_2: 1.05
  # recommend to set and forget fan, preferably at 100
 
  fan_speed: 40

  # optional command to execute after overclocking
  # post_oc_cmd:


  # Phoenix mining setup (see full example for how to use cgminer instead)
  # We strongly recommend you use phoenix at, least until you are familiar
  # with BAMT

  # kernel to use.. one of:  phatk phatk2 poclbm
  # if in doubt, use phatk2

  kernel: phatk2

  # phoenix style kernel params.  *do not* include DEVICE=x, otherwise
  # exactly same as any phoenix setup. 
  # if in doubt: BFI_INT VECTORS AGGRESSION=11
  # (though 9 on GPU0 often makes using the GUI more pleasant)

  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=9


  # Pool file

  # IMPORTANT: pool_file must contain a list of pool URLs.. one at least, more if
  # you like.  You can share the same file for all GPUs, or have one for each.
  # Miner will start with first URL in file, however if no shares are accepted
  # for any reason in (pool_timeout) seconds, the miner will move to next URL
  # in the file.  Wraps around to first URL when last one fails.
  # You can also set pool specific values, see the example pools file.
  # if in doubt: /etc/bamt/pools

  pool_file: /etc/bamt/pools

  # max time to allow phoenix to run without finding a share..
  # exceed this and we kill phoenix, start a new instance with
  # next line in pools file

  pool_timeout: 180



  # monitoring limits, used by email alerts and gpumon
  # an alert is generated if the current value goes below a 'lo'
  # or above a 'hi'.

  # GPU temp sensor reading (in C)
  monitor_temp_lo: 45
  monitor_temp_hi: 80

  # GPU load (in %)
  monitor_load_lo: 80

  # average hashrate (in mh/s)
  monitor_hash_lo: 125

  # fam rpm (in rpm)
  monitor_fan_lo: 2000

  # effective reject rate (in % of total)
  monitor_reject_hi: 2



# OK.. hopefully you get the idea.  Stubs for additional GPUs below.
# There are many additional paramters to help you deal with various
# scenarios, see /opt/bamt/examples and the docs (if we write some)


gpu1:
  disabled: 0
  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 1060
  core_speed_2: 900
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 1120
  mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000
  core_voltage_2: 1.05
  fan_speed: 30

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_fan_lo: 2000
  monitor_reject_hi: 1


gpu2:
  disabled: 0

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  core_speed_2: 900
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000
  core_voltage_2: 1.05
  fan_speed: 30

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_fan_lo: 2000
  monitor_reject_hi: 1



gpu3:
  disabled: 0
 
  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  core_speed_2: 900
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000
  core_voltage_2: 1.05
  fan_speed: 35

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_fan_lo: 2000
  monitor_reject_hi: 1


gpu4:
  disabled: 0

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  core_speed_2: 900
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000
  core_voltage_2: 1.05
  fan_speed: 40

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1


gpu5:
  disabled: 1

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  core_speed_2: 900
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000
  core_voltage_2: 1.05
  fan_speed: 50

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1


gpu6:
  disabled: 1

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 100

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1


gpu7:
  disabled: 1

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 100

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_shares_lo: 1
fuxianhui888
Full Member
***
Offline Offline

Activity: 205



View Profile
June 01, 2012, 01:30:41 AM
 #6

Haven't you been having trouble with this for a while? It's little hard to advise w/o reviewing what you have tried so far, but here are some basic suggestions. I got 5x5850 going on BAMT, but it was pretty unstable at first. You have probably already tried this, but if you have made *any* hardware configuration changes, even if they seem trivial, boot from a fresh copy of BAMT. At one point I swapped one 5850 for another, so the two were in different slots, and BAMT completely freaked out about this. I had to start over with a fresh copy. Also, you might try being uber anal about that fresh copy, as in write zeros to the usb drive to completely wipe it and then use dd in linux as opposed to win32diskimager to copy the image. Another thing to try is to get the cards going manually in phoenix - i.e. cd /opt/miners/phoenix - and start each card manually. If you can get all 5 going this way, this will at least tell you that the problem is specific to the process of starting automatically from the configuration script. Also, try starting your GPUs with *REALLY* moderate settings (like 600/500 core/clock at stock voltage). If they work this way, you know you are pushing the clocks of one or more GPUs too much. If they still don't work, lower the voltage - then if they work you know your PSU can't handle 5 cards at stock voltage.

I think BAMT is awesome, but for me it did a lot of really strange things. I know it's supposed to be essentially plug and play, but in my experience it was a bit less friendly than this. I've switched now to cgminer on a flavor of ubuntu 11.04 (Peppermint Two), and I'm liking this better. I definitely recommend cgminer if you can't get BAMT working.


thanks for your suggestion,I will try Smiley Smiley Smiley Smiley
Dargo
Legendary
*
Offline Offline

Activity: 1554



View Profile
June 01, 2012, 01:44:19 AM
 #7

Looking at your config file, the first thing to try is backing way off of 900 as your core speed. You are are at 1.05 volts, so you are undervolting, and at that voltage 900 is *really* optimistic. Drop down to 600 to start, and I would also raise your memory clock to at least 450 - I have one 5850 that doesn't like to clock much below that. If you can get all 5 working with these moderate settings, then you can start raising the core/lowering the memory to find out where your cards are getting unstable. If you still can't get all 5 working that way, then try one card at a time by disabling the other four to see if it is just one card giving you trouble. Also, what motherboard are you using? I have read that for some motherboards you have to go into bios and change the latency timer to get 5 cards working. The needed change is to go from 64 --> 96. This didn't seem to matter for my biostar, but I read that gigabyte boards need this setting changed. 
rjk
Sr. Member
****
Offline Offline

Activity: 420


1ngldh


View Profile
June 01, 2012, 01:46:29 AM
 #8

850/160 works great on 5870s

Mining Rig Extraordinaire - the Trenton BPX6806 18-slot PCIe backplane [PICS] Dead project is dead, all hail the coming of the mighty ASIC!
Dargo
Legendary
*
Offline Offline

Activity: 1554



View Profile
June 01, 2012, 01:55:06 AM
 #9

850/160 works great on 5870s

Probably so, but the OP needs to troubleshoot here, so it would be better to start with something really modest to find out if the issue is the clock settings or something else entirely. I have 6 5850s, and all of them are fine with going to 150 memory setting, except one, which gets unhappy much below 450. So it may be that in general 5870s are fine with 850/160 @1.05 volts, but it doesn't follow that all the OP's 5870s are happy with this.
fuxianhui888
Full Member
***
Offline Offline

Activity: 205



View Profile
June 01, 2012, 02:03:03 AM
 #10

850/160 works great on 5870s

your core voltage and  mhash?
rjk
Sr. Member
****
Offline Offline

Activity: 420


1ngldh


View Profile
June 01, 2012, 02:04:38 AM
 #11

850/160 works great on 5870s

what's your core voltage?
Anywhere from 1.125 to 1.175, i.e. stock. If you are undervolting, those probably won't work.

Mining Rig Extraordinaire - the Trenton BPX6806 18-slot PCIe backplane [PICS] Dead project is dead, all hail the coming of the mighty ASIC!
fuxianhui888
Full Member
***
Offline Offline

Activity: 205



View Profile
June 01, 2012, 02:30:53 AM
 #12

just can get about 333mhash when I set it to 850/150(I can get 410+before when I set to 900/300,big difference)
still testing if it is stable!

thanks for all the suggestions!thanks
rjk
Sr. Member
****
Offline Offline

Activity: 420


1ngldh


View Profile
June 01, 2012, 02:32:44 AM
 #13

just can get about 333mhash when I set it to 850/150(I can get 410+before when I set to 900/300,big difference)
still testing if it is stable!

thanks for all the suggestions!thanks
wtf 333 is wrong, you must have wrong vectors or something. Sorry I don't have rigs running right now so I can't check.

Mining Rig Extraordinaire - the Trenton BPX6806 18-slot PCIe backplane [PICS] Dead project is dead, all hail the coming of the mighty ASIC!
ssateneth
Legendary
*
Offline Offline

Activity: 1288



View Profile
June 01, 2012, 02:49:47 AM
 #14

just can get about 333mhash when I set it to 850/150(I can get 410+before when I set to 900/300,big difference)
still testing if it is stable!

thanks for all the suggestions!thanks
wtf 333 is wrong, you must have wrong vectors or something. Sorry I don't have rigs running right now so I can't check.

that sounds like he is using a worksize of 256, which likes 300+ memory and hates 150ish memory. 150ish is only good for 128 worksize.

Dargo
Legendary
*
Offline Offline

Activity: 1554



View Profile
June 01, 2012, 02:51:30 AM
 #15

just can get about 333mhash when I set it to 850/150(I can get 410+before when I set to 900/300,big difference)
still testing if it is stable!

thanks for all the suggestions!thanks
wtf 333 is wrong, you must have wrong vectors or something. Sorry I don't have rigs running right now so I can't check.

Add WORKSIZE=128 to your flags. Right now, you are using the default (256), which is probably too large for mem=150. If that doesn't help, go back to mem=300 and try both 128 and 256 as your worksize. You might even try 64 for your worksize - I think some people get best results with that, but 128 is best for me.

I also noticed a weird thing with BAMT where mem=250 (and I think worksize 256) gave me a boost in reported hash rate. But as far as I could tell it actually throttled my share submission rate, so I didn't stick with it.
rjk
Sr. Member
****
Offline Offline

Activity: 420


1ngldh


View Profile
June 01, 2012, 02:53:06 AM
 #16

Probably is the worksize. Note that I said 160, not 150. For a negligible power bump, you get a few more hashes with that. That is assuming a core of 850 to 900 or so.

Mining Rig Extraordinaire - the Trenton BPX6806 18-slot PCIe backplane [PICS] Dead project is dead, all hail the coming of the mighty ASIC!
ssateneth
Legendary
*
Offline Offline

Activity: 1288



View Profile
June 01, 2012, 09:12:20 AM
 #17

Probably is the worksize. Note that I said 160, not 150. For a negligible power bump, you get a few more hashes with that. That is assuming a core of 850 to 900 or so.

+1 for truth. Mind, memory frequencies are approximate. It's hard to explain without rambling, but if you have a bunch of 5830's (different VGA BIOS -may- cause a difference due to possibly different memory latencies coded in. Untested) at a certain core frequency, they should all have a the same "favorite" memory frequency. If you have a 5870 at the same core frequency though, it won't have the same "favorite" as the 5830's as I've found. My 5870's prefer a slightly lower memory at a certain core compared to my 5830's.

dreamwatcher
Legendary
*
Offline Offline

Activity: 1050


View Profile WWW
June 03, 2012, 04:12:32 AM
 #18

850/160 works great on 5870s

what's your core voltage?
Anywhere from 1.125 to 1.175, i.e. stock. If you are undervolting, those probably won't work.

Interesting , I have 3 5870's.

The 2 reference design cards, I am running at 875 mhz core, 150 mhz mem @ 1.025v and getting around around 401 Mh/s for each one.

Then I have the big boy with the arctic cooling set up, 1000 mhz core, 150 mhz mem @ 1.080v and getting around 450 mh/s.... Grin

Using Cgminer 2.4.1 with a 128 work size, 2 vectors..phatk kernel with 11.11 catalyst drivers.

fuxianhui888
Full Member
***
Offline Offline

Activity: 205



View Profile
June 05, 2012, 02:15:13 AM
 #19

I set the WORKSIZE=128 today,and I got 373 per card right now

I got another problem,I am using powerline ,but after couple hours,the  network  disconnected, and it won't reconnect,I have to do it manually,anybody has anycode can check the connection and can reconnect automatically?
thanks everyone!
fuxianhui888
Full Member
***
Offline Offline

Activity: 205



View Profile
June 05, 2012, 05:51:31 PM
 #20

solved loss network problem by following this link:
http://www.bitcointrading.com/forum/index.php?topic=416.msg1235#msg1235

still testing
Pages: [1] 2 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!