Bitcoin Forum
December 05, 2016, 02:48:53 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Second GPU running slow with guiminer / diablominer  (Read 2079 times)
yuhannl
Jr. Member
*
Offline Offline

Activity: 33


View Profile
June 13, 2012, 03:36:08 PM
 #1

Howdy all, figured this is probably a good place to start...

I've just setup a rig with 2 x ATI HD 7870, running on Windows Server 2008 R2 and got everything configured (ATI Catalyst / OpenCL drivers, etc).

When running guiminer for some reason the first GPU runs at a decent speed of some 400MH/s, but the second GPU runs at a mere 38MH/s. At some point in time during one of the re-installs I think I did something and caused it to function properly and was doing some 800MH/s in total - only to find out the next morning that the 2nd GPU's gone back down to slug speed. Maybe I was dreaming?

Anyhow, tried BAMT, and got some issues there but won't go into details here and will just focus on windows for now. Tried Windows 7 x64 and had the same result. Rather mind boggling and wouldn't mind ripping my hair out but I'd start to look older than the colleagues at work... Wink

Now, I don't believe there's any hardware faults. I've tried to mine with only the 2nd GPU plugged in (same slot) and on it's own it works beautifully. Got a decent power supply and the rig does stuff all apart from just running a tiny SSD - system runs at some <200 watts.
 
I've tried both guiminer and even just poclbm on it's own with GPU 2 only and had same result there.

I did have the crossfire cable installed previously but have taken it out after what I read about ppl's comment saying it's best to be left out.

Any help will be very appreciated =) Before I lose any hair I suppose.. heh.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480906133
Hero Member
*
Offline Offline

Posts: 1480906133

View Profile Personal Message (Offline)

Ignore
1480906133
Reply with quote  #2

1480906133
Report to moderator
1480906133
Hero Member
*
Offline Offline

Posts: 1480906133

View Profile Personal Message (Offline)

Ignore
1480906133
Reply with quote  #2

1480906133
Report to moderator
1480906133
Hero Member
*
Offline Offline

Posts: 1480906133

View Profile Personal Message (Offline)

Ignore
1480906133
Reply with quote  #2

1480906133
Report to moderator
yuhannl
Jr. Member
*
Offline Offline

Activity: 33


View Profile
June 13, 2012, 03:42:05 PM
 #2

Maybe worthwhile to add that I've tried both Catalyst 12.4 / 12.6 beta and obviously with appropriate x64 parts.
GPU-z shows both GPUs have opencl support etc, and stats both look the same.

SAD_MAN
Newbie
*
Offline Offline

Activity: 15



View Profile WWW
June 13, 2012, 10:12:03 PM
 #3

I had a similar issue with my 5850...after a couple of hours mining it would slow down. I would just reset the clocks with Sapphire TRIXX to make it mine fast again.
Don't know if that will help in your case anyway. Good luck!

I am attempting to live, don't judge me, please.
yuhannl
Jr. Member
*
Offline Offline

Activity: 33


View Profile
June 13, 2012, 11:17:22 PM
 #4

sad_man - yeah, you're right. Just popped on afterburner and checked out the stats, GPU1 is running at full speed (1100MHz) and GPU2 runs at a mere 150MHz. What did you have to do to reset the speed...?
SAD_MAN
Newbie
*
Offline Offline

Activity: 15



View Profile WWW
June 14, 2012, 11:33:51 AM
 #5

In my case I only had to change the mem clock to any other value, and that would make the mining speed get to full again.
Hope it helps

I am attempting to live, don't judge me, please.
yuhannl
Jr. Member
*
Offline Offline

Activity: 33


View Profile
June 14, 2012, 12:47:48 PM
 #6

sad_man thanks for the info.

What I end up doing this time round are as follows -

- do a clean build (windows 2008 server 2 sp1 standard edition)
- install necessary chipset drivers
- install ONLY the catalyst drivers required for the video cards thru device manager (i.e. not installing from the catalyst package)
- install vc 2008 redistributables (x86)
- drop in guiminer and configure 2 opencl miners using -v -w 128

and.. voila! Getting 750+ MH/s, guess we'll have to do a bit more tweaking I suppose but certainly better than not getting any juice from the second GPU like before.... Wink

Gonna monitor the rig for 24 hours and see whether it continues to hash at that rate.

Hopefully this will help others who might come along and wanting to do the same thing.

yuhannl
Jr. Member
*
Offline Offline

Activity: 33


View Profile
June 16, 2012, 12:58:19 PM
 #7

Darn, restarted computer just so I can check out the wattage, but guess what, 2nd GPU gone slow mode again!

-ck
Staff
Legendary
*
Offline Offline

Activity: 1988


Ruu \o/


View Profile WWW
June 16, 2012, 01:06:49 PM
 #8

12.4 driver has a bug that enables ULPS on the 2nd+ GPUs. Downgrade drivers or search google for "disable ULPS". Some regedit shit on windows will fix it.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
yuhannl
Jr. Member
*
Offline Offline

Activity: 33


View Profile
June 16, 2012, 01:56:41 PM
 #9

Man, so much hassle, and finally resolved it.. I guess it is the driver indeed. Using 12.3 now, and happily hashing along.

System idle - 58W
Full Load - 218W
Hash Rate - ~800MH/s

Thanks for the help....... Wink
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!