Bitcoin Forum
December 11, 2016, 06:28:43 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: GuiMiner - Use on Local Network Failed to Connect. And Too many Sockets?  (Read 5633 times)
windygamer
Newbie
*
Offline Offline

Activity: 4



View Profile
May 24, 2011, 05:04:43 AM
 #1

After a lot of searching and false turns, I finally found GuiMiner to make use of my two computers both with NVidia cards. So Thumbs up on a reasonable program for using GPUs for mining.  Grin

I know I'm bucking the trend here, but I want to Solo mine on my two machines and point them both to the same BitCoin instance running on one of the machines to collect any coins in one account.

I've got it running locally on one machine which has a GTX 470.
And it connects to localhost on that machine to an instance of BitCoin.exe. That seems to work fine and I'm getting 84MH. Which we can talk about later if that seems like a problem.

The other machine has a GTX 260, so I'd like to fire it up too.
But I can't connect between the machines.

Both machines are running Win 7 x64.

I've opened the firewall for BitCoin and for guiminer.exe and for poclbm.exe for both Home/work(private) and Public networks.
I'm guessing that I don't need to open it for guiminer.exe, but at this point I'm not sure.
Using TcpView ( from here if you've not seen it: http://technet.microsoft.com/en-us/sysinternals/bb897437 ) I see that poclbm.exe is trying to connect to the machine running BitCoin.
When I start the guiminer the following appears in the guiminer console:
Quote
2011-05-23 21:47:33: Running command: poclbm.exe --user=uuuuu --pass=ppppp -o cyberstorm -p 8332 -d0 --verbose
2011-05-23 21:47:33: Listener for "Default" started
2011-05-23 21:47:43: Listener for "Default": 23/05/2011 21:47:43, Problems communicating with bitcoin RPC
2011-05-23 21:47:54: Listener for "Default": 23/05/2011 21:47:54, Problems communicating with bitcoin RPC
2011-05-23 21:48:05: Listener for "Default": 23/05/2011 21:48:05, Problems communicating with bitcoin RPC
2011-05-23 21:48:16: Listener for "Default": 23/05/2011 21:48:16, Problems communicating with bitcoin RPC

Oddly enough. Using TCPView on the local machine shows this:
bitcoin.exe:2464   TCP   AlienStorm:8333   AlienStorm:0   LISTENING   

How strange. The local machine appears to be listening on 8333.
Is this because 8332 is used on the other machine, and they both need to be unique over the public network since I'm behind a NAT router?
So to connect to my local machine I have to use port 8333. Ok I guess I can deal with that.

But I'd like to use the other machine on the network.

Any clue why guiminer [poclbm.exe] can't connect to cyberstorm?
Actually, it does not appear to be able to connect to the local machine either.

TCPview shows a pile of strange entries:
Quote
[System Process]:0   TCP   AlienStorm:8332   localhost:55859   TIME_WAIT   
[System Process]:0   TCP   alienstorm:56297   192.168.1.1:65535   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56296   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   alienstorm:56300   192.168.1.1:60001   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56299   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56302   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56306   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56309   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56311   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56313   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56316   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56319   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56321   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56323   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56328   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56332   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56334   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56336   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56340   localhost:8333   TIME_WAIT   
[System Process]:0   TCP   AlienStorm:56342   localhost:8333   TIME_WAIT   
bitcoin.exe:2464   TCP   AlienStorm:8333   AlienStorm:0   LISTENING   
   

Not knowing any better, I would guess that someone is not cleaning up their failed sockets.
But I do see this:
Quote
poclbm.exe:1440   TCP   AlienStorm:56344   localhost:8333   ESTABLISHED   

Which leads me to guess that the problem is not that the connection can't be established, but that the protocol fails in some other way.

Thanks for your help.
WG




Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481437723
Hero Member
*
Offline Offline

Posts: 1481437723

View Profile Personal Message (Offline)

Ignore
1481437723
Reply with quote  #2

1481437723
Report to moderator
1481437723
Hero Member
*
Offline Offline

Posts: 1481437723

View Profile Personal Message (Offline)

Ignore
1481437723
Reply with quote  #2

1481437723
Report to moderator
1481437723
Hero Member
*
Offline Offline

Posts: 1481437723

View Profile Personal Message (Offline)

Ignore
1481437723
Reply with quote  #2

1481437723
Report to moderator
windygamer
Newbie
*
Offline Offline

Activity: 4



View Profile
May 24, 2011, 06:45:15 AM
 #2

Not clear what changed, but now localhost works with the same local server.

Does the Bitcoin server need to complete loading the blocks or something before mining succeeds?
Seems like there was a communication error, and now it's working fine. Locally. 39 Mh/s, which is about what I'd expect from a GTX 260.

I still can't connect to the remote host to mine into a single instance of bitcoin.exe on my network.

Thanks,
wg
foggyb
Legendary
*
Offline Offline

Activity: 1302


View Profile
May 24, 2011, 05:32:37 PM
 #3

Same problem here: Server is Win7 x64 SP1 and client is Win7 x32 with no updates.

I'm going to try XP next on client.

I noticed some weird behaviour also. Locally I was able to get GUIminer working, but then I tried to repeat my results, I can no longer connect to local bitcoin server.'

GUIminer client on remote client PC is stuck in "connecting" mode.


Here is my TCP/IP scan:



Seems to show local GUIminer is connected at 8332, but GUIminer doesn't think so.
windygamer
Newbie
*
Offline Offline

Activity: 4



View Profile
May 25, 2011, 05:03:47 AM
 #4

After running for a couple of days I see:

Accepted
1775 (68)

On the summary page.
Any clue what this means?
Something like 1776 hashes found, and 68 are still being worked on?
Stale is just a -, which I'm guessing means that these have been claimed by someone else, or are otherwise unavailable.

Also, any guidance about how long before I might actually see a coin or two?
It would seem from these results that I'm repeating a large number of solutions that other folks have already claimed, so I'm not getting any coins.

I'm just trying to confirm that things are actually working.
The main bitcoin display is completely devoid of any useful display at this point.

Since I'm not able to connect the two machines to the same bitcoin instance, but rather there are two instances, I presume that the two systems are solving the same hashes, which is certainly sub-optimal. Am I correct in assuming that if the two machines were talking to the same instance then they would divide the work without duplication?

Thanks,
wg
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!