Bitcoin Forum
November 14, 2018, 10:02:33 AM *
News: Latest Bitcoin Core release: 0.17.0 [Torrent].
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: [Fixed] Email addressess are displayed on profile page by default for new users  (Read 554 times)
Blazr
Hero Member
*****
Offline Offline

Activity: 882
Merit: 1001



View Profile
September 27, 2015, 09:14:14 AM
 #1

I notice that email addresses are now being shown on profile pages of new accounts by default. One account here has likely been hacked due to this (insecure email address). IIRC one of the first changes Satoshi made to SMF when he created this forum was to disable showing emails by default, any reason why this was changed or is it a mistake?

1542189753
Hero Member
*
Offline Offline

Posts: 1542189753

View Profile Personal Message (Offline)

Ignore
1542189753
Reply with quote  #2

1542189753
Report to moderator
1542189753
Hero Member
*
Offline Offline

Posts: 1542189753

View Profile Personal Message (Offline)

Ignore
1542189753
Reply with quote  #2

1542189753
Report to moderator
1542189753
Hero Member
*
Offline Offline

Posts: 1542189753

View Profile Personal Message (Offline)

Ignore
1542189753
Reply with quote  #2

1542189753
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1542189753
Hero Member
*
Offline Offline

Posts: 1542189753

View Profile Personal Message (Offline)

Ignore
1542189753
Reply with quote  #2

1542189753
Report to moderator
1542189753
Hero Member
*
Offline Offline

Posts: 1542189753

View Profile Personal Message (Offline)

Ignore
1542189753
Reply with quote  #2

1542189753
Report to moderator
accountbuyer103_hacked
Newbie
*
Offline Offline

Activity: 7
Merit: 0


View Profile
September 27, 2015, 11:45:11 AM
 #2

Thanks for reporting this, maybe it will help someone
Edit: this is a dream come true for email farmers.
Athertle
Sr. Member
****
Offline Offline

Activity: 252
Merit: 250


Go figure! | I'm nearing 1337 posts...


View Profile WWW
September 27, 2015, 11:51:26 AM
 #3

This is almost 100% a bug. I went through and created an account from scratch (here); the checkbox for "hide my email from the public" was checked by default, but when I created the account the setting switched to being public automatically.

This is a bug that needs to be fixed.

accountbuyer103_hacked
Newbie
*
Offline Offline

Activity: 7
Merit: 0


View Profile
September 27, 2015, 11:58:02 AM
 #4

http://snag.gy/Kzwao.jpg (Would be good if someone can quote it)
Proof that what blazr said is indeed true
alani123
Legendary
*
Offline Offline

Activity: 1834
Merit: 1039



View Profile
September 27, 2015, 12:04:17 PM
 #5

Try going in incognito and hit register. Email being hidden is ticked.

This issue was fixed, long, long ago.

"Hide email address from public?" should be selected by default on https://bitcointalk.org/index.php?action=profile;sa=account


This has been the case since 2009...

I left the admin account set to the original SMF theme so if I somehow completely wedge the custom theme I can still get in to fix it.

I've got a neat little 12x12 coin image to replace those pip stars with.  Should look nice.  Also some nice button images to try.

The registration page has "hide your e-mail address" unchecked by default.  I must fix that in php before we can open up.

The Announcements forum is currently moderator access only.



███             ▄▄▄███████▄▄▄          ████                   ████          ▄▄▄███████▄▄▄         
███         ▄███████████████████▄       ████                 ████       ▄███████████████████▄     
███       ▄██████▀▀       ▀▀██████▄      ████               ████      ▄██████▀▀       ▀▀██████▄   
███      █████▀               ▀█████      ████             ████      █████▀               ▀█████ 
███    ▐████▀                   ▀████▌     ████           ████     ▐████▀                   ▀████▌
███    ████▌                     ▐████      ████         ████      ████▌                     ▐████
███    ████                       ████       ████       ████       ████                       ████
███    ████                       ████        ████     ████        ████                       ████
███    ████▌                     ▐████         ████   ████         ████▌                     ▐████
███    ▐████▄                   ▄████▌          ████ ████          ▐████▄                   ▄████▌
███      █████▄               ▄█████             ███████             █████▄               ▄█████ 
███       ▀██████▄▄       ▄▄██████▀               █████               ▀██████▄▄       ▄▄██████▀   
███         ▀███████████████████▀                  ███                  ▀███████████████████▀     
███             ▀▀▀███████▀▀▀                       █                       ▀▀▀███████▀▀▀         
INTERNET OF VALUE OMNILEDGER
|
   
   
 
 
|


             ▄████▄▄   ▄
█▄          ██████████▀▄
███        ███████████▀
▐████▄     ██████████▌
▄▄██████▄▄▄▄█████████▌
▀████████████████████
  ▀█████████████████
  ▄▄███████████████
   ▀█████████████▀
    ▄▄█████████▀
▀▀██████████▀
    ▀▀▀▀▀
M
 

             █▀▀▀▄▄▄██▄
             █     ▀██▀
            █
         ▄▄▄█▄▄▄
 ████▄▄███████████▄▄████
▐██████▀▀███████▀▀██████▌
 ▀████    █████    ████▀
  ████▄  ▄█████▄  ▄████
  ▀███████████████████▀
   ▀████▄▀█████▀▄████▀
     ▀▀███▄▄▄▄▄███▀▀
         ▀▀▀▀▀▀▀
 

    ▄█████
   ████▀▀▀
   ████
   ████
██████████
▀▀▀████▀▀
   ████
   ████
   ████
   ████
   ████
   ▀▀▀▀
|
Athertle
Sr. Member
****
Offline Offline

Activity: 252
Merit: 250


Go figure! | I'm nearing 1337 posts...


View Profile WWW
September 27, 2015, 12:07:35 PM
 #6

Try going in incognito and hit register. Email being hidden is ticked.

This issue was fixed, long, long ago.

Try reading the posts above in this thread. I already said that the checkbox was checked, but after registration the setting immediately goes to automatically showing. I created a test account; try creating one as well and you'll see what I'm talking about.

This is almost 100% a bug. I went through and created an account from scratch (here); the checkbox for "hide my email from the public" was checked by default, but when I created the account the setting switched to being public automatically.

This is a bug that needs to be fixed.

alani123
Legendary
*
Offline Offline

Activity: 1834
Merit: 1039



View Profile
September 27, 2015, 12:14:48 PM
 #7



Try reading the posts above in this thread. I already said that the checkbox was checked, but after registration the setting immediately goes to automatically showing. I created a test account; try creating one as well and you'll see what I'm talking about.


I did read this prior to posting. If a recent change made this issue resurface doesn't have to do much with what I posted, which is confirmation to what OP remembers about satoshi. Anyway, it could be that a recent change made this issue resurface if things are as you say.



███             ▄▄▄███████▄▄▄          ████                   ████          ▄▄▄███████▄▄▄         
███         ▄███████████████████▄       ████                 ████       ▄███████████████████▄     
███       ▄██████▀▀       ▀▀██████▄      ████               ████      ▄██████▀▀       ▀▀██████▄   
███      █████▀               ▀█████      ████             ████      █████▀               ▀█████ 
███    ▐████▀                   ▀████▌     ████           ████     ▐████▀                   ▀████▌
███    ████▌                     ▐████      ████         ████      ████▌                     ▐████
███    ████                       ████       ████       ████       ████                       ████
███    ████                       ████        ████     ████        ████                       ████
███    ████▌                     ▐████         ████   ████         ████▌                     ▐████
███    ▐████▄                   ▄████▌          ████ ████          ▐████▄                   ▄████▌
███      █████▄               ▄█████             ███████             █████▄               ▄█████ 
███       ▀██████▄▄       ▄▄██████▀               █████               ▀██████▄▄       ▄▄██████▀   
███         ▀███████████████████▀                  ███                  ▀███████████████████▀     
███             ▀▀▀███████▀▀▀                       █                       ▀▀▀███████▀▀▀         
INTERNET OF VALUE OMNILEDGER
|
   
   
 
 
|


             ▄████▄▄   ▄
█▄          ██████████▀▄
███        ███████████▀
▐████▄     ██████████▌
▄▄██████▄▄▄▄█████████▌
▀████████████████████
  ▀█████████████████
  ▄▄███████████████
   ▀█████████████▀
    ▄▄█████████▀
▀▀██████████▀
    ▀▀▀▀▀
M
 

             █▀▀▀▄▄▄██▄
             █     ▀██▀
            █
         ▄▄▄█▄▄▄
 ████▄▄███████████▄▄████
▐██████▀▀███████▀▀██████▌
 ▀████    █████    ████▀
  ████▄  ▄█████▄  ▄████
  ▀███████████████████▀
   ▀████▄▀█████▀▄████▀
     ▀▀███▄▄▄▄▄███▀▀
         ▀▀▀▀▀▀▀
 

    ▄█████
   ████▀▀▀
   ████
   ████
██████████
▀▀▀████▀▀
   ████
   ████
   ████
   ████
   ████
   ▀▀▀▀
|
theymos
Administrator
Legendary
*
Offline Offline

Activity: 3206
Merit: 3917


View Profile
September 27, 2015, 01:45:48 PM
 #8

Fixed.

1NXYoJ5xU91Jp83XfVMHwwTUyZFK64BoAD
Pips
Full Member
***
Offline Offline

Activity: 168
Merit: 100


If life gives you lemons, make orange juice.


View Profile
September 27, 2015, 01:50:13 PM
 #9

Fixed.

Thanks for the fast response. Time to close this thread.

If life gives you lemons, make orange juice and leave them wondering how you did it.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!