Bitcoin Forum
August 14, 2018, 09:39:57 PM *
News: Latest stable version of Bitcoin Core: 0.16.2  [Torrent].
 
   Home   Help Search Donate Login Register  
Poll
Question: Bismuth and Clarity
Create two independent systems - 2 (22.2%)
Dev rewards like Dash and ZCASH, one system - 7 (77.8%)
Total Voters: 9

Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 [33] 34 35 36 37 »
  Print  
Author Topic: [TESTNET]Bismuth - New Language, Interpretation Engines, DAPPs  (Read 49346 times)
gawlea
Hero Member
*****
Offline Offline

Activity: 630
Merit: 575


In crypto I trust !!


View Profile WWW
March 07, 2017, 09:21:43 AM
 #641

A "gui" desktop version of my query tools is now in development

Initial developement screenshots can be found here:

https://github.com/maccaspacca/Bismuth-Tools/tree/master/Bismuth%20Query/gui

Smiley

Great work maccaspacca. This is very useful tool.
Offtopic: nice BTC  address! Smiley

███████▀▄▄███████▄▄
█████▀▄████▀▀▀▀▀▀▀███▄
███▀▄███▀▄▄███████▄▄▄▀█
██▀▄███▀██▀▀     ▀▀███▄
██ ███▀           █▄▀███
██▄███             ██▄███
███▄▀   ▄▄███████▄▄ ██ ██
▀█▀▄ ▄█████▀▀▀▀▄▄▄  ██ ██
  █▀▄██▀▀▄▄█████▀▄█▄██ ██
 █▀▄██ █▀▀     ▄██▄███▄█
██ ██ █▀▄███████▀▄███▄█
██ ███ ▀▀▀▀▀▀▄▄▄███▀ ▀ ▄█
██ ███▀▀█████████▀ ▄█ ███
▀██ ██             ██ ███
█▄██▄▀█           ███ ███
██▄███▄▀▄▄     ▄ ████ ██
███▄▀▀███████▀▀▀▄███ ██
██████▄▄▄▄▄▄▄▄████▀▄█▀
█████████████████▀


    ████▀
█  ███▀  ▀
█  ██▀  ▀
█  █▀  ▀
█  ▀  ▀
█  ▄  ▄
█  █▄  ▄
█  ██▄  ▄
█  ███▄  ▄
    ████▄


  ▀████
▀  ▀███  █
  ▀  ▀██  █
    ▀  ▀█  █
      ▀  ▀  █
      ▄  ▄  █
    ▄  ▄█  █
  ▄  ▄██  █
▄  ▄███  █
  ▄████
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1534282797
Hero Member
*
Offline Offline

Posts: 1534282797

View Profile Personal Message (Offline)

Ignore
1534282797
Reply with quote  #2

1534282797
Report to moderator
1534282797
Hero Member
*
Offline Offline

Posts: 1534282797

View Profile Personal Message (Offline)

Ignore
1534282797
Reply with quote  #2

1534282797
Report to moderator
HCLivess
Legendary
*
Offline Offline

Activity: 1498
Merit: 1062


[[[],[]],[[],[]]]


View Profile WWW
March 08, 2017, 10:29:09 AM
 #642

I updated the fee calculation to be more predictable, combined it with diff calc in gui to save resources, changed the float number handling (set to 8 decimals), undone some rebranding in GUI, set max coins (mining)

More updates here:
https://cryptobismuth.herokuapp.com/

Bismuth - New Language, Interpretation Engines, Free Set of DAPPs https://bitcointalk.org/index.php?topic=1896497
Bitrated user: HCLivess.
gawlea
Hero Member
*****
Offline Offline

Activity: 630
Merit: 575


In crypto I trust !!


View Profile WWW
March 09, 2017, 07:43:28 AM
 #643

I updated the fee calculation to be more predictable, combined it with diff calc in gui to save resources, changed the float number handling (set to 8 decimals), undone some rebranding in GUI, set max coins (mining)

More updates here:
https://cryptobismuth.herokuapp.com/

Hi hclivess! Did you returned from your vacantion or you are still on the road? We can't wait to have you back doing your thing in Bismuth project Cheesy Take care!

███████▀▄▄███████▄▄
█████▀▄████▀▀▀▀▀▀▀███▄
███▀▄███▀▄▄███████▄▄▄▀█
██▀▄███▀██▀▀     ▀▀███▄
██ ███▀           █▄▀███
██▄███             ██▄███
███▄▀   ▄▄███████▄▄ ██ ██
▀█▀▄ ▄█████▀▀▀▀▄▄▄  ██ ██
  █▀▄██▀▀▄▄█████▀▄█▄██ ██
 █▀▄██ █▀▀     ▄██▄███▄█
██ ██ █▀▄███████▀▄███▄█
██ ███ ▀▀▀▀▀▀▄▄▄███▀ ▀ ▄█
██ ███▀▀█████████▀ ▄█ ███
▀██ ██             ██ ███
█▄██▄▀█           ███ ███
██▄███▄▀▄▄     ▄ ████ ██
███▄▀▀███████▀▀▀▄███ ██
██████▄▄▄▄▄▄▄▄████▀▄█▀
█████████████████▀


    ████▀
█  ███▀  ▀
█  ██▀  ▀
█  █▀  ▀
█  ▀  ▀
█  ▄  ▄
█  █▄  ▄
█  ██▄  ▄
█  ███▄  ▄
    ████▄


  ▀████
▀  ▀███  █
  ▀  ▀██  █
    ▀  ▀█  █
      ▀  ▀  █
      ▄  ▄  █
    ▄  ▄█  █
  ▄  ▄██  █
▄  ▄███  █
  ▄████
HCLivess
Legendary
*
Offline Offline

Activity: 1498
Merit: 1062


[[[],[]],[[],[]]]


View Profile WWW
March 10, 2017, 09:35:09 AM
 #644

I updated the fee calculation to be more predictable, combined it with diff calc in gui to save resources, changed the float number handling (set to 8 decimals), undone some rebranding in GUI, set max coins (mining)

More updates here:
https://cryptobismuth.herokuapp.com/

Hi hclivess! Did you returned from your vacantion or you are still on the road? We can't wait to have you back doing your thing in Bismuth project Cheesy Take care!

Hi, I'm back and making some changes already in preparation for the public release. Not releasing the new testnet version yet because it will break things (new fee calc, new notation)

Bismuth - New Language, Interpretation Engines, Free Set of DAPPs https://bitcointalk.org/index.php?topic=1896497
Bitrated user: HCLivess.
kakaxibkl
Jr. Member
*
Offline Offline

Activity: 53
Merit: 0


View Profile
March 11, 2017, 06:38:11 PM
 #645

Can't run on Ubuntu system?

Hi, yes you should be able to run from Ubuntu. Some Linux systems have python installed by default.

What you need to run from the directory after you download zip/master branch from github releases and unpack it:

1.
Code:
pip install pillow pyqrcode pypng pyinstaller web.py pycrypto simple-crypt

2.
Code:
pyinstaller --uac-admin --onefile --noconsole --log-level=INFO gui.py --icon=graphics\icon.ico
pyinstaller --uac-admin --onefile --log-level=INFO node.py --icon=graphics\icon.ico
pyinstaller --uac-admin --onefile --log-level=INFO miner.py --icon=graphics\icon.ico
pyinstaller --uac-admin --onefile --log-level=INFO ledger_explorer.py --icon=graphics\icon.ico --hidden-import=ledger_explorer

Then, you should be able to run your executable.
Alternatively, you can choose to run node/miner/gui.py directly without the second step (if you have pyhton installed).

I have installed pyhton,
But unable to execute wallet,
Please tell me how to do it, thank you
An error occurred while executing the following code: command not found
------------------------------------------------------------------------------------------------------------------
Code:
pyinstaller --uac-admin --noconsole --log-level=INFO gui.py --onefile --icon=graphics\icon.ico
Pyinstaller --uac-admin --log-level=INFO node.py --onefile --icon=graphics\icon.ico
Pyinstaller --uac-admin --log-level=INFO miner.py --onefile --icon=graphics\icon.ico
Pyinstaller --uac-admin --log-level=INFO ledger_explorer.py --icon=graphics\icon.ico --onefile --hidden-import=ledger_explorer
gawlea
Hero Member
*****
Offline Offline

Activity: 630
Merit: 575


In crypto I trust !!


View Profile WWW
March 11, 2017, 06:49:45 PM
 #646

I updated the fee calculation to be more predictable, combined it with diff calc in gui to save resources, changed the float number handling (set to 8 decimals), undone some rebranding in GUI, set max coins (mining)

More updates here:
https://cryptobismuth.herokuapp.com/

Hi hclivess! Did you returned from your vacantion or you are still on the road? We can't wait to have you back doing your thing in Bismuth project Cheesy Take care!

Hi, I'm back and making some changes already in preparation for the public release. Not releasing the new testnet version yet because it will break things (new fee calc, new notation)

Nice to have you back! Smiley

███████▀▄▄███████▄▄
█████▀▄████▀▀▀▀▀▀▀███▄
███▀▄███▀▄▄███████▄▄▄▀█
██▀▄███▀██▀▀     ▀▀███▄
██ ███▀           █▄▀███
██▄███             ██▄███
███▄▀   ▄▄███████▄▄ ██ ██
▀█▀▄ ▄█████▀▀▀▀▄▄▄  ██ ██
  █▀▄██▀▀▄▄█████▀▄█▄██ ██
 █▀▄██ █▀▀     ▄██▄███▄█
██ ██ █▀▄███████▀▄███▄█
██ ███ ▀▀▀▀▀▀▄▄▄███▀ ▀ ▄█
██ ███▀▀█████████▀ ▄█ ███
▀██ ██             ██ ███
█▄██▄▀█           ███ ███
██▄███▄▀▄▄     ▄ ████ ██
███▄▀▀███████▀▀▀▄███ ██
██████▄▄▄▄▄▄▄▄████▀▄█▀
█████████████████▀


    ████▀
█  ███▀  ▀
█  ██▀  ▀
█  █▀  ▀
█  ▀  ▀
█  ▄  ▄
█  █▄  ▄
█  ██▄  ▄
█  ███▄  ▄
    ████▄


  ▀████
▀  ▀███  █
  ▀  ▀██  █
    ▀  ▀█  █
      ▀  ▀  █
      ▄  ▄  █
    ▄  ▄█  █
  ▄  ▄██  █
▄  ▄███  █
  ▄████
maccaspacca
Sr. Member
****
Offline Offline

Activity: 278
Merit: 258


Twitter: @maccaspacca1


View Profile
March 11, 2017, 10:09:58 PM
 #647

I have released first version of the Bismuth Query Tools Desktop Edition

If running from Python:

https://github.com/maccaspacca/Bismuth-Tools/tree/master/Bismuth%20Query/Desktop%20Edition

Compiled Windows executable:

https://github.com/maccaspacca/Bismuth-Tools/releases/tag/0.10-beta

Only tested on Win 10 but should work well on Win7 or better

Moving forward I will look at Linux version or testing on Linux

HCLivess
Legendary
*
Offline Offline

Activity: 1498
Merit: 1062


[[[],[]],[[],[]]]


View Profile WWW
March 11, 2017, 11:29:01 PM
 #648

Awesome job. Thank you, maccaspacca. I have added link to your tools to the OP. There shouldn't be a problem compiling on Linux. The only issue I've ever had is icon/graphics handling, but I've only worked with tkinter. wx is amazing and I have overlooked it for long enough.

Bismuth - New Language, Interpretation Engines, Free Set of DAPPs https://bitcointalk.org/index.php?topic=1896497
Bitrated user: HCLivess.
kakaxibkl
Jr. Member
*
Offline Offline

Activity: 53
Merit: 0


View Profile
March 12, 2017, 02:46:30 AM
 #649

Can't run on Ubuntu system?

Hi, yes you should be able to run from Ubuntu. Some Linux systems have python installed by default.

What you need to run from the directory after you download zip/master branch from github releases and unpack it:

1.
Code:
pip install pillow pyqrcode pypng pyinstaller web.py pycrypto simple-crypt

2.
Code:
pyinstaller --uac-admin --onefile --noconsole --log-level=INFO gui.py --icon=graphics\icon.ico
pyinstaller --uac-admin --onefile --log-level=INFO node.py --icon=graphics\icon.ico
pyinstaller --uac-admin --onefile --log-level=INFO miner.py --icon=graphics\icon.ico
pyinstaller --uac-admin --onefile --log-level=INFO ledger_explorer.py --icon=graphics\icon.ico --hidden-import=ledger_explorer

Then, you should be able to run your executable.
Alternatively, you can choose to run node/miner/gui.py directly without the second step (if you have pyhton installed).

I have installed pyhton,
But unable to execute wallet,
Please tell me how to do it, thank you
An error occurred while executing the following code: command not found
------------------------------------------------------------------------------------------------------------------
Code:
pyinstaller --uac-admin --noconsole --log-level=INFO gui.py --onefile --icon=graphics\icon.ico
Pyinstaller --uac-admin --log-level=INFO node.py --onefile --icon=graphics\icon.ico
Pyinstaller --uac-admin --log-level=INFO miner.py --onefile --icon=graphics\icon.ico
Pyinstaller --uac-admin --log-level=INFO ledger_explorer.py --icon=graphics\icon.ico --onefile --hidden-import=ledger_explorer




RUN代码:pip install pillow pyqrcode pypng pyinstaller web.py pycrypto simple-crypt
得到以下提示:

Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 209, in main
    status = self.run(options, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 328, in run
    wb.build(autobuilding=True)
  File "/usr/lib/python2.7/dist-packages/pip/wheel.py", line 748, in build
    self.requirement_set.prepare_files(self.finder)
  File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 360, in prepare_files
    ignore_dependencies=self.ignore_dependencies))
  File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 512, in _prepare_file
    finder, self.upgrade, require_hashes)
  File "/usr/lib/python2.7/dist-packages/pip/req/req_install.py", line 273, in populate_link
    self.link = finder.find_requirement(self, upgrade)
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 442, in find_requirement
    all_candidates = self.find_all_candidates(req.name)
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 400, in find_all_candidates
    for page in self._get_pages(url_locations, project_name):
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 545, in _get_pages
    page = self._get_page(location)
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 648, in _get_page
    return HTMLPage.get_page(link, session=self.session)
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 757, in get_page
    "Cache-Control": "max-age=600",
  File "/usr/share/python-wheels/requests-2.9.1-py2.py3-none-any.whl/requests/sessions.py", line 480, in get
    return self.request('GET', url, **kwargs)
  File "/usr/lib/python2.7/dist-packages/pip/download.py", line 378, in request
    return super(PipSession, self).request(method, url, *args, **kwargs)
  File "/usr/share/python-wheels/requests-2.9.1-py2.py3-none-any.whl/requests/sessions.py", line 468, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/share/python-wheels/requests-2.9.1-py2.py3-none-any.whl/requests/sessions.py", line 576, in send
    r = adapter.send(request, **kwargs)
  File "/usr/share/python-wheels/CacheControl-0.11.5-py2.py3-none-any.whl/cachecontrol/adapter.py", line 46, in send
    resp = super(CacheControlAdapter, self).send(request, **kw)
  File "/usr/share/python-wheels/requests-2.9.1-py2.py3-none-any.whl/requests/adapters.py", line 376, in send
    timeout=timeout
  File "/usr/share/python-wheels/urllib3-1.13.1-py2.py3-none-any.whl/urllib3/connectionpool.py", line 610, in urlopen
    _stacktrace=sys.exc_info()[2])
  File "/usr/share/python-wheels/urllib3-1.13.1-py2.py3-none-any.whl/urllib3/util/retry.py", line 228, in increment
    total -= 1
TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'
HCLivess
Legendary
*
Offline Offline

Activity: 1498
Merit: 1062


[[[],[]],[[],[]]]


View Profile WWW
March 12, 2017, 08:25:03 AM
 #650



RUN代码:pip install pillow pyqrcode pypng pyinstaller web.py pycrypto simple-crypt
得到以下提示:

Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 209, in main
...


Please try easy_install, looks like a pip-related issue (or requests?)
What is the Linux you are using?
Code:
pip install setuptools

try upgrading/reinstalling pip also

Bismuth - New Language, Interpretation Engines, Free Set of DAPPs https://bitcointalk.org/index.php?topic=1896497
Bitrated user: HCLivess.
kakaxibkl
Jr. Member
*
Offline Offline

Activity: 53
Merit: 0


View Profile
March 12, 2017, 03:58:03 PM
 #651



RUN代码:pip install pillow pyqrcode pypng pyinstaller web.py pycrypto simple-crypt
得到以下提示:

Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 209, in main
...


Please try easy_install, looks like a pip-related issue (or requests?)
What is the Linux you are using?
Code:
pip install setuptools

try upgrading/reinstalling pip also


 python gui.py
Traceback (most recent call last):
  File "gui.py", line 4, in <module>
    import PIL.Image
ImportError: No module named PIL.Image
kakaxibkl
Jr. Member
*
Offline Offline

Activity: 53
Merit: 0


View Profile
March 12, 2017, 03:59:35 PM
 #652



RUN代码:pip install pillow pyqrcode pypng pyinstaller web.py pycrypto simple-crypt
得到以下提示:

Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 209, in main
...


Please try easy_install, looks like a pip-related issue (or requests?)
What is the Linux you are using?
Code:
pip install setuptools

try upgrading/reinstalling pip also


 python gui.py
Traceback (most recent call last):
  File "gui.py", line 4, in <module>
    import PIL.Image
ImportError: No module named PIL.Image

I am using Ubuntu 16.04
madjihad
Sr. Member
****
Offline Offline

Activity: 245
Merit: 250


🌟 æternity🌟 blockchain🌟


View Profile
March 12, 2017, 06:26:04 PM
 #653

i'm not technical enough to do all this but i'm still watching with eagerness

HCLivess
Legendary
*
Offline Offline

Activity: 1498
Merit: 1062


[[[],[]],[[],[]]]


View Profile WWW
March 13, 2017, 04:35:18 PM
 #654

Quote
I am using Ubuntu 16.04


Please try one of these solutions:
http://stackoverflow.com/questions/8863917/importerror-no-module-named-pil

Also, thanks for letting me know, might opt for a more integrated graphics handling in the future

Code:
python -m pip install Pillow
looks interesting

Bismuth - New Language, Interpretation Engines, Free Set of DAPPs https://bitcointalk.org/index.php?topic=1896497
Bitrated user: HCLivess.
kakaxibkl
Jr. Member
*
Offline Offline

Activity: 53
Merit: 0


View Profile
March 13, 2017, 07:57:27 PM
 #655

Quote
I am using Ubuntu 16.04


Please try one of these solutions:
http://stackoverflow.com/questions/8863917/importerror-no-module-named-pil

Also, thanks for letting me know, might opt for a more integrated graphics handling in the future

Code:
python -m pip install Pillow
looks interesting
-------------------------------------------
Now the situation is like this, there is nothing wrong with it, thank you
python gui.py
Traceback (most recent call last):
  File "gui.py", line 6, in <module>
    import pyqrcode
ImportError: No module named pyqrcode
HCLivess
Legendary
*
Offline Offline

Activity: 1498
Merit: 1062


[[[],[]],[[],[]]]


View Profile WWW
March 13, 2017, 10:53:57 PM
 #656

Quote
I am using Ubuntu 16.04


Please try one of these solutions:
http://stackoverflow.com/questions/8863917/importerror-no-module-named-pil

Also, thanks for letting me know, might opt for a more integrated graphics handling in the future

Code:
python -m pip install Pillow
looks interesting
-------------------------------------------
Now the situation is like this, there is nothing wrong with it, thank you
python gui.py
Traceback (most recent call last):
  File "gui.py", line 6, in <module>
    import pyqrcode
ImportError: No module named pyqrcode


"generate QR code" I think does not work for Linux currently, but you may try this:

Code:
python -m pip install pyqrcode

Bismuth - New Language, Interpretation Engines, Free Set of DAPPs https://bitcointalk.org/index.php?topic=1896497
Bitrated user: HCLivess.
kakaxibkl
Jr. Member
*
Offline Offline

Activity: 53
Merit: 0


View Profile
March 14, 2017, 04:52:30 PM
 #657

I really want to have a Ubuntu system installation guide, I like this coin, but my system is Ubuntu, I can not run him. I think there are a lot of people with me.
kellendil
Hero Member
*****
Offline Offline

Activity: 630
Merit: 503


Earn with impressio.io


View Profile
March 14, 2017, 05:26:04 PM
 #658

When will you guys launch the mainnet ?

.▄███     ██████     ███▄
██████   ███████   ██████
 ██████ ██████████ ██████
  ██████████████████████
   █████████  ████████
    ██████    ██████
    ███████    ██████
   █████████  █████████
  ██████████████████████
 ██████ ██████████ ██████
██████   ██████   ██████
 ▀███     ██████     ███▀
.IMPRESSIO.     ▄███████████████▄
     ██             ██
     ▀███████████████▀
           ██ ██
           ██ ██
       ▄▄█████████▄▄ ▄███▄
    ▄███▀▀       ▀▀████ ▀██▄
  ▄██▀   ▄▄█████▄▄   ▀██▄ ██
 ▄██  ▄███  █  █████▄  ██▄█▀
 ██  ███         █████  ██
██  ██████  ███   █████  ██
██  ██████  ▀▀▀  ▄█████  ██
██  ██████  ▄▄▄▄  █████  ██
██  ██████  ████   ████  ██
 ██  ███          ████  ██
 ▀██  ▀███  █  █████▀  ██▀
  ▀██▄   ▀▀█████▀▀   ▄██▀
    ▀███▄▄       ▄▄███▀
       ▀▀█████████▀▀
maccaspacca
Sr. Member
****
Offline Offline

Activity: 278
Merit: 258


Twitter: @maccaspacca1


View Profile
March 14, 2017, 09:46:33 PM
 #659

I really want to have a Ubuntu system installation guide, I like this coin, but my system is Ubuntu, I can not run him. I think there are a lot of people with me.

If you are installing the dependencies on Ubuntu, you need to install as 'sudo'


example commands include;

sudo apt install python-pip
sudo pip install pillow pyqrcode pypng pyinstaller web.py pycrypto simple-crypt
sudo apt-get install python-tk

I have a node running on Ubuntu 16.04 and the executable successfully compiles (at least on my machine) using

pyinstaller --onefile --log-level=INFO node.py --icon=graphics\icon.ico

At some point (if I have time) I might write a guide for running on Ubuntu.

HCLivess
Legendary
*
Offline Offline

Activity: 1498
Merit: 1062


[[[],[]],[[],[]]]


View Profile WWW
March 15, 2017, 11:55:45 AM
 #660

Hyperblock code is ready, will be released in the upcoming version. Since now, there will be an extra parameter in the config where you can choose if you want to run with hyperblocks or not.

If you do, all but the last 10000 blocks will be trimmed and transactions converted to outstanding balance.

This effectively means that your blockchain size will never grow over 10 MB + sum(transactions) - can be up to 100 MB or more if the network is highly used. Also, it anonymizes the historical transactions, so if you want to keep them, run without hyperblocks.

This is how it looks in GUI:

Bismuth - New Language, Interpretation Engines, Free Set of DAPPs https://bitcointalk.org/index.php?topic=1896497
Bitrated user: HCLivess.
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 [33] 34 35 36 37 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!