Bitcoin Forum
January 27, 2020, 09:19:02 PM *
News: Latest Bitcoin Core release: 0.19.0.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 ... 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 [64] 65 »
  Print  
Author Topic: [ANN] Datacoin - Censorship-Free Data Storage  (Read 60991 times)
FontSeli
Hero Member
*****
Offline Offline

Activity: 602
Merit: 578



View Profile
November 20, 2019, 01:17:51 AM
 #1261

configure: error: libdb_cxx headers missing, Datacoin Core requires this library for wallet functionality (--disable-wallet to disable wallet functionality)

You're missing the Berkeley DB packages.
Unix Build Notes

I did everything as stated in the instructions, but at the stage of make I have an error.



distro: Linux Ubuntu 18.04.3 LTS
1580159942
Hero Member
*
Offline Offline

Posts: 1580159942

View Profile Personal Message (Offline)

Ignore
1580159942
Reply with quote  #2

1580159942
Report to moderator
1580159942
Hero Member
*
Offline Offline

Posts: 1580159942

View Profile Personal Message (Offline)

Ignore
1580159942
Reply with quote  #2

1580159942
Report to moderator
1580159942
Hero Member
*
Offline Offline

Posts: 1580159942

View Profile Personal Message (Offline)

Ignore
1580159942
Reply with quote  #2

1580159942
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
sampei7777
Newbie
*
Offline Offline

Activity: 60
Merit: 0


View Profile WWW
November 20, 2019, 06:49:21 AM
 #1262

configure: error: libdb_cxx headers missing, Datacoin Core requires this library for wallet functionality (--disable-wallet to disable wallet functionality)

You're missing the Berkeley DB packages.
Unix Build Notes

I did everything as stated in the instructions, but at the stage of make I have an error.

https://i.postimg.cc/T3y6XSWK/Make-error.png

distro: Linux Ubuntu 18.04.3 LTS

Code:
sudo apt-get install libboost-all-dev
sudo apt-get install libgmp-dev
sudo apt-get install libczmq-dev
FontSeli
Hero Member
*****
Offline Offline

Activity: 602
Merit: 578



View Profile
November 20, 2019, 08:20:33 PM
 #1263

configure: error: libdb_cxx headers missing, Datacoin Core requires this library for wallet functionality (--disable-wallet to disable wallet functionality)

You're missing the Berkeley DB packages.
Unix Build Notes

I did everything as stated in the instructions, but at the stage of make I have an error.

https://i.postimg.cc/T3y6XSWK/Make-error.png

distro: Linux Ubuntu 18.04.3 LTS

Code:
sudo apt-get install libboost-all-dev
sudo apt-get install libgmp-dev
sudo apt-get install libczmq-dev

I installed the libraries from your list. And I was given a new error. I so understand it is connected with versions of protocols.

FontSeli
Hero Member
*****
Offline Offline

Activity: 602
Merit: 578



View Profile
November 22, 2019, 09:17:18 AM
 #1264

I tried to install earlier versions of the latest libraries. It did not help. The error remains the same.

Can someone give a hint?
sampei7777
Newbie
*
Offline Offline

Activity: 60
Merit: 0


View Profile WWW
November 22, 2019, 10:53:02 AM
 #1265

I tried to install earlier versions of the latest libraries. It did not help. The error remains the same.

Can someone give a hint?

This was an old issue.

Did you download the latest release?

Also, is your ubuntu updated?

Code:
sudo apt-get update
sudo apt-get dist-upgrade
xandry
Staff
Legendary
*
Offline Offline

Activity: 1876
Merit: 1269



View Profile
November 22, 2019, 11:07:26 AM
 #1266

Can someone give a hint?
Did you tried
Code:
make clean
I just found that it can help in some cases: Build Caffe: #error This file was generated by an older version of protoc which is
#5645

████████████████████████████
████████▀▀ █▀ █▀ ▀██████████
█████████▄ ▄▄▄▄▄▄███████████
██████████▀     ▀  ▀████████
███████▀ ▀  ▄█▀▀▀█▀▀████████
██████▄      █▄  ▀▀  ▀██████
██████         ▄▄█▄ ▄ ▀█████
█████ ▄         ▀▀ ▄ ▀ █████
██████▌          █▀█▀ ▐█████
███████  ▄▌         ▄ ██████
████████▄█         ▄████████
█████████▀     ▄▄ ▄█████████
████████████████████████████
.JACKMATE'S...........
.
MAJESTIC..
████████████████████████
███████████████████████
████████████████████████
████████████████████████
████████████████████████
████████████████████████
████████████████████████
████████████████████████
████████████████████████
████████████████████████
████████████████████████
████████████████████████
████████████████████████
.
..WIN 1 BITCOIN ON EVERY PREMIER LEAGUE MATCHDAY..
████████████████████████████████
████████████▀█▀ ▀█▀█▀███████████
███████████▄ ▄▄▄▄▄▄▄████████████
███████████▀▀▄▄▄▄▄▄▄▄███████████
█████████▀▄ ██▀▄▄▄ ▀ ▄▀█████████
███████▀ ▀█████▄▄▄█▄▄▄██████████
███████▀▄████████▀  ▀█ █▐███████
███████ ▀█████████▄█▀▀██ ███████
████████ ███▀██████ ▄ ██ ███████
████████▌▐▀▄ ██████████ ▄███████
█████████▄██▌▐█████▀██ █████████
████████████▄▀▀▀▀▀▄ ▀▄██████████
████████████████████████████████
.
.JOIN US - IT'S FREE! .
FontSeli
Hero Member
*****
Offline Offline

Activity: 602
Merit: 578



View Profile
November 22, 2019, 12:39:54 PM
 #1267

I tried to install earlier versions of the latest libraries. It did not help. The error remains the same.

Can someone give a hint?

This was an old issue.

Did you download the latest release?

Also, is your ubuntu updated?

Code:
sudo apt-get update
sudo apt-get dist-upgrade

I downloaded the source code from the repository: https://github.com/datacoinproject/datacoin/archive/v0.16.3.tar.gz

My system has the latest possible updates for Linux Ubuntu 18.04.3 LTS



Can someone give a hint?
Did you tried
Code:
make clean
I just found that it can help in some cases: Build Caffe: #error This file was generated by an older version of protoc which is
#5645


I haven't tried that. When I get to my home computer, I'll try. Thanks.
gjhiggins
Legendary
*
Offline Offline

Activity: 1792
Merit: 1110



View Profile WWW
November 22, 2019, 02:43:55 PM
 #1268

I tried to install earlier versions of the latest libraries. It did not help. The error remains the same.

Can someone give a hint?

Try ...
Code:
sudo apt install libprotobuf-dev protobuf-compiler
cd datacoin/src/madpool
protoc --proto_path=./ --cpp_out=./ protocol.proto
mv protocol.pb.cc protocol.pb.cpp

Cheers

Graham
hinc
Newbie
*
Offline Offline

Activity: 1
Merit: 0


View Profile
November 22, 2019, 05:35:44 PM
 #1269

BELLE QUESTION
MostlyGhostly
Full Member
***
Offline Offline

Activity: 275
Merit: 101


View Profile
November 23, 2019, 04:51:42 PM
Last edit: November 23, 2019, 06:09:10 PM by MostlyGhostly
 #1270

Your belly question is ignored. I got a better question: when the era of shits will end to make room for a single decent mover that is to take over this space? I have been looking into Data coin's pants and found no organs of reproduction, nor pubic hair. A coin has no means to support its existence over a long term. And it has failed to revamp its dignity after having been battered by paid shills a year ago. That is a total defeat, gentlemen.
gjhiggins
Legendary
*
Offline Offline

Activity: 1792
Merit: 1110



View Profile WWW
November 23, 2019, 07:11:24 PM
 #1271

Your belly question is ignored. I got a better question: when the era of shits will end to make room for a single decent mover that is to take over this space? I have been looking into Data coin's pants and found no organs of reproduction, nor pubic hair. A coin has no means to support its existence over a long term. And it has failed to revamp its dignity after having been battered by paid shills a year ago. That is a total defeat, gentlemen.
Strong words from a longstanding contributor and stalwart of the community. Or rather they would be if you were one, rather than merely a drive-by ranter.

Cheers

Graham
FontSeli
Hero Member
*****
Offline Offline

Activity: 602
Merit: 578



View Profile
December 04, 2019, 05:50:39 PM
 #1272

I tried to install earlier versions of the latest libraries. It did not help. The error remains the same.

Can someone give a hint?

Try ...
Code:
sudo apt install libprotobuf-dev protobuf-compiler
cd datacoin/src/madpool
protoc --proto_path=./ --cpp_out=./ protocol.proto
mv protocol.pb.cc protocol.pb.cpp

Cheers

Graham


I tried. I was given in the beginning of such an error.


Then I executed the following command:
Code:
mv protocol.pb.cc protocol.pb.cpp

After it I managed to "make" a make with a few "warnings"

extro1
Newbie
*
Offline Offline

Activity: 26
Merit: 2


View Profile
December 31, 2019, 11:43:11 AM
 #1273

Datacoin Shop:  https://datacoin.cash.


Let me emphasize that the Datacoin Shop is in Alpha.  I am new to Shopify, dropshipping and CodeIgniter.

The Datacoin.Cash website has 3 components:  a Datacoin Shop, lending packages (with ROI of 34%) and a Multi-Level-Marketing system (paying 25% referral bonus for a miniumum investment of $150).

The capital (in Bitcoin) raised with the lending packages will be used to pay for the products.  Suppliers do not accept Datacoin.  

You can pay for the products in the shop with Datacoin (send the amount on the product page to the Datacoin address indicated).  The online Datacoin wallet is active at datacoin dot tk/wallet.

Please register and buy to help us test the website.  This is intended as an economic ecosystem to support the Datacoin price.  

Please be patient.  Shipping times vary, up to one or two months.  But sometimes also shorter.


-extro
minerja
Sr. Member
****
Offline Offline

Activity: 980
Merit: 274


View Profile
December 31, 2019, 12:16:01 PM
 #1274

Datacoin Shop:  https://datacoin.cash.


Let me emphasize that the Datacoin Shop is in Alpha.  I am new to Shopify, dropshipping and CodeIgniter.

The Datacoin.Cash website has 3 components:  a Datacoin Shop, lending packages (with ROI of 34%) and a Multi-Level-Marketing system (paying 25% referral bonus for a miniumum investment of $150).

The capital (in Bitcoin) raised with the lending packages will be used to pay for the products.  Suppliers do not accept Datacoin.  

You can pay for the products in the shop with Datacoin (send the amount on the product page to the Datacoin address indicated).  The online Datacoin wallet is active at datacoin dot tk/wallet.

Please register and buy to help us test the website.  This is intended as an economic ecosystem to support the Datacoin price.  

Please be patient.  Shipping times vary, up to one or two months.  But sometimes also shorter.


-extro

Looked quite intertesting....until i saw the min investment....try reducing that by a factor of 10 please....
extro1
Newbie
*
Offline Offline

Activity: 26
Merit: 2


View Profile
January 02, 2020, 07:13:40 AM
 #1275


Looked quite intertesting....until i saw the min investment....try reducing that by a factor of 10 please....


Yes, we will take it down to $20.

-extro
minerja
Sr. Member
****
Offline Offline

Activity: 980
Merit: 274


View Profile
January 02, 2020, 02:39:38 PM
 #1276


Looked quite intertesting....until i saw the min investment....try reducing that by a factor of 10 please....


Yes, we will take it down to $20.

-extro

Apologies...i was being quite a lot cheeky really...but much appreciated...
batesresearch
Legendary
*
Offline Offline

Activity: 2114
Merit: 1061


View Profile
January 02, 2020, 02:57:10 PM
 #1277

Renewed http://www.datacoininfo.org for another year.

If anyone would like to go through the site with me to remove dead links / update content and add new links then PM me and we will get it sorted.

Fallen down the crypto rabbithole!
batesresearch
Legendary
*
Offline Offline

Activity: 2114
Merit: 1061


View Profile
January 05, 2020, 03:35:31 PM
 #1278

Ok, just had a quick look over the site (and following some advice on a PM) - Edited the website:

Updates made:

Removed: Next Exchange

Removed: Chainz.cryptoid.info/dtc

Removed: Facebook link

Added: Datacoin.Cash

Fallen down the crypto rabbithole!
GameKyuubi
Sr. Member
****
Offline Offline

Activity: 253
Merit: 790


DTCxNMC


View Profile
January 10, 2020, 01:07:58 AM
 #1279

Renewed http://www.datacoininfo.org for another year.

If anyone would like to go through the site with me to remove dead links / update content and add new links then PM me and we will get it sorted.

👏 I'm down

BTC: 15SLrNo6PKVfsH5JLtatJcVkSQXCk1LXyq
full stack Node
batesresearch
Legendary
*
Offline Offline

Activity: 2114
Merit: 1061


View Profile
January 10, 2020, 06:17:09 PM
 #1280

Renewed http://www.datacoininfo.org for another year.

If anyone would like to go through the site with me to remove dead links / update content and add new links then PM me and we will get it sorted.

👏 I'm down

Sent you a PM  Grin

Fallen down the crypto rabbithole!
Pages: « 1 ... 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 [64] 65 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!