Bitcoin Forum
September 19, 2018, 04:27:02 AM *
News: ♦♦ Bitcoin Core users must update to 0.16.3 [Torrent]. More info.
 
   Home   Help Search Donate Login Register  
Pages: [1] 2 3 »  All
  Print  
Author Topic: Solution for ANTMINER S9 FANS SPEED Up & Down every 20 Seconds.  (Read 1831 times)
grivero1983
Newbie
*
Offline Offline

Activity: 13
Merit: 4


View Profile
January 04, 2018, 06:24:42 PM
Merited by BitMaxz (2), frodocooper (1), castiel0504 (1)
 #1

As a precaution, always do this porcedures at your own risk.

Hey guys, just find a solution for this issue that was driving me insane like a lot of people with the same problem.
I have two Antminer S9, one is 13.0 TH and one is 13.5 TH, both are Autofreq, the issue at hand is that the miner goes up 100% maximum RPM on both fans every 10-20 seconds, and that its really anoying specially with those with miners at home. I just figured out a solution taking a tread with the Antminers S7 that gave me the same solution when i needed to shut down the beep when the internet was down!, for those who had S7's you could notice that this beep was anoying from hell!. But some guy found the solution to shut down the beep by modifying the HTML code in the browser, No linux, no programming, just FN+F12 and follow some steps and the secret menu options will display. Just like the old miners S5, S7 that had this options.

Let's start!

First open your browser in this example i will use Firefox.

https://eximmagazine.files.wordpress.com/2018/01/1.jpg
https://eximmagazine.files.wordpress.com/2018/01/2.jpg
https://eximmagazine.files.wordpress.com/2018/01/3.jpg
https://eximmagazine.files.wordpress.com/2018/01/4.jpg
https://eximmagazine.files.wordpress.com/2018/01/5.jpg
https://eximmagazine.files.wordpress.com/2018/01/6.jpg
https://eximmagazine.files.wordpress.com/2018/01/7.jpg


If you need further help, please let me know.

If you find my post interesting and solved your issue consider donating, the amount its not important just to know you are gratefull it's fine for me.
BTC: 1FV1t9cKq3pybtGojprV6K1P8oshA5yDpe

Regards.

Grivero1983
1537331222
Hero Member
*
Offline Offline

Posts: 1537331222

View Profile Personal Message (Offline)

Ignore
1537331222
Reply with quote  #2

1537331222
Report to moderator
1537331222
Hero Member
*
Offline Offline

Posts: 1537331222

View Profile Personal Message (Offline)

Ignore
1537331222
Reply with quote  #2

1537331222
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
dlezama
Member
**
Offline Offline

Activity: 140
Merit: 17


View Profile
January 04, 2018, 06:38:44 PM
 #2

Interesting, will this disable autotune? I like the idea of fixing the fan so it stops cycling, but I want to leave autotune on.
grivero1983
Newbie
*
Offline Offline

Activity: 13
Merit: 4


View Profile
January 04, 2018, 07:38:24 PM
 #3

It wont disable the autotune mode. Just enable in the hidden funtions of the fan control and leave the freq just as it is.

Regards.

Grivero1983
lrowland21093
Jr. Member
*
Offline Offline

Activity: 73
Merit: 6


View Profile
January 04, 2018, 08:45:20 PM
 #4

I played with these hidden settings also.  The did seem to affect the intake fan but not the primary (and louder) outtake one.  Bitmain seems to have written the autotune firmware to ignore the fan % setting on one fan (and most of the other hidden options).  That is probably why they hid the options! 
fanatic26
Hero Member
*****
Offline Offline

Activity: 756
Merit: 560


View Profile
January 04, 2018, 09:44:50 PM
 #5

I played with these hidden settings also.  The did seem to affect the intake fan but not the primary (and louder) outtake one.  Bitmain seems to have written the autotune firmware to ignore the fan % setting on one fan (and most of the other hidden options).  That is probably why they hid the options! 

The intake fan is the one that spins faster, the exhaust side is the slower one.

Stop buying industrial miners, running them at home, and then complaining about the noise.
fyoung55
Member
**
Offline Offline

Activity: 130
Merit: 12


View Profile
January 18, 2018, 04:18:05 AM
 #6

How do you save the changes?  I cant get the fan % to show up
grivero1983
Newbie
*
Offline Offline

Activity: 13
Merit: 4


View Profile
January 18, 2018, 04:32:09 AM
 #7

How do you save the changes?  I cant get the fan % to show up

Hello have you followed the proceedures on the images i published ? you have first to modify the html code in the miner configuration window when the % appears yoy put the number and then click save in order to save the changes.

Regards,

GRivero1983
fyoung55
Member
**
Offline Offline

Activity: 130
Merit: 12


View Profile
January 18, 2018, 01:05:54 PM
 #8

yes, when I delete the word :none and leave it just as you described there is no fan option displayed on the tab still.
HoleShot
Member
**
Offline Offline

Activity: 70
Merit: 28


View Profile
January 21, 2018, 06:28:18 AM
 #9

I'm developing a liquid cooled S9. I need a way to unplug the fans as they are not needed and I don't want to power them. Any suggestions welcome.
Megaquake
Hero Member
*****
Offline Offline

Activity: 603
Merit: 505


View Profile WWW
January 21, 2018, 07:30:28 AM
 #10

Easier way

Add these line to /config/bmminer.conf using winscp set connection file protocol SCP

"bitmain-fan-ctrl" : true,
"bitmain-fan-pwm" : "90",

Then restart bmminer logging SSH using putty

/etc/init.d/bmminer.sh restart

When finished fans will run at 90% or whatever % bitmain-fan-pwm is set to.
fyoung55
Member
**
Offline Offline

Activity: 130
Merit: 12


View Profile
January 22, 2018, 03:24:20 AM
 #11

Using what?  Are there more detailed instructions somehwere?
HoleShot
Member
**
Offline Offline

Activity: 70
Merit: 28


View Profile
January 22, 2018, 08:47:43 AM
 #12

Easier way

Add these line to /config/bmminer.conf using winscp set connection file protocol SCP

"bitmain-fan-ctrl" : true,
"bitmain-fan-pwm" : "90",

Then restart bmminer logging SSH using putty

/etc/init.d/bmminer.sh restart

When finished fans will run at 90% or whatever % bitmain-fan-pwm is set to.


Thanks so much. This may solve my problem by setting to 0%. Hopefully, the missing fans will not cause an alarm if set to zero.

i'm not familiar with winscp and it's been decades since I used putty. I'll try to muddle through.
grivero1983
Newbie
*
Offline Offline

Activity: 13
Merit: 4


View Profile
January 22, 2018, 06:17:17 PM
 #13

yes, when I delete the word :none and leave it just as you described there is no fan option displayed on the tab still.

Please also delete the following line, then the options will appear in the panel.

https://eximmagazine.files.wordpress.com/2018/01/nueva-imagen.jpg

Let me know if it worked.

Regards.

fyoung55
Member
**
Offline Offline

Activity: 130
Merit: 12


View Profile
January 22, 2018, 08:37:08 PM
 #14

nope, that wiped out my pool displys
fyoung55
Member
**
Offline Offline

Activity: 130
Merit: 12


View Profile
January 22, 2018, 08:47:33 PM
 #15

GOT IT!

worked in chrome for me, not sure why firefox wasn't working.  now to test the fan setting!
fyoung55
Member
**
Offline Offline

Activity: 130
Merit: 12


View Profile
January 24, 2018, 01:54:31 AM
 #16

update:
It works great on my S9 13.5T Auto-tune miner.  The interface does indeed set both fans (front and back) based on percentage.  I've played around with the speed from 60% to 90% to optimize power draw vs hashrate.  75% is my butter zone!

Thanks for this!
jeecom
Jr. Member
*
Offline Offline

Activity: 56
Merit: 1


View Profile
January 25, 2018, 12:01:43 AM
 #17

When you use this option, don't you also have to choose a frequency?  What happens if you use this to set a frequency on an auto-tune S9?
fyoung55
Member
**
Offline Offline

Activity: 130
Merit: 12


View Profile
January 25, 2018, 01:13:47 AM
 #18

I'm not sure... I didn't enable that option, since I figured autotune would over-ride it.  Anybody else try it?
castiel0504
Full Member
***
Offline Offline

Activity: 266
Merit: 109

Ultra Mega Giga Super Cool Flying Oposum!


View Profile
January 25, 2018, 10:32:11 PM
 #19

This works perfectly! I havent tempered with frequenzy i only changed the percentage of which my S9 works, i put it at 100%(since im using some kind of box with sound isolation and temperature got quite high around 87C). and at the moment(2h of working there were no problems.
grivero1983
Newbie
*
Offline Offline

Activity: 13
Merit: 4


View Profile
January 29, 2018, 11:41:32 PM
 #20

When you use this option, don't you also have to choose a frequency?  What happens if you use this to set a frequency on an auto-tune S9?

Very Interesting, thanks for sharing, could you post the page print of that mod. I wasn't sure to mess with the freq. because all my all my miners are autotune.

When you set the freq to xxx MHZ does the 3 boards set to the same fqcy?

Thanks.

GRIVERO
Pages: [1] 2 3 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!