Bitcoin Forum
September 26, 2018, 02:15:39 AM *
News: ♦♦ New info! Bitcoin Core users absolutely must upgrade to previously-announced 0.16.3 [Torrent]. All Bitcoin users should temporarily trust confirmations slightly less. More info.
 
   Home   Help Search Donate Login Register  
Pages: « 1 [2]  All
  Print  
Author Topic: Low speed at two Block Erupters (CGMiner) :(  (Read 4195 times)
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2660
Merit: 1143


Ruu \o/


View Profile WWW
August 28, 2013, 01:43:21 AM
 #21

But still i want solve that problem with CGMiner. So what binary i need?
Your problem is you have chosen a distribution that does not have an up to date libusb which cgminer depends on, and none of the binaries are made for your distribution. Even if you build cgminer yourself, the problem will remain there due to the library for usb included with debian. Your choices are to install a better libusb by building it yourself at the same time as building cgminer, or downloading one from somewhere (no there is none available for your distribution as far as I'm aware) or changing distribution. The only binaries that have libusb built in statically (included in the binary instead of using the system one) are the ones provided in that link I gave you earlier.

We did not anticipate running into such a libusb bug. For windows we included a good dll. That's not how things work on linux. We are considering including a "good" libusb built in statically on later versions of cgminer.

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
1537928139
Hero Member
*
Offline Offline

Posts: 1537928139

View Profile Personal Message (Offline)

Ignore
1537928139
Reply with quote  #2

1537928139
Report to moderator
1537928139
Hero Member
*
Offline Offline

Posts: 1537928139

View Profile Personal Message (Offline)

Ignore
1537928139
Reply with quote  #2

1537928139
Report to moderator
Make a difference with your Ether.
Donate Ether for the greater good.
SPRING.WETRUST.IO
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1537928139
Hero Member
*
Offline Offline

Posts: 1537928139

View Profile Personal Message (Offline)

Ignore
1537928139
Reply with quote  #2

1537928139
Report to moderator
1537928139
Hero Member
*
Offline Offline

Posts: 1537928139

View Profile Personal Message (Offline)

Ignore
1537928139
Reply with quote  #2

1537928139
Report to moderator
1537928139
Hero Member
*
Offline Offline

Posts: 1537928139

View Profile Personal Message (Offline)

Ignore
1537928139
Reply with quote  #2

1537928139
Report to moderator
taxik
Newbie
*
Offline Offline

Activity: 45
Merit: 0


View Profile
August 28, 2013, 08:19:51 AM
 #22

OK i will be waiting for next version of CGMiner then Smiley
vesperwillow
Hero Member
*****
Offline Offline

Activity: 616
Merit: 500


View Profile
August 30, 2013, 04:00:59 AM
 #23

maybe its a bit underpowered? I had a similar problem when I connected two Block Erupters to a 5-port USB hub with cardreader that only has a 1000mA PSU.

I think not,

Output voltage 5 V

Output current 1 A


500mA + 500mA = 1A.  Not counting the hub's overhead, so your hub's PSU is underpowered.

You're forgetting the port is powered, and all of the current is summed together. 500 + 500 + 500 = 1.5A. He wasn't underpowered.

zamot
Member
**
Offline Offline

Activity: 121
Merit: 10



View Profile
September 29, 2013, 04:52:55 PM
 #24

Hello,

i have the same problem with my Eruptors.
I get Timeout messages for all of them.
Till today i used cgminer 3.3.0 and there was no problem, when i tryed 3.4.0 and now currently 3.5.0 version there is present this error.
I run cgminer in Windows XP SP2.
Zadig drivers are installed ( otherwise i couldn't run cgminer 3.3.0 ).
USB HUB have 3.5A max utput, so there is no underpower problem.
I also rebooted XP before i started cgminer 3.5.0.

How can i eliminate this timeout problem?
Here is the command for starting of cgminer: cgminer-nogpu.exe -c cgminer.conf --no-submit-stale

And this is the content of cgminer.conf:
Code:
{
"pools" : [
{
"url" : xxxxxxxxx",
"user" : "xxxxxxxx",
"pass" : "xxxxxxxxx"
}
]
,
"api-port" : "4028",
"expiry" : "240",
"hotplug" : "5",
"log" : "10",
"no-pool-disable" : true,
"queue" : "4",
"scan-time" : "5",
"shares" : "0",
"load-balance" : true,
"kernel-path" : "/usr/local/bin"
}

Pages: « 1 [2]  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!