Bitcoin Forum
June 18, 2018, 12:06:13 PM *
News: Latest stable version of Bitcoin Core: 0.16.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: linux cgminer-1.4.0 compilation does not work  (Read 1074 times)
govindas
Newbie
*
Offline Offline

Activity: 9
Merit: 0


View Profile
July 24, 2011, 08:16:20 AM
 #1

Hallo.
i am trying to compile cgminer-1.4.0 on linux_x86-64.
 ./configure CFLAGS="-O3 -Wall" seams to work, but make breaks with:

Code:
util.c
util.c:254: error: syntax error before "curl_socket_t"
util.c: In function `json_rpc_call_sockopt_cb':
util.c:263: error: `fd' undeclared (first use in this function)
util.c:263: error: (Each undeclared identifier is reported only once
util.c:263: error: for each function it appears in.)
util.c: In function `json_rpc_call':
util.c:348: error: `CURLOPT_SOCKOPTFUNCTION' undeclared (first use in this function)
make[2]: *** [cgminer-util.o] Error 1
make[2]: Leaving directory `/home/xxxxxx'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/xxxxxxx'
make: *** [all] Error 2

cgminer-1.3.1 was still able to compile on the system, so i think curl is ok.
and i uesed this source-code http://ck.kolivas.org/apps/cgminer/cgminer-1.4.0.tar.bz2 with jansson included.
any ideas?
1529323573
Hero Member
*
Offline Offline

Posts: 1529323573

View Profile Personal Message (Offline)

Ignore
1529323573
Reply with quote  #2

1529323573
Report to moderator
1529323573
Hero Member
*
Offline Offline

Posts: 1529323573

View Profile Personal Message (Offline)

Ignore
1529323573
Reply with quote  #2

1529323573
Report to moderator
The World's Betting Exchange

Bet with play money. Win real Bitcoin. 5BTC Prize Fund for World Cup 2018.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1529323573
Hero Member
*
Offline Offline

Posts: 1529323573

View Profile Personal Message (Offline)

Ignore
1529323573
Reply with quote  #2

1529323573
Report to moderator
1529323573
Hero Member
*
Offline Offline

Posts: 1529323573

View Profile Personal Message (Offline)

Ignore
1529323573
Reply with quote  #2

1529323573
Report to moderator
1529323573
Hero Member
*
Offline Offline

Posts: 1529323573

View Profile Personal Message (Offline)

Ignore
1529323573
Reply with quote  #2

1529323573
Report to moderator
-ck
Staff
Legendary
*
Offline Offline

Activity: 2548
Merit: 1092


Ruu \o/


View Profile WWW
July 24, 2011, 11:56:31 AM
 #2

That's a function from a newer curl. RHEL5 (and others) has a curl that's too old so you need to find a way to update curl - either through non-standard packages or some kind of upgrade or manual install.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org 1% Fee Solo mining at solo.ckpool.org
-ck
govindas
Newbie
*
Offline Offline

Activity: 9
Merit: 0


View Profile
July 24, 2011, 12:14:29 PM
 #3

well thanks!
i compiled curl from source and used "--with-libcurl=PREFIX" now it works... Smiley

is there a similar option like "--with-libcurl=PREFIX" for yasm? because i don't have root-acces to the PC i like to run cgmine on and can't change the $PATH var or have my own bin/ dir or anything, but 32cpus and sse2 support Wink
govindas
Newbie
*
Offline Offline

Activity: 9
Merit: 0


View Profile
July 25, 2011, 01:09:27 PM
 #4

i would really like to run the sse2_64 sha256 function in cgminer on the 32CPU's...
i tried to tell configure to use the compiled yasm code, but it did not work Sad
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!