Bitcoin Forum
November 16, 2018, 11:19:08 PM *
News: Latest Bitcoin Core release: 0.17.0 [Torrent].
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: How to Optimize cgminer for 5870  (Read 6067 times)
worldinacoin
Hero Member
*****
Offline Offline

Activity: 756
Merit: 500



View Profile
November 27, 2011, 02:12:39 AM
 #1

Just tested two 5870 on Ubuntu with cgminer and crossfire (can't detect two GPU without using crossfire), but I am only having about 600 mhash/s .  Wonder what is the best commands for it to maximize the hashes?
1542410348
Hero Member
*
Offline Offline

Posts: 1542410348

View Profile Personal Message (Offline)

Ignore
1542410348
Reply with quote  #2

1542410348
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1542410348
Hero Member
*
Offline Offline

Posts: 1542410348

View Profile Personal Message (Offline)

Ignore
1542410348
Reply with quote  #2

1542410348
Report to moderator
1542410348
Hero Member
*
Offline Offline

Posts: 1542410348

View Profile Personal Message (Offline)

Ignore
1542410348
Reply with quote  #2

1542410348
Report to moderator
1542410348
Hero Member
*
Offline Offline

Posts: 1542410348

View Profile Personal Message (Offline)

Ignore
1542410348
Reply with quote  #2

1542410348
Report to moderator
Turbor
Legendary
*
Offline Offline

Activity: 1022
Merit: 1000


BitMinter


View Profile WWW
November 27, 2011, 01:59:53 PM
 #2

Change the intensity to 9 or so. Never used crossfire. I was able to use my second card without a VGA dummy plug in Win7. But using one is better for me. Now i can change the settings the way i want. That was not possible before.

worldinacoin
Hero Member
*****
Offline Offline

Activity: 756
Merit: 500



View Profile
November 27, 2011, 02:09:36 PM
 #3

Prob is without cross fire, my cgminer can only recognize 1 GPU using Ubuntu Linux, will Windows recognize two without cross fire?
Turbor
Legendary
*
Offline Offline

Activity: 1022
Merit: 1000


BitMinter


View Profile WWW
November 27, 2011, 02:35:59 PM
 #4

Prob is without cross fire, my cgminer can only recognize 1 GPU using Ubuntu Linux, will Windows recognize two without cross fire?

It should.

P4man
Hero Member
*****
Offline Offline

Activity: 518
Merit: 500



View Profile
November 27, 2011, 03:10:10 PM
 #5

600MH? Thats weird. Its too much a single card and not enough for two.
And you shouldnt have to use crossfire

Turbor
Legendary
*
Offline Offline

Activity: 1022
Merit: 1000


BitMinter


View Profile WWW
November 27, 2011, 03:31:42 PM
 #6

I think 600 MH/s is two in crossfire

worldinacoin
Hero Member
*****
Offline Offline

Activity: 756
Merit: 500



View Profile
November 27, 2011, 03:40:56 PM
 #7

Yeap it is two in cross fire, or should I be using windows and guiminer?
Turbor
Legendary
*
Offline Offline

Activity: 1022
Merit: 1000


BitMinter


View Profile WWW
November 27, 2011, 04:32:24 PM
 #8

You can stick with cgminer in windows. Works well.

coretechs
Donator
Sr. Member
*
Offline Offline

Activity: 360
Merit: 250



View Profile
November 27, 2011, 10:14:47 PM
 #9

1. Disable crossfire and remove the plug
2. Run as root or sudo "aticonfig -f --initial --adapter=all"
3. reboot
4. In a new terminal run "export DISPLAY=:0"
5. Then run "cgminer --gpu-memclock 300 --gpu-fan 100 --gpu-engine 900 --gpu-vddc 1.1625 -o http://xxx.xxx -u user -p pass -I 9"

That should get you over 400mh per card as a baseline.  Hit "G" to confirm clocks and voltage.  If it's stable, adjust the gpu-engine up by 5-10 mhz at a time (or voltage down, fan, etc) until you are happy with temp and perf.  You may add --cpu-threads 1 if you have the max cpu bug to isolate to a core.


http://bitcoindoc.com - The Rise and Rise of Bitcoin | http://nxtportal.org - Nxt blockchain explorer
P4man
Hero Member
*****
Offline Offline

Activity: 518
Merit: 500



View Profile
November 27, 2011, 10:27:11 PM
 #10

Try to get it working at default gpu clock and voltage before tinkering with those.

-ck
Moderator
Legendary
*
Offline Offline

Activity: 2702
Merit: 1145


Ruu \o/


View Profile WWW
November 27, 2011, 11:11:08 PM
 #11

As coretechs said "aticonfig -f --initial --adapter=all" is probably what was missing. It sounds like you only had one GPU configured and the second is limping along purely by being attached by crossfire. You shouldn't need crossfire.

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
worldinacoin
Hero Member
*****
Offline Offline

Activity: 756
Merit: 500



View Profile
November 29, 2011, 04:47:40 AM
 #12

I think I will reinstall, any recommendations?  Ubuntu 11.10 or 10.4?
kano
Legendary
*
Offline Offline

Activity: 2632
Merit: 1059


Linux since 1997 RedHat 4


View Profile
November 29, 2011, 06:31:45 AM
 #13

11.04 Tongue
See my sig
(and don't update it to 11.10 - not needed and not enough space if you use a USB to run updates)

Pool: https://kano.is Here on Bitcointalk: Forum BTC: 1KanoPb8cKYqNrswjaA8cRDk4FAS9eDMLU
FreeNode IRC: irc.freenode.net channel #kano.is Majority developer of the ckpool code
Help keep Bitcoin secure by mining on pools with full block verification on all blocks - and NO empty blocks!
worldinacoin
Hero Member
*****
Offline Offline

Activity: 756
Merit: 500



View Profile
November 29, 2011, 06:41:27 AM
 #14

11.04 Tongue
See my sig
(and don't update it to 11.10 - not needed and not enough space if you use a USB to run updates)

Thanks a million, your sig is just what I need!
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!