Bitcoin Forum
November 17, 2017, 06:05:08 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: How to override the default 0.0002 transaction fee?  (Read 1475 times)
Este Nuno
Legendary
*
Offline Offline

Activity: 826


amarha


View Profile
June 08, 2014, 05:30:55 PM
 #1

Someone mentioned in another thread that they override the default fee in Electrum and send most transactions without a fee. I'm not sure how to do this. Would anyone mind explaining?

Thanks.
Coinlancer is Disrupting the Freelance marketplace!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1510941908
Hero Member
*
Offline Offline

Posts: 1510941908

View Profile Personal Message (Offline)

Ignore
1510941908
Reply with quote  #2

1510941908
Report to moderator
1510941908
Hero Member
*
Offline Offline

Posts: 1510941908

View Profile Personal Message (Offline)

Ignore
1510941908
Reply with quote  #2

1510941908
Report to moderator
1510941908
Hero Member
*
Offline Offline

Posts: 1510941908

View Profile Personal Message (Offline)

Ignore
1510941908
Reply with quote  #2

1510941908
Report to moderator
jonald_fyookball
Legendary
*
Offline Offline

Activity: 1246


Core dev leaves me neg feedback #abuse #political


View Profile
June 08, 2014, 07:25:20 PM
 #2

Just go under tools, preferences ... You can change default fee, or just change on each transaction.

Este Nuno
Legendary
*
Offline Offline

Activity: 826


amarha


View Profile
June 08, 2014, 07:40:53 PM
 #3

Just go under tools, preferences ... You can change default fee, or just change on each transaction.

It still does not let me send. I've done that before but it won't accept it. It just says 'This transaction requires a higher fee or it will not be propagated by the network.'.
jonald_fyookball
Legendary
*
Offline Offline

Activity: 1246


Core dev leaves me neg feedback #abuse #political


View Profile
June 08, 2014, 08:06:52 PM
 #4

What version of electrum? How much are you sending?

Este Nuno
Legendary
*
Offline Offline

Activity: 826


amarha


View Profile
June 08, 2014, 08:21:30 PM
 #5

What version of electrum? How much are you sending?

1.9.8 I've tried it with different amounts. Last normal sized transaction I did was ~0.3 and it wanted 0.0004. Maybe if I set the default to 0.0001 it would have taken it as a 0.0002 transaction, but I'm not sure.

I'll keep testing it out seeing if I can find ways to send some tx's with lower fees. I guess some of my transactions are just too many kbs.
btcven
Hero Member
*****
Offline Offline

Activity: 717


Bitcoin Venezuela


View Profile WWW
June 08, 2014, 11:09:18 PM
 #6

The fee depends on the size of the transaction, making it for free would probably get your transaction to limbo and dropped eventually.

Admin: rdymac (PGP) | contacto@bitcoinvenezuela.com | @cafebitcoin | Electrum, lightweight bitcoin client
If I've been helpful tip me a coffee! Cheesy1rdymachKZpA9pTYHYHMYZjfjnoBW6B3k Bitrated user: rdymac.
dabura667
Sr. Member
****
Offline Offline

Activity: 478


View Profile
June 10, 2014, 11:43:55 AM
 #7

What version of electrum? How much are you sending?

1.9.8 I've tried it with different amounts. Last normal sized transaction I did was ~0.3 and it wanted 0.0004. Maybe if I set the default to 0.0001 it would have taken it as a 0.0002 transaction, but I'm not sure.

I'll keep testing it out seeing if I can find ways to send some tx's with lower fees. I guess some of my transactions are just too many kbs.

Open /lib/bitcoin.py in electrum's install folder. (you can't do this with the standalone version)

Search for
Code:
MIN_RELAY_TX_FEE =

Change that number from 10000 to 1000 (this is the new minimum fee for 0.9.0 and beyond.)

Then after you save that file, restart electrum, then go into preferences and set the default fee to 0.00001 BTC (or 0.01 mBTC) and save.

A little more than half of miners use 0.9.0 and beyond, so you might have to wait 20 minutes instead of 10 minutes for your first confirmation.


WARNING: Setting that number in bitcoin.py to 0 is a bad idea, recently 0 fee transactions that require fees can take days or even weeks to confirm.

My Tip Address:
1DXcHTJS2DJ3xDoxw22wCt11FeAsgfzdBU
Este Nuno
Legendary
*
Offline Offline

Activity: 826


amarha


View Profile
June 10, 2014, 01:20:37 PM
 #8

What version of electrum? How much are you sending?

1.9.8 I've tried it with different amounts. Last normal sized transaction I did was ~0.3 and it wanted 0.0004. Maybe if I set the default to 0.0001 it would have taken it as a 0.0002 transaction, but I'm not sure.

I'll keep testing it out seeing if I can find ways to send some tx's with lower fees. I guess some of my transactions are just too many kbs.

Open /lib/bitcoin.py in electrum's install folder. (you can't do this with the standalone version)

Search for
Code:
MIN_RELAY_TX_FEE =

Change that number from 10000 to 1000 (this is the new minimum fee for 0.9.0 and beyond.)

Then after you save that file, restart electrum, then go into preferences and set the default fee to 0.00001 BTC (or 0.01 mBTC) and save.

A little more than half of miners use 0.9.0 and beyond, so you might have to wait 20 minutes instead of 10 minutes for your first confirmation.


WARNING: Setting that number in bitcoin.py to 0 is a bad idea, recently 0 fee transactions that require fees can take days or even weeks to confirm.

Excellent. Thanks a lot.
Este Nuno
Legendary
*
Offline Offline

Activity: 826


amarha


View Profile
June 14, 2014, 06:29:20 PM
 #9

I still can't send anything lower than 0.0001 no matter what. The software says the network won't accept anything lower than than even when i change it in the python file.
dabura667
Sr. Member
****
Offline Offline

Activity: 478


View Profile
June 15, 2014, 04:15:19 AM
 #10

I still can't send anything lower than 0.0001 no matter what. The software says the network won't accept anything lower than than even when i change it in the python file.

Did you also change the preferences fee to 0?

bitcoin.py's minimum fee is set to zero.

Tools > Preferences > Transaction Fees is also set to 0.

send some bitcoins without a fee. (make sure the "Fee" box says "0" or "0." or something along those lines.) (ALSO make sure you have enough bitcoins, and that they are not immature mining reward coins.)

I just tried it out, and it worked fine for me.

I don't think it has anything to do with it, but just in case, I was connected to electrum.206industries.com when I tested just now. Try manually connecting to them.

My Tip Address:
1DXcHTJS2DJ3xDoxw22wCt11FeAsgfzdBU
fxbit
Jr. Member
*
Offline Offline

Activity: 42


View Profile
November 12, 2017, 04:32:17 PM
 #11

Is this things still work today in 2017, I tried it, its not working anymore with backlog of transaction probably will not work for sometime, anyone have good result please share
TheButterZone
Legendary
*
Offline Offline

Activity: 1960


Nemo me impune lacessit


View Profile WWW
November 13, 2017, 12:13:21 AM
 #12

Is this things still work today in 2017, I tried it, its not working anymore with backlog of transaction probably will not work for sometime, anyone have good result please share

https://github.com/TheButterZone/electrum/commit/fca33e290015b475463481fc9b6626489aad5495#commitcomment-25346743

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!