Bitcoin Forum
December 09, 2016, 12:27:44 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1] 2 »  All
  Print  
Author Topic: Trouble Overclocking 5850 to 900MHz shader  (Read 3737 times)
fpgaminer
Hero Member
*****
Offline Offline

Activity: 546



View Profile WWW
April 28, 2011, 01:10:23 AM
 #1

I recently bought a Sapphire HD 5850 ($150 after taxes) ... so I can race it against my FPGAs  Tongue

I have Ubuntu 10.10 32-bit, fglrx 8.801, 2.1 SDK. Using aticonfig I can overclock up to 900MHz, which is good enough for me, except that at that speed it freezes within a few seconds (screen no longer responds; have to REISUB). It ran overnight at 765MHz just fine. In Windows it could run at 900MHz for about an hour, and then Windows restarts the driver because it stops responding.

Is my card just a weak batch and won't ever get to 900MHz stable, or is there something else I can do?

Thank you!

1481243264
Hero Member
*
Offline Offline

Posts: 1481243264

View Profile Personal Message (Offline)

Ignore
1481243264
Reply with quote  #2

1481243264
Report to moderator
1481243264
Hero Member
*
Offline Offline

Posts: 1481243264

View Profile Personal Message (Offline)

Ignore
1481243264
Reply with quote  #2

1481243264
Report to moderator
1481243264
Hero Member
*
Offline Offline

Posts: 1481243264

View Profile Personal Message (Offline)

Ignore
1481243264
Reply with quote  #2

1481243264
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481243264
Hero Member
*
Offline Offline

Posts: 1481243264

View Profile Personal Message (Offline)

Ignore
1481243264
Reply with quote  #2

1481243264
Report to moderator
1481243264
Hero Member
*
Offline Offline

Posts: 1481243264

View Profile Personal Message (Offline)

Ignore
1481243264
Reply with quote  #2

1481243264
Report to moderator
rezin777
Full Member
***
Offline Offline

Activity: 154


View Profile
April 28, 2011, 01:16:42 AM
 #2

This could be a possible BIOS limitation.

If it is a reference board, you can easily flash the BIOS to allow for higher overclocking limits. Simply pick a BIOS from a different reference board that allows for higher overclocking.

If it is a non-reference board, you should download RBE from http://www.techpowerup.com/downloads/1962/TechPowerUp_Radeon_Bios_Editor_v1.28.html and modify your BIOS to the limits you prefer.
grndzero
Sr. Member
****
Offline Offline

Activity: 392


View Profile
April 28, 2011, 01:20:03 AM
 #3

I recently bought a Sapphire HD 5850 ($150 after taxes) ... so I can race it against my FPGAs  Tongue

I have Ubuntu 10.10 32-bit, fglrx 8.801, 2.1 SDK. Using aticonfig I can overclock up to 900MHz, which is good enough for me, except that at that speed it freezes within a few seconds (screen no longer responds; have to REISUB). It ran overnight at 765MHz just fine. In Windows it could run at 900MHz for about an hour, and then Windows restarts the driver because it stops responding.

Is my card just a weak batch and won't ever get to 900MHz stable, or is there something else I can do?

Thank you!

The highest I could get my 5850's to before freezing was 875. I got them up to 900 by flashing them with 5870 BIOS.
http://www.techpowerup.com/vgabios/61848/ATI.HD5870.1024.091112.html

Ubuntu Desktop x64 -  HD5850 Reference - 400Mh/s w/ cgminer  @ 975C/325M/1.175V - 11.6/2.1 SDK
Donate if you find this helpful: 1NimouHg2acbXNfMt5waJ7ohKs2TtYHePy
fpgaminer
Hero Member
*****
Offline Offline

Activity: 546



View Profile WWW
April 28, 2011, 01:27:25 AM
 #4

Quote
The highest I could get my 5850's to before freezing was 875. I got them up to 900 by flashing them with 5870 BIOS.
Just to be clear, you had to flash your BIOS to make it stable, or to even set it to 900?

I can set my card to 900 MHz no problem. It's just that the display freezes and I have to do a restart (REISUB).

What does that BIOS do that would prevent the card from failing at higher clock speeds?

rezin777
Full Member
***
Offline Offline

Activity: 154


View Profile
April 28, 2011, 01:28:53 AM
 #5

Just to be clear, you had to flash your BIOS to make it stable, or to even set it to 900?

I can set my card to 900 MHz no problem. It's just that the display freezes and I have to do a restart (REISUB).

What does that BIOS do that would prevent the card from failing at higher clock speeds?

The BIOS has clock speed limits.
grndzero
Sr. Member
****
Offline Offline

Activity: 392


View Profile
April 28, 2011, 02:03:18 AM
 #6

Quote
The highest I could get my 5850's to before freezing was 875. I got them up to 900 by flashing them with 5870 BIOS.
Just to be clear, you had to flash your BIOS to make it stable, or to even set it to 900?

I can set my card to 900 MHz no problem. It's just that the display freezes and I have to do a restart (REISUB).

What does that BIOS do that would prevent the card from failing at higher clock speeds?

Just to be able to get to 900 core speed. Mine wouldn't go past 875.

The 5870 bios ups the voltage allowing it to run at higher clock speeds.

On the Reference boards most of the PCB's are the same, the 5850 just has less stream processors.

Ubuntu Desktop x64 -  HD5850 Reference - 400Mh/s w/ cgminer  @ 975C/325M/1.175V - 11.6/2.1 SDK
Donate if you find this helpful: 1NimouHg2acbXNfMt5waJ7ohKs2TtYHePy
fpgaminer
Hero Member
*****
Offline Offline

Activity: 546



View Profile WWW
April 28, 2011, 05:39:19 AM
 #7

Quote
The BIOS has clock speed limits.
I know. This board lets me go up to 900 without any mods, in all the overclock tools I've tried. So that isn't the issue. The issue is that going to 900 makes the card go KERBLEWIE.

Quote
The 5870 bios ups the voltage allowing it to run at higher clock speeds.
Thank you for clarifying what you meant. I remember that AMDOverdriveCtrl let me adjust the voltages. If that's true, would that be the same as BIOS flashing? And what kind of voltage is appropriate for 900MHz?

I'm a bit wary of BIOS flashing the card, since I don't have a spare PCI card to help fix it if things go awry (only one PCI-E slot on that machine Sad )

Thank you for the suggestions and help so far!

grndzero
Sr. Member
****
Offline Offline

Activity: 392


View Profile
April 28, 2011, 05:56:01 AM
 #8

Quote
The BIOS has clock speed limits.
I know. This board lets me go up to 900 without any mods, in all the overclock tools I've tried. So that isn't the issue. The issue is that going to 900 makes the card go KERBLEWIE.

Quote
The 5870 bios ups the voltage allowing it to run at higher clock speeds.
Thank you for clarifying what you meant. I remember that AMDOverdriveCtrl let me adjust the voltages. If that's true, would that be the same as BIOS flashing? And what kind of voltage is appropriate for 900MHz?

I'm a bit wary of BIOS flashing the card, since I don't have a spare PCI card to help fix it if things go awry (only one PCI-E slot on that machine Sad )

Thank you for the suggestions and help so far!

Understandable. I have 4-5 crappy PCI cards laying around, so I didn't have a problem trying out all the tweaked BIOS that were posted. I think I've had to recover 3 times now. lol

I didn't try AMDOverdriveCtl until I had already flashed the BIOS. Upping the voltage with AMDOverdriveCtl could work, but you may run into a hard limit with the BIOS.

If aticonfig --odgc says that the BIOS supports up to 900 then try AMDOverdriveCtl .. my overdrive file:

Code:
<?xml version="1.0" encoding="utf-8"?>
<OVERDRIVE_PROFILE>
  <PERFORMANCE_LEVEL level="2" gpu="90000" mem="30000" voltage="1088"/>
  <PERFORMANCE_LEVEL level="1" gpu="55000" mem="30000" voltage="1038"/>
  <PERFORMANCE_LEVEL level="0" gpu="15700" mem="30000" voltage="1000"/>
  <FAN_SETTING percentage="80"/>
  <FAN_CTRL enabled="no"/>
</OVERDRIVE_PROFILE>

If the BIOS doesn't say 900 then try changing the 90000 to your current running speed, etc 87500 with the 1088 voltage and reassess with aticonfig --odgc and see if it raises the limit to 900. If so then try to step it up with either aticonfig or overdrivectl.

If that doesn't work then you're probably hitting a hard BIOS limit.

Ubuntu Desktop x64 -  HD5850 Reference - 400Mh/s w/ cgminer  @ 975C/325M/1.175V - 11.6/2.1 SDK
Donate if you find this helpful: 1NimouHg2acbXNfMt5waJ7ohKs2TtYHePy
rezin777
Full Member
***
Offline Offline

Activity: 154


View Profile
April 28, 2011, 04:23:48 PM
 #9

The issue is that going to 900 makes the card go KERBLEWIE.

I am under the assumption that this is what happens when you hit the BIOS limit. I could be wrong.
fpgaminer
Hero Member
*****
Offline Offline

Activity: 546



View Profile WWW
April 28, 2011, 10:00:18 PM
 #10

Quote
my overdrive file:
Thank you for that.

So I checked, and at 900MHz the chip receives 1.088V, the same as yours.  Undecided

I was able to run the card at 850MHz all through last night. So it's just 900 MHz specifically that's giving me unhappy times. Maybe I should try 899 ...

Quote
I am under the assumption that this is what happens when you hit the BIOS limit. I could be wrong.
Perhaps. The odd thing is that, under Windows, it can run 900MHz for a while. About an hour. And then it goes KERBLEWIE. If it were a hard limit in the BIOS I assume it would just go KERBLEWIE immediately.

Also, in Windows it resets the driver when things go awry, instead of locking up like Ubuntu does. From there, it's back to normal (at 900MHz), except the miner (phoenix) has stopped because of the driver reset.

CoinMan
Member
**
Offline Offline

Activity: 104



View Profile
April 29, 2011, 04:47:20 AM
 #11

I have purchased this same card a couple of days ago and am experiencing the same issue with Ubuntu 10.10 64bit.  I tried simply flashing my board with it's most recent bios but that didn't help.  I'm at 850,1200 right now get 300 M/hs and it seems to be "holding".

I ran in for the first day just fine at 875,1000 but then realized today that it locked up at midnight Sad...lost about 10 hours of mining before I noticed the problem.

Hopefully these settings keep me stable.  I think I'll skip the 11.04 upgrade and any others that come along.  It seems any update just causes me pain and sorrow!

I'll report back if this continues to be stable with these settings and good luck!

CoinMan

My Bitcoin Identity
Bitcoin: 183DFFQXR4xCyseBXzmh3XWc22izDWE5Dw
marcus_of_augustus
Legendary
*
Offline Offline

Activity: 2100



View Profile
April 29, 2011, 04:58:53 AM
 #12


X server is not so happy to share GPU resources as windows with OClocking tools enabled... i'm pretty sure it is the Xorg process that is hanging but if you could ssh or otherwise remotely login you may find the OS is still up ... at least I did ... othertimes it really is the OS (kernel) that has crashed.

It is a real mess in linux because the x server is taking care of hardware control of the GPU's that are acting as compute nodes in this application but it is a different philosophy than what the x server was built todo  (graphics display management) ...

djex
Full Member
***
Offline Offline

Activity: 196


View Profile
April 29, 2011, 05:14:50 AM
 #13

I have a XFX 5850 running at 900Mhz core and 1000Mhz Memory using unlocked MSI Afterburner. Works fine with no problems and I've run it a full day with out any issues.

My card has a BIOS limit of 775Mhz on the core. With MSI Afterburner I'm able to go beyond that. I'm not sure why this is or how MSI Afterburner does it without having to flash the BIOS to a 5870. Of course this only works in Windows and I am unaware of any program that will do this in Linux.

Smiley  : 1LbvSEJwtQZKLSQQVYxQJes8YneQk2yhE3
grndzero
Sr. Member
****
Offline Offline

Activity: 392


View Profile
April 29, 2011, 05:18:15 AM
 #14


I was able to run the card at 850MHz all through last night. So it's just 900 MHz specifically that's giving me unhappy times. Maybe I should try 899 ...


I don't know if you can do increments other than 25, but you can try it.

Also, in Windows it resets the driver when things go awry, instead of locking up like Ubuntu does. From there, it's back to normal (at 900MHz), except the miner (phoenix) has stopped because of the driver reset.

I came at it from the BIOS perspective since I set out to run it on Linux and hadn't seen anything about power management (and didn't really expect anything).

They have had a lot more time to perfect the ungodly things they can do to the cards in Windows, especially since Vista/7 managed to separate the kernel and video drivers a bit so it's more stable (relatively) and can reload the drivers without rebooting.

Ubuntu Desktop x64 -  HD5850 Reference - 400Mh/s w/ cgminer  @ 975C/325M/1.175V - 11.6/2.1 SDK
Donate if you find this helpful: 1NimouHg2acbXNfMt5waJ7ohKs2TtYHePy
fpgaminer
Hero Member
*****
Offline Offline

Activity: 546



View Profile WWW
April 29, 2011, 05:24:06 AM
 #15

Quote
I'm at 850,1200 right now get 300 M/hs and it seems to be "holding".
300 seems low. Are you using phoenix with BFI_INT?

I'm getting 320 MH/s on Windows at 850, SDK 2.3, phoenix 1.3. Linux was getting slightly better figures (when it wasn't crashing ...).

I haven't tried SDK 2.1 on Windows yet. That might bring me closer to grndzero's glorious 360 MH/s.  Grin

Quote
i'm pretty sure it is the Xorg process
Maybe. I tried ctrl+alt+backspace to no avail. Had to REISUB every time it locked up. The miner also stopped. I did not try SSH though. I might take another stab at getting Linux stable later.

CoinMan
Member
**
Offline Offline

Activity: 104



View Profile
April 29, 2011, 05:32:03 AM
 #16

Quote
I'm at 850,1200 right now get 300 M/hs and it seems to be "holding".
300 seems low. Are you using phoenix with BFI_INT?

I'm getting 320 MH/s on Windows at 850, SDK 2.3, phoenix 1.3. Linux was getting slightly better figures (when it wasn't crashing ...).

I haven't tried SDK 2.1 on Windows yet. That might bring me closer to grndzero's glorious 360 MH/s.  Grin

Quote
i'm pretty sure it is the Xorg process
Maybe. I tried ctrl+alt+backspace to no avail. Had to REISUB every time it locked up. The miner also stopped. I did not try SSH though. I might take another stab at getting Linux stable later.

What is phoenix 1.3?  Obviously I'm not using that...maybe I should.

My Bitcoin Identity
Bitcoin: 183DFFQXR4xCyseBXzmh3XWc22izDWE5Dw
grndzero
Sr. Member
****
Offline Offline

Activity: 392


View Profile
April 29, 2011, 05:53:50 AM
 #17

What is phoenix 1.3?  Obviously I'm not using that...maybe I should.

A new OpenCL miner.

http://bitcointalk.org/index.php?topic=6458.msg94376#msg94376

Ubuntu Desktop x64 -  HD5850 Reference - 400Mh/s w/ cgminer  @ 975C/325M/1.175V - 11.6/2.1 SDK
Donate if you find this helpful: 1NimouHg2acbXNfMt5waJ7ohKs2TtYHePy
CoinMan
Member
**
Offline Offline

Activity: 104



View Profile
April 29, 2011, 05:58:07 AM
 #18

What is phoenix 1.3?  Obviously I'm not using that...maybe I should.

A new OpenCL miner.

http://bitcointalk.org/index.php?topic=6458.msg94376#msg94376


Thanks! Getting it now.


My Bitcoin Identity
Bitcoin: 183DFFQXR4xCyseBXzmh3XWc22izDWE5Dw
grndzero
Sr. Member
****
Offline Offline

Activity: 392


View Profile
April 29, 2011, 06:03:23 AM
 #19

Quote
I'm at 850,1200 right now get 300 M/hs and it seems to be "holding".
300 seems low. Are you using phoenix with BFI_INT?

I'm getting 320 MH/s on Windows at 850, SDK 2.3, phoenix 1.3. Linux was getting slightly better figures (when it wasn't crashing ...).

I haven't tried SDK 2.1 on Windows yet. That might bring me closer to grndzero's glorious 360 MH/s.  Grin

Quote
i'm pretty sure it is the Xorg process
Maybe. I tried ctrl+alt+backspace to no avail. Had to REISUB every time it locked up. The miner also stopped. I did not try SSH though. I might take another stab at getting Linux stable later.

Wow, then it's a trade off because before overclocking and lowering the mem clock I had to go to 875/1000 to get 300 Mh/s and at 900/1000 I was getting 317Mh/s with poclbm. phoenix and BFI_INT brought that up to 343.5Mh/s then once I added lowering the mem clock to 300 I got to 361Mh/s.

Ubuntu Desktop x64 -  HD5850 Reference - 400Mh/s w/ cgminer  @ 975C/325M/1.175V - 11.6/2.1 SDK
Donate if you find this helpful: 1NimouHg2acbXNfMt5waJ7ohKs2TtYHePy
Grinder
Legendary
*
Offline Offline

Activity: 1269


View Profile
April 29, 2011, 08:21:59 AM
 #20

I was able to run the card at 850MHz all through last night. So it's just 900 MHz specifically that's giving me unhappy times. Maybe I should try 899 ...
50 MHz is a *huge* difference for stability. For instance, the last GPU I optimised will run just fine at 850 MHz, crash after a while at 860, and crash immediately at 870.
Pages: [1] 2 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!