Bitcoin Forum
August 22, 2018, 12:22:44 AM *
News: Latest stable version of Bitcoin Core: 0.16.2  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 [8] 9 10 11 12 13 14 15 16 »  All
  Print  
Author Topic: 7xGPU + Windows // modding AMD video driver is the answer  (Read 71201 times)
JJ12880
Hero Member
*****
Offline Offline

Activity: 661
Merit: 501


Blockchain and stuff


View Profile
November 25, 2016, 06:20:49 PM
 #141

Am I wasting my time, trying to get mixed 2x 7970 1x 7990, 2x RX 480's on the same windows rig?    It seems the standard 15.12 wont recognize the 480's, and get BSOD's after 10 seconds when using 16.9.  

EDIT

Seems to work just fine without the 7990 (4cards) but with the 7990 (6 cards) its very unstable. BSOD and blackscreens.

In my small farm, I use ASrock H81 (3,4,5,6,7 GPUs with risers) and Biostar Z170 (4xGPU no risers).

I am done doing rig with risers, so future rigs with 4xGPU formats only to simplify mining operations.

Mixing GPU types is always a nightmare mainly because of drivers, PCI-USB risers, PCI slot and power draw issues...

For AMD, newer cards like RX / Polaris based - better on separate rigs because of driver support and other peculiar RX add-ons.




That is what I am learning. My 79xx tahiti based cards all are happy as clams on 15.12, but unstable on the 16.x series drivers, though I have yet to try them all.  I have the asrock btc pro, so I have 6 slots and was hoping to mix cards, but alas, seems it wont be so

Radium  Bringing Advanced Utility to the Blockchain!
BTCT Thread | Telegram[/b]
1534897364
Hero Member
*
Offline Offline

Posts: 1534897364

View Profile Personal Message (Offline)

Ignore
1534897364
Reply with quote  #2

1534897364
Report to moderator
1534897364
Hero Member
*
Offline Offline

Posts: 1534897364

View Profile Personal Message (Offline)

Ignore
1534897364
Reply with quote  #2

1534897364
Report to moderator
BOUNTY PORTALS
BLOG
WHERE BOUNTY MANAGEMENT
MEETS AUTOMATION
SIGNATURE CAMPAIGNS
TWITTER
FACEBOOK
MEDIA CAMPAIGNS
AND MORE!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
go6ooo1212
Legendary
*
Offline Offline

Activity: 1400
Merit: 1000


Get smart !


View Profile
November 30, 2016, 10:45:45 PM
 #142

Would someone give me a hint , how to run 7+ Polaris GPUs under Win8.1 x64.
I succeed to run only 6 , the mod could not fix the 7th gpu...
citronick
Legendary
*
Offline Offline

Activity: 1078
Merit: 1031


---- winter*juvia -----


View Profile
December 01, 2016, 01:48:46 AM
 #143

Would someone give me a hint , how to run 7+ Polaris GPUs under Win8.1 x64.
I succeed to run only 6 , the mod could not fix the 7th gpu...

Get this - https://www.aliexpress.com/item/PCI-e-Express-1X-to-3-Port-1X-Switch-Multiplier-HUB-Riser-Card-USB-Cable-Drop/32688639286.html?spm=2114.13010608.0.0.CkQQsb

and you may need to upgrade to Win10 to make it work.

If I provided you good and useful info or just bring a smile to your day, consider sending me merit points to further validate this Bitcointalk account ~ useful for future account recovery... BINANCE vs Huobi.Pro - Buy/Sell hash at Nicehash - Rent Rigs at MRR - SMOS -BBT/VOSK/AANTONOP/CBB/PM57/CryptoNEWS/CoinMktCap/Cryptoboreas
go6ooo1212
Legendary
*
Offline Offline

Activity: 1400
Merit: 1000


Get smart !


View Profile
December 01, 2016, 05:03:16 AM
 #144

Would someone give me a hint , how to run 7+ Polaris GPUs under Win8.1 x64.
I succeed to run only 6 , the mod could not fix the 7th gpu...

Get this - https://www.aliexpress.com/item/PCI-e-Express-1X-to-3-Port-1X-Switch-Multiplier-HUB-Riser-Card-USB-Cable-Drop/32688639286.html?spm=2114.13010608.0.0.CkQQsb

and you may need to upgrade to Win10 to make it work.
Yeah I've setup a similar one with 4 additional slots , but the problem is how to run all the cards on win 8.1
citronick
Legendary
*
Offline Offline

Activity: 1078
Merit: 1031


---- winter*juvia -----


View Profile
December 01, 2016, 12:08:07 PM
 #145

Would someone give me a hint , how to run 7+ Polaris GPUs under Win8.1 x64.
I succeed to run only 6 , the mod could not fix the 7th gpu...

Get this - https://www.aliexpress.com/item/PCI-e-Express-1X-to-3-Port-1X-Switch-Multiplier-HUB-Riser-Card-USB-Cable-Drop/32688639286.html?spm=2114.13010608.0.0.CkQQsb

and you may need to upgrade to Win10 to make it work.
Yeah I've setup a similar one with 4 additional slots , but the problem is how to run all the cards on win 8.1

hmmm.... RX480s or 470s x 7 on Win8.1.... sorry dude havent tried that because when RX480s first came out it only supported W10 and W7..... I think W8.1 support only came later and with Wattman etc. seems only W10 can do the job.

Anyways, for what its worth my 7 x R370 on Win 8.1 below no issues with the PCI multiplexor, last PCI slot with 2 x GPU with this special riser. The only thing unique I guess is the Crimson version 16.11.2. I remembered upgrading this rig from 15.12; also I think I had to do the 6XGPU hack too to get rid of the Error 43 thinghy.

I believe there is no issues in supporting 7 GPUs on W10 - should work.

Have you tried safe mode DDU and install latest Crimson?




If I provided you good and useful info or just bring a smile to your day, consider sending me merit points to further validate this Bitcointalk account ~ useful for future account recovery... BINANCE vs Huobi.Pro - Buy/Sell hash at Nicehash - Rent Rigs at MRR - SMOS -BBT/VOSK/AANTONOP/CBB/PM57/CryptoNEWS/CoinMktCap/Cryptoboreas
cryptomined
Full Member
***
Offline Offline

Activity: 168
Merit: 104



View Profile WWW
December 01, 2016, 12:52:27 PM
 #146

How about how to get 8 or 9 GPU's working in windows 10?

go6ooo1212
Legendary
*
Offline Offline

Activity: 1400
Merit: 1000


Get smart !


View Profile
December 01, 2016, 02:52:44 PM
 #147

How about how to get 8 or 9 GPU's working in windows 10?
I'll try with 8 and 9 these days
batko
Full Member
***
Offline Offline

Activity: 164
Merit: 100


View Profile
December 01, 2016, 03:40:26 PM
 #148

How about how to get 8 or 9 GPU's working in windows 10?
i have 8xRX 480, but not working, black screen, with 7x480 works fine.

Donation: ETH: 0x0c8ce94dd3d1bfd09c0f887559c61d1b551e4b4d
Makurika
Jr. Member
*
Offline Offline

Activity: 32
Merit: 0


View Profile
December 05, 2016, 05:28:53 PM
 #149

How about how to get 8 or 9 GPU's working in windows 10?
I'll try with 8 and 9 these days

9 will not work.
hwlgraka
Newbie
*
Offline Offline

Activity: 8
Merit: 0


View Profile
December 06, 2016, 04:13:23 AM
 #150

Hello,

I have the following setup running:

6x XFX RX 480
Asrock Pro BTC
Windows 8.1

The problem is, the driver 15.12 is not working for RX 480 anymore, therefore I have to use the newest driver, which at the moment is Crimson 16.11.5.
Five GPUs are working fine, but I can't get the sixth GPU recognized from the system.

I also tried 6xGPU Mod with 16.11.5, but it's not working. It's not an issue related to a clean uninstall, because I've successfully used DDU with a safe restart.

I also tried the drivers 14.4 and 16.1.1, but they are also not able to be installed on the RX 480.
The problem always is, that only the two options "HDMI Audio Driver" and "AMD Install Manager" can be selected, but after clicking the Install button, the installation is finished within a few seconds and ONLY those two items have been installed but no display drivers.

Do you know any fix for getting the sixth GPU to work with the 16.11.5 driver version?

Thanks very much in advance.

Kind regards,
- hwlgraka
lbr
Sr. Member
****
Offline Offline

Activity: 421
Merit: 254


View Profile
December 06, 2016, 08:34:25 AM
 #151

Do you know any fix for getting the sixth GPU to work with the 16.11.5 driver version?

Windows Server 2016

BTC: 18ozhbkfHneX8tnPgHJuTizyBmspM5Vgpa  LTC: LgVc7KdedPGZyDXHXEH9G7z6AoTmTvDdWb
cgminer 2.11.13 x64 portable for Mac OS X 10.6.8
6+ GPUs driver mod for Windows
Aktor
Full Member
***
Offline Offline

Activity: 147
Merit: 100


View Profile
December 06, 2016, 10:19:28 AM
 #152

some links for 8 gpu
http://cryptomining-blog.com/tag/8x-gpu-mining-rig/
https://devtalk.nvidia.com/default/topic/738070/cuda-setup-and-installation/8x-gpu-gtx-issue-under-windows/post/4208565/#4208565
http://forum.ethereum.org/discussion/5195/riser-1-to-3-pci-e-1x
http://forum.ethereum.org/discussion/comment/34553/#Comment_34553
hwlgraka
Newbie
*
Offline Offline

Activity: 8
Merit: 0


View Profile
December 06, 2016, 12:52:49 PM
 #153

Do you know any fix for getting the sixth GPU to work with the 16.11.5 driver version?

Windows Server 2016

Thanks for the hint. Do I have to take anything special into account?
Or is it just installing Windows Server 2016 GUI-Version, installing the newest AMD driver for the RX 480, running the 6xGPU Mod and then it should work?

Did you already test Windows Server 2016? Because I tried WinSrv2012R2 but I wasn't able to install any of the AMD drivers. It always failed due to the message "Application install: install package failure". I installed all the c++ redistributables, but couldn't get it working, therefore I switched to Win8.1.

Thanks
TeamButtcoin
Sr. Member
****
Offline Offline

Activity: 467
Merit: 500



View Profile
December 06, 2016, 01:53:39 PM
 #154

Hello,

I have the following setup running:

6x XFX RX 480
Asrock Pro BTC
Windows 8.1

The problem is, the driver 15.12 is not working for RX 480 anymore, therefore I have to use the newest driver, which at the moment is Crimson 16.11.5.
Five GPUs are working fine, but I can't get the sixth GPU recognized from the system.

I also tried 6xGPU Mod with 16.11.5, but it's not working. It's not an issue related to a clean uninstall, because I've successfully used DDU with a safe restart.

I also tried the drivers 14.4 and 16.1.1, but they are also not able to be installed on the RX 480.
The problem always is, that only the two options "HDMI Audio Driver" and "AMD Install Manager" can be selected, but after clicking the Install button, the installation is finished within a few seconds and ONLY those two items have been installed but no display drivers.

Do you know any fix for getting the sixth GPU to work with the 16.11.5 driver version?

Thanks very much in advance.

Kind regards,
- hwlgraka
For me it works  with Crimson 16.10.2 + 6gpu_mod ( win7 and win 8.1 )

     ███▄▄  ▄▄███
██▄▄   ▀▀████▀▀   ▄▄██
 ▀▀███▄▄      ▄▄███▀▀
█▄▄  ▀▀███▄▄███▀▀
█████▄▄  ▀▀▀▀  ▄▄
██  ▀▀███▄▄▄▄███▀
██      ▀▀██▀▀     ▄▄▄
██   ▄▄        ▄▄███▀▀
██   ▀███▄▄▄▄███▀▀
██▄     ▀▀██▀▀     ▄▄▄
▀▀███▄▄        ▄▄███▀▀
    ▀▀███▄▄▄▄███▀▀
        ▀▀██▀▀
graIn..
.
The Backbone of
Modern Work Agreements.
███████████████
████▀▀▀▀▀▀▀▀▀▀▀
████ ██████████████████
████ ██
████ ██
████ ██
████ ██
████
████
████
████


█████████████   █████

.Whitepaper.
█████   █████████████


████
████
████
████
██ ████
██ ████
██ ████
██ ████
██████████████████ ████
▄▄▄▄▄▄▄▄▄▄▄████
███████████████

Quote
hwlgraka
Newbie
*
Offline Offline

Activity: 8
Merit: 0


View Profile
December 06, 2016, 05:42:25 PM
 #155

For me it works  with Crimson 16.10.2 + 6gpu_mod ( win7 and win 8.1 )

Thanks for the input.
Just did a safe reboot DDU, then installed Crimson 16.10.2 and executed 6gpu_mod (including Force, Modify Registry and Restart).

The result unfortunately is the same:

https://i.imgsafe.org/6f810a5c7a.png

Any help would be appreciated.
Otherwise I have to also try Winsrv2016.

Thanks

lbr
Sr. Member
****
Offline Offline

Activity: 421
Merit: 254


View Profile
December 07, 2016, 06:38:17 AM
 #156

Do you know any fix for getting the sixth GPU to work with the 16.11.5 driver version?

Windows Server 2016

Thanks for the hint. Do I have to take anything special into account?
Or is it just installing Windows Server 2016 GUI-Version, installing the newest AMD driver for the RX 480, running the 6xGPU Mod and then it should work?

Did you already test Windows Server 2016? Because I tried WinSrv2012R2 but I wasn't able to install any of the AMD drivers. It always failed due to the message "Application install: install package failure". I installed all the c++ redistributables, but couldn't get it working, therefore I switched to Win8.1.

Thanks

Yes I really tested it -


I've also tested 2012 and 2008 and 2003. Mining(OpenCL) works fine.
But I've never installed drivers via AMD installation manager/Catalyst. I always install drivers manually.
Hm. Tho I do remember that to get Catalyst working you need to do something in the registry.. enable hardware acceleration for the GPUs.

No.. nothing special ; ) Or you can try Win10. Basically the same, except all the crap is turned off in the Server.

BTC: 18ozhbkfHneX8tnPgHJuTizyBmspM5Vgpa  LTC: LgVc7KdedPGZyDXHXEH9G7z6AoTmTvDdWb
cgminer 2.11.13 x64 portable for Mac OS X 10.6.8
6+ GPUs driver mod for Windows
lbr
Sr. Member
****
Offline Offline

Activity: 421
Merit: 254


View Profile
December 07, 2016, 06:40:43 AM
 #157

For me it works  with Crimson 16.10.2 + 6gpu_mod ( win7 and win 8.1 )
...
The result unfortunately is the same:


This is odd.
What differences in the hardware do you both have?

BTC: 18ozhbkfHneX8tnPgHJuTizyBmspM5Vgpa  LTC: LgVc7KdedPGZyDXHXEH9G7z6AoTmTvDdWb
cgminer 2.11.13 x64 portable for Mac OS X 10.6.8
6+ GPUs driver mod for Windows
lbr
Sr. Member
****
Offline Offline

Activity: 421
Merit: 254


View Profile
December 07, 2016, 06:42:30 AM
 #158

executed 6gpu_mod (including Force, Modify Registry and Restart).

Run As admin? Were the registry mods applied?
You can backup registry in the mod and send me those files, I can check.

BTC: 18ozhbkfHneX8tnPgHJuTizyBmspM5Vgpa  LTC: LgVc7KdedPGZyDXHXEH9G7z6AoTmTvDdWb
cgminer 2.11.13 x64 portable for Mac OS X 10.6.8
6+ GPUs driver mod for Windows
ioglnx
Sr. Member
****
Offline Offline

Activity: 574
Merit: 250

Fighting mob law and inquisition in this forum


View Profile
December 09, 2016, 10:32:10 AM
 #159

I would be interested on how you guys install new driver or initial setup with more than 3 cards.
I tried the method 1 card install and then install next one after each other..

But i often came across the point of loop flickering, BSOD, or random..how to say looks like MEM freeze artifacted picture.
It also takes a long time ..very long e.g with 4 cards until the setup is done and inbetween the system often freeze mouse and keyboard not working and then it suddenly after 10min works a few seconds and freezes again.

It took me always more than 2h to get 6 cards to work after countless bsods, crashes, freezes on Windows 10..So I'm curious how you guys do it and what problems you experienced.

GTX 1080Ti rocks da house... seriously... this card is a beast³
Owning by now 18x GTX1080Ti :-D @serious love of efficiency
lbr
Sr. Member
****
Offline Offline

Activity: 421
Merit: 254


View Profile
December 09, 2016, 12:16:17 PM
 #160

I would be interested on how you guys install new driver or initial setup with more than 3 cards.
I tried the method 1 card install and then install next one after each other..

But i often came across the point of loop flickering, BSOD, or random..how to say looks like MEM freeze artifacted picture.
It also takes a long time ..very long e.g with 4 cards until the setup is done and inbetween the system often freeze mouse and keyboard not working and then it suddenly after 10min works a few seconds and freezes again.

It took me always more than 2h to get 6 cards to work after countless bsods, crashes, freezes on Windows 10..So I'm curious how you guys do it and what problems you experienced.

I'd say you have some hardware issue.

AMD driver install can take a lot of time(max I've seen ~1h) because it keeps re-installing driver for all GPUs on each GPU setup, hence 6 ! installs on 6xGPU rig.
However, I've never seen lockups on driver setup. On properly working PC I mean.

Also, imo W10/2016 is very HDD IO demanding. So slower than 7/2k8.

And BSODs... well.. what do they say exactly?

BTC: 18ozhbkfHneX8tnPgHJuTizyBmspM5Vgpa  LTC: LgVc7KdedPGZyDXHXEH9G7z6AoTmTvDdWb
cgminer 2.11.13 x64 portable for Mac OS X 10.6.8
6+ GPUs driver mod for Windows
Pages: « 1 2 3 4 5 6 7 [8] 9 10 11 12 13 14 15 16 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!