Bitcoin Forum
December 07, 2016, 10:36:27 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: 7970 + Linux(Ubuntu) + 12.2 + SDK 2.6 + cgminer 2.3.1 => always coredump  (Read 8234 times)
gr0bi42
Full Member
***
Offline Offline

Activity: 158


View Profile WWW
March 30, 2012, 03:12:32 PM
 #1

Hi all,

I have a problem with my 7970 under Linux. cgminer always terminates with a segfault. Just a simple cgminer -n (without a configfile) crashes.

Same PC with flgrx, SDK 2.4 and 5870 is working well.

To get the 7970 running I've replaced:

uninstall: flgrx
uninstall: SDK 2.4
install: SDK 2.6 (latest from AMD website)
install: amd 12.2 driver (latest from AMD website)

Rest:
Ubuntu 10.04 (64 Bit)
cgminer-2.3.1-2_x86_64 (precompiled binary)

Here the ldd-output:
Code:
ldd ./cgminer
linux-vdso.so.1 =>  (0x00007fff515ff000)
libdl.so.2 => /lib/libdl.so.2 (0x00007f2bb2c4f000)
libcurl.so.4 => /usr/lib/libcurl.so.4 (0x00007f2bb2a07000)
libpthread.so.0 => /lib/libpthread.so.0 (0x00007f2bb27e9000)
libOpenCL.so.1 => /opt/AMD-APP-SDK-v2.6-RC3-lnx64/lib/x86_64/libOpenCL.so.1 (0x00007f2bb25e3000)
libncurses.so.5 => /lib/libncurses.so.5 (0x00007f2bb23a0000)
libm.so.6 => /lib/libm.so.6 (0x00007f2bb211c000)
libc.so.6 => /lib/libc.so.6 (0x00007f2bb1d99000)
/lib64/ld-linux-x86-64.so.2 (0x00007f2bb2e75000)
libidn.so.11 => /usr/lib/libidn.so.11 (0x00007f2bb1b66000)
liblber-2.4.so.2 => /usr/lib/liblber-2.4.so.2 (0x00007f2bb1957000)
libldap_r-2.4.so.2 => /usr/lib/libldap_r-2.4.so.2 (0x00007f2bb170b000)
librt.so.1 => /lib/librt.so.1 (0x00007f2bb1503000)
libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00007f2bb12ce000)
libssl.so.0.9.8 => /lib/libssl.so.0.9.8 (0x00007f2bb107c000)
libcrypto.so.0.9.8 => /lib/libcrypto.so.0.9.8 (0x00007f2bb0cec000)
libz.so.1 => /lib/libz.so.1 (0x00007f2bb0ad4000)
libresolv.so.2 => /lib/libresolv.so.2 (0x00007f2bb08bb000)
libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0x00007f2bb06a0000)
libgnutls.so.26 => /usr/lib/libgnutls.so.26 (0x00007f2bb03fe000)
libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007f2bb013a000)
libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007f2baff13000)
libcom_err.so.2 => /lib/libcom_err.so.2 (0x00007f2bafd0f000)
libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007f2bafb07000)
libkeyutils.so.1 => /lib/libkeyutils.so.1 (0x00007f2baf903000)
libtasn1.so.3 => /usr/lib/libtasn1.so.3 (0x00007f2baf6f2000)
libgcrypt.so.11 => /lib/libgcrypt.so.11 (0x00007f2baf479000)
libgpg-error.so.0 => /lib/libgpg-error.so.0 (0x00007f2baf275000)

Anyone out there with a working combo 7970+cgminer+linux?
What SW and versions do you use?
Any tricks/workarounds to make this combo work?
Do I have to compile cgminer by myself?

Reagrds

Donations are welcome: 1Btf3BqUegfe5iFdWsgfBf1Ew3YsAvsrLT
1481106987
Hero Member
*
Offline Offline

Posts: 1481106987

View Profile Personal Message (Offline)

Ignore
1481106987
Reply with quote  #2

1481106987
Report to moderator
1481106987
Hero Member
*
Offline Offline

Posts: 1481106987

View Profile Personal Message (Offline)

Ignore
1481106987
Reply with quote  #2

1481106987
Report to moderator
1481106987
Hero Member
*
Offline Offline

Posts: 1481106987

View Profile Personal Message (Offline)

Ignore
1481106987
Reply with quote  #2

1481106987
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481106987
Hero Member
*
Offline Offline

Posts: 1481106987

View Profile Personal Message (Offline)

Ignore
1481106987
Reply with quote  #2

1481106987
Report to moderator
1481106987
Hero Member
*
Offline Offline

Posts: 1481106987

View Profile Personal Message (Offline)

Ignore
1481106987
Reply with quote  #2

1481106987
Report to moderator
1481106987
Hero Member
*
Offline Offline

Posts: 1481106987

View Profile Personal Message (Offline)

Ignore
1481106987
Reply with quote  #2

1481106987
Report to moderator
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2002


Ruu \o/


View Profile WWW
March 30, 2012, 09:30:52 PM
 #2

12.2 was a bit of a mess and was unstable for me on linux+7970 too. 8.921 (which was the 7970 specific driver before 12.2) and 12.3 were better for me.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
vindimy
Full Member
***
Offline Offline

Activity: 239



View Profile
March 31, 2012, 12:03:54 AM
 #3

You know, I have dual 7970s and could never get them to work reliably with my Ubuntu install. I tried compiling cgminer, using the binary, etc, etc. So I said "screw it" and now run them with BAMT. Setup time down from days/weeks to minutes, plus you get nice graphs and stats!

ummas
Sr. Member
****
Offline Offline

Activity: 274


View Profile
March 31, 2012, 03:22:44 AM
 #4

My frined asked me to set up rig with 4x7970 on linux ubuntu 11.04.
It took me 30 minutes to get it working with cgminer, where most of the time was downloading drivers and updates.
cat 12.2 on 11.04 + cgminer 2.3.1 - working really nice..
if you need somme help, PM me, i`ll provide if i can.
omo
Full Member
***
Offline Offline

Activity: 148


View Profile
April 01, 2012, 04:11:30 PM
 #5

I tried 12.3+sdk2.6 on linux, and coredump too, cgminer231

BTC:1Fu4TNpVPToxxhSXBNSvE9fz6X3dbYgB8q
nathanghart
Full Member
***
Offline Offline

Activity: 140



View Profile
April 05, 2012, 05:04:07 PM
 #6

I am having the hardest time getting a rig with 3x5970 and 1x7970 to work reliably.

It keeps locking up cgminer with 99.9 CPU on Xorg

My current setup is as follows:

Asrock 970 Extreme3
debian squeeze 64bit
PCIe powered extenders (2 16x and 2 1x to 16x)
  0. 03:00.0 ATI Radeon HD 5900 Series
  1. 04:00.0 ATI Radeon HD 5900 Series
  2. 05:00.0 AMD Radeon HD 7900 Series
  3. 09:00.0 ATI Radeon HD 5900 Series
  4. 0a:00.0 ATI Radeon HD 5900 Series
  5. 0d:00.0 ATI Radeon HD 5900 Series
  6. 0e:00.0 ATI Radeon HD 5900 Series
SDK 2.6
Driver 12.3 (I have tried 12.2,12.3,921)
cgminer 2.3.2 (i have tried 2.3.1-2)

I have also ran cgminer with gpu2 OFF and it still locked up

my cgminer conf is:
Code:
{
"pools" : [
        {       "url" : "http://pool.bonuspool.co.cc:1234",
                "user" : "xxxxxx",
                "pass" : "xxxxxx"
        },
        {
                "url" : "http://us2.eclipsemc.com:8337",
                "user" : "xxxxxxx",
                "pass" : "xxxxxxx"
        }
],
"intensity" : "9",
"gpu-engine" : "725-750,725-750,825-1125,725-750,725-750,725-725,725-750",
"gpu-fan" : "75",
"gpu-memclock" : "180,180,550,180,180,380,180",
"gpu-vddc" : "1.05",
"temp-cutoff" : "95",
"temp-overheat" : "85",
"temp-target" : "75",
"api-listen" : true,
"api-allow" : "W:127.0.0.1, W:192.168.0.0/24",
"auto-gpu" : true,
"kernel-path" : "/opt/miners/cgminer",
"vectors" : "2",
"worksize" : "256"
}

Things to try now include:
1.) moving the 7970 card to slot1. Should this be the first PCIe x16 slot or the PCIe x1 slot which is physically 1st? Currently the 7970 is in PCIe slot 2 which is the 4th physical slot (it goes x1, x16, x1, x16)?
2.) switch out MB for Asrock Extreme 4 (x1, x16, x16, x16)
3.) BAMT
4.) revert to 11.6 2.4 and remove 7970

here's the current cgminer screen (currently hung... Huh):
Code:
cgminer version 2.3.2 - Started: [2012-04-05 16:46:52]
--------------------------------------------------------------------------------
 (5s):2163.6 (avg):2409.3 Mh/s | Q:465  A:535  R:0  HW:0  E:115%  U:33.17/m
 TQ: 12  ST: 14  SS: 0  DW: 11  NB: 2  LW: 1041  GF: 0  RF: 0
 Connected to http://pool.bonuspool.co.cc:1234 with LP as user xxxxxxxxxx
 Block: 0000012aeb82adfcdadfa2ecd5d4d81f...  Started: [16:53:11]
--------------------------------------------------------------------------------
 [P]ool management [G]PU management [S]ettings [D]isplay options [Q]uit
 GPU 0:  52.0C 4169RPM | 327.6/322.1Mh/s | A: 77 R:0 HW:0 U:  4.77/m I: 9
 GPU 1:  52.0C 4174RPM | 328.6/326.9Mh/s | A: 69 R:0 HW:0 U:  4.28/m I: 9
 GPU 2:  57.0C 4376RPM | 465.6/464.4Mh/s | A:113 R:0 HW:0 U:  7.01/m I: 9
 GPU 3:  56.0C 4104RPM | 328.2/326.8Mh/s | A: 68 R:0 HW:0 U:  4.22/m I: 9
 GPU 4:  55.5C 4104RPM | 327.1/327.0Mh/s | A: 63 R:0 HW:0 U:  3.91/m I: 9
 GPU 5:  63.5C 4161RPM | 320.1/319.5Mh/s | A: 70 R:0 HW:0 U:  4.34/m I: 9
 GPU 6:  56.0C 4156RPM | 328.2/326.8Mh/s | A: 75 R:0 HW:0 U:  4.65/m I: 9
--------------------------------------------------------------------------------

[2012-04-05 17:02:57] Accepted 00000000.53b883ad.2295b046 GPU 3 thread 6 pool 0
[2012-04-05 17:02:57] Accepted 00000000.bd27af01.7bcb1b84 GPU 5 thread 11 pool 0

[2012-04-05 17:02:58] Accepted 00000000.c55bfd2d.f8743636 GPU 3 thread 6 pool 0
[2012-04-05 17:03:00] Accepted 00000000.4a01ebdd.17971fd4 GPU 5 thread 11 pool 0

I have two other rigs with 4x5970 11.6 2.4 cgminer 2.3.1-2 and ASRock 970 Extreme4 that have been running fine for a week...it's just this one rig that keeps locking up (by that I mean the Xorg 99.9 cpu usage and cgminer screen hung). BTW I have this to start my cgminer session:
Code:
export DISPLAY=:0
export GPU_USE_SYNC_OBJECTS=1

cd /opt/miners/cgminer
./cgminer -c cgminer.conf

Anyone have suggestions, before I rage quit?

Not mining since 6-26-2012
DeathAndTaxes
Donator
Legendary
*
Offline Offline

Activity: 1218


Gerald Davis


View Profile
April 05, 2012, 05:47:13 PM
 #7

I have never had any luck w/ 5970s & SDK 2.6 or newest drivers.

Your best bet may be to just run dedicated 7970 rigs and either sell the 5970s or buy 2 more and make a dedicated 5970 rig.

As an experiment if you remove the 5970s (and do an aticonfig adapter=all -f --initial then sync and reboot) is the system stable again?
nathanghart
Full Member
***
Offline Offline

Activity: 140



View Profile
April 05, 2012, 07:01:06 PM
 #8

I have never had any luck w/ 5970s & SDK 2.6 or newest drivers.

Your best bet may be to just run dedicated 7970 rigs and either sell the 5970s or buy 2 more and make a dedicated 5970 rig.

As an experiment if you remove the 5970s (and do an aticonfig adapter=all -f --initial then sync and reboot) is the system stable again?

OK, that's likely the issue that I am running into. I'd rather scrap the 1 7970 than the 3 5970s though. But thanks for bringing a sanity check into my life.

I might take that 7970 and a page out of your book to start working on a water-cooled 7970 rig for home use and gaming Smiley Unlike you, my wife cannot stand an air-cooled rig at home for even a day, so my rigs are colo'd in a data center. That would be its only ticket for living at home OR anyone want to by an almost unused MSI 7970 for 510 oops 110 BTC?  Wink

Not mining since 6-26-2012
mc_lovin
Legendary
*
Offline Offline

Activity: 1134


www.bitcointrading.com


View Profile WWW
April 20, 2012, 09:49:46 PM
 #9

howdy Smiley

so how are you guys uninstalling AMD SDK?

according to the users manual pdf, this is what they say:

4.2 On Linux Systems
1. Delete the directory pointed to the AMDAPPSDDKROO environment variable.
2. Remove the AMDAPPSDKROOT and LD_LIBRARY_PATH environment variables.
3. Delete the libamdocl* file and libOpenCL* from /usr/lib(64).
4. Delete the amdocl[32][64].so from /etc/OpenCL/vendors.
5. Manually remove temporary and new files created with OpenCL.

is that what you are doing?

gr0bi42
Full Member
***
Offline Offline

Activity: 158


View Profile WWW
April 22, 2012, 07:48:55 AM
 #10

Thank you, for all the post. It seems there are some Ubuntu setups up and running, in contrast I had no luck  Huh

I've tried 5 clean installs, varying cgminer 2.3.1-2.3.2, ATI 12.2-12.3 and install order. I always got a coredump.

Now I'm running windows.

BTW using Windows has a big advantage. I can undervolt with MSI Afterburner. This saves 55W for every card.

These are factory overclocked card running at 1050 Mhz. At stock voltage they need 250W each. Undervolted to 1081mV they need only 195W each.

What is the best cgminer setting for the 7970 cards.

I'm using: -I 9 -k poclbm -v 1 -w 128 => 622-625 MHash/s.

Donations are welcome: 1Btf3BqUegfe5iFdWsgfBf1Ew3YsAvsrLT
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2002


Ruu \o/


View Profile WWW
April 22, 2012, 08:58:32 AM
 #11

Default cgminer settings are designed to be the best for 7970 automatically because I spent a heck of a lot of time optimising it for GCN. They end up being -v 1 -w 64 -k poclbm and if you don't specify anything, that's what you'll get.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!