Bitcoin Forum
December 11, 2017, 10:09:59 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 [39] 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 ... 101 »
  Print  
Author Topic: [ANN] [JUDGE] Judge Coin | Multipool is UP @ http://judge.bemining.net/  (Read 148360 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic.
Rainer4256
Full Member
***
Offline Offline

Activity: 196

For the benefit of medical research


View Profile
July 08, 2014, 06:08:43 PM
 #761

add BDB_LIB_SUFFIX=-5.1 in *.pro file
This made it even worse. I got tons of undefined references in bitcoin.cpp, bitcoingui.cpp etc. Too long to post here.

Examples

Code:
bitcoin.cpp:(.text+0xacc): Undefined reference to `QString::fromAscii(char const*, int)'
bitcoingui.cpp:(.text+0x195): Undefined reference to `QMetaObject::tr(char const*, char const*) const'

Thank you anyway for trying to help.
I just compiled on ubuntu 14.04 without problems.
purge libdb and install this:

aptitude install libdb-dev

and keep the original *.pro

I did what you suggested. Now I got this:

Code:
/usr/bin/ld: cannot find -ldb_cxx
collect2: error: ld returned 1 exit status

Code:
sudo locate db_cxx
/usr/include/db_cxx.h
/usr/lib/libdb_cxx-5.1.so
/usr/lib/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.a
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx.a
/usr/lib/x86_64-linux-gnu/libdb_cxx.so
/usr/local/db_cxx.h
/usr/local/BerkeleyDB.4.8/docs/programmer_reference/upgrade_3_0_db_cxx.html
/usr/local/BerkeleyDB.4.8/include/db_cxx.h
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.la
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.so


I can't even build the daemon. Same crappy "db_cxx" error. I think this won't build here and my JUDGE are lost. Congrats!

ReserveShare - 100% Free and Fair. New source code. Proof Of Reserve
CureCoin: B78ozT6ChVMxiB5dMaY9d5rdzZ5GZvn9hT -- A giant leap for mankind! -- Start folding proteins now.
BitcoinDark: RF4asDkANqyb65yHaoEX8X896ek8eKrLhL -- Unprecedented! Check it out.
1513030199
Hero Member
*
Offline Offline

Posts: 1513030199

View Profile Personal Message (Offline)

Ignore
1513030199
Reply with quote  #2

1513030199
Report to moderator
1513030199
Hero Member
*
Offline Offline

Posts: 1513030199

View Profile Personal Message (Offline)

Ignore
1513030199
Reply with quote  #2

1513030199
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1513030199
Hero Member
*
Offline Offline

Posts: 1513030199

View Profile Personal Message (Offline)

Ignore
1513030199
Reply with quote  #2

1513030199
Report to moderator
judgecrypto
Full Member
***
Offline Offline

Activity: 238


View Profile
July 08, 2014, 06:12:10 PM
 #762

add BDB_LIB_SUFFIX=-5.1 in *.pro file
This made it even worse. I got tons of undefined references in bitcoin.cpp, bitcoingui.cpp etc. Too long to post here.

Examples

Code:
bitcoin.cpp:(.text+0xacc): Undefined reference to `QString::fromAscii(char const*, int)'
bitcoingui.cpp:(.text+0x195): Undefined reference to `QMetaObject::tr(char const*, char const*) const'

Thank you anyway for trying to help.
I just compiled on ubuntu 14.04 without problems.
purge libdb and install this:

aptitude install libdb-dev

and keep the original *.pro

I did what you suggested. Now I got this:

Code:
/usr/bin/ld: cannot find -ldb_cxx
collect2: error: ld returned 1 exit status

Code:
sudo locate db_cxx
/usr/include/db_cxx.h
/usr/lib/libdb_cxx-5.1.so
/usr/lib/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.a
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx.a
/usr/lib/x86_64-linux-gnu/libdb_cxx.so
/usr/local/db_cxx.h
/usr/local/BerkeleyDB.4.8/docs/programmer_reference/upgrade_3_0_db_cxx.html
/usr/local/BerkeleyDB.4.8/include/db_cxx.h
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.la
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.so


I can't even build the daemon. Same crappy "db_cxx" error. I think this won't build here and my JUDGE are lost. Congrats!

Why would you Judge be lost?  Save your wallet.dat file.  Do you not have the old wallet?
Rainer4256
Full Member
***
Offline Offline

Activity: 196

For the benefit of medical research


View Profile
July 08, 2014, 06:17:05 PM
 #763

Why would you Judge be lost?  Save your wallet.dat file.  Do you not have the old wallet?

Sure I have saved it. But how can I use it without a wallet or daemon?

ReserveShare - 100% Free and Fair. New source code. Proof Of Reserve
CureCoin: B78ozT6ChVMxiB5dMaY9d5rdzZ5GZvn9hT -- A giant leap for mankind! -- Start folding proteins now.
BitcoinDark: RF4asDkANqyb65yHaoEX8X896ek8eKrLhL -- Unprecedented! Check it out.
judgecrypto
Full Member
***
Offline Offline

Activity: 238


View Profile
July 08, 2014, 06:42:40 PM
 #764

add BDB_LIB_SUFFIX=-5.1 in *.pro file
This made it even worse. I got tons of undefined references in bitcoin.cpp, bitcoingui.cpp etc. Too long to post here.

Examples

Code:
bitcoin.cpp:(.text+0xacc): Undefined reference to `QString::fromAscii(char const*, int)'
bitcoingui.cpp:(.text+0x195): Undefined reference to `QMetaObject::tr(char const*, char const*) const'

Thank you anyway for trying to help.
I just compiled on ubuntu 14.04 without problems.
purge libdb and install this:

aptitude install libdb-dev

and keep the original *.pro

I did what you suggested. Now I got this:

Code:
/usr/bin/ld: cannot find -ldb_cxx
collect2: error: ld returned 1 exit status

Code:
sudo locate db_cxx
/usr/include/db_cxx.h
/usr/lib/libdb_cxx-5.1.so
/usr/lib/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.a
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx.a
/usr/lib/x86_64-linux-gnu/libdb_cxx.so
/usr/local/db_cxx.h
/usr/local/BerkeleyDB.4.8/docs/programmer_reference/upgrade_3_0_db_cxx.html
/usr/local/BerkeleyDB.4.8/include/db_cxx.h
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.la
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.so


I can't even build the daemon. Same crappy "db_cxx" error. I think this won't build here and my JUDGE are lost. Congrats!

100 Judge Coin bounty to whomever can help get Rainer4256 to compile his wallet.
MinerMario
Member
**
Offline Offline

Activity: 112


View Profile
July 08, 2014, 06:50:39 PM
 #765

add BDB_LIB_SUFFIX=-5.1 in *.pro file
This made it even worse. I got tons of undefined references in bitcoin.cpp, bitcoingui.cpp etc. Too long to post here.

Examples

Code:
bitcoin.cpp:(.text+0xacc): Undefined reference to `QString::fromAscii(char const*, int)'
bitcoingui.cpp:(.text+0x195): Undefined reference to `QMetaObject::tr(char const*, char const*) const'

Thank you anyway for trying to help.
I just compiled on ubuntu 14.04 without problems.
purge libdb and install this:

aptitude install libdb-dev

and keep the original *.pro

I did what you suggested. Now I got this:

Code:
/usr/bin/ld: cannot find -ldb_cxx
collect2: error: ld returned 1 exit status

Code:
sudo locate db_cxx
/usr/include/db_cxx.h
/usr/lib/libdb_cxx-5.1.so
/usr/lib/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.a
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx.a
/usr/lib/x86_64-linux-gnu/libdb_cxx.so
/usr/local/db_cxx.h
/usr/local/BerkeleyDB.4.8/docs/programmer_reference/upgrade_3_0_db_cxx.html
/usr/local/BerkeleyDB.4.8/include/db_cxx.h
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.la
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.so


I can't even build the daemon. Same crappy "db_cxx" error. I think this won't build here and my JUDGE are lost. Congrats!

100 Judge Coin bounty to whomever can help get Rainer4256 to compile his wallet.

Rainer, what version of Ubuntu are you running?

Is it completely up to date:

sudo apt-get update
sudo apt-get upgrade

??

Keep the bounty Judge. Let's see what happens.

Shitcoins are never "undervalued"
Rainer4256
Full Member
***
Offline Offline

Activity: 196

For the benefit of medical research


View Profile
July 08, 2014, 06:55:18 PM
 #766

add BDB_LIB_SUFFIX=-5.1 in *.pro file
This made it even worse. I got tons of undefined references in bitcoin.cpp, bitcoingui.cpp etc. Too long to post here.

Examples

Code:
bitcoin.cpp:(.text+0xacc): Undefined reference to `QString::fromAscii(char const*, int)'
bitcoingui.cpp:(.text+0x195): Undefined reference to `QMetaObject::tr(char const*, char const*) const'

Thank you anyway for trying to help.
I just compiled on ubuntu 14.04 without problems.
purge libdb and install this:

aptitude install libdb-dev

and keep the original *.pro

I did what you suggested. Now I got this:

Code:
/usr/bin/ld: cannot find -ldb_cxx
collect2: error: ld returned 1 exit status

Code:
sudo locate db_cxx
/usr/include/db_cxx.h
/usr/lib/libdb_cxx-5.1.so
/usr/lib/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.a
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx.a
/usr/lib/x86_64-linux-gnu/libdb_cxx.so
/usr/local/db_cxx.h
/usr/local/BerkeleyDB.4.8/docs/programmer_reference/upgrade_3_0_db_cxx.html
/usr/local/BerkeleyDB.4.8/include/db_cxx.h
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.la
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.so


I can't even build the daemon. Same crappy "db_cxx" error. I think this won't build here and my JUDGE are lost. Congrats!

100 Judge Coin bounty to whomever can help get Rainer4256 to compile his wallet.

Wow! Nice! I promise not to dump my 41 JUDGE (just got a HD7950).  Wink

ReserveShare - 100% Free and Fair. New source code. Proof Of Reserve
CureCoin: B78ozT6ChVMxiB5dMaY9d5rdzZ5GZvn9hT -- A giant leap for mankind! -- Start folding proteins now.
BitcoinDark: RF4asDkANqyb65yHaoEX8X896ek8eKrLhL -- Unprecedented! Check it out.
Rainer4256
Full Member
***
Offline Offline

Activity: 196

For the benefit of medical research


View Profile
July 08, 2014, 06:58:40 PM
 #767

add BDB_LIB_SUFFIX=-5.1 in *.pro file
This made it even worse. I got tons of undefined references in bitcoin.cpp, bitcoingui.cpp etc. Too long to post here.

Examples

Code:
bitcoin.cpp:(.text+0xacc): Undefined reference to `QString::fromAscii(char const*, int)'
bitcoingui.cpp:(.text+0x195): Undefined reference to `QMetaObject::tr(char const*, char const*) const'

Thank you anyway for trying to help.
I just compiled on ubuntu 14.04 without problems.
purge libdb and install this:

aptitude install libdb-dev

and keep the original *.pro

I did what you suggested. Now I got this:

Code:
/usr/bin/ld: cannot find -ldb_cxx
collect2: error: ld returned 1 exit status

Code:
sudo locate db_cxx
/usr/include/db_cxx.h
/usr/lib/libdb_cxx-5.1.so
/usr/lib/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.a
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx.a
/usr/lib/x86_64-linux-gnu/libdb_cxx.so
/usr/local/db_cxx.h
/usr/local/BerkeleyDB.4.8/docs/programmer_reference/upgrade_3_0_db_cxx.html
/usr/local/BerkeleyDB.4.8/include/db_cxx.h
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.la
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.so


I can't even build the daemon. Same crappy "db_cxx" error. I think this won't build here and my JUDGE are lost. Congrats!

100 Judge Coin bounty to whomever can help get Rainer4256 to compile his wallet.

Rainer, what version of Ubuntu are you running?

Is it completely up to date:

sudo apt-get update
sudo apt-get upgrade

??

Keep the bounty Judge. Let's see what happens.

Hi,
I'm on 14.04, my OS is updated and upgraded.

ReserveShare - 100% Free and Fair. New source code. Proof Of Reserve
CureCoin: B78ozT6ChVMxiB5dMaY9d5rdzZ5GZvn9hT -- A giant leap for mankind! -- Start folding proteins now.
BitcoinDark: RF4asDkANqyb65yHaoEX8X896ek8eKrLhL -- Unprecedented! Check it out.
MinerMario
Member
**
Offline Offline

Activity: 112


View Profile
July 08, 2014, 07:21:09 PM
 #768

add BDB_LIB_SUFFIX=-5.1 in *.pro file
This made it even worse. I got tons of undefined references in bitcoin.cpp, bitcoingui.cpp etc. Too long to post here.

Examples

Code:
bitcoin.cpp:(.text+0xacc): Undefined reference to `QString::fromAscii(char const*, int)'
bitcoingui.cpp:(.text+0x195): Undefined reference to `QMetaObject::tr(char const*, char const*) const'

Thank you anyway for trying to help.
I just compiled on ubuntu 14.04 without problems.
purge libdb and install this:

aptitude install libdb-dev

and keep the original *.pro

I did what you suggested. Now I got this:

Code:
/usr/bin/ld: cannot find -ldb_cxx
collect2: error: ld returned 1 exit status

Code:
sudo locate db_cxx
/usr/include/db_cxx.h
/usr/lib/libdb_cxx-5.1.so
/usr/lib/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.a
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx.a
/usr/lib/x86_64-linux-gnu/libdb_cxx.so
/usr/local/db_cxx.h
/usr/local/BerkeleyDB.4.8/docs/programmer_reference/upgrade_3_0_db_cxx.html
/usr/local/BerkeleyDB.4.8/include/db_cxx.h
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.la
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.so


I can't even build the daemon. Same crappy "db_cxx" error. I think this won't build here and my JUDGE are lost. Congrats!

100 Judge Coin bounty to whomever can help get Rainer4256 to compile his wallet.

Rainer, what version of Ubuntu are you running?

Is it completely up to date:

sudo apt-get update
sudo apt-get upgrade

??

Keep the bounty Judge. Let's see what happens.

Hi,
I'm on 14.04, my OS is updated and upgraded.

Okay thanks. Gimme a bit, I need to build a new Ubuntu 14.04 machine, normally I run 12.04. If I can get wallet compiled then I will post the steps.


Shitcoins are never "undervalued"
G K G
Sr. Member
****
Offline Offline

Activity: 280


View Profile
July 08, 2014, 07:29:14 PM
 #769

So what issue were we having with the POS?

MinerMario
Member
**
Offline Offline

Activity: 112


View Profile
July 08, 2014, 07:39:21 PM
 #770

Solid buy wall at 0.00001925 satoshi has crumbled and 0.00001700 is the next stop.

People 0.00001700 is the place to get in and buy. Get your BTC ready.  Grin Grin

Shitcoins are never "undervalued"
Rainer4256
Full Member
***
Offline Offline

Activity: 196

For the benefit of medical research


View Profile
July 08, 2014, 07:47:49 PM
 #771

Okay thanks. Gimme a bit, I need to build a new Ubuntu 14.04 machine, normally I run 12.04. If I can get wallet compiled then I will post the steps.

Glad that you are trying to help. I will be patient.

ReserveShare - 100% Free and Fair. New source code. Proof Of Reserve
CureCoin: B78ozT6ChVMxiB5dMaY9d5rdzZ5GZvn9hT -- A giant leap for mankind! -- Start folding proteins now.
BitcoinDark: RF4asDkANqyb65yHaoEX8X896ek8eKrLhL -- Unprecedented! Check it out.
MinerMario
Member
**
Offline Offline

Activity: 112


View Profile
July 08, 2014, 08:03:06 PM
 #772

Okay thanks. Gimme a bit, I need to build a new Ubuntu 14.04 machine, normally I run 12.04. If I can get wallet compiled then I will post the steps.

Glad that you are trying to help. I will be patient.

Just keep the wallet.dat safe. I have 14.04 installed now and it's patching.


Shitcoins are never "undervalued"
karimdr2
Sr. Member
****
Offline Offline

Activity: 364


View Profile
July 08, 2014, 08:08:09 PM
 #773

add BDB_LIB_SUFFIX=-5.1 in *.pro file
This made it even worse. I got tons of undefined references in bitcoin.cpp, bitcoingui.cpp etc. Too long to post here.

Examples

Code:
bitcoin.cpp:(.text+0xacc): Undefined reference to `QString::fromAscii(char const*, int)'
bitcoingui.cpp:(.text+0x195): Undefined reference to `QMetaObject::tr(char const*, char const*) const'

Thank you anyway for trying to help.
I just compiled on ubuntu 14.04 without problems.
purge libdb and install this:

aptitude install libdb-dev

and keep the original *.pro

I did what you suggested. Now I got this:

Code:
/usr/bin/ld: cannot find -ldb_cxx
collect2: error: ld returned 1 exit status

Code:
sudo locate db_cxx
/usr/include/db_cxx.h
/usr/lib/libdb_cxx-5.1.so
/usr/lib/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.a
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx.a
/usr/lib/x86_64-linux-gnu/libdb_cxx.so
/usr/local/db_cxx.h
/usr/local/BerkeleyDB.4.8/docs/programmer_reference/upgrade_3_0_db_cxx.html
/usr/local/BerkeleyDB.4.8/include/db_cxx.h
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.la
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.so


I can't even build the daemon. Same crappy "db_cxx" error. I think this won't build here and my JUDGE are lost. Congrats!

100 Judge Coin bounty to whomever can help get Rainer4256 to compile his wallet.

Rainer, what version of Ubuntu are you running?

Is it completely up to date:

sudo apt-get update
sudo apt-get upgrade

??

Keep the bounty Judge. Let's see what happens.

Hi,
I'm on 14.04, my OS is updated and upgraded.

Okay thanks. Gimme a bit, I need to build a new Ubuntu 14.04 machine, normally I run 12.04. If I can get wallet compiled then I will post the steps.



Install a fresh Ubuntu

sudo apt-get update
sudo apt-get install qt4-dev-tools libqt4-dev libqt4-core libqt4-gui
sudo apt-get install build-essential
sudo apt-get install libssl-dev
sudo apt-get install libdb-dev
sudo apt-get install libdb++-dev
sudo apt-get install libqrencode-dev
sudo apt-get install libboost1.55-all-dev

no need to install db48 and db53

change QString qVolume = QString::number(volume); in statisticspage.cpp

qmake
make

It work for me like a charm Cheesy

★ BitNet ★ New Darknet, better than TOR ! FREE VPN ! Free Distribution 14,000,000 VPNCOIN!!! Vg7NuuuJt2snso5N1EMPyPwSTHb2ByiHRo
BTC: 1Gu3KYr3HV1TGJmqgSXXQbGxxdLzTEAN6o
MinerMario
Member
**
Offline Offline

Activity: 112


View Profile
July 08, 2014, 09:03:40 PM
 #774

add BDB_LIB_SUFFIX=-5.1 in *.pro file
This made it even worse. I got tons of undefined references in bitcoin.cpp, bitcoingui.cpp etc. Too long to post here.

Examples

Code:
bitcoin.cpp:(.text+0xacc): Undefined reference to `QString::fromAscii(char const*, int)'
bitcoingui.cpp:(.text+0x195): Undefined reference to `QMetaObject::tr(char const*, char const*) const'

Thank you anyway for trying to help.
I just compiled on ubuntu 14.04 without problems.
purge libdb and install this:

aptitude install libdb-dev

and keep the original *.pro

I did what you suggested. Now I got this:

Code:
/usr/bin/ld: cannot find -ldb_cxx
collect2: error: ld returned 1 exit status

Code:
sudo locate db_cxx
/usr/include/db_cxx.h
/usr/lib/libdb_cxx-5.1.so
/usr/lib/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.a
/usr/lib/x86_64-linux-gnu/libdb_cxx-5.3.so
/usr/lib/x86_64-linux-gnu/libdb_cxx.a
/usr/lib/x86_64-linux-gnu/libdb_cxx.so
/usr/local/db_cxx.h
/usr/local/BerkeleyDB.4.8/docs/programmer_reference/upgrade_3_0_db_cxx.html
/usr/local/BerkeleyDB.4.8/include/db_cxx.h
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.la
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.8.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx-4.so
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.a
/usr/local/BerkeleyDB.4.8/lib/libdb_cxx.so


I can't even build the daemon. Same crappy "db_cxx" error. I think this won't build here and my JUDGE are lost. Congrats!

100 Judge Coin bounty to whomever can help get Rainer4256 to compile his wallet.

Rainer, what version of Ubuntu are you running?

Is it completely up to date:

sudo apt-get update
sudo apt-get upgrade

??

Keep the bounty Judge. Let's see what happens.

Hi,
I'm on 14.04, my OS is updated and upgraded.

Okay thanks. Gimme a bit, I need to build a new Ubuntu 14.04 machine, normally I run 12.04. If I can get wallet compiled then I will post the steps.



Install a fresh Ubuntu

sudo apt-get update
sudo apt-get install qt4-dev-tools libqt4-dev libqt4-core libqt4-gui
sudo apt-get install build-essential
sudo apt-get install libssl-dev
sudo apt-get install libdb-dev
sudo apt-get install libdb++-dev
sudo apt-get install libqrencode-dev
sudo apt-get install libboost1.55-all-dev

no need to install db48 and db53

change QString qVolume = QString::number(volume); in statisticspage.cpp

qmake
make

It work for me like a charm Cheesy

Hey. Trying to help rainer, but I am not getting any joy either. Did you attempt this on Ubuntu 14.04? x64? I have tried 3 different attempts to build from the various INSTALL/README/readme-qt.rst and I can't get a compile to work with any of them.

Maybe I am not the guy to help rainer, try the solution above and see if it helps you.


Shitcoins are never "undervalued"
Rainer4256
Full Member
***
Offline Offline

Activity: 196

For the benefit of medical research


View Profile
July 08, 2014, 09:10:04 PM
 #775


Install a fresh Ubuntu

sudo apt-get update
sudo apt-get install qt4-dev-tools libqt4-dev libqt4-core libqt4-gui
sudo apt-get install build-essential
sudo apt-get install libssl-dev
sudo apt-get install libdb-dev
sudo apt-get install libdb++-dev
sudo apt-get install libqrencode-dev
sudo apt-get install libboost1.55-all-dev

no need to install db48 and db53

change QString qVolume = QString::number(volume); in statisticspage.cpp

qmake
make

It work for me like a charm Cheesy
Thank you. Doing a backup first ...

ReserveShare - 100% Free and Fair. New source code. Proof Of Reserve
CureCoin: B78ozT6ChVMxiB5dMaY9d5rdzZ5GZvn9hT -- A giant leap for mankind! -- Start folding proteins now.
BitcoinDark: RF4asDkANqyb65yHaoEX8X896ek8eKrLhL -- Unprecedented! Check it out.
Rainer4256
Full Member
***
Offline Offline

Activity: 196

For the benefit of medical research


View Profile
July 08, 2014, 09:15:43 PM
 #776


Hey. Trying to help rainer, but I am not getting any joy either. Did you attempt this on Ubuntu 14.04? x64? I have tried 3 different attempts to build from the various INSTALL/README/readme-qt.rst and I can't get a compile to work with any of them.

Maybe I am not the guy to help rainer, try the solution above and see if it helps you.



Thank you. Yes, I tried with x64 of course. You have to know that this is not my first wallet. I built about 50 or 60 before. Except of a few smaller issues they built fine. No clue why this is refusing.

ReserveShare - 100% Free and Fair. New source code. Proof Of Reserve
CureCoin: B78ozT6ChVMxiB5dMaY9d5rdzZ5GZvn9hT -- A giant leap for mankind! -- Start folding proteins now.
BitcoinDark: RF4asDkANqyb65yHaoEX8X896ek8eKrLhL -- Unprecedented! Check it out.
teamcryptonator
Hero Member
*****
Offline Offline

Activity: 744



View Profile
July 08, 2014, 10:04:58 PM
 #777

Hey guys!

We have just added Judge Coin to Cryptonator so now you can use all its free features


Should you own an iPhone or an Android device, we also have all these in our free mobile apps for iOS / Android

Cheers


           ▄▄▄▄▄▄▄▄▄▄▄▄
       ▄▄█▀▀ ▄▄▄▄▄▄▄▄▄ ▀▀█▄▄
     ▄█▀ ▄▄█████████████▄▄ ▀█▄

    █▀ ▄███████▀   ▀███████▄ ▀█
   █ ▄████████▀     ▀████████▄ █
  █ ▄████████▀       ▀████████▄ █

 █ ▄████████▀    █    ▀████████▄ █
▄▀▄█████        ▄█▄        █████▄▀▄
█ ██████▀▀▀     ███     ▀▀▀██████ █

█ ██████▄▄     ▄███▄     ▄▄██████ █
█ ███████▀     ▀▀▀▀▀     ▀███████ █
▀▄▀█████▀                 ▀█████▀▄▀

 █ ▀███▀      ▄▄▄▄▄▄▄      ▀███▀ █
  █ ▀██      █████████      ██▀ █
   █ ▀██▄  ▄███████████▄  ▄██▀ █

    █▄ ▀███████████████████▀ ▄█
     ▀█▄ ▀▀█████████████▀▀ ▄█▀

       ▀▀█▄▄ ▀▀▀▀▀▀▀▀▀ ▄▄█▀▀
           ▀▀▀▀▀▀▀▀▀▀▀▀▀
AppCoins










.
0WHITEPAPER0
.
0CROWDSALE0
Rainer4256
Full Member
***
Offline Offline

Activity: 196

For the benefit of medical research


View Profile
July 08, 2014, 11:03:48 PM
 #778


Hey. Trying to help rainer, but I am not getting any joy either. Did you attempt this on Ubuntu 14.04? x64? I have tried 3 different attempts to build from the various INSTALL/README/readme-qt.rst and I can't get a compile to work with any of them.

Maybe I am not the guy to help rainer, try the solution above and see if it helps you.



Thank you. Yes, I tried with x64 of course. You have to know that this is not my first wallet. I built about 50 or 60 before. Except of a few smaller issues they built fine. No clue why this is refusing.

Well, I started a new installation of Ubuntu on an external drive. Partitioning will take several hours. So I guess the installation will be finished tomorrow evening. In the meantime I can't mine. I doubt it that this is a satisfying solution.

ReserveShare - 100% Free and Fair. New source code. Proof Of Reserve
CureCoin: B78ozT6ChVMxiB5dMaY9d5rdzZ5GZvn9hT -- A giant leap for mankind! -- Start folding proteins now.
BitcoinDark: RF4asDkANqyb65yHaoEX8X896ek8eKrLhL -- Unprecedented! Check it out.
Replicant
Newbie
*
Offline Offline

Activity: 7


View Profile
July 08, 2014, 11:45:15 PM
 #779

A single multipool makes up nearly half of this coins network hash. Undoubtedly most of those miners are dumping. Doesn't look good for the long term success of the coin if ~50% get dumped onto exchanges.
Bonn3rs
Full Member
***
Offline Offline

Activity: 154


View Profile
July 08, 2014, 11:52:26 PM
 #780

A single multipool makes up nearly half of this coins network hash. Undoubtedly most of those miners are dumping. Doesn't look good for the long term success of the coin if ~50% get dumped onto exchanges.

You forget that once the PoW is over, they can't mine it anymore and the dumping stops so it's not even the slightest bit of an issue. Lots of cheap coins for the rest of us who are interested in the long term future of this coin.

And despite this constant dumping the coin market cap has increased by $4000 in the last 24 hours. Nice try but your newbie FUD is clearly incorrect.

Judge Coin Facebook Manager
Judge: JbJjiXGnQpNMKQZTrbhChBKX3SfDaS85hi || BTC: 14WATjFEu7731o6MGsHs3CRn7fMigxEdvL
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 [39] 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 ... 101 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!