Bitcoin Forum
April 23, 2014, 07:06:21 PM *
News: Due to the OpenSSL heartbleed bug, changing your forum password is recommended.
 
   Home   Help Search Donate Login Register  
Pages: 1 2 3 4 5 [6] 7 8 9 10 11 12 13 14 15 16  All
  Print  
Author Topic: Modified Kernel for Phoenix 1.5  (Read 69314 times)
ssateneth
Hero Member
*****
Online Online

Activity: 1022



View Profile

Ignore
July 30, 2011, 04:38:25 AM
 #101

Win7 x64, 5870, Catalyst 11.7, latest GUIMiner (Phoenix 1.5).
After copying v2.0 files into "kernels\phatk" i get this messages in console:
Code:
2011-07-29 11:02:49: Listener for "itzod2": [29/07/2011 11:02:49] [4.19 Ghash/sec] [0 Accepted] [0 Rejected] [RPC (+LP)]
2011-07-29 11:02:50: Listener for "itzod2": [29/07/2011 11:02:50] Warning: work queue empty, miner is idle
No work is being done.

Here's miner starting parameters:
Code:
2011-07-29 18:08:49: Running command: .\phoenix.exe -u http://****:****@lp1.itzod.ru:8344 PLATFORM=0 DEVICE=0 AGGRESSION=12 -k phatk VECTORS BFI_INT FASTLOOP=false WORKSIZE=256

Your v1.0 and Diapolo's 2011-07-17 kernel works fine.


This is exactly what happens to mine too. guiminer 7-01-2011 with phoenix 1.5, using newest kernel in this thread, catalyst 11.7, win7 x64.
It just spams "Warning: work queue empty, miner is idle" in console.
I'm going to assume this kernel is either meant for an older miner, or its just plain broken. I'll be looking at this thread and diapolo's for an update. 12alu improvement is huge Smiley, might be able to break 470 mhash on my 5870.

edit: I thought you had to declare kernel arguments -after- the -k switch and argument after to declare what kernel to use.

If I helped you, please consider donating some BTC my way! 1FVLZTwSiAsf9z9dLZcfEuBY59HQprFJwQ
I am a long time trusted user: Bitcointalk forum trust ratings, Bitcoin-OTC Ratings, eBay Feedback, and Localbitcoins public profile.
1398279981
Hero Member
*
Offline Offline

Posts: 1398279981

View Profile Personal Message (Offline)

Ignore
1398279981
Reply with quote  #2

1398279981
Report to moderator

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1398279981
Hero Member
*
Offline Offline

Posts: 1398279981

View Profile Personal Message (Offline)

Ignore
1398279981
Reply with quote  #2

1398279981
Report to moderator
BOARBEAR
Member
**
Offline Offline

Activity: 77


View Profile

Ignore
July 30, 2011, 06:44:30 AM
 #102

Win7 x64, 5870, Catalyst 11.7, latest GUIMiner (Phoenix 1.5).
After copying v2.0 files into "kernels\phatk" i get this messages in console:
Code:
2011-07-29 11:02:49: Listener for "itzod2": [29/07/2011 11:02:49] [4.19 Ghash/sec] [0 Accepted] [0 Rejected] [RPC (+LP)]
2011-07-29 11:02:50: Listener for "itzod2": [29/07/2011 11:02:50] Warning: work queue empty, miner is idle
No work is being done.

Here's miner starting parameters:
Code:
2011-07-29 18:08:49: Running command: .\phoenix.exe -u http://****:****@lp1.itzod.ru:8344 PLATFORM=0 DEVICE=0 AGGRESSION=12 -k phatk VECTORS BFI_INT FASTLOOP=false WORKSIZE=256

Your v1.0 and Diapolo's 2011-07-17 kernel works fine.


This is exactly what happens to mine too. guiminer 7-01-2011 with phoenix 1.5, using newest kernel in this thread, catalyst 11.7, win7 x64.
It just spams "Warning: work queue empty, miner is idle" in console.
I'm going to assume this kernel is either meant for an older miner, or its just plain broken. I'll be looking at this thread and diapolo's for an update. 12alu improvement is huge Smiley, might be able to break 470 mhash on my 5870.

edit: I thought you had to declare kernel arguments -after- the -k switch and argument after to declare what kernel to use.
this is an old bug of phoenix that the author was not able to fix.  Try search for idle bug.  It is not the problem of this kernel.
see http://forum.bitcoin.org/index.php?topic=19169.0
ssateneth
Hero Member
*****
Online Online

Activity: 1022



View Profile

Ignore
July 30, 2011, 07:40:15 AM
 #103

What makes you so sure its phoenix and not the kernel? 7-11 kernel and 7-17 kernel = work perfectly. Swap out to 2.0 kernel, spams idle.

Btw I searched that thread you linked and didn't see any mention of idle bug. :/

edit: did some other searching and apparently someone mentione didle bug was fixed in 1.50 but guiminer v2011-07-01 uses phoenix 1.50 according to my console, so I don't know where to go from here.
If someone can figure out the problem and give steps to solve the idle bug with guiminer v2011-07-01, catalyst 11.7, opencl driver 2.5, win7 x64, and this kernel, i'll donate 0.25 btc to you. I would prefer to keep using phoenix in guiminer.

If I helped you, please consider donating some BTC my way! 1FVLZTwSiAsf9z9dLZcfEuBY59HQprFJwQ
I am a long time trusted user: Bitcointalk forum trust ratings, Bitcoin-OTC Ratings, eBay Feedback, and Localbitcoins public profile.
dishwara
Hero Member
*****
Offline Offline

Activity: 1162


Truth may get delay, but NEVER fails


View Profile

Ignore
July 30, 2011, 12:41:19 PM
 #104

Seems it only gives problem to those using GUIminer. I am using AOCLBF 1.75 & i so far didn't get any error, except strange Mhash/s variation which i already posted in this thread some posts back.
GUIminer users , try with AOCLBF to check that also gives you problem.

OS-Windows 7, 64 bit with AERO enabled, catalyst 11.8 beta.
Diapolo
Hero Member
*****
Offline Offline

Activity: 766


Bitcoin-Qt co-developer


View Profile WWW

Ignore
July 30, 2011, 01:15:45 PM
 #105

Yup the new kernel doesnt work.

BAH!.. I'll look through it, tonight I am going to a Sublime with Rome and 311 concert... so this weekend.

 
1st question, how is 0x2004000U in line 170 computed? Currently I don't get it Cheesy.

Dia

Basically, since only the last bit is different between the 2 nonces W3.x and W3.y, the first calculation done on those values is P2:
Code:
P2(18) = rot(W[3],25)^rot(W[3],14)^((W[3])>>3U);

So, basically, instead of flipping Bit 0 on W[3] and calculating both W[18].x and W[18].y, we can calculate W[18].x and W[18].y will be the same besides bits 25 and 14 being flipped

Code:
P2(18).x = rot(W[3].x,25)^rot(W[3].x,14)^((W[3].x)>>3U);
W[3].y = W[3].x ^ 1, therefore:

P2(18).y = P2(18).x ^ (rot(1,25)^rot(1,14)^((1)>>3U));
so, P2(18).y = P2(18).x ^ 0x2004000U;

This is the first change that I implemented into my kernel, but it seems that only 69XX cards do benefit from that change. Will investigate further ...

Dia

Like my work for Bitcoin-Qt?
1PwnvixzVAKnAqp8LCV8iuv7ohzX2pbn5x
bitcoin:1PwnvixzVAKnAqp8LCV8iuv7ohzX2pbn5x?label=Diapolo
ssateneth
Hero Member
*****
Online Online

Activity: 1022



View Profile

Ignore
July 30, 2011, 01:38:17 PM
 #106

Seems it only gives problem to those using GUIminer. I am using AOCLBF 1.75 & i so far didn't get any error, except strange Mhash/s variation which i already posted in this thread some posts back.
GUIminer users , try with AOCLBF to check that also gives you problem.

OS-Windows 7, 64 bit with AERO enabled, catalyst 11.8 beta.


I tried aoclbf about a week or 2 back. I didn't like how the on-screen display was ugly, or didn't even show, so I didn't know the status of my miners. :/

If I helped you, please consider donating some BTC my way! 1FVLZTwSiAsf9z9dLZcfEuBY59HQprFJwQ
I am a long time trusted user: Bitcointalk forum trust ratings, Bitcoin-OTC Ratings, eBay Feedback, and Localbitcoins public profile.
fpgaminer
Hero Member
*****
Offline Offline

Activity: 546



View Profile WWW

Ignore
July 30, 2011, 02:36:57 PM
 #107

Good stuff Phateus Smiley I'm getting an extra 2-3MH/s with your newest kernel compared to Diapolo's last kernel. I merged the code into my fork of poclbm and it seems to be working fine there (with command line option --phatk2):
https://github.com/progranism/poclbm

The only bug I found was that the kernel wouldn't compile without BITALIGN. Not really important, since all my mining cards support BITALIGN. It complained about rotate being ambiguous.

Keep up the good work!

techwtf
Full Member
***
Offline Offline

Activity: 140


View Profile

Ignore
July 30, 2011, 02:45:57 PM
 #108

I'm also trying to port the kernel to poclbm.

RuntimeError: clBuildProgram failed: build program failure

Build on <pyopencl.Device 'Cypress' at 0x2d6d530>:

/tmp/OCLZO4wZQ.cl(184): error: bad argument type to opencl builtin function:
          expected type "uint2", actual type "int"
     sharoundC(4);
     ^
...

/tmp/OCLZO4wZQ.cl(185): error: bad argument type to opencl builtin function:
          expected type "uint2", actual type "int"
     W[20] = P4C(20) + P1(20);

/tmp/OCLZO4wZQ.cl(186): error: bad argument type to opencl builtin function:
          expected type "uint2", actual type "int"
     sharoundC(5);
     ^


/tmp/OCLZO4wZQ.cl(187): error: bad argument type to opencl builtin function:
          expected type "uint2", actual type "int"
     W[21] = P1(21);
             ^

/tmp/OCLZO4wZQ.cl(189): error: mixed vector-scalar operation not allowed
          unless up-convertable(scalar-type=>vector-element-type)
     W[22] = P3C(22) + P1(22);
                       ^


Update: Is SDK 2.4 Required? I'm using 2.1.
without VECTORS, it works...
techwtf
Full Member
***
Offline Offline

Activity: 140


View Profile

Ignore
July 30, 2011, 03:25:32 PM
 #109

Finally Working now. 435.5 -> 437.2. Some other small issue still exists, but not kernel related.
Vince
Jr. Member
*
Offline Offline

Activity: 38


View Profile

Ignore
July 30, 2011, 03:34:00 PM
 #110

I had some trouble getting this to work with SDK 2.4, but finally its running.

On my HD6950 I get ~343Mhash/s,
with diapolo's 11-07-17 its slightly better, ~345Mhash/s.

I tested some combinations - but both run best with BFI_INT WORKSIZE=128 VECTORS AGGRESSION=11

Like what I'm posting? -> 1DtHZgVufX1tc5jRCoNiUnygenwRWj939C
MiningBuddy
Moderator
Hero Member
*
Online Online

Activity: 952


฿itcoin ฿itcoin ฿itcoin


View Profile

Ignore
July 30, 2011, 05:45:21 PM
 #111

V2 works fine on my windows box with 11.6 drivers and sdk 2.4 (gives me around 3mhs extra)
But it does not work on my linux boxes with 11.5 drivers and sdk 2.1 or 2.4, giving errors such as  FATAL kernel error: Failed to load OpenCL kernel!

Dropped back to diapolo's version on my linux box.

Thanks!

iopq
Sr. Member
****
Offline Offline

Activity: 448


View Profile

Ignore
July 30, 2011, 06:10:13 PM
 #112

Good stuff Phateus Smiley I'm getting an extra 2-3MH/s with your newest kernel compared to Diapolo's last kernel. I merged the code into my fork of poclbm and it seems to be working fine there (with command line option --phatk2):
https://github.com/progranism/poclbm

The only bug I found was that the kernel wouldn't compile without BITALIGN. Not really important, since all my mining cards support BITALIGN. It complained about rotate being ambiguous.

Keep up the good work!
doesn't work when vectors are turned on
I am running SDK 2.1, it's either -v or --phatk2, doesn't work with both

"I may be mean-spirited, but at least I don't eat babies" - Lolcust
COMM: CXiuyneQjU1MqBnxQQSvUbGsNwh9cMAiyD
BOARBEAR
Member
**
Offline Offline

Activity: 77


View Profile

Ignore
July 30, 2011, 06:32:29 PM
 #113

What makes you so sure its phoenix and not the kernel? 7-11 kernel and 7-17 kernel = work perfectly. Swap out to 2.0 kernel, spams idle.

Btw I searched that thread you linked and didn't see any mention of idle bug. :/

edit: did some other searching and apparently someone mentione didle bug was fixed in 1.50 but guiminer v2011-07-01 uses phoenix 1.50 according to my console, so I don't know where to go from here.
If someone can figure out the problem and give steps to solve the idle bug with guiminer v2011-07-01, catalyst 11.7, opencl driver 2.5, win7 x64, and this kernel, i'll donate 0.25 btc to you. I would prefer to keep using phoenix in guiminer.
"[0 Khash/sec] blah blah" is referring to the idle problem.

See
http://forum.bitcoin.org/index.php?topic=6458.msg229912#msg229912

That is with the original kernel that people are having the idling problem.  And the author basically said he will not be able to fix that bug and he is leaving it to other developers.
He claimed the idling bug might be fixed in 1.50, in fact it was not.

The idling bug has something to do with the AGGRESSION option, try lowing it might fix the problem.
Clipse
SCAMMER
Hero Member
*****
Offline Offline

Activity: 504


View Profile

Ignore
July 30, 2011, 08:09:08 PM
 #114

Im having issue with this version 2.0 of phatk

On my ubuntu machines running phoenix 1.5, and the 3 updated files from phatk 2.0, I get some Queuereader error and it just hangs.

On my windows machines Im using phatk 2.0 with phoenix 1.5 and it isnt giving me the same error, works great(additional 9mh/s gained from previous diapolo kernel changes.)

...In the land of the stale, the man with one share is king... >> Clipse

We pay miners at 130% PPS | Signup here : Bonus PPS Pool (Please read OP to understand the current process)
Diapolo
Hero Member
*****
Offline Offline

Activity: 766


Bitcoin-Qt co-developer


View Profile WWW

Ignore
July 31, 2011, 01:00:59 AM
 #115

Phat, what is the effect of "LLLL" instead of "IIII" in the .py file? It seems to work even with IIII.

Thanks,
Dia

Like my work for Bitcoin-Qt?
1PwnvixzVAKnAqp8LCV8iuv7ohzX2pbn5x
bitcoin:1PwnvixzVAKnAqp8LCV8iuv7ohzX2pbn5x?label=Diapolo
1bitc0inplz
Member
**
Offline Offline

Activity: 112


View Profile

Ignore
July 31, 2011, 01:42:40 AM
 #116

Hey,

Thanks for the updated kernel. My 5830 went from 303 MH/s to 307 MH/s.

However, this new kernel does not seem to work for my 5670, I went back to Diapolo's latest for that card. Using this kernel on my 5670 resulted in a strange "connecting" / "disconnected" loop where the card never actually did any hashing.... very odd.

I don't know if this helps you any, but I'm on Windows 7 64-bit, Catalyst 11.7, Phoenix 1.5, and the configuration that I normally use for my 5670 is:

Code:
phoenix.exe -k phatk VECTORS BFI_INT FASTLOOP=false AGGRESSION=15 WORKSIZE=128 -q 3 -u http://username:password@pool.bitp.it:8334 DEVICE=1

Mine @ http://pool.bitp.it - No fees, virtually 0 stales, what's not to love!
Chat with us @ #bitp.it on irc.freenode.net
Learn more about our pool @ http://forum.bitcoin.org/index.php?topic=12181.0
ssateneth
Hero Member
*****
Online Online

Activity: 1022



View Profile

Ignore
July 31, 2011, 02:56:00 AM
 #117

What makes you so sure its phoenix and not the kernel? 7-11 kernel and 7-17 kernel = work perfectly. Swap out to 2.0 kernel, spams idle.

Btw I searched that thread you linked and didn't see any mention of idle bug. :/

edit: did some other searching and apparently someone mentione didle bug was fixed in 1.50 but guiminer v2011-07-01 uses phoenix 1.50 according to my console, so I don't know where to go from here.
If someone can figure out the problem and give steps to solve the idle bug with guiminer v2011-07-01, catalyst 11.7, opencl driver 2.5, win7 x64, and this kernel, i'll donate 0.25 btc to you. I would prefer to keep using phoenix in guiminer.
"[0 Khash/sec] blah blah" is referring to the idle problem.

See
http://forum.bitcoin.org/index.php?topic=6458.msg229912#msg229912

That is with the original kernel that people are having the idling problem.  And the author basically said he will not be able to fix that bug and he is leaving it to other developers.
He claimed the idling bug might be fixed in 1.50, in fact it was not.

The idling bug has something to do with the AGGRESSION option, try lowing it might fix the problem.

I tried all aggressions from 1 to 14 as well as changing FASTLOOP from false to true. Setting to true would just spam idle. Setting to false above aggression 6 would also spam idle. Setting to 6 or lower would spam stuff like..
Code:
2011-07-30 21:50:53: Listener for "5830": [30/07/2011 21:50:53] [16.77 Ghash/sec] [0 Accepted] [0 Rejected] [RPC (+LP)]
2011-07-30 21:50:54: Listener for "5830": [30/07/2011 21:50:54] [16.77 Ghash/sec] [0 Accepted] [0 Rejected] [RPC (+LP)]
2011-07-30 21:50:55: Listener for "5830": [30/07/2011 21:50:55] [16.77 Ghash/sec] [0 Accepted] [0 Rejected] [RPC (+LP)]
2011-07-30 21:50:56: Listener for "5830": [30/07/2011 21:50:56] [15.22 Ghash/sec] [0 Accepted] [0 Rejected] [RPC (+LP)]
2011-07-30 21:50:57: Listener for "5830": [30/07/2011 21:50:57] [16.77 Ghash/sec] [0 Accepted] [0 Rejected] [RPC (+LP)]
2011-07-30 21:50:58: Listener for "5830": [30/07/2011 21:50:58] [16.77 Ghash/sec] [0 Accepted] [0 Rejected] [RPC (+LP)]
2011-07-30 21:50:59: Listener for "5830": [30/07/2011 21:50:59] [16.77 Ghash/sec] [0 Accepted] [0 Rejected] [RPC (+LP)]
2011-07-30 21:51:00: Listener for "5830": [30/07/2011 21:51:00] [16.77 Ghash/sec] [0 Accepted] [0 Rejected] [RPC (+LP)]
2011-07-30 21:51:01: Listener for "5830": [30/07/2011 21:51:01] [16.77 Ghash/sec] [0 Accepted] [0 Rejected] [RPC (+LP)]
...which I know is absolutely wrong. Plus my GPU utilization is still 0% when it's spamming that.

The donation (or prize if you want to look at it like that) of 0.25 btc for a fix to this while using guiminer v2011-07-01 win7 x64 is still up for grabs.

edit: I also tried different WORKSIZE, no avail.

Under regular phoenix (no guiminer) the kernel seems to work, though the improvement isn't as big as I had hoped. Still looking for a fix for guiminer based phoenix, unless the phoenix for guiminer is bad. I don't suppose anyone knows is subbing original phoenix 1.5 (the 6 meg one) in for the 22KB one in guiminer will work?

edit2: subbing the 6800KB phoenix.exe in guiminer dir instead of the 22KB one -seems- to work (my shares are going up) but guiminer doesn't know what phoenix is doing. it only shwos shares going up. It doesnt show hash rate or any system messages in the console (LP new block, opencl errors, etc)

If I helped you, please consider donating some BTC my way! 1FVLZTwSiAsf9z9dLZcfEuBY59HQprFJwQ
I am a long time trusted user: Bitcointalk forum trust ratings, Bitcoin-OTC Ratings, eBay Feedback, and Localbitcoins public profile.
fpgaminer
Hero Member
*****
Offline Offline

Activity: 546



View Profile WWW

Ignore
July 31, 2011, 05:10:05 AM
 #118

Quote
doesn't work when vectors are turned on
I am running SDK 2.1, it's either -v or --phatk2, doesn't work with both
How odd. Do you recall what the error message was, if any?

Yannick
Jr. Member
*
Offline Offline

Activity: 59



View Profile

Ignore
July 31, 2011, 07:27:55 AM
 #119

I have two 5870 in my machine with W7 ultimate, AERO disabled.

I'm using:

SDK 2.1
ATI Drivers 10.7

I tested all drivers and SDK versions, this combination of driver and SDK version gave me the highest Hash/sec.

But I'm not able to use the phatk kernel. I'm getting the following error: FATAL kernel error: Failed to load OpenCL kernel! Sad

How can I fix this? poclbm works fine. I'd like to try phatk too. Sad

macboy80
Member
**
Offline Offline

Activity: 102


View Profile

Ignore
July 31, 2011, 09:23:08 AM
 #120

Working well for me.

Radeon 6950 @ 900/900
7/11 = ~360 Mh/s
2.0   = ~370 Mh/s

Windows 7 x64 AERO
Phoenix 1.5 -k phatk DEVICE=0 VECTORS BFI_INT FASTLOOP WORKSIZE=128 AGGRESSION=8
Catalyst 11.7
SDK 2.4

Thanks for the hard work.  Smiley

EDIT: Did not work in Phoenix 1.4. I had to upgrade to 1.5.
Pages: 1 2 3 4 5 [6] 7 8 9 10 11 12 13 14 15 16  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!