Bitcoin Forum
June 21, 2018, 03:14:26 AM *
News: Latest stable version of Bitcoin Core: 0.16.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 [17] 18 19 20 21 22 »  All
  Print  
Author Topic: Electrum server discussion thread  (Read 60364 times)
mustyoshi
Sr. Member
****
Offline Offline

Activity: 288
Merit: 250



View Profile
July 23, 2015, 04:29:58 AM
 #321

I believe I am correctly running a public Electrum node at btc.mustyoshi.com:50001

You server doesn't seem to be connected on IRC... So no, you're not correctly running a public Electrum node Smiley
How do I fix that? I thought I had the config file setup right.
EDIT: So apparently report_host can't be the same as host.
1529550866
Hero Member
*
Offline Offline

Posts: 1529550866

View Profile Personal Message (Offline)

Ignore
1529550866
Reply with quote  #2

1529550866
Report to moderator
The World's Betting Exchange

Bet with play money. Win real Bitcoin. 5BTC Prize Fund for World Cup 2018.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1529550866
Hero Member
*
Offline Offline

Posts: 1529550866

View Profile Personal Message (Offline)

Ignore
1529550866
Reply with quote  #2

1529550866
Report to moderator
1529550866
Hero Member
*
Offline Offline

Posts: 1529550866

View Profile Personal Message (Offline)

Ignore
1529550866
Reply with quote  #2

1529550866
Report to moderator
1529550866
Hero Member
*
Offline Offline

Posts: 1529550866

View Profile Personal Message (Offline)

Ignore
1529550866
Reply with quote  #2

1529550866
Report to moderator
JWU42
Legendary
*
Offline Offline

Activity: 1666
Merit: 1000


View Profile
July 23, 2015, 11:03:29 AM
 #322

I believe I am correctly running a public Electrum node at btc.mustyoshi.com:50001

You server doesn't seem to be connected on IRC... So no, you're not correctly running a public Electrum node Smiley
How do I fix that? I thought I had the config file setup right.
EDIT: So apparently report_host can't be the same as host.

host is the IP of the server
report_host is the FQDN of the server

mustyoshi
Sr. Member
****
Offline Offline

Activity: 288
Merit: 250



View Profile
July 27, 2015, 03:51:05 AM
 #323

So now I'm in the process of rebuilding the server's db because apparently mine was incorrect, it was giving the wrong hash.

But the server hangs during block import every few blocks and I have to kill and restart it.
molecular
Donator
Legendary
*
Offline Offline

Activity: 2520
Merit: 1006



View Profile
July 27, 2015, 05:27:02 AM
 #324

So now I'm in the process of rebuilding the server's db because apparently mine was incorrect, it was giving the wrong hash.

But the server hangs during block import every few blocks and I have to kill and restart it.

Are you sure it hangs? Can you look at cpu and io load during the "hang"?

First time I built the db I thought it was hung a couple of time, too. But it really wasn't, just taking very long.

I ended up using a db download.

PGP key molecular F9B70769 fingerprint 9CDD C0D3 20F8 279F 6BE0  3F39 FC49 2362 F9B7 0769
JWU42
Legendary
*
Offline Offline

Activity: 1666
Merit: 1000


View Profile
July 27, 2015, 11:10:21 PM
 #325

First time I built the db I thought it was hung a couple of time, too. But it really wasn't, just taking very long.

I ended up using a db download.


I built a DB (1000 limit) from scratch back in April - it took 5 weeks  Roll Eyes

Much better to DL one  Grin

mustyoshi
Sr. Member
****
Offline Offline

Activity: 288
Merit: 250



View Profile
July 28, 2015, 07:19:18 PM
 #326

First time I built the db I thought it was hung a couple of time, too. But it really wasn't, just taking very long.

I ended up using a db download.


I built a DB (1000 limit) from scratch back in April - it took 5 weeks  Roll Eyes

Much better to DL one  Grin
2 days and I'm at block 170k
Everytime I download it fails the md5 check.
JWU42
Legendary
*
Offline Offline

Activity: 1666
Merit: 1000


View Profile
July 28, 2015, 11:45:41 PM
 #327

First time I built the db I thought it was hung a couple of time, too. But it really wasn't, just taking very long.

I ended up using a db download.


I built a DB (1000 limit) from scratch back in April - it took 5 weeks  Roll Eyes

Much better to DL one  Grin
2 days and I'm at block 170k
Everytime I download it fails the md5 check.

The first 170K is fine - the next 200K will take forever  Grin

santzi
Newbie
*
Offline Offline

Activity: 3
Merit: 0


View Profile
August 05, 2015, 12:54:23 PM
 #328

Hi,

I have just finished Electrum LTC server up and running, but I have" small" issue left.

All working fine when I connected to Electrum client from localhost.
But I like to get work also as public server.

The problem is that, TCP and SSL sockets could not open...I don't know why.

[05/08/2015-15:36:26] Blockchain height 828417
[05/08/2015-15:36:26] UTXO tree root hash: dd4cdb5b61e1d92b50b745b3d758b62c98bb2fc9b28925033cb6c8c0667aa8ca
[05/08/2015-15:36:26] Coins in database: 4141945190326061
[05/08/2015-15:36:26] could not open TCP socket on zz.xx.cc.vv:50001
[05/08/2015-15:36:26] could not open SSL socket on zz.xx.cc.vv.:50002
[05/08/2015-15:36:26] Blockchain is up to date.
[05/08/2015-15:36:26] Memory pool initialized.
[05/08/2015-15:36:26] blockchain: 828418 (0.005s)
[05/08/2015-15:36:26] litecoind is responding
[05/08/2015-15:36:27] joining IRC

IRC connect is OK.
"electrum-ltc-server peers" -command prints my nick name correctly.
Port forwarding has done to these two ports (50001 and 50002) and iptables should be ok. Also ports 50001 and 50002 are open.

Could someone help me with this issue?

Thank you!
santzi
Newbie
*
Offline Offline

Activity: 3
Merit: 0


View Profile
August 05, 2015, 03:10:42 PM
 #329

Hi,

I have just finished Electrum LTC server up and running, but I have" small" issue left.

All working fine when I connected to Electrum client from localhost.
But I like to get work also as public server.

The problem is that, TCP and SSL sockets could not open...I don't know why.

[05/08/2015-15:36:26] Blockchain height 828417
[05/08/2015-15:36:26] UTXO tree root hash: dd4cdb5b61e1d92b50b745b3d758b62c98bb2fc9b28925033cb6c8c0667aa8ca
[05/08/2015-15:36:26] Coins in database: 4141945190326061
[05/08/2015-15:36:26] could not open TCP socket on zz.xx.cc.vv:50001
[05/08/2015-15:36:26] could not open SSL socket on zz.xx.cc.vv.:50002
[05/08/2015-15:36:26] Blockchain is up to date.
[05/08/2015-15:36:26] Memory pool initialized.
[05/08/2015-15:36:26] blockchain: 828418 (0.005s)
[05/08/2015-15:36:26] litecoind is responding
[05/08/2015-15:36:27] joining IRC

IRC connect is OK.
"electrum-ltc-server peers" -command prints my nick name correctly.
Port forwarding has done to these two ports (50001 and 50002) and iptables should be ok. Also ports 50001 and 50002 are open.

Could someone help me with this issue?

Thank you!

Problem solved.
Configuration problem on /etc/electrum-ltc.conf -file.

Should be:
"host = 192.168.1.33"
not FQDN address.
tnkflx
Sr. Member
****
Offline Offline

Activity: 347
Merit: 250


View Profile
August 05, 2015, 04:26:32 PM
 #330

Hi,

I have just finished Electrum LTC server up and running, but I have" small" issue left.

All working fine when I connected to Electrum client from localhost.
But I like to get work also as public server.

The problem is that, TCP and SSL sockets could not open...I don't know why.

[05/08/2015-15:36:26] Blockchain height 828417
[05/08/2015-15:36:26] UTXO tree root hash: dd4cdb5b61e1d92b50b745b3d758b62c98bb2fc9b28925033cb6c8c0667aa8ca
[05/08/2015-15:36:26] Coins in database: 4141945190326061
[05/08/2015-15:36:26] could not open TCP socket on zz.xx.cc.vv:50001
[05/08/2015-15:36:26] could not open SSL socket on zz.xx.cc.vv.:50002
[05/08/2015-15:36:26] Blockchain is up to date.
[05/08/2015-15:36:26] Memory pool initialized.
[05/08/2015-15:36:26] blockchain: 828418 (0.005s)
[05/08/2015-15:36:26] litecoind is responding
[05/08/2015-15:36:27] joining IRC

IRC connect is OK.
"electrum-ltc-server peers" -command prints my nick name correctly.
Port forwarding has done to these two ports (50001 and 50002) and iptables should be ok. Also ports 50001 and 50002 are open.

Could someone help me with this issue?

Thank you!

Problem solved.
Configuration problem on /etc/electrum-ltc.conf -file.

Should be:
"host = 192.168.1.33"
not FQDN address.


Also, there's no support whatsoever for Electrum and altcoins here...

| Operating electrum.be & us.electrum.be |
fronti
Legendary
*
Offline Offline

Activity: 2002
Merit: 1028



View Profile
August 11, 2015, 08:59:06 AM
 #331

First time I built the db I thought it was hung a couple of time, too. But it really wasn't, just taking very long.

I ended up using a db download.


I built a DB (1000 limit) from scratch back in April - it took 5 weeks  Roll Eyes

Much better to DL one  Grin
2 days and I'm at block 170k
Everytime I download it fails the md5 check.

The first 170K is fine - the next 200K will take forever  Grin

yes.. i noticed by myself.
even on a 30 GB Ramdisk and fast CPU..

What is the main point which takes that long?
Request from bitcoind? generate the DB?..

If you like to give me a tip:  bc1q8ht32j5hj42us5qfptvu08ug9zeqgvxuhwznzk

"Bankraub ist eine Unternehmung von Dilettanten. Wahre Profis gründen eine Bank." Bertolt Brecht
tl121
Sr. Member
****
Offline Offline

Activity: 279
Merit: 250


View Profile
September 02, 2015, 02:15:15 AM
 #332

The September Bitcoin test/demonstration/spam attack/DDoS attack has begun.  Now is the time for all Electrum Server operators to check how their node is standing up, including looking at the processor loading used by Electrum and Bitcoind.

JWU42
Legendary
*
Offline Offline

Activity: 1666
Merit: 1000


View Profile
September 06, 2015, 01:16:09 PM
 #333

All server ops - please update your servers.  A new patch was pushed a few days ago...

Code:
#cd to electrum-server directory then do...
git pull
sudo python setup.py install

Then you should be good to go!

molecular
Donator
Legendary
*
Offline Offline

Activity: 2520
Merit: 1006



View Profile
September 08, 2015, 07:10:24 PM
 #334

All server ops - please update your servers.  A new patch was pushed a few days ago...

Code:
#cd to electrum-server directory then do...
git pull
sudo python setup.py install

Then you should be good to go!

because of this?

Code:
commit be63d5fc48e0a95a800e95b2a8622109c2e3e549
Merge: f6bb080 a187370
Author: ThomasV <thomasv@electrum.org>
Date:   Fri Sep 4 08:36:21 2015 +0200

    Merge pull request #122 from fireduck64/master

    Change to make address history sorted and deterministic



hmm. Seems overkill to prompt everybody to update for this. What am I missing?

PGP key molecular F9B70769 fingerprint 9CDD C0D3 20F8 279F 6BE0  3F39 FC49 2362 F9B7 0769
JWU42
Legendary
*
Offline Offline

Activity: 1666
Merit: 1000


View Profile
September 09, 2015, 01:08:50 AM
 #335

All server ops - please update your servers.  A new patch was pushed a few days ago...

Code:
#cd to electrum-server directory then do...
git pull
sudo python setup.py install

Then you should be good to go!

because of this?

Code:
commit be63d5fc48e0a95a800e95b2a8622109c2e3e549
Merge: f6bb080 a187370
Author: ThomasV <thomasv@electrum.org>
Date:   Fri Sep 4 08:36:21 2015 +0200

    Merge pull request #122 from fireduck64/master

    Change to make address history sorted and deterministic



hmm. Seems overkill to prompt everybody to update for this. What am I missing?


@Molecular,

I simply passed on the request from the devs to encourage all server ops to update.  Yes, it is due to the patch you reference.

molecular
Donator
Legendary
*
Offline Offline

Activity: 2520
Merit: 1006



View Profile
September 09, 2015, 04:31:32 PM
 #336


@Molecular,

I simply passed on the request from the devs to encourage all server ops to update.  Yes, it is due to the patch you reference.
Why such a simple upgrade shouldn't  achieve concensus easily ?

Lol.

I don't oppose the patch. Just not going to update my running server for every little change

PGP key molecular F9B70769 fingerprint 9CDD C0D3 20F8 279F 6BE0  3F39 FC49 2362 F9B7 0769
fydel
Hero Member
*****
Offline Offline

Activity: 533
Merit: 500


Hasta la Bitcoin siempre!


View Profile
October 11, 2015, 01:28:32 PM
 #337

I have set up an electrum-server but the ssl connection is not working.

I followed the instructions in the how-to but I keep getting this error:

Quote
[11/10/2015-14:31:47] cannot start TCP session[Errno 336265218] _ssl.c:351: error:140B0002:SSL routines:SSL_CTX_use_PrivateKey_file:system lib ('109.x.x.81', 51527)

What does this error message mean?

Edit: This is my SSL configuration:

Quote
>openssl req -new -key server.key -out server.csr

Country Name (2 letter code) [AU]:DE
State or Province Name (full name) [Some-State]:NRW
Locality Name (eg, city) []:Cologne
Organization Name (eg, company) [Internet Widgits Pty Ltd]:.
Organizational Unit Name (eg, section) []:.
Common Name (e.g. server FQDN or YOUR name) []:einfachmalnettsein.de
Email Address []:marc@tinyint.de

Please enter the following 'extra' attributes
to be sent with your certificate request
A challenge password []:
An optional company name []:.


>openssl x509 -req -days 730 -in server.csr -signkey server.key -out server.crt

Signature ok
subject=/C=DE/ST=NRW/L=Cologne/CN=einfachmalnettsein.de/emailAddress=marc@tinyint.de
Getting Private key

This is my log:

Quote
[11/10/2015-17:07:24] Starting Electrum server on 0.0.0.0
[11/10/2015-17:07:26] Database version 3.
[11/10/2015-17:07:26] Pruning limit for spent outputs is 10000.
[11/10/2015-17:07:26] Blockchain height 378441
[11/10/2015-17:07:26] UTXO tree root hash: 363913361787b003187a5628440fdf48377beb0a1e56c7f21126e2cca7718f5e
[11/10/2015-17:07:26] Coins in database: 1470823448062842
[11/10/2015-17:07:26] TCP server started on 0.0.0.0:50001
[11/10/2015-17:07:26] SSL server started on 0.0.0.0:50002
[11/10/2015-17:07:26] Blockchain is up to date.
[11/10/2015-17:11:24] utxo not in database; postponing mempool update
[11/10/2015-17:11:25] Memory pool initialized.
[11/10/2015-17:12:28] block 378442 (1954 63.45s) 02c76e47b2e90ee1bf610ba8107b104e3e1fe81339ac02ab7d519c1a7a3a17f4 (30.80tx/s, 63.45s/block)
[11/10/2015-17:12:54] block 378443 (711 26.16s) 90012c37feb4ea11316021b4c613643358710bb696e240b224d553da82491643 (29.73tx/s, 44.62s/block)
[11/10/2015-17:12:58] mempool_update 3.49787020683 18473 8238
[11/10/2015-17:12:58] bitcoind is responding
[11/10/2015-17:12:58] joining IRC
[11/10/2015-17:12:58] cannot start TCP session[Errno 336265218] _ssl.c:351: error:140B0002:SSL routines:SSL_CTX_use_PrivateKey_file:system lib ('188.xx.x.143', 6907)
[11/10/2015-17:12:58] cannot start TCP session[Errno 336265218] _ssl.c:351: error:140B0002:SSL routines:SSL_CTX_use_PrivateKey_file:system lib ('188.x.143', 55134)
[11/10/2015-17:12:58] cannot start TCP session[Errno 336265218] _ssl.c:351: error:140B0002:SSL routines:SSL_CTX_use_PrivateKey_file:system lib ('106.x.x.160', 42757)




UPDATE: It works now. I had a typo in the keyfile. Thanks #electrum for helping.

Bitrated user: fydel.
mdelfin
Newbie
*
Offline Offline

Activity: 1
Merit: 0


View Profile
December 21, 2015, 03:53:37 PM
 #338

I just lauched an electrum server (electrum.stoff-sammlung.de).
(Are there really only 47 servers online?)

I'm a bit puzzled about the tuning.
tmpfs is mentioned to speed up the server (and my hard drives are busy now).
But that means, that the leveldb files are lost at every reboot, right?

I assume seeding the tmpfs is nescessary and saving the leveldb files to permantent storage would be a good idea.

Is there any template for such a setup?

Martin
JWU42
Legendary
*
Offline Offline

Activity: 1666
Merit: 1000


View Profile
December 22, 2015, 11:20:22 AM
 #339

The instructions on github are a bit outdated.

You should download the DB from the foundry.  Building the DB would take 2+ months (assuming modern processor and SSD), so again, just download a snapshot and start from there.

As far as the number of servers.  47 is quite a large number.  It had been in the lower 20's for quite some time and we have seen several new servers start recently.  The more important factor is consistency of servers (i.e., high availability and still running 12 months from now).

The IRC channel #electrum on freenode is also a good resource.

torusJKL
Hero Member
*****
Offline Offline

Activity: 621
Merit: 500


View Profile
December 31, 2015, 03:41:51 PM
 #340

Hi everyone

I installed electrum-server.
It is still syncing to the latest block.

But I get an error "could not open TCP socket on 5.9.29.151:50001"

See the log:
Code:
[31/12/2015-17:32:17] Starting Electrum server on electrum2.ueo.ch
[31/12/2015-17:32:28] Database version 3.
[31/12/2015-17:32:28] Pruning limit for spent outputs is 10000.
[31/12/2015-17:32:28] Blockchain height 390737
[31/12/2015-17:32:28] UTXO tree root hash: 5ac363c9e4f63f1d2387ba079779a5b54c4519f2f0fd816f917024e31b74eff4
[31/12/2015-17:32:28] Coins in database: 1501563237657201
[31/12/2015-17:32:28] catching up missing headers: 390736 390737
[31/12/2015-17:32:31] could not open TCP socket on 5.9.29.151:50001

I also tried port 50010 and even disabled the firewall to no avail.

Thanks.

If you find my post useful send some BTC: 167XM1Za8aG9CdbYuHFMpL2kvPsw6uC8da
Bitrated || bitcoin-otc || Moon Bitcoin Faucet
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 [17] 18 19 20 21 22 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!