Bitcoin Forum
December 09, 2016, 07:24:48 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 [5] 6 7 »  All
  Print  
Author Topic: poclbm using CPU 100% even though using GPU?  (Read 62867 times)
allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
May 26, 2011, 03:05:25 PM
 #81

Hmm if that's the case does anyone know of a windows catalyst driver package version for win 7 64 bit that does not exhibit this annoying 100% cpu usage? I'm currently  using 10.11 (why you may ask, well it's cause it actually works faster than 11.5 with phoenix and the phatk kernel).

1481311488
Hero Member
*
Offline Offline

Posts: 1481311488

View Profile Personal Message (Offline)

Ignore
1481311488
Reply with quote  #2

1481311488
Report to moderator
1481311488
Hero Member
*
Offline Offline

Posts: 1481311488

View Profile Personal Message (Offline)

Ignore
1481311488
Reply with quote  #2

1481311488
Report to moderator
1481311488
Hero Member
*
Offline Offline

Posts: 1481311488

View Profile Personal Message (Offline)

Ignore
1481311488
Reply with quote  #2

1481311488
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481311488
Hero Member
*
Offline Offline

Posts: 1481311488

View Profile Personal Message (Offline)

Ignore
1481311488
Reply with quote  #2

1481311488
Report to moderator
Kluge
Donator
Legendary
*
Offline Offline

Activity: 1218


Michael, send me some coins before I hitman you


View Profile
May 27, 2011, 12:11:22 AM
 #82

Just set CPU affinity for each miner to one core.
All miners can be shoved onto the same core. Through BIOS, AOD, or similar tool, you can downclock and downvolt individual cores in most modern setups. Shove all miners onto one core, downclock and downvolt that core as much as possible, and losses will be minimal. There is no effect on hash rate by doing this because (for the most part) the CPU usage does not seem related to the work the miner is doing. It does not solve the issue -- one core will still effectively be useless -- but I think this is preferable to the earlier suggestion of downclocking/volting all of the cores.

Edit: Meant to say entire CPU voltage can be lowered more after individually underclocking the core the miners use.

Don't mix your coins someone said isn't legal
supa
Jr. Member
*
Offline Offline

Activity: 42


View Profile
May 27, 2011, 03:37:49 AM
 #83

My investigations shows that problem may be in driver version.

When I was using Ubuntu 10.10 and NVidia 260.19.36, there are no problems - poclbm was using only 0-5 %
Today I upgraded to Ubuntu 11.04 and fresh NVidia driver 270.41.19, and now poclbm (and phoenix too) are using up to 100% Sad

When I install old NVidia driver 260.19.36 on Ubuntu 11.04, poclbm is digging and "top" shows low cpu usage (0-5%), but unfortunately X server cannot starting complaining about "ABI version mismatch". Now I am on Ubuntu 11.04 with fresh driver, and also seeking for better solution... Maybe I'll have to go back to Ubuntu 10.10.

EDIT: videocard is - nVidia Corporation GT215 [GeForce GT 240] (rev a2) ~20.000 khash/s

This.

I recently moved to Fedora 15 and upgraded drivers for my 8500GT.  poclbm was maxing at 100% CPU across two CPUs.

Threw the machine into run level 3, downloaded the nVidia driver mentioned by the user above (260.19.36), installed, reloaded the module - viola.  poclbm is taking < 1% CPU.

Very, very, very easy to recreate.  Use the versions mentioned above.

DigDug3445
Newbie
*
Offline Offline

Activity: 3


View Profile
May 28, 2011, 04:24:58 PM
 #84

But then U are limiting something from doing it's job, no?

I mean -there is a reason the CPU is on a 100%, no? Or actually the fault is that it's doing NOTHING while running on 100%???

I am limiting it but it does not seem to effect my hashrate as long as its set at 57% or so even if i drop it down too something like 20% i do not see any reduction in my hashrate with my two cards, i set it at 57% as at 58% it starts to use about 70w rather than 40w when at 57% mostly so it quieter although the powersaving is also good Smiley.
This is because i am still using my computer for search the web watching youtube etc when the two gfx cards are running and i the computer becomes sluggish if it was set real low but does not seem to effect the hashrate just the responsiveness of my system in general.

Transisto
Donator
Legendary
*
Offline Offline

Activity: 1624



View Profile WWW
May 30, 2011, 04:06:28 PM
 #85

My rig has a one core CPU, so that doesn't help.

CPU at 100% from poclbm does not affect hash rate but CPU at 100% from anything else almost stop it.

I can't use the afterburner UI when poclbm use 100%

allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
May 31, 2011, 08:56:42 PM
 #86

My rig has a one core CPU, so that doesn't help.

CPU at 100% from poclbm does not affect hash rate but CPU at 100% from anything else almost stop it.

I can't use the afterburner UI when poclbm use 100%



Yeah that sucks. For you the only option is to go the linux route or to get a cpu with dual cores (AMD Athlon II X2 250 may be a good one)


SchizophrenicX
Full Member
***
Offline Offline

Activity: 126

"I'm not psychic; I'm just damn good"


View Profile
May 31, 2011, 11:58:18 PM
 #87

So this have not been solve for ATI yet huh... Man. And I'm having problems for my windows to install correctly. damnit.

unroar
Newbie
*
Offline Offline

Activity: 1


View Profile
June 02, 2011, 05:22:38 AM
 #88

It doesn't seem like it should be that hard to debug python the to find where the cpu peg is happening.  Even if it's not poclbm's fault it would still be good to know on which opencl calls this happens.  I don't know opencl or bitcoin otherwise I'd dive in.
supa
Jr. Member
*
Offline Offline

Activity: 42


View Profile
June 02, 2011, 05:31:59 AM
 #89

I don't know opencl or bitcoin otherwise I'd dive in.

Sounds like the perfect opportunity to learn something new, eh? Wink

SchizophrenicX
Full Member
***
Offline Offline

Activity: 126

"I'm not psychic; I'm just damn good"


View Profile
June 02, 2011, 06:31:45 AM
 #90

I realized that if I don't overclock the GPU (meaning I disable ATI Overdrive) then poclbm works normally. Idk if this is universal, could someone verify if this is repeatable (forgot the right word for bugs). If it is we might be getting closer to solving this problem.

allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
June 02, 2011, 08:26:16 AM
 #91

I realized that if I don't overclock the GPU (meaning I disable ATI Overdrive) then poclbm works normally. Idk if this is universal, could someone verify if this is repeatable (forgot the right word for bugs). If it is we might be getting closer to solving this problem.

Umm, that sounds odd. I don't overclock at all but I do have ATI Overdrive enabled just to set the fan profile manually, yet I still have high cpu usage. I also have the memory underclocked but not via ATI overdrive but MSI afterburner. Hmm, I guess this weekend I'm going to have to try disabling overdrive and see if this works. But maybe someone can beat me to it and report back their findings here?

nased0
Newbie
*
Offline Offline

Activity: 20


View Profile
June 03, 2011, 11:33:55 PM
 #92

My investigations shows that problem may be in driver version.

When I was using Ubuntu 10.10 and NVidia 260.19.36, there are no problems - poclbm was using only 0-5 %
Today I upgraded to Ubuntu 11.04 and fresh NVidia driver 270.41.19, and now poclbm (and phoenix too) are using up to 100% Sad

When I install old NVidia driver 260.19.36 on Ubuntu 11.04, poclbm is digging and "top" shows low cpu usage (0-5%), but unfortunately X server cannot starting complaining about "ABI version mismatch". Now I am on Ubuntu 11.04 with fresh driver, and also seeking for better solution... Maybe I'll have to go back to Ubuntu 10.10.

EDIT: videocard is - nVidia Corporation GT215 [GeForce GT 240] (rev a2) ~20.000 khash/s
IMHO this problem is caused by the OpenCL implementation in the driver, I am testing the RPC miner (CUDA) under Windows 7 and it works fine, with very small CPU usage (< 1%) and 80% of the poclbm efficiency (43 vs 55 mhash/s).

I have tested also the OpenCL version of the RPC miner, and the tests were inconclusive, it used 100% of one of the cores for a few minutes and repeatedly generated 0 khash/s, then crashed because of the memory allocation error.

I have GTX 275 and C2Q 9450 @ 2,66 GHz.

If my posts are helpful, please send me something to 1AAj2HTautkcbVdHwwQu4rYWRFSUm4pAT7 . Thanks!
allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
June 04, 2011, 08:08:05 AM
 #93

Well dammit why doesn't AMD fix this sh*t! Is it really so hard to at the very least allow us to turn off the cpu spin state flag off? I'm thinking a simple .ini or config file option would be all that is needed.


jamesb
Jr. Member
*
Offline Offline

Activity: 30


View Profile
June 04, 2011, 02:00:43 PM
 #94

When I was using Ubuntu 10.10 and NVidia 260.19.36, there are no problems - poclbm was using only 0-5 %
Today I upgraded to Ubuntu 11.04 and fresh NVidia driver 270.41.19, and now poclbm (and phoenix too) are using up to 100% Sad

When I install old NVidia driver 260.19.36 on Ubuntu 11.04, poclbm is digging and "top" shows low cpu usage (0-5%), but unfortunately X server cannot starting complaining about "ABI version mismatch". Now I am on Ubuntu 11.04 with fresh driver, and also seeking for better solution... Maybe I'll have to go back to Ubuntu 10.10.

EDIT: videocard is - nVidia Corporation GT215 [GeForce GT 240] (rev a2) ~20.000 khash/s

I can confirm this problem too, new drivers 270... makes my cpu work more for nothing! I've downgraded to 260 and now it's fine. Thank you Wink and about your ubuntu problem you should rmmod and modprobe your nvidia kernel module before restarting xorg, or reboot. It should fix your error.

IMHO this problem is caused by the OpenCL implementation in the driver, I am testing the RPC miner (CUDA) under Windows 7 and it works fine, with very small CPU usage (< 1%) and 80% of the poclbm efficiency (43 vs 55 mhash/s). [...]

I have GTX 275 and C2Q 9450 @ 2,66 GHz.

I've got a GTX 285 and the same CPU and got 60 Mhs on linux with poclbm (at max without Xorg). Do you think CUDA could change dramatically the performance? Something like > 65 Mhs?
EDIT: I've tested puddinpop's miner with CUDA and I'm getting less (45-55 Mhs and it has frozen my kernel!) than poclbm OpenCL at "low rate" (-f at 150 I get 56 Mhs) which allows me to use my computer without refreshing latency at all (if I whish I can set -f0 and mine at 60 Mhs without Xorg! How can it be better?).
dishwara
Legendary
*
Offline Offline

Activity: 1386

Truth may get delay, but NEVER fails


View Profile
June 04, 2011, 05:21:55 PM
 #95

Check this link, It MUST solve CPU usage problem.

http://forum.bitcoin.org/index.php?topic=6188.msg168009#msg168009
allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
June 04, 2011, 10:12:34 PM
 #96

I already use 10.9 on two of my dedicated miners and it does not solve the high cpu usage problem. So just running 10 series does not work on windows. I'll look into that granola program. I hope though that I can trust it and it won't be some spyware/malware scam.

Transisto
Donator
Legendary
*
Offline Offline

Activity: 1624



View Profile WWW
June 05, 2011, 04:05:03 AM
 #97

does the phoenix miner exhibit this same problem ?
Kluge
Donator
Legendary
*
Offline Offline

Activity: 1218


Michael, send me some coins before I hitman you


View Profile
June 05, 2011, 04:14:48 AM
 #98

does the phoenix miner exhibit this same problem ?
Yes, for at least some of us.

Don't mix your coins someone said isn't legal
allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
June 05, 2011, 04:30:57 AM
 #99

Guys this is not a miner issue..it's just the opencl drivers...

kiwiasian
Full Member
***
Offline Offline

Activity: 168


View Profile
June 05, 2011, 02:47:34 PM
 #100

Guys...
Just set the CPU affinity...

Tradehill referral link, save 10% | http://www.tradehill.com/?r=TH-R12328
www.payb.tc/kiwiasian | 1LHNW1JGMBo2e7rKiiFz7KJPKE57bqCdEC
Pages: « 1 2 3 4 [5] 6 7 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!