Bitcoin Forum
December 05, 2016, 04:46:36 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 [9] 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 »
  Print  
Author Topic: Pushpool - Tech Support  (Read 126693 times)
phorensic
Hero Member
*****
Offline Offline

Activity: 630



View Profile
June 21, 2011, 05:29:51 AM
 #161

How do i send "listtransactions" to it? I am using Ubuntu Server 11.04 w/ bitcoind.  How do i send queries to the daemon? Im a linux n00b
https://en.bitcoin.it/wiki/Original_Bitcoin_client/API_calls_list
1480913196
Hero Member
*
Offline Offline

Posts: 1480913196

View Profile Personal Message (Offline)

Ignore
1480913196
Reply with quote  #2

1480913196
Report to moderator
1480913196
Hero Member
*
Offline Offline

Posts: 1480913196

View Profile Personal Message (Offline)

Ignore
1480913196
Reply with quote  #2

1480913196
Report to moderator
1480913196
Hero Member
*
Offline Offline

Posts: 1480913196

View Profile Personal Message (Offline)

Ignore
1480913196
Reply with quote  #2

1480913196
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480913196
Hero Member
*
Offline Offline

Posts: 1480913196

View Profile Personal Message (Offline)

Ignore
1480913196
Reply with quote  #2

1480913196
Report to moderator
1480913196
Hero Member
*
Offline Offline

Posts: 1480913196

View Profile Personal Message (Offline)

Ignore
1480913196
Reply with quote  #2

1480913196
Report to moderator
jgarzik
Legendary
*
Offline Offline

Activity: 1470


View Profile
June 21, 2011, 05:30:10 AM
 #162

How do i send "listtransactions" to it? I am using Ubuntu Server 11.04 w/ bitcoind.  How do i send queries to the daemon? Im a linux n00b

This has nothing to do with pushpoold.  pushpoold is just an HTTP proxy, sitting between mining clients and bitcoind.

All commands such as listtransactions go straight to bitcoind as usual.  'getwork' is the only JSON-RPC method supported by pushpool.


Jeff Garzik, bitcoin core dev team and BitPay engineer; opinions are my own, not my employer.
Donations / tip jar: 1BrufViLKnSWtuWGkryPsKsxonV2NQ7Tcj
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 21, 2011, 06:20:23 AM
 #163

How do i send "listtransactions" to it? I am using Ubuntu Server 11.04 w/ bitcoind.  How do i send queries to the daemon? Im a linux n00b
https://en.bitcoin.it/wiki/Original_Bitcoin_client/API_calls_list

Theres probubly a better way but for simplicity i use a php bitcoin library to query bicoind
FreddyE
Newbie
*
Offline Offline

Activity: 27


View Profile
June 22, 2011, 06:50:08 AM
 #164

This is because when starting pushpool you need to specify the path to the config.
Quote
pushpoold --config=/mypath/to/config/somefile.json

oh...I thought it was something simple as that. thanks ;-)

Finally I had time to try it. Still not working...but it seems it can at least find the file...because if I enter a WRONG path I get "config file: no such file or directory" instead of "JSON parse failed".
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 22, 2011, 07:11:18 AM
 #165

This is because when starting pushpool you need to specify the path to the config.
Quote
pushpoold --config=/mypath/to/config/somefile.json

oh...I thought it was something simple as that. thanks ;-)

Finally I had time to try it. Still not working...but it seems it can at least find the file...because if I enter a WRONG path I get "config file: no such file or directory" instead of "JSON parse failed".
Download a fresh coppy of server.json I would say you have an error in JSON file.
FreddyE
Newbie
*
Offline Offline

Activity: 27


View Profile
June 22, 2011, 07:17:36 AM
 #166

This is because when starting pushpool you need to specify the path to the config.
Quote
pushpoold --config=/mypath/to/config/somefile.json

oh...I thought it was something simple as that. thanks ;-)

Finally I had time to try it. Still not working...but it seems it can at least find the file...because if I enter a WRONG path I get "config file: no such file or directory" instead of "JSON parse failed".
Download a fresh coppy of server.json I would say you have an error in JSON file.

I copy and pasted the code for server.json thats posted at the start of this thread. Then I added my data. Where can I download a working server.json?
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 22, 2011, 07:25:34 AM
 #167

This is because when starting pushpool you need to specify the path to the config.
Quote
pushpoold --config=/mypath/to/config/somefile.json

oh...I thought it was something simple as that. thanks ;-)

Finally I had time to try it. Still not working...but it seems it can at least find the file...because if I enter a WRONG path I get "config file: no such file or directory" instead of "JSON parse failed".
Download a fresh coppy of server.json I would say you have an error in JSON file.

I copy and pasted the code for server.json thats posted at the start of this thread. Then I added my data. Where can I download a working server.json?
I would try copying and pasting again, and make sure you include both { } when copying and pasting one missing semi-colon, hyphenation, etc, etc json dosn't like this
FreddyE
Newbie
*
Offline Offline

Activity: 27


View Profile
June 22, 2011, 07:31:59 AM
 #168

Thanks Xenland! I found the problem. When I entered my ip-adress I accidentally deleted the closing ". Its working now :-)

Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 22, 2011, 07:37:12 AM
 #169

Thanks Xenland! I found the problem. When I entered my ip-adress I accidentally deleted the closing ". Its working now :-)


Yep yep, Do you have any spare change for my programming addiction... I have to pay electricity costs too ya know Tongue !@! lol
FreddyE
Newbie
*
Offline Offline

Activity: 27


View Profile
June 22, 2011, 09:32:57 AM
 #170

All my BTC are at mtgox right now :-(
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
June 22, 2011, 09:50:15 AM
 #171

Hello,

could someone please give me the share(solution) hash for an actual block that was found.
And one other question: why is pushpoold quiting/not starting without any errors?
I have the latest pushpool version.

regards, redshark1802

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 22, 2011, 10:17:10 AM
 #172

Hello,

could someone please give me the share(solution) hash for an actual block that was found.
And one other question: why is pushpoold quiting/not starting without any errors?
I have the latest pushpool version.

regards, redshark1802
the newest pushpool has a bug where output dosen't display. There's a fix for it on the previous page and an easy delete greather than sign then replace it with a less then sign or somthing like that.
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
June 22, 2011, 11:27:10 AM
 #173

Thanks i already had that version, the problem was that the pid was not removed properly.

Do you have a valid for an actual block?

regards, redshark1802

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
FreddyE
Newbie
*
Offline Offline

Activity: 27


View Profile
June 22, 2011, 01:05:18 PM
 #174

It seems pushpool is not listening on any ports for me.
I get this:

"[1308747727.006541] Listening on host :: port 8347
[1308747727.006620] Listening on host :: port 8344
[1308747727.007214] Listening on host 127.0.0.1 port 8338
"

Where it says "host ;;" I had actually entered an ip adress in the config file.
According to nmap none of those ports is actually open and beeing listened on.

What am I doing wrong?
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
June 22, 2011, 01:40:36 PM
 #175

It seems pushpool is not listening on any ports for me.
I get this:

"[1308747727.006541] Listening on host :: port 8347
[1308747727.006620] Listening on host :: port 8344
[1308747727.007214] Listening on host 127.0.0.1 port 8338
"

Where it says "host ;;" I had actually entered an ip adress in the config file.
According to nmap none of those ports is actually open and beeing listened on.

What am I doing wrong?

You should only connect to *:8347 with your miner.
Did you nmap on the localhost or the remote and what parameters did you use?
Try "nmap -sS -p 1-6000 -v <targetip>" from an remote host.

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
FreddyE
Newbie
*
Offline Offline

Activity: 27


View Profile
June 22, 2011, 01:58:36 PM
 #176

It seems pushpool is not listening on any ports for me.
I get this:

"[1308747727.006541] Listening on host :: port 8347
[1308747727.006620] Listening on host :: port 8344
[1308747727.007214] Listening on host 127.0.0.1 port 8338
"

Where it says "host ;;" I had actually entered an ip adress in the config file.
According to nmap none of those ports is actually open and beeing listened on.

What am I doing wrong?

You should only connect to *:8347 with your miner.
Did you nmap on the localhost or the remote and what parameters did you use?
Try "nmap -sS -p 1-6000 -v <targetip>" from an remote host.

I nmaped from the remote. I now get 8332 and 8333 as open ports, but none of the pushpool ports (if using -p 1-9000).

redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
June 22, 2011, 02:02:55 PM
 #177

It seems pushpool is not listening on any ports for me.
I get this:

"[1308747727.006541] Listening on host :: port 8347
[1308747727.006620] Listening on host :: port 8344
[1308747727.007214] Listening on host 127.0.0.1 port 8338
"

Where it says "host ;;" I had actually entered an ip adress in the config file.
According to nmap none of those ports is actually open and beeing listened on.

What am I doing wrong?

You should only connect to *:8347 with your miner.
Did you nmap on the localhost or the remote and what parameters did you use?
Try "nmap -sS -p 1-6000 -v <targetip>" from an remote host.

I nmaped from the remote. I now get 8332 and 8333 as open ports, but none of the pushpool ports (if using -p 1-9000).




Please post your server.json config, preferable on pastebin.com and I recommend closing 8332 and 8333 via iptables.
For an standard iptables installation type:
iptables -A INPUT -p tcp --dport 8332 -j DROP
iptables -A INPUT -p tcp --dport 8333 -j DROP

regards, redshark1802

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
FreddyE
Newbie
*
Offline Offline

Activity: 27


View Profile
June 22, 2011, 02:26:54 PM
 #178

here is my server.json, I removed password data etc. I closed 8332 and 8333 as you suggested

Code:
{
   # network ports
   "listen" : [
      # binary protocol (default), port 8342
      { "port" : 8342 },

      # HTTP JSON-RPC protocol, port 8341
      { "port" : 8347, "protocol" : "http-json" },

      # HTTP JSON-RPC protocol, port 8344,
      #proxy is most likely your external ip address if your running a public pool | Public pools WON'T have the following ip addresses: (10.0.0.1, 127.0.0.1, 192.168.1.100, or 192.168.254.254,etc,etc)
      # requests to us | "proxy" should be set to your ip address that people will connect through
      { "port" : 8344, "protocol" : "http-json",
        "proxy" : "myexternalstaticip" },
 


      # binary protocol, localhost-only port 8338
      # host is most likely your localhost address
      { "host" : "127.0.0.1", "port" : 8338, "protocol" : "binary" }
   ],

   # database settings
   "database" : {
      "engine" : "mysql",

      "host" : "localhost",

      "port" : 3306,

      #database name
      "name" : "xxxxx",
      #database username
      "username" : "xxxx",
      #database password
      "password" : "xxxxxxxx",
      #enable sharelog | to insert share data or sometimes known as "work"
      "sharelog" : true,
      "stmt.pwdb":"SELECT password FROM pool_worker WHERE username = ?",
     
      "stmt.sharelog":"INSERT INTO shares (rem_host, username, our_result, upstream_result, reason, solution) VALUES (?, ?, ?, ?, ?, ?)"

   },

   #uncoment this when you want to use memcached (Recommended for servers over 1.5gb of ram)
   # cache settings
   #"memcached" : {
   #   "servers" : [
   #      { "host" : "127.0.0.1", "port" : 11211 }
   #   ]
   #},

   "pid" : "/tmp/pushpoold.pid",

   # overrides local hostname detection
   "forcehost" : "localhost.localdomain",

   "log.requests" : "/tmp/request.log",
   "log.shares" : "/tmp/shares.log",

   # the server assumes longpolling (w/ SIGUSR1 called for each blk)
   "longpoll.disable" : false,

   # length of time to cache username/password credentials, in seconds
   "auth.cred_cache.expire" : 75,

   # RPC settings
   #Bitcoind Protocal settings
   #Host were bitcoind can be found on the network
   "rpc.url" : "http://127.0.0.1:8332/",
   #Username & password to connect to bitcoind
   
   "rpc.user": "xxxxxx",
   "rpc.pass" : "xxxxxxxr",

   # rewrite returned 'target' to difficulty-1?
   "rpc.target.rewrite" : true
}
redshark1802
Jr. Member
*
Offline Offline

Activity: 44


View Profile
June 22, 2011, 02:52:08 PM
 #179

here is my server.json, I removed password data etc. I closed 8332 and 8333 as you suggested

Code:
{
   # network ports
   "listen" : [
      # binary protocol (default), port 8342
      { "port" : 8342 },

      # HTTP JSON-RPC protocol, port 8341
      { "port" : 8347, "protocol" : "http-json" },

      # HTTP JSON-RPC protocol, port 8344,
      #proxy is most likely your external ip address if your running a public pool | Public pools WON'T have the following ip addresses: (10.0.0.1, 127.0.0.1, 192.168.1.100, or 192.168.254.254,etc,etc)
      # requests to us | "proxy" should be set to your ip address that people will connect through
      { "port" : 8344, "protocol" : "http-json",
        "proxy" : "myexternalstaticip" },
 


      # binary protocol, localhost-only port 8338
      # host is most likely your localhost address
      { "host" : "127.0.0.1", "port" : 8338, "protocol" : "binary" }
   ],

   # database settings
   "database" : {
      "engine" : "mysql",

      "host" : "localhost",

      "port" : 3306,

      #database name
      "name" : "xxxxx",
      #database username
      "username" : "xxxx",
      #database password
      "password" : "xxxxxxxx",
      #enable sharelog | to insert share data or sometimes known as "work"
      "sharelog" : true,
      "stmt.pwdb":"SELECT password FROM pool_worker WHERE username = ?",
     
      "stmt.sharelog":"INSERT INTO shares (rem_host, username, our_result, upstream_result, reason, solution) VALUES (?, ?, ?, ?, ?, ?)"

   },

   #uncoment this when you want to use memcached (Recommended for servers over 1.5gb of ram)
   # cache settings
   #"memcached" : {
   #   "servers" : [
   #      { "host" : "127.0.0.1", "port" : 11211 }
   #   ]
   #},

   "pid" : "/tmp/pushpoold.pid",

   # overrides local hostname detection
   "forcehost" : "localhost.localdomain",

   "log.requests" : "/tmp/request.log",
   "log.shares" : "/tmp/shares.log",

   # the server assumes longpolling (w/ SIGUSR1 called for each blk)
   "longpoll.disable" : false,

   # length of time to cache username/password credentials, in seconds
   "auth.cred_cache.expire" : 75,

   # RPC settings
   #Bitcoind Protocal settings
   #Host were bitcoind can be found on the network
   "rpc.url" : "http://127.0.0.1:8332/",
   #Username & password to connect to bitcoind
   
   "rpc.user": "xxxxxx",
   "rpc.pass" : "xxxxxxxr",

   # rewrite returned 'target' to difficulty-1?
   "rpc.target.rewrite" : true
}


everything looks good, are you sure pushpoold is still running?
ps aux | grep pushpoold

regards, redshark1802

If the post above is something worth to you, please consider donating Wink.
1HYek9jXvbMDYyYwN7rxy9i3oDWgCYhATx
grue
Global Moderator
Legendary
*
Offline Offline

Activity: 1932



View Profile
June 22, 2011, 03:13:29 PM
 #180

linux noob here.

installed a fresh copy of ubuntu desktop on VMware. Jansson was installed successfully, but i can't get libmemcached to install.

i got an error when using ./configure, and make does not work.
Code:
configure: error: "could not find memcached binary"
pool@pool-virtual-machine:~/libmemcached-0.50$ make
make: *** No targets specified and no makefile found.  Stop.

It is pitch black. You are likely to be eaten by a grue.

Tired of annoying signature ads? Ad block for signatures
Pages: « 1 2 3 4 5 6 7 8 [9] 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!