Bitcoin Forum
December 03, 2016, 11:59:17 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 [5] 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 »
  Print  
Author Topic: Pushpool - Tech Support  (Read 126679 times)
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 05, 2011, 10:51:33 AM
 #81

Do you have mysql or any other database engine running? It's mandatory, also, bitcoinD should be running prior to launching pushpool

Yeah, mysqld running and bitcoind running as well. How strange, it just exits right after launching pretty much ... I've recompiled it, restarted processes - nothing. What am I missing here?

EDIT: Fixed it. Looks like I had the some issue someone else had, permissions problem. I changed all references of '/tmp' to /home/user1'

Woohoo! That consumed way too much time ... I wish pushpoold had kicked out an error or something about it.

Yeah you are find out all my frustration I incurred in the IRC chat, You really do just have to "play with it", server.json.
One thing is to make sure that you set your bitcoind RPC details correctly at the end of the server.json file.
The next thing to do is to change all the ports to something different, one-by-one. As I released the server.json file with the original but better commenting, which means its the original that your seeing. On my personal VPS I had to change one of the RPC ports for it to initialise for some reason port 8333 was open and unknown in the ping scan but when I changed it to something like 8338. It finally initialised, after that I started getting connected clients from my miner but pwdb query errors then i knew right away it was MySql database problem so I fiddled around a tid-bit and realised i was connected to my local database on my computer and not the local database on my VPS server. So i fixed those details and then all of a sudden I started getting "RPC not responding from my server" the second I uploaded the correct database details. Well after much frustration I realised that push pool dosen't properly alert the user that it was a bad user name and password and/or port number. So I typed in the right port number with the right database details and vola... after 18hours I got my pushpoold server to work..

This was my whole experience on pushpool, and what problems was caused by it..... Its the only I go off of because pushpool fails to give out logging messages
1480809557
Hero Member
*
Offline Offline

Posts: 1480809557

View Profile Personal Message (Offline)

Ignore
1480809557
Reply with quote  #2

1480809557
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
slowmining
Newbie
*
Offline Offline

Activity: 22


View Profile
June 06, 2011, 06:06:49 PM
 #82

Hi. Me and my friend turlando are triyng to set up pushpool.
On an old server all went fine, but on a new server, with the same config (except for some passwords), we get this error:
[1307382484.476195] tcp socket: Address family not supported by protocol
This is the config:
Code:

{
   # network ports
   "listen" : [
      # binary protocol (default), port 8342
      { "port" : 8342 },

      # HTTP JSON-RPC protocol, port 8341
      { "port" : 8347, "protocol" : "http-json" },

      # HTTP JSON-RPC protocol, port 8344,
      #proxy is most likely your external ip address if your running a public pool | Public pools WON'T have the following ip addresses: (10.0.0.1, 127.0.0.1, 192.168.1.100, or 192.168.254.254,etc,etc)
      # requests to us | "proxy" should be set to your ip address that people will connect through
      { "port" : 8344, "protocol" : "http-json",
        "proxy" : "127.0.0.1" },

      # binary protocol, localhost-only port 8338
      # host is most likely your localhost address
      { "host" : "127.0.0.1", "port" : 8338, "protocol" : "binary" }
   ],


# database settings
"database" : {

"engine" : "postgresql",

"host" : "127.0.0.1",

"port" : 5432,

"name" : "pushpool",
"username" : "bitcoin",
"password" : "hidden",

# set to true to enable logging of shares to db
"sharelog" : true,

# edit queries to match your database structure if necessary
"stmt.pwdb" :
  "SELECT password FROM pool_worker WHERE username = $1",

                "stmt.sharelog" :
                  "INSERT INTO shares (rem_host, username, our_result, upstream_result, reason, solution) VALUES ($1, $2, $3, $4, $5, decode($6, 'hex'))"

},

# cache settings
# comment out to disable memcache - NOT RECOMMENDED
"memcached" : {
"servers" : [
{ "host" : "127.0.0.1", "port" : 11211 }
]
},

"pid" : "/tmp/pushpoold.pid",

# overrides local hostname detection
#"forcehost" : "localhost.localdomain",

# logfiles for requests and shares
"log.requests" : "/tmp/request.log",
"log.shares" : "/tmp/shares.log",

# the server assumes longpolling (w/ SIGUSR1 called for each blk)
"longpoll.disable" : false,

# length of time to cache username/password credentials, in seconds
"auth.cred_cache.expire" : 75,

# RPC settings to bitcoind upstream server (same as bitcoin.conf if using original client)
"rpc.url" : "http://127.0.0.1:8332/",
"rpc.user" : "bitcoin",
"rpc.pass" : "hidden",

# rewrite returned 'target' to difficulty-1?
"rpc.target.rewrite" : true
}

We did some search but we didn't found anything. Someone can help us?

Sorry for my english ._.
Mobotek
Newbie
*
Offline Offline

Activity: 18


View Profile
June 07, 2011, 02:26:32 AM
 #83

I am having an issue with Installation... I am running Ubuntu 11.04 Server and when I get to the point to configure the files for install I get:
 I Enter this:
Code:
./configure --prefix=/home/[b]my_user_name[/b]/pushpool/


I Get This:
Quote
configure: command not found


Am I missing something that needs to be installed in Ubuntu?

Sorry I am kind of a Linux Newb.
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 07, 2011, 03:15:14 AM
 #84

I am having an issue with Installation... I am running Ubuntu 11.04 Server and when I get to the point to configure the files for install I get:
 I Enter this:
Code:
./configure --prefix=/home/[b]my_user_name[/b]/pushpool/


I Get This:
Quote
configure: command not found


Am I missing something that needs to be installed in Ubuntu?

Sorry I am kind of a Linux Newb.

./configure --prefix=folder you want to install

make sure that you acknowledge that this is working directory after the "--prefix=" usually your home folder other then that why it doesn't recognise "./configure" command(notice the ./) type it in exactly as I have except for the prefix part.
Mobotek
Newbie
*
Offline Offline

Activity: 18


View Profile
June 07, 2011, 03:28:59 AM
 #85

Made sure and it def. does... I am signed in as root so its not a permission issue... After installing a few extra packages like build-essentials I now get this.


Code:
bash: ./configure: No such file or directory
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 07, 2011, 04:04:56 AM
 #86

and did you change into the directory where the "./configure" file is?
Whats the exact output in the directory where you type in ./configure at when you type in
Code:
ls
Mobotek
Newbie
*
Offline Offline

Activity: 18


View Profile
June 07, 2011, 04:24:07 AM
 #87

when I do an LS in that directory I get this.

Code:
.           blkmond       db-postgresql.c     hist.c       msg.c       ubbp.h
..          ChangeLog     db-sqlite.c         htab.c       NEWS        util.c
anet.c      config.c      elist.h             htab.h       protocol.h
anet.h      configure.ac  example-blkmon.cfg  LICENSE      README
AUTHORS     COPYING       example-cfg.json    m4           server.c
autogen.sh  db-mysql.c    .gitignore          Makefile.am  server.h
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 07, 2011, 05:03:33 AM
 #88

when I do an LS in that directory I get this.

Code:
.           blkmond       db-postgresql.c     hist.c       msg.c       ubbp.h
..          ChangeLog     db-sqlite.c         htab.c       NEWS        util.c
anet.c      config.c      elist.h             htab.h       protocol.h
anet.h      configure.ac  example-blkmon.cfg  LICENSE      README
AUTHORS     COPYING       example-cfg.json    m4           server.c
autogen.sh  db-mysql.c    .gitignore          Makefile.am  server.h
Yeah it looks like configure isn't there, I would try downloading pushpool tarball again,
Latest release: http://yyz.us/bitcoin/pushpool-0.4.1.tar.gz
(You may have downloaded the developer version of pushpool)
fpgaminer
Hero Member
*****
Offline Offline

Activity: 546



View Profile WWW
June 07, 2011, 06:51:24 AM
 #89

I experienced an odd problem with pushpool.

I got it setup, and accepting shares against a bitcoin --testnet client setup correctly with RPC. So, everything appeared to work. I even found a few blocks, and those submitted fine.

However, at a difficulty of 38, and >1000 shares, it had only found 2 blocks.  Huh That's either really bad luck, or something was broken.

So I tried pointing the miners at bitcoind directly, and they found 3 blocks in a few minutes (as expected for the hashrate).

Mobotek
Newbie
*
Offline Offline

Activity: 18


View Profile
June 07, 2011, 02:09:24 PM
 #90

So I downloaded the package and exacted it using tar... still no configuration file

ls -a:

Code:
.           blkmond       db-postgresql.c     hist.c       msg.c       ubbp.h
..          ChangeLog     db-sqlite.c         htab.c       NEWS        util.c
anet.c      config.c      elist.h             htab.h       protocol.h
anet.h      configure.ac  example-blkmon.cfg  LICENSE      README
AUTHORS     COPYING       example-cfg.json    m4           server.c
autogen.sh  db-mysql.c    .gitignore          Makefile.am  server.h


Anyone know what is happening to this configuration file?


davout
Legendary
*
Offline Offline

Activity: 1358


1davout


View Profile WWW
June 07, 2011, 02:23:20 PM
 #91

So I downloaded the package and exacted it using tar... still no configuration file

ls -a:

Code:
.           blkmond       db-postgresql.c     hist.c       msg.c       ubbp.h
..          ChangeLog     db-sqlite.c         htab.c       NEWS        util.c
anet.c      config.c      elist.h             htab.h       protocol.h
anet.h      configure.ac  example-blkmon.cfg  LICENSE      README
AUTHORS     COPYING       example-cfg.json    m4           server.c
autogen.sh  db-mysql.c    .gitignore          Makefile.am  server.h


Anyone know what is happening to this configuration file?
Use autogen

dikidera
Full Member
***
Offline Offline

Activity: 126


View Profile
June 07, 2011, 04:27:48 PM
 #92

Hmm, i wonder what this is

davout
Legendary
*
Offline Offline

Activity: 1358


1davout


View Profile WWW
June 07, 2011, 04:54:18 PM
 #93

Hmm, i wonder what this is


These are two example configuration files, one for pushpool, one for blkmond which is used to notify pushpool of new blocks when longpolling is used

Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 07, 2011, 11:18:30 PM
 #94

I experienced an odd problem with pushpool.

I got it setup, and accepting shares against a bitcoin --testnet client setup correctly with RPC. So, everything appeared to work. I even found a few blocks, and those submitted fine.

However, at a difficulty of 38, and >1000 shares, it had only found 2 blocks.  Huh That's either really bad luck, or something was broken.

So I tried pointing the miners at bitcoind directly, and they found 3 blocks in a few minutes (as expected for the hashrate).

I think you mean it found shares, unless your running a mining farm with a bunch of computers, if you find 3 blocks in a few minutes that should be a problem. but then again a finding a few shares every couple of minutes isn't really a problem either. I run at about 85000Khash/s and i find a share on average 2-3 minutes.
Gotserved
Newbie
*
Offline Offline

Activity: 4


View Profile
June 07, 2011, 11:55:14 PM
 #95

Hi i have some problems with my new mining pool.

OS= Ubuntu 10.04 LTS Terminal.

I got this in the client.
2011-06-08 01:44:43: Listener for "pengar": 08/06/2011 01:44:43, Problems communicating with bitcoin RPC

I got this in the pushpool.
[1307490305.141689] client host 78.73.80.189 port 50768 connected <--- mass spam.

But when i run the bitcoind service like this

./bitcoind -server

nothing happens, is it loaded or what?

my bitcoind.conf

Code:
rpcuser=hello
rpcpassword=hello2

My server.josn
Code:
{
   # network ports
   "listen" : [
      # binary protocol (default), port 8342
      { "port" : 8342 },

      # HTTP JSON-RPC protocol, port 8341
      { "port" : 8347, "protocol" : "http-json" },

      # HTTP JSON-RPC protocol, port 8344,
      #proxy is most likely your external ip address if your running a public pool | Public pools WON'T have the following ip addresses: (10.0.0.1, 127.0.0.$
      # requests to us | "proxy" should be set to your ip address that people will connect through
      { "port" : 8344, "protocol" : "http-json",
        "proxy" : "80.67.11.172" },

      # binary protocol, localhost-only port 8338
      # host is most likely your localhost address
      { "host" : "80.67.11.172", "port" : 8338, "protocol" : "binary" }
   ],

   # database settings
   "database" : {
      "engine" : "mysql",

      "host" : "localhost",

      "port" : 3306,

      #database name
      "name" : "pushpool",
      #database username
      "username" : "pushpool",
      #database password
      "password" : "g321",
      #enable sharelog | to insert share data or sometimes known as "work"
      "sharelog" : true,
      "stmt.pwdb":"SELECT password FROM pool_worker WHERE username = ?",

      "stmt.sharelog":"INSERT INTO shares (rem_host, username, our_result, upstream_result, reason, solution) VALUES (?, ?, ?, ?, ?, ?)"

   },
  #uncoment this when you want to use memcached (Recommended for servers over 1.5gb of ram)
   # cache settings
   #"memcached" : {
   #   "servers" : [
   #      { "host" : "127.0.0.1", "port" : 11211 }
   #   ]
   #},

   "pid" : "/tmp/pushpoold.pid",

   # overrides local hostname detection
   "forcehost" : "localhost.localdomain",

   "log.requests" : "/tmp/request.log",
   "log.shares" : "/tmp/shares.log",

   # the server assumes longpolling (w/ SIGUSR1 called for each blk)
 # the server assumes longpolling (w/ SIGUSR1 called for each blk)
   "longpoll.disable" : false,

   # length of time to cache username/password credentials, in seconds
   "auth.cred_cache.expire" : 75,

   # RPC settings
   #Bitcoind Protocal settings
   #Host were bitcoind can be found on the network
   "rpc.url" : "http://127.0.0.1:8332/",
   #Username & password to connect to bitcoind
   "rpc.user" : "hello",
   "rpc.pass" : "hello2",

   # rewrite returned 'target' to difficulty-1?
   "rpc.target.rewrite" : true
}


Why wont it work for me?
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 08, 2011, 01:43:40 AM
 #96

Hi i have some problems with my new mining pool.

OS= Ubuntu 10.04 LTS Terminal.

I got this in the client.
2011-06-08 01:44:43: Listener for "pengar": 08/06/2011 01:44:43, Problems communicating with bitcoin RPC

I got this in the pushpool.
[1307490305.141689] client host 78.73.80.189 port 50768 connected <--- mass spam.

But when i run the bitcoind service like this

./bitcoind -server

nothing happens, is it loaded or what?

my bitcoind.conf

Code:
rpcuser=hello
rpcpassword=hello2

My server.josn
Code:
{
   # network ports
   "listen" : [
      # binary protocol (default), port 8342
      { "port" : 8342 },

      # HTTP JSON-RPC protocol, port 8341
      { "port" : 8347, "protocol" : "http-json" },

      # HTTP JSON-RPC protocol, port 8344,
      #proxy is most likely your external ip address if your running a public pool | Public pools WON'T have the following ip addresses: (10.0.0.1, 127.0.0.$
      # requests to us | "proxy" should be set to your ip address that people will connect through
      { "port" : 8344, "protocol" : "http-json",
        "proxy" : "80.67.11.172" },

      # binary protocol, localhost-only port 8338
      # host is most likely your localhost address
      { "host" : "80.67.11.172", "port" : 8338, "protocol" : "binary" }
   ],

   # database settings
   "database" : {
      "engine" : "mysql",

      "host" : "localhost",

      "port" : 3306,

      #database name
      "name" : "pushpool",
      #database username
      "username" : "pushpool",
      #database password
      "password" : "g321",
      #enable sharelog | to insert share data or sometimes known as "work"
      "sharelog" : true,
      "stmt.pwdb":"SELECT password FROM pool_worker WHERE username = ?",

      "stmt.sharelog":"INSERT INTO shares (rem_host, username, our_result, upstream_result, reason, solution) VALUES (?, ?, ?, ?, ?, ?)"

   },
  #uncoment this when you want to use memcached (Recommended for servers over 1.5gb of ram)
   # cache settings
   #"memcached" : {
   #   "servers" : [
   #      { "host" : "127.0.0.1", "port" : 11211 }
   #   ]
   #},

   "pid" : "/tmp/pushpoold.pid",

   # overrides local hostname detection
   "forcehost" : "localhost.localdomain",

   "log.requests" : "/tmp/request.log",
   "log.shares" : "/tmp/shares.log",

   # the server assumes longpolling (w/ SIGUSR1 called for each blk)
 # the server assumes longpolling (w/ SIGUSR1 called for each blk)
   "longpoll.disable" : false,

   # length of time to cache username/password credentials, in seconds
   "auth.cred_cache.expire" : 75,

   # RPC settings
   #Bitcoind Protocal settings
   #Host were bitcoind can be found on the network
   "rpc.url" : "http://127.0.0.1:8332/",
   #Username & password to connect to bitcoind
   "rpc.user" : "hello",
   "rpc.pass" : "hello2",

   # rewrite returned 'target' to difficulty-1?
   "rpc.target.rewrite" : true
}


Why wont it work for me?

If your getting alot of connected ports and no connected miners then your most likely connecting on the wrong port. When i use poclbm I specifcly have to use the -p flag and write the port number and not type with the --host flag, other wise it just dosnet connect at all for some reason. Hope this helps!
fpgaminer
Hero Member
*****
Offline Offline

Activity: 546



View Profile WWW
June 08, 2011, 02:29:14 AM
 #97

Quote
I think you mean it found shares, unless your running a mining farm with a bunch of computers, if you find 3 blocks in a few minutes that should be a problem. but then again a finding a few shares every couple of minutes isn't really a problem either. I run at about 85000Khash/s and i find a share on average 2-3 minutes.
Nope, I mean blocks. I threw ~3GH/s at it for a few minutes, and it was running against testnet (Difficulty == 38). Running against pushpool, I got tons of shares but very few blocks (2 blocks with >1000 shares). Running directly against bitcoind it found 3 blocks in a few minutes.

Gotserved
Newbie
*
Offline Offline

Activity: 4


View Profile
June 08, 2011, 08:33:54 AM
 #98


If your getting alot of connected ports and no connected miners then your most likely connecting on the wrong port. When i use poclbm I specifcly have to use the -p flag and write the port number and not type with the --host flag, other wise it just dosnet connect at all for some reason. Hope this helps!

i got connected now.

But i dont get any shares on my client?

And how should my cronjob line looks like in ubuntu?
netsky
Newbie
*
Offline Offline

Activity: 2


View Profile
June 08, 2011, 12:54:10 PM
 #99

Hey! I am running Ubuntu 10.10 and everything is setup correctly, as a client attempts to connect this error is produced
Code:
JSON protocol request:
{"method": "getwork", "params": [], "id":1}

* About to connect() to 127.0.0.1 port 8333 (#0)
*   Trying 127.0.0.1... * TCP_NODELAY set
* connected
* Connected to 127.0.0.1 (127.0.0.1) port 8333 (#0)
* Server auth using Basic with user '---------'
> POST / HTTP/1.1
Authorization: Basic ---------------------
Host: 127.0.0.1:8333
Accept: */*
Accept-Encoding: deflate, gzip
Content-type: application/json
Content-Length: 45

After that, nothing happens. I run pushpoold using follow params: debug2 stderr and E.
FreddyE
Newbie
*
Offline Offline

Activity: 27


View Profile
June 08, 2011, 01:31:14 PM
 #100

I installed pushpool on a fresh ubuntu 11, but for some reason it seems the configuration files are not recognised. I tripple checked that the .conf and .json files are in the right folders, but bitcoind doesnt seem to see the file, it just keeps asking for it. If I set rpcpassword and rpcuser when starting bitcoind it seems to start. If I then try to start pushpool I get a "json parse error".

Any help would be greatly appreciated.
Pages: « 1 2 3 4 [5] 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!