Bitcoin Forum
December 08, 2016, 10:35:10 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 [21] 22 23 »  All
  Print  
Author Topic: [REQUESTS] Minimal Electrum builds for Windows  (Read 44235 times)
flatfly
Hero Member
*****
Offline Offline

Activity: 938


View Profile
February 03, 2013, 05:51:54 PM
 #401

Yeah AHK is often a great answer to this type of little problems Smiley

PS: I'm actually working on a new, purely AHK-based solution for optimized
Windows builds. That would (finally) make my build process fully open source
and deterministic Smiley

1111127SpvabYpoeDoiz5L7QPkfiSh2Q. Only donate if you have a reason to.
1481236510
Hero Member
*
Offline Offline

Posts: 1481236510

View Profile Personal Message (Offline)

Ignore
1481236510
Reply with quote  #2

1481236510
Report to moderator
1481236510
Hero Member
*
Offline Offline

Posts: 1481236510

View Profile Personal Message (Offline)

Ignore
1481236510
Reply with quote  #2

1481236510
Report to moderator
1481236510
Hero Member
*
Offline Offline

Posts: 1481236510

View Profile Personal Message (Offline)

Ignore
1481236510
Reply with quote  #2

1481236510
Report to moderator
"Governments are good at cutting off the heads of a centrally controlled networks like Napster, but pure P2P networks like Gnutella and Tor seem to be holding their own." -- Satoshi
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481236510
Hero Member
*
Offline Offline

Posts: 1481236510

View Profile Personal Message (Offline)

Ignore
1481236510
Reply with quote  #2

1481236510
Report to moderator
1481236510
Hero Member
*
Offline Offline

Posts: 1481236510

View Profile Personal Message (Offline)

Ignore
1481236510
Reply with quote  #2

1481236510
Report to moderator
minorman
Full Member
***
Offline Offline

Activity: 160


View Profile
February 09, 2013, 09:37:51 PM
 #402

Recently started using electrum so I'm a newbie with this client.

Seems very powerful - IF - you use the coomand prompt. On the other hand, the gui offers only limited functionality.

This leads me to my question: How do I activate the command line interface??
I'm running the flatfly build under windows8. The wiki says a lot about what you can do in the command line interface - but nothing about how to run it??

“Banking doesn’t involve fraud, banking IS fraud.”
- Tim Madden
Tachikoma
Hero Member
*****
Offline Offline

Activity: 938



View Profile WWW
February 10, 2013, 08:30:23 AM
 #403

Hold shift when clicking the exe.

Electrum: the convenience of a web wallet, without the risks | Bytesized Seedboxes BTC/LTC supported
minorman
Full Member
***
Offline Offline

Activity: 160


View Profile
February 10, 2013, 08:40:33 PM
 #404

Hold shift when clicking the exe.

Thanks! It worked, but now I've got a second problem:

Shift brings up a python cmd promt, but if I try to run a command - e.g. by typing "electrum -a" it just starts the GUI?

“Banking doesn’t involve fraud, banking IS fraud.”
- Tim Madden
Tachikoma
Hero Member
*****
Offline Offline

Activity: 938



View Profile WWW
February 10, 2013, 08:53:26 PM
 #405

-a is a argument you give the "electrum addresses" command for instance.

Electrum: the convenience of a web wallet, without the risks | Bytesized Seedboxes BTC/LTC supported
minorman
Full Member
***
Offline Offline

Activity: 160


View Profile
February 12, 2013, 09:58:32 PM
 #406

Got it. Everything makes sense now!

“Banking doesn’t involve fraud, banking IS fraud.”
- Tim Madden
flatfly
Hero Member
*****
Offline Offline

Activity: 938


View Profile
March 17, 2013, 09:46:40 PM
 #407

OK, I've managed to rewrite a compact build using open-source autoit (aka ahk) scripting. It's still a work in progress. Also I didn't bother with the console functionality now that this is handled inside Electrum itself.

The good news is that this is a lightweight, transparent and auditable process. Expect new compact builds soon!

; Notes:
; -- requires the latest release of AHK and AHK2EXE, PyQt 4.9.6, Python 2.7 and the 7-zip DLL
; -- first, do a git pull master of the Electrum source code and copy that to %APPDATA%\Electrum_SysFiles


The packer script:

Code:

WhichFolder = 1.7.0.1

FileDelete, %A_scriptdir%\Electrum.arc

runwait, cmd /c del *.pyc /s, %WhichFolder%, hide

runwait, d:\tools\7za.dll a "%A_scriptdir%\Electrum.arc" "%WhichFolder%" -r -sfx, d:\tools

FileCount = 0
Loop, %WhichFolder%\*.*, , 1
   FileCount ++
msgbox %FileCount% items compacted.  



The launcher script:

Code:

process, close, python.exe
sleep 100

Rel = 1.7.0.1
commandline = %1% %2% %3% %4% %5% %6% %7% %8%
ReleaseDir = %appdata%\Electrum_SysFiles\%Rel%
  

if 1 !=
 if 1 not contains -P,-w,bitcoin
  {
  exitapp  
 }

 commandline = -P -w "./electrum.dat"
 ReleaseDir = %a_scriptdir%\Electrum_SysFiles\%Rel%


ifNOTexist, %ReleaseDir%
{

FileCreateDir, %ReleaseDir%

Gui, Add, text,, Please wait while unpacking files to the "Electrum_SysFiles" directory...
Gui, Add, Progress, vlvl  -Smooth 0x8 p0 w350 h12 ; PBS_MARQUEE = 0x8
Gui, Add, text,,  Thanks for using flatfly's optimized builds of Electrum!
Gui, -MinimizeBox
Gui, Show, , Electrum for Windows (flatfly build)
; SetTimer, Push, 61  

sleep 850
 
 FileInstall, Electrum.arc, %ReleaseDir%\Electrum.arc, 1
 runwait, %ReleaseDir%\Electrum.arc -y -o"%ReleaseDir%\.." ,, hide
}
    
Groupadd, bado, Electrum 1
Groupadd, bado, Message

EnvSet, path, %ReleaseDir%\`%System`%;%ReleaseDir%\C_\Python27;%path%
Setworkingdir, %ReleaseDir%\C_\ElectrumPY


HourGlassON()
run "%ReleaseDir%\C_\Python27\python.exe"  "%ReleaseDir%\C_\ElectrumPY\electrum" %commandline% ,,hide useErrorLevel
WinWait ahk_group bado
WinActivate
WinShow
HourGlassOFF()


FileDelete, %ReleaseDir%\Electrum.arc
exitapp


HourGlassON()
{
   CursorHandle := DllCall( "LoadCursor", Uint,0, Int, 32650 )
   DllCall( "SetSystemCursor", Uint,CursorHandle, Int, 32512)
}

HourGlassOFF()
{
   DllCall( "SystemParametersInfo", UInt, 0x57, UInt,0, UInt,0, UInt,0 )
}




1111127SpvabYpoeDoiz5L7QPkfiSh2Q. Only donate if you have a reason to.
Tachikoma
Hero Member
*****
Offline Offline

Activity: 938



View Profile WWW
March 17, 2013, 10:02:19 PM
 #408

Awesome, I have not been able to produce a single .exe build on 1.7 so this is most welcome if you can pull it off Smiley

Electrum: the convenience of a web wallet, without the risks | Bytesized Seedboxes BTC/LTC supported
ScoMo
Jr. Member
*
Offline Offline

Activity: 56


View Profile
March 29, 2013, 11:39:35 PM
 #409

I'm getting an error when running the executable. It says:
"Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item."
How do I fix this?

This signature available for a good price, PM me for offers.
writer • business help • advertising • referral marketing • rapping
Tip me via 16FYsPVoUP4shwfDWjAy2JwBs4pYa25Jpi
flatfly
Hero Member
*****
Offline Offline

Activity: 938


View Profile
March 30, 2013, 09:34:59 AM
 #410

I'm getting an error when running the executable. It says:
"Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item."
How do I fix this?

This is unusual and could be related to the new build process... Could you confirm if you're running it from C drive or somewhere else? Also, are there any spaces in the path you're running it from?

1111127SpvabYpoeDoiz5L7QPkfiSh2Q. Only donate if you have a reason to.
ScoMo
Jr. Member
*
Offline Offline

Activity: 56


View Profile
March 30, 2013, 01:34:21 PM
 #411

I'm getting an error when running the executable. It says:
"Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item."
How do I fix this?

This is unusual and could be related to the new build process... Could you confirm if you're running it from C drive or somewhere else? Also, are there any spaces in the path you're running it from?
I am running it from C drive, in my Downloads folder.

This signature available for a good price, PM me for offers.
writer • business help • advertising • referral marketing • rapping
Tip me via 16FYsPVoUP4shwfDWjAy2JwBs4pYa25Jpi
flatfly
Hero Member
*****
Offline Offline

Activity: 938


View Profile
March 30, 2013, 03:32:07 PM
 #412

Strange... Are you running any HIPS or whitelisting software, by any chance? Or perhaps it's just a corrupted download? The executable should be 6.3MB.  You can also double-check if the SHA1 hash is correct.

1111127SpvabYpoeDoiz5L7QPkfiSh2Q. Only donate if you have a reason to.
ScoMo
Jr. Member
*
Offline Offline

Activity: 56


View Profile
March 31, 2013, 06:45:52 PM
 #413

Strange... Are you running any HIPS or whitelisting software, by any chance? Or perhaps it's just a corrupted download? The executable should be 6.3MB.  You can also double-check if the SHA1 hash is correct.
Not doing anything of the sort.
Executable is indeed 6.3MB.
You're welcome to take a look with Remote Assistance.

This signature available for a good price, PM me for offers.
writer • business help • advertising • referral marketing • rapping
Tip me via 16FYsPVoUP4shwfDWjAy2JwBs4pYa25Jpi
flatfly
Hero Member
*****
Offline Offline

Activity: 938


View Profile
March 31, 2013, 08:47:55 PM
 #414

Strange... Are you running any HIPS or whitelisting software, by any chance? Or perhaps it's just a corrupted download? The executable should be 6.3MB.  You can also double-check if the SHA1 hash is correct.
Not doing anything of the sort.
Executable is indeed 6.3MB.
You're welcome to take a look with Remote Assistance.

Sorry, i won't be able to help right now due to time constraints...
Hopefully someone else can help you out, or you can try the builds from electrum.org.

1111127SpvabYpoeDoiz5L7QPkfiSh2Q. Only donate if you have a reason to.
leopard2
Legendary
*
Offline Offline

Activity: 913


View Profile
April 19, 2013, 08:39:29 PM
 #415

version 172 is not working

flatflys binary stays at "please wait while unpacking..." forever

the standalone from the electrum homepage does not start

the installed 172 destroys my wallet, lucky I got a backup

so 162 is the last working version, wtheck is going on?

f you have found my post helpful, please donate what you feel it is worth: 146eC5dop4j2x8rTmrboeAHm3QntaQ86xz
Math Man
Full Member
***
Offline Offline

Activity: 150


View Profile
April 19, 2013, 11:57:32 PM
 #416

version 172 is not working

flatflys binary stays at "please wait while unpacking..." forever

the standalone from the electrum homepage does not start

the installed 172 destroys my wallet, lucky I got a backup

so 162 is the last working version, wtheck is going on?

1.7.2 works great for me.
flatfly
Hero Member
*****
Offline Offline

Activity: 938


View Profile
November 16, 2013, 07:40:47 PM
 #417

After a long hiatus, I'm planning (probably in the next few days) to release a new build for Electrum version 1.9.4. For anyone not familiar with these builds, they are basically alternative, independent builds of electrum optimized for windows users.

The codebase is the same as the main github repo, only the toolchain and building process is different (documented higher in this thread.)  The result is a much leaner build (around 6.5 MB vs 20MB for the standard build), the "Plastique" PyQT style and a Python debugging console for stderr output.


Note: The current build (1.7.4), released in May, still works fine.

1111127SpvabYpoeDoiz5L7QPkfiSh2Q. Only donate if you have a reason to.
leopard2
Legendary
*
Offline Offline

Activity: 913


View Profile
November 17, 2013, 11:31:09 PM
 #418

Hi Flatfly

these nasty hangs that all versions (flatfly and official) after 1.6.2 and up to 1.8 produced on my Win7 32bit, are gone with 1.9

The official 1.9 version works fine, but the deterministic restoration of my (flatfly build) wallet is not working, several change wallets do not show up. Presumably the official version works with a different lookup gap? There is also no option to configure it, not even when importing a private key. Pretty nasty.

Pretty sure that affects every flatfly user with change wallets, who tries to switch to the official download.

So if you could produce a flatfly build of 1.9 that would be great, a donation is ready.

Cheers
Leo

f you have found my post helpful, please donate what you feel it is worth: 146eC5dop4j2x8rTmrboeAHm3QntaQ86xz
flatfly
Hero Member
*****
Offline Offline

Activity: 938


View Profile
November 18, 2013, 06:25:14 AM
 #419

Hi Flatfly

these nasty hangs that all versions (flatfly and official) after 1.6.2 and up to 1.8 produced on my Win7 32bit, are gone with 1.9

The official 1.9 version works fine, but the deterministic restoration of my (flatfly build) wallet is not working, several change wallets do not show up. Presumably the official version works with a different lookup gap? There is also no option to configure it, not even when importing a private key. Pretty nasty.

Pretty sure that affects every flatfly user with change wallets, who tries to switch to the official download.

So if you could produce a flatfly build of 1.9 that would be great, a donation is ready.

Cheers
Leo

Great, I will be sure to make an updated stable build available some time this week so you can give it a go. You'll be able to change the gap limit from the command line (by the way, my builds never change the default gap limit value, so perhaps this is be a more general issue with the wallet structure update in version 1.9.x.)

1111127SpvabYpoeDoiz5L7QPkfiSh2Q. Only donate if you have a reason to.
flatfly
Hero Member
*****
Offline Offline

Activity: 938


View Profile
November 18, 2013, 08:16:02 PM
 #420

Hi Flatfly

these nasty hangs that all versions (flatfly and official) after 1.6.2 and up to 1.8 produced on my Win7 32bit, are gone with 1.9

The official 1.9 version works fine, but the deterministic restoration of my (flatfly build) wallet is not working, several change wallets do not show up. Presumably the official version works with a different lookup gap? There is also no option to configure it, not even when importing a private key. Pretty nasty.

Pretty sure that affects every flatfly user with change wallets, who tries to switch to the official download.

So if you could produce a flatfly build of 1.9 that would be great, a donation is ready.

Cheers
Leo

Alright, please find my latest build for 1.9.4 here.

After installing, you can try following the below procedure to resolve your issue:

0. Have your wallet seed (12-word passphrase) at hand, you will need it.

1. Make sure Electrum is closed and rename your wallet file from "default_wallet" to something else, such as "default_wallet1". Typically this file will be in "%APPDATA%\Electrum\wallets\"    

2. Shift-click the executable to open the console and enter this command (without the quotes)
   "electrum setconfig gap_limit 20"  

3. Start Electrum. In the initial menu, select the option to restore a wallet from seed.

4. Wait for the restore process to complete, and that should be it.

If this does not restore your missing addresses, retry the above process with a higher gap_limit value.
 

1111127SpvabYpoeDoiz5L7QPkfiSh2Q. Only donate if you have a reason to.
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 [21] 22 23 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!