Bitcoin Forum
December 02, 2016, 08:27:23 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 [137] 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 »
  Print  
Author Topic: [~1000 GH/sec] BTC Guild - 0% Fee Pool, LP, SSL, Full Precision, and More  (Read 358531 times)
bodhipraxis
Jr. Member
*
Offline Offline

Activity: 56


View Profile
August 02, 2011, 07:25:21 AM
 #2721

BTW, another interesting thing is that weird network behavior with the mining server correlates well with freezes of the card (it is a 5830). IE long periods at Zero increase the likelihood that the card will freeze the OS. 

1480710443
Hero Member
*
Offline Offline

Posts: 1480710443

View Profile Personal Message (Offline)

Ignore
1480710443
Reply with quote  #2

1480710443
Report to moderator
1480710443
Hero Member
*
Offline Offline

Posts: 1480710443

View Profile Personal Message (Offline)

Ignore
1480710443
Reply with quote  #2

1480710443
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480710443
Hero Member
*
Offline Offline

Posts: 1480710443

View Profile Personal Message (Offline)

Ignore
1480710443
Reply with quote  #2

1480710443
Report to moderator
1480710443
Hero Member
*
Offline Offline

Posts: 1480710443

View Profile Personal Message (Offline)

Ignore
1480710443
Reply with quote  #2

1480710443
Report to moderator
1480710443
Hero Member
*
Offline Offline

Posts: 1480710443

View Profile Personal Message (Offline)

Ignore
1480710443
Reply with quote  #2

1480710443
Report to moderator
TheMalon
Member
**
Offline Offline

Activity: 70


View Profile
August 02, 2011, 07:56:58 AM
 #2722


so what would you suggest, other than the following (I am using Phoenix 1.50):

${HOMEDIR}/phoenix-1.50/phoenix.py -u http://${MINERUSER}:${MINERPASS}@${$MINERSERV} -q 3 -k phatk VECTORS BFI_INT AGGRESSION=12 WORKSIZE=128 DEVICE=${1}

where $MINERSERV is either uswest or uscentral.

Both miners on Xubuntu boxen, one is catalyst 11.5, the other is 11.6; both use APP SDK 2.4. (that shouldn't affect the behavior that is occurring today with BTCGuild)

It seems that the part you are interested in is the -q (queue) size. You setted it to 3 now ... try to increase it but keep in mind that the pool server will check if the result the miner submitted is actually a result of a work requested by that miner. I think is better to ask the pool owner how many requests the server records per miner. (If the server checks only at the last getwork request the -q configuration is useless).

Quote from: bodhipraxis
BTW, another interesting thing is that weird network behavior with the mining server correlates well with freezes of the card (it is a 5830). IE long periods at Zero increase the likelihood that the card will freeze the OS.

Try to use some software to monitor the health of your card and some software to monitor the http traffic miners do.
Xephan
Jr. Member
*
Offline Offline

Activity: 42


View Profile
August 02, 2011, 08:15:14 AM
 #2723

I just checked my logs as a result of the posts talking about idling/disconnects and realize I am having similar problems. I know that I've gotten slightly below expected returns on BTCG but chalked that up to my donation and the wild luck swings. I guess I don't refresh the stats page enough to see the problem.

Seems like I get  "Problems communicating with bitcoin RPC 0 2" at least 2~3 times an hour. Since I run workers on different pools, it is quite obvious it's not my internet connection acting up, there other pool doesn't have a single communication error in the 12 hours or so of log that I scanned through.

I've switched the BTCG server I'm using and going to see if that makes a difference.


186q9YUW3x8TVHC5aYBEqgZZYMxft8Cw9f
sharky112065
Sr. Member
****
Offline Offline

Activity: 383



View Profile
August 02, 2011, 09:01:08 AM
 #2724

I'm glad to see more people bring up the idles. I posted on this a few days ago and was basically told it was on my end despite using the exact same mining software/arguments on another pool and not getting the idles on the other pool.

Maybe now that it is getting more attention something will be done about it, or at least an investigation as to why it is happening.

What I noticed was that the idle messages came immediately after a Long Poll message.

Maybe it is a Guiminer ==> Phoenix ==> Phatk issue with BTC Guild only? I don't seem to see anyone using Poclbm having this issue on BTC Guild.

(Edit: Hmm. Looks like it is not Guiminer. I saw a post above that looks like it was run from cmd line. So maybe a Phoenix Phatk issue with BTC Guild)

I'm really bummed about it because I want to use BTC Guild. The pool op said the problem was on my end and suggested I mine elsewhere. I was even donating 2.5%.  Sad

Donations welcome: 12KaKtrK52iQjPdtsJq7fJ7smC32tXWbWr
Clipse
Hero Member
*****
Offline Offline

Activity: 504


View Profile
August 02, 2011, 12:01:34 PM
 #2725

I'm glad to see more people bring up the idles. I posted on this a few days ago and was basically told it was on my end despite using the exact same mining software/arguments on another pool and not getting the idles on the other pool.

Maybe now that it is getting more attention something will be done about it, or at least an investigation as to why it is happening.

What I noticed was that the idle messages came immediately after a Long Poll message.

Maybe it is a Guiminer ==> Phoenix ==> Phatk issue with BTC Guild only? I don't seem to see anyone using Poclbm having this issue on BTC Guild.

(Edit: Hmm. Looks like it is not Guiminer. I saw a post above that looks like it was run from cmd line. So maybe a Phoenix Phatk issue with BTC Guild)

I'm really bummed about it because I want to use BTC Guild. The pool op said the problem was on my end and suggested I mine elsewhere. I was even donating 2.5%.  Sad

Sharky Im not sure what the issue is but maybe Eleuthria can figure it out. I must note eleuthria mean you should go mine at another pool, he meant you should try a different server on btcguild to see if it sorts out the idle issues.

...In the land of the stale, the man with one share is king... >> Clipse

We pay miners at 130% PPS | Signup here : Bonus PPS Pool (Please read OP to understand the current process)
sharky112065
Sr. Member
****
Offline Offline

Activity: 383



View Profile
August 02, 2011, 01:07:10 PM
 #2726

I'm glad to see more people bring up the idles. I posted on this a few days ago and was basically told it was on my end despite using the exact same mining software/arguments on another pool and not getting the idles on the other pool.

Maybe now that it is getting more attention something will be done about it, or at least an investigation as to why it is happening.

What I noticed was that the idle messages came immediately after a Long Poll message.

Maybe it is a Guiminer ==> Phoenix ==> Phatk issue with BTC Guild only? I don't seem to see anyone using Poclbm having this issue on BTC Guild.

(Edit: Hmm. Looks like it is not Guiminer. I saw a post above that looks like it was run from cmd line. So maybe a Phoenix Phatk issue with BTC Guild)

I'm really bummed about it because I want to use BTC Guild. The pool op said the problem was on my end and suggested I mine elsewhere. I was even donating 2.5%.  Sad

Sharky Im not sure what the issue is but maybe Eleuthria can figure it out. I must note eleuthria mean you should go mine at another pool, he meant you should try a different server on btcguild to see if it sorts out the idle issues.

No. It was quite clear what he said. He said, "all I can say is go elsewhere". I had stated that all BTC Guild servers were tried in my earlier posts.

Anyway, I tried the new 2.1 Phatk kernel tonight (via Phoenix) and still get the idles.

05:56:22 on miner BC2-0 LP: New work pushed.
05:56:22 on miner BC2-1 LP: New work pushed.
05:56:22 on miner BC2-2 LP: New work pushed.
05:56:22 on miner BC2-3 LP: New work pushed.
05:56:32 on miner BC2-0 LP: Warning: Work queue empty, miner is idle.
05:56:32 on miner BC2-1 LP: Warning: Work queue empty, miner is idle.

BC2-2 and BC 2-3 did not show a miner idle message.

I get the warnings 10 seconds after the LP.

Hopefully this will help someone figure it out.

Switched back over to Deepbit and no more errors. FML

Here is an exact quote of his post (Eleuthria - 2 pages back):

sharky:  All I can say is it's nothing I can do to fix it.  When idles do pop up, its because pushpool/bitcoind are generating a ton of work after an LP.  Normally an idle only shows up when two blocks are found rapidly on the network, and two long polls go out less than a minute apart.  Even in those cases, they normally don't show up.  Like I said, I have 4 miners split 2 per server, and have not had one idle today.

If you're getting them regularly, all I can say is go elsewhere.  I can't fix a problem that seems to be only be affecting you.  If the problem was with our servers at least 1/8th the users would be experiencing it, since the pools are roughly split up to be 1/8th the total load per internal server.



Donations welcome: 12KaKtrK52iQjPdtsJq7fJ7smC32tXWbWr
Clipse
Hero Member
*****
Offline Offline

Activity: 504


View Profile
August 02, 2011, 03:04:45 PM
 #2727

You do know everyone get idleminers ?

I get them on every single pool, Im not sure how often you get them but I also get them due to longpolls ~3times an hour, no matter which pool I mine at.

If you get these miner idles for every single longpoll which would be about every 8mins, there is probably something else going on.

...In the land of the stale, the man with one share is king... >> Clipse

We pay miners at 130% PPS | Signup here : Bonus PPS Pool (Please read OP to understand the current process)
Acejam
Sr. Member
****
Offline Offline

Activity: 283


View Profile
August 02, 2011, 03:15:21 PM
 #2728

I'm constantly getting idle's and "problem communicating with bitcoin RPC" errors. My network and computer setup is perfect, I know this for a fact. Also, when I switch to DeepBit I never have these issues.

Sorry BTC Guild, but it looks like we're parting ways for now. I'd rather pay 3% and not have to worry about if my miners are actually active or not. (or if your servers are actually up)
Xephan
Jr. Member
*
Offline Offline

Activity: 42


View Profile
August 02, 2011, 04:03:52 PM
 #2729

In the eight hours or so since my previous post on this, I've gotten about 14 comms problem errors with BTCG, doesn't seem related to LP since only in one instance did any LP msg occur within 30 sec of the problem.

Code:
Snipped out other unrelated messages as long as they didn't occur within 30 sec of comms problem
 02/08/2011 16:37:38 , Problems communicating with bitcoin RPC 0 2
 02/08/2011 16:37:51 , Problems communicating with bitcoin RPC 1 2
 02/08/2011 17:54:36 , Problems communicating with bitcoin RPC 0 2
 02/08/2011 18:22:46 , Problems communicating with bitcoin RPC 0 2
 02/08/2011 19:47:23 , Problems communicating with bitcoin RPC 0 2
 02/08/2011 20:24:20 , Problems communicating with bitcoin RPC 0 2
 02/08/2011 20:55:55 , Problems communicating with bitcoin RPC 0 2
 02/08/2011 20:57:25 , Problems communicating with bitcoin RPC 0 2
 02/08/2011 21:43:54 , Problems communicating with bitcoin RPC 0 2
 02/08/2011 21:44:00 , Problems communicating with bitcoin RPC 1 2
 02/08/2011 21:44:00 , long poll: new block 0000050d929d26a1
 02/08/2011 21:44:16 , Problems communicating with bitcoin RPC 2 2
 02/08/2011 22:43:34 , Problems communicating with bitcoin RPC 0 2
 02/08/2011 22:59:21 , Problems communicating with bitcoin RPC 0 2
 02/08/2011 23:18:25 , Problems communicating with bitcoin RPC 0 2


In comparison, during the same time frame, on my other pool, running the same settings except the backup and card of course.

Code:
02/08/2011 18:00: 03, warning: job finished, miner is idle
02/08/2011 18:00: 04, Problems communicating with bitcoin RPC 0 2
Occurred at the same time so it's probably related. Didn't happen near the BTCG error times so it eliminates potential Internet problems on my side.

p.s. using guiminer & poclbm

p.p.s. I suppose I should be glad I'm not getting idle warnings, but I'm wondering if that would lead to rejected shares or stales.

186q9YUW3x8TVHC5aYBEqgZZYMxft8Cw9f
eleuthria
Legendary
*
Offline Offline

Activity: 1750


BTC Guild Owner


View Profile WWW
August 02, 2011, 04:28:33 PM
 #2730

Problems communicating with bitcoin RPC 0 2 isn't going to cause you much harm unless it ends up happening just before a long poll causing a stale.  It simply means poclbm tried to talk to the server and it didn't get a proper response, and tries again shortly after.  poclbm grabs work in advance, so you're still hashing away until the idle shows up (meaning it couldn't get new work in advance and eventually ran out).


I just re-routed a couple new botnets that showed up on both US Central and US East which were adding about 15,000 long poll connections worth of overhead/stress per server, so the comm errors should start to go away.  I'm also getting ready to re-implement my inefficient miner auto-ban for miners that are requesting tons of work but sending back only a tiny amount of shares.

R.I.P. BTC Guild, 2011 - 2015.
BTC Guild Forum Thread
bodhipraxis
Jr. Member
*
Offline Offline

Activity: 56


View Profile
August 02, 2011, 05:23:18 PM
 #2731

thank you for the update, Eleutheria.

and to the rest: we sit here and argue and then the pool op says, yep, there were botnets and i am fixing it.

for those of you who are so quick to judge ~ remember that there may be problems that manifest faster for some people because of differential network effects from different routing architectures between BTCGuild servers and wherever we happen to be.


dime
Member
**
Offline Offline

Activity: 86


View Profile
August 02, 2011, 06:38:54 PM
 #2732

It happens on and off.. My internet connection is rock steady as I stay connected to my company vpn 24/7 and I basically never get d/c from slush's pool when I mine there.

Any troubleshooting ideas?

All I can suggest is switching servers from Central/West to the other, and/or upgrading your miner.

This has been solved. Apparently, the answer was not to upgrade but to downgrade my miner. I was on either phoenix revision 111 or 112.

Quote
The rewrite for the RPC protocol is finished, and has been uploaded to the SVN.

It works fine in my testing, but more feedback would be great before pushing this as a new version. This SHOULD definitively fix the idle problem, since that was related to the old RPCProtocol.

i tested it and it resulted in constant disconnects from btcguild (all servers). I reverted back to r110 and the problem disappeared.

I reverted to 110 as well and so far have not seen disconnects for an hour.
jme621
Sr. Member
****
Offline Offline

Activity: 308



View Profile
August 02, 2011, 07:25:50 PM
 #2733

look what i did overnight lol

   Blocks Found       1

GO POOL!

jjiimm_64
Legendary
*
Offline Offline

Activity: 1680


View Profile
August 03, 2011, 12:48:27 AM
 #2734

look what i did overnight lol

   Blocks Found       1

GO POOL!

nice --  3337687  shares and still no block Smiley

1jimbitm6hAKTjKX4qurCNQubbnk2YsFw
jjiimm_64
Legendary
*
Offline Offline

Activity: 1680


View Profile
August 04, 2011, 05:19:22 PM
 #2735

isn't time to sacrifice a goat or something...

1jimbitm6hAKTjKX4qurCNQubbnk2YsFw
hugolp
Hero Member
*****
Offline Offline

Activity: 742



View Profile
August 04, 2011, 05:26:28 PM
 #2736

isn't time to sacrifice a goat or something...

We need a virgin.

Im sure we can find one in this forums...
JinTu
Full Member
***
Offline Offline

Activity: 132


Hopping down the bunny trail


View Profile
August 04, 2011, 08:28:29 PM
 #2737

eleuthria, any possibility we could get 24 Hour Luck added to the JSON API? This would be helpful to reference WRT the 24 hour rewards already available in the API over the same time period.

Please donate if this was helpful: 14CLqCNphUJ54ro2PtqQWJDmW3Eic1WmUd
Cacti templates for pool, GPU and CGMINER monitoring.
GPU monitoring with SNMP
jjiimm_64
Legendary
*
Offline Offline

Activity: 1680


View Profile
August 04, 2011, 09:39:54 PM
 #2738

at down 45%.  it borders on non-profitable!

1jimbitm6hAKTjKX4qurCNQubbnk2YsFw
mike85123
Full Member
***
Offline Offline

Activity: 196


View Profile
August 05, 2011, 01:36:59 AM
 #2739

Feel like lady luck kicked us in the balls today...
hiVe
Member
**
Offline Offline

Activity: 102


View Profile
August 05, 2011, 05:38:07 AM
 #2740

Feel like lady luck kicked us in the balls today...

Lady luck is kicking us in the balls far too often lately, I remember 1 day, yes "one", we had a positive luck in the last 2 weeks.
Pages: « 1 ... 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 [137] 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!