Bitcoin Forum
December 09, 2016, 06:16:53 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 [25] 26 27 28 29 30 31 »
  Print  
Author Topic: ATTN Litecoin GPU Miners - Scrypt support for cgminer  (Read 169319 times)
nitrox
Full Member
***
Offline Offline

Activity: 136


tester


View Profile
July 28, 2012, 07:26:06 PM
 #481

Your aggression seems like it's too high try this in cgminer or reaper
     worksize 64
     aggression 13
     threads_per_gpu 4 (or 2 or 1)
     sharethreads 18
     lookup_gap 2
     gpu_thread_concurrency 8192
105~130kH/s - going low

...... already thinking to drop mining LTC ......

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481264213
Hero Member
*
Offline Offline

Posts: 1481264213

View Profile Personal Message (Offline)

Ignore
1481264213
Reply with quote  #2

1481264213
Report to moderator
tacotime
Legendary
*
Offline Offline

Activity: 1484



View Profile
July 28, 2012, 07:32:47 PM
 #482


i try use reaper v13 beta 4 x64 with that settings :
worksize 64
aggression 20
threads_per_gpu 1
lookup_gap 5
gpu_thread_concurrency 8192

its work , but only 240~220 kH/s for HD7950OC i think is too little.
my old HD6950 reached ~360 kH/s

but i stil lito to use cgminer
i try same worksize , thread_concurrency and lookup_gap but again fail.

Use cgminer and these settings

--scrypt -I 19 --shaders 1792 --thread-concurrency 8960 -g 1

Should get 500+ kh/s

also try --thread-concurrency of 17920, may be a little faster

for the 7xxx series you must always use -g 1 to achieve high intensities

Code:
XMR: 44GBHzv6ZyQdJkjqZje6KLZ3xSyN1hBSFAnLP6EAqJtCRVzMzZmeXTC2AHKDS9aEDTRKmo6a6o9r9j86pYfhCWDkKjbtcns
nitrox
Full Member
***
Offline Offline

Activity: 136


tester


View Profile
July 28, 2012, 07:44:44 PM
 #483

Use cgminer and these settings
--scrypt -I 19 --shaders 1792 --thread-concurrency 8960 -g 1
Should get 500+ kh/s
also try --thread-concurrency of 17920, may be a little faster
for the 7xxx series you must always use -g 1 to achieve high intensities

----------------------------------------------------------------------------------------
 [2012-07-28 22:42:05] Started cgminer 2.5.0
 [2012-07-28 22:42:06] Probing for an alive pool
 [2012-07-28 22:42:06] Long-polling activated for http://ltc.xurious.com:9332/LP
 [2012-07-28 22:42:28] Maximum buffer memory device 0 supports says 536870912, your scrypt settings come to 0
 [2012-07-28 22:42:28] Error -61: clCreateBuffer (padbuffer8), decrease CT or increase LG
 [2012-07-28 22:42:28] Failed to init GPU thread 0, disabling device 0
 [2012-07-28 22:42:28] Restarting the GPU from the menu will not fix this.
 [2012-07-28 22:42:28] Try restarting cgminer.
Press enter to continue:
----------------------------------------------------------------------------------------
same for --thread-concurrency 8960 and 17920  Sad

tacotime
Legendary
*
Offline Offline

Activity: 1484



View Profile
July 28, 2012, 07:50:28 PM
 #484

Use cgminer and these settings
--scrypt -I 19 --shaders 1792 --thread-concurrency 8960 -g 1
Should get 500+ kh/s
also try --thread-concurrency of 17920, may be a little faster
for the 7xxx series you must always use -g 1 to achieve high intensities

----------------------------------------------------------------------------------------
[2012-07-28 22:42:05] Started cgminer 2.5.0
 [2012-07-28 22:42:06] Probing for an alive pool
 [2012-07-28 22:42:06] Long-polling activated for http://ltc.xurious.com:9332/LP
 [2012-07-28 22:42:28] Maximum buffer memory device 0 supports says 536870912, your scrypt settings come to 0
 [2012-07-28 22:42:28] Error -61: clCreateBuffer (padbuffer8), decrease CT or increase LG
 [2012-07-28 22:42:28] Failed to init GPU thread 0, disabling device 0
 [2012-07-28 22:42:28] Restarting the GPU from the menu will not fix this.
 [2012-07-28 22:42:28] Try restarting cgminer.
Press enter to continue:
----------------------------------------------------------------------------------------
same for --thread-concurrency 8960 and 17920  Sad

Hum, that's strange, that's 5x the number of SPUs which should work.  You can try the 7970 setting of --thread-concurrency 10240, I don't know why that wouldn't work.

That is the normal error for incorrect buffer sizes though.  I wonder why it doesn't work?

Also --lookup-gap should always be 2, but that's the default

Code:
XMR: 44GBHzv6ZyQdJkjqZje6KLZ3xSyN1hBSFAnLP6EAqJtCRVzMzZmeXTC2AHKDS9aEDTRKmo6a6o9r9j86pYfhCWDkKjbtcns
nitrox
Full Member
***
Offline Offline

Activity: 136


tester


View Profile
July 28, 2012, 07:53:59 PM
 #485

same whit --thread-concurrency 10240 .... Sad

tacotime
Legendary
*
Offline Offline

Activity: 1484



View Profile
July 28, 2012, 07:55:50 PM
 #486

same whit --thread-concurrency 10240 .... Sad

try --shaders 2048 and --thread-concurrency 10240

I'm starting to think something is wrong with your cgminer build though, these should not give 0 memory values

Code:
XMR: 44GBHzv6ZyQdJkjqZje6KLZ3xSyN1hBSFAnLP6EAqJtCRVzMzZmeXTC2AHKDS9aEDTRKmo6a6o9r9j86pYfhCWDkKjbtcns
nitrox
Full Member
***
Offline Offline

Activity: 136


tester


View Profile
July 28, 2012, 07:58:59 PM
 #487

try --shaders 2048 and --thread-concurrency 10240
I'm starting to think something is wrong with your cgminer build though, these should not give 0 memory values

--------------------------------------------------------------------------------
 [2012-07-28 22:57:09] Started cgminer 2.5.0
 [2012-07-28 22:57:09] Probing for an alive pool
 [2012-07-28 22:57:10] Long-polling activated for http://ltc.xurious.com:9332/LP
 [2012-07-28 22:57:23] LONGPOLL from pool 0 detected new block
 [2012-07-28 22:57:33] Pool 0 http://ltc.xurious.com:9332 alive
 [2012-07-28 22:57:33] Error -5: Enqueueing kernel onto command queue. (clEnqueueNDRangeKernel)
 [2012-07-28 22:57:33] GPU 0 failure, disabling!
 [2012-07-28 22:57:33] Thread 0 being disabled
--------------------------------------------------------------------------------

dishwara
Legendary
*
Offline Offline

Activity: 1372

Truth may get delay, but NEVER fails


View Profile
July 28, 2012, 07:59:22 PM
 #488

Ok I found my issue, cgminer.conf was conflicting and it overrides the command line settings! So check your config file and make sure things like work size and intensity etc match what youre attempting on the command line. Currently cranking along at 203kh/s on my 5770 w/intensity 18, working on tuning the 6970 still it overheats way to easy and forces the machine to reboot.

I don't see cgminer.conf in the unziped files on windows.
Can point me where i can see cgminer.conf.
Thanks.
tacotime
Legendary
*
Offline Offline

Activity: 1484



View Profile
July 28, 2012, 08:02:31 PM
 #489

try --shaders 2048 and --thread-concurrency 10240
I'm starting to think something is wrong with your cgminer build though, these should not give 0 memory values

--------------------------------------------------------------------------------
 [2012-07-28 22:57:09] Started cgminer 2.5.0
 [2012-07-28 22:57:09] Probing for an alive pool
 [2012-07-28 22:57:10] Long-polling activated for http://ltc.xurious.com:9332/LP
 [2012-07-28 22:57:23] LONGPOLL from pool 0 detected new block
 [2012-07-28 22:57:33] Pool 0 http://ltc.xurious.com:9332 alive
 [2012-07-28 22:57:33] Error -5: Enqueueing kernel onto command queue. (clEnqueueNDRangeKernel)
 [2012-07-28 22:57:33] GPU 0 failure, disabling!
 [2012-07-28 22:57:33] Thread 0 being disabled
--------------------------------------------------------------------------------

Yeah, that's what I expected...  with reaper and --thread-concurrency of 7168, 8960, or 16000 and number of threads 1 (intensity 19) or 4/5 (intensity 13) should give you at least 400kh/s with a lookup gap of 2 and a worksize of 128 or 256

Code:
XMR: 44GBHzv6ZyQdJkjqZje6KLZ3xSyN1hBSFAnLP6EAqJtCRVzMzZmeXTC2AHKDS9aEDTRKmo6a6o9r9j86pYfhCWDkKjbtcns
nitrox
Full Member
***
Offline Offline

Activity: 136


tester


View Profile
July 28, 2012, 08:04:25 PM
 #490

I'm starting to think something is wrong with your cgminer build though, these should not give 0 memory values

i use windows build "ckolivas-cgminer-43752ee" i think is newest at the moment

nitrox
Full Member
***
Offline Offline

Activity: 136


tester


View Profile
July 28, 2012, 08:12:58 PM
 #491

Yeah, that's what I expected...  with reaper and --thread-concurrency of 7168, 8960, or 16000 and number of threads 1 (intensity 19) or 4/5 (intensity 13) should give you at least 400kh/s with a lookup gap of 2 and a worksize of 128 or 256

reaper chrash, chrash, chrash, chrash, chrash, chrash ......

whit :
---------------------------------
worksize 256
aggression 19
threads_per_gpu 1
lookup_gap 5
gpu_thread_concurrency 7168
---------------------------------
run normal but < 250kH/s

tacotime
Legendary
*
Offline Offline

Activity: 1484



View Profile
July 28, 2012, 08:14:50 PM
 #492

Yeah, that's what I expected...  with reaper and --thread-concurrency of 7168, 8960, or 16000 and number of threads 1 (intensity 19) or 4/5 (intensity 13) should give you at least 400kh/s with a lookup gap of 2 and a worksize of 128 or 256

reaper chrash, chrash, chrash, chrash, chrash, chrash ......

whit :
---------------------------------
worksize 256
aggression 19
threads_per_gpu 1
lookup_gap 5
gpu_thread_concurrency 7168
---------------------------------
run normal but < 250kH/s

something is very wrong, lookup_gap 2 should work fine.  might want to try uninstalling 12.6 drivers and reinstalling them, and also uninstalling app sdk 2.6 and installing 2.7.  other than that i do not know, something is broken.

Code:
XMR: 44GBHzv6ZyQdJkjqZje6KLZ3xSyN1hBSFAnLP6EAqJtCRVzMzZmeXTC2AHKDS9aEDTRKmo6a6o9r9j86pYfhCWDkKjbtcns
nitrox
Full Member
***
Offline Offline

Activity: 136


tester


View Profile
July 28, 2012, 09:00:45 PM
 #493

something is very wrong, lookup_gap 2 should work fine.  might want to try uninstalling 12.6 drivers and reinstalling them, and also uninstalling app sdk 2.6 and installing 2.7.  other than that i do not know, something is broken.
exactly the same result crash, crash, crash, crash, crash, crash, crash ...

but BTC digging well ~ 530MH/s

rahlquist
Jr. Member
*
Offline Offline

Activity: 46


View Profile
July 28, 2012, 09:45:41 PM
 #494

Ok I found my issue, cgminer.conf was conflicting and it overrides the command line settings! So check your config file and make sure things like work size and intensity etc match what youre attempting on the command line. Currently cranking along at 203kh/s on my 5770 w/intensity 18, working on tuning the 6970 still it overheats way to easy and forces the machine to reboot.

I don't see cgminer.conf in the unziped files on windows.
Can point me where i can see cgminer.conf.
Thanks.

If you have one it will be in the same directory as the cgminer.exe most likely. If you dont have one then this isnt whats holding you back.
rahlquist
Jr. Member
*
Offline Offline

Activity: 46


View Profile
July 28, 2012, 09:46:44 PM
 #495

something is very wrong, lookup_gap 2 should work fine.  might want to try uninstalling 12.6 drivers and reinstalling them, and also uninstalling app sdk 2.6 and installing 2.7.  other than that i do not know, something is broken.
exactly the same result crash, crash, crash, crash, crash, crash, crash ...

but BTC digging well ~ 530MH/s
Ok its a stupid question but I havent seen it asked. You are shutting down BTC when testing for LTC right?
nitrox
Full Member
***
Offline Offline

Activity: 136


tester


View Profile
July 28, 2012, 09:52:46 PM
 #496

Ok its a stupid question but I havent seen it asked. You are shutting down BTC when testing for LTC right?
of course, also restart PC when i change digging currency.

nitrox
Full Member
***
Offline Offline

Activity: 136


tester


View Profile
July 29, 2012, 08:52:06 AM
 #497

Come on guys, if not you no one can't help, give ideas    Embarrassed

-ck
Staff
Legendary
*
Offline Offline

Activity: 2002


Ruu \o/


View Profile WWW
July 29, 2012, 09:03:36 AM
 #498

Come on guys, if not you no one can't help, give ideas    Embarrassed
Start it with just your login details and: --shaders 1792 -T -D --verbose -g 1
and see what it reports.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
nitrox
Full Member
***
Offline Offline

Activity: 136


tester


View Profile
July 29, 2012, 09:21:21 AM
 #499

Come on guys, if not you no one can't help, give ideas    Embarrassed
Start it with just your login details and: --shaders 1792 -T -D --verbose -g 1
and see what it reports.

here is log file:
http://www.uploadmb.com/dw.php?id=1343553631

-ck
Staff
Legendary
*
Offline Offline

Activity: 2002


Ruu \o/


View Profile WWW
July 29, 2012, 09:27:59 AM
 #500

Come on guys, if not you no one can't help, give ideas    Embarrassed
Start it with just your login details and: --shaders 1792 -T -D --verbose -g 1
and see what it reports.

here is log file:
http://www.uploadmb.com/dw.php?id=1343553631
Everything looks in order there, but it's still failing. How much system ram do you have? Try forcing smaller multiples of 1792 for thread concurrency. Eg --thread-concurrency 1792 , then 3584, then 5376.

Primary developer/maintainer for cgminer and ckpool/ckproxy.
Pooled mine at kano.is, solo mine at solo.ckpool.org
-ck
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 [25] 26 27 28 29 30 31 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!