Bitcoin Forum
June 25, 2019, 06:44:57 AM *
News: Latest Bitcoin Core release: 0.18.0 [Torrent] (New!)
 
  Home Help Search Login Register More  
  Show Posts
Pages: « 1 2 3 4 5 6 7 8 9 10 11 [12] 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 »
221  Bitcoin / Hardware / Re: Official Avalon Technical Support Thread on: May 30, 2013, 01:12:39 PM
Batch #2 do not have a P2 jumper on the fpga controller board.
I have Batch #2 units, and my controller boards do still have a P5 jumper.  It's located just behind the USB type B receptacle.  As shown in this picture.

Ah!.. I seem to remember you had a "silver" case avalon.  I guessing you got the last of the <v1.5 batch#1 leftover parts.
222  Bitcoin / Hardware / Re: Official Avalon Technical Support Thread on: May 29, 2013, 03:12:55 PM
One of my Batch #2 Avalons is having trouble.  Every so often (~15 minutes on average) I get a long burst of these kinds of messages in the System Log (dmesg):

Code:
May 18 06:42:59 avalon1 kern.err kernel: [ 3872.320000] usb 1-1: clear tt 1 (8040) error -71
May 18 06:42:59 avalon1 kern.err kernel: [ 3872.330000] ftdi_sio ttyUSB1: failed to get modem status: -71
May 18 06:42:59 avalon1 kern.err kernel: [ 3872.340000] usb 1-1: clear tt 1 (8040) error -71
May 18 06:42:59 avalon1 kern.err kernel: [ 3872.350000] ftdi_sio ttyUSB1: failed to get modem status: -71
May 18 06:42:59 avalon1 kern.err kernel: [ 3872.350000] usb 1-1: clear tt 1 (8040) error -71
May 18 06:42:59 avalon1 kern.err kernel: [ 3872.460000] ftdi_sio ttyUSB1: failed to get modem status: -32

While that is occuring, all mining stops.  Either it eventually goes back to normal, or I see a message in the System Log saying that ttyUSB1 was disconnected, and then reconnected as ttyUSB0 (and vica-versa).  cgminer dies if that happens, and restarts.

I have another Batch #2 running smoothly.  So far, I have checked all of the connectors on the TP-LINK, PDU, and control unit.  I replaced the PSU, left the cover off, and left the PSU outside of the unit.  No joy.  All of the version numbers match my other Batch #2, so there are no differences in software/firmware.  One odd thing is that I notice mention of a usb hub on the wiki page, but there is no hub inside either of my black Avalons.  Is the hub built into the control unit?

I can only think of two other things to try.  Backup the working Avalon, and flash it to this Avalon, in case there's something weird in the software.  Or, replace the TP-LINK with a RasPi and hope that the control unit isn't at fault.
Check the usb Cable first dude.

If i were you i would remove p5 jumper, use USB powered hub and connect usb cable to batch one unit easiest or to linux PC to check. But first change usb cables and try other ports of internal usb hub if batch2 still has it



Batch #2 do not have a P2 jumper on the fpga controller board.  They also do not have an external USB hub. It appears the v1.5 fpga controller boards in the batch #2 avalons have a renesas usb hub chip included to attempt to account for the usb stability problem with the tp703 See: https://forum.openwrt.org/viewtopic.php?id=39956

If anyone from Avalon reads this thread, could you please provide info on whether something can be changed on the fpga board so that it won't backfeed power on the usb port?  It's been mentioned that attempting to connect the fpga board usb port to a desktop could cause problems since the fpga usb port is still powered.

What do J1 and J2 do?

Is it possible to JTAG firmware/bitstream to the fpga? Instructions?

TIA
223  Economy / Trading Discussion / Re: bitcoinity.org/markets - live bitcoin price charts on: May 29, 2013, 12:50:26 PM
Its a really nice site. Good job, my only suggestion is to add a chatbox for users.

My only suggestion is no chatbox please.

If you want chat, use irc.
224  Economy / Trading Discussion / Re: bitcoinity.org/markets - live bitcoin price charts on: May 28, 2013, 02:26:21 PM
There is some bug in the order book chart: http://bitcoinity.org/markets/btce/USD

If I click the minus sign, the vertical scale goes from 0-100 to 0-15, when it should go to a larger scale. See images, before:

....


+ = Zoom In
- = Zoom Out

Seems to work ok for me.
225  Bitcoin / Project Development / Re: BAMT version 0.5 - Easy USB based mining Linux with farm wide management tools on: May 27, 2013, 05:02:00 PM
Except as I said a couple times, rebooting doesn't fix it.  CGMiner does not work after reboot, no matter the settings.   The only solution I've found is formatting and doing a new installation.

I am mining LTC but I am not running the cards hard at all.  After I preform a fresh install and put my settings in, the system will run for days at a time with 0 HW errors at less than 70C.  The problem arises if I make the slightest change to the system or if CGminer disconnects from the server for some reason.  Basically anything that causes CGMiner to stop functioning.  CGMiner will then hang at "starting" indefinitely.  And as I've said, rebooting the system does not fix this.

Your settings cause the cards to crash.  A reboot will not "fix" this.  You need to edit the cgminer config back to a known state before rebooting. A "sync" after editing the file wouldn't hurt either.
226  Bitcoin / Project Development / Re: BAMT version 0.5 - Easy USB based mining Linux with farm wide management tools on: May 27, 2013, 01:24:28 PM
3.1.0.  Changes like thead-concurrency, gpu-voltage, gpu core/memory speed, powertune.. basically anything.  I'm not even pushing the cards that hard but the pattern is it will run for a bit, then cgminer will crash.  After that I will be unable to start cgminer again no matter what parameters.  And as I said about, the only thing that fixes this is formatting and starting over.  Also the webui stops working with the error " One of the BAMT tools has suffered a fatal error. Can't use an undefined value as a HASH reference at /usr/lib/cgi-bin/status.pl line 88. "

sounds like you are mining ltc.  sounds like the settings you are using are crashing the cards hard and only a reboot will fix things.
227  Bitcoin / Project Development / Re: BAMT version 0.5 - Easy USB based mining Linux with farm wide management tools on: May 27, 2013, 03:20:48 AM
I have a problem in my BAMT system where I can get it running stable for long periods of time, but then if I make the slightest change to cgminer.conf and restart the miner the system will no longer function.  That is, cgminer will just hang at "Starting Cgminer..".  Restarting/shutdowning/reverting changes has no effect on this, the only solution I've found is to start a fresh installation.  But then the problem just repeats itself.  Has anyone experienced this?

what changes to cgminer are we talking about?

also, what version of cgminer?
228  Bitcoin / Project Development / Re: BAMT version 0.5 - Easy USB based mining Linux with farm wide management tools on: May 26, 2013, 10:46:46 PM
I was told if you did not have something plugged into the GPU's VGA port the OS would idle it, so people put things like dummy plugs in the ports?

none of my BAMT rigs have anything plugged into GPU video ports
229  Bitcoin / Project Development / Re: BAMT version 0.5 - Easy USB based mining Linux with farm wide management tools on: May 26, 2013, 03:22:41 PM
....is the anything I need to do to stop the GPU from idling, or does not idle automatically

Come again?
230  Bitcoin / Hardware / Re: Avalon batch 2 delivered, dead PSU, beware of GS800 2013 edition on: May 25, 2013, 05:38:33 PM
Hi

This is an AP9331(the cpu of 703n) bug. I have document it here:(Why there is a USB-HUB inside )
  https://en.bitcoin.it/wiki/Avalon#FAQ
  more info here: https://forum.openwrt.org/viewtopic.php?id=39956

But it not happen on all 703n. if the Avalon have this issue.(this should be test before Avalon ship out) people can try those:
  1. Try different 703n. you can easy to buy them. and it's very cheap.
  2. Add another usb-hub inside. <-- ONLY For Fpga controller 1.5
  3. Replace 703n with other device. like RaspberryPi. cheap PC. then you have to handle the cgminer/monitor etc.
  4. Replace your fpga controller also MAY fix that.

Cherish your life, stay away from mining.
Xiangfu


xiangfu,  my avalon batch #2 does not have a  USB hub between the router and the v1.5 fpga controller.
should I add one?
231  Bitcoin / Hardware / Re: Avalon ASIC users thread on: May 25, 2013, 05:31:42 PM
xiangfu,

any further info on the fpga firmware/bitstream?

http://downloads.qi-hardware.com/people/xiangfu/avalon/fpga-controller/

is a JTAG required to flash the fpga?
232  Bitcoin / Project Development / Re: BAMT version 0.5 - Easy USB based mining Linux with farm wide management tools on: May 24, 2013, 09:57:16 PM
Has anybody else had issues with two BAMT rigs on the same network?

If I put two BAMT rigs (different hardware different IP's leased) only one of them will mine, If I place the other on a different subnet they both work fine?

thanks

-Tom


hook up a monitor and see what's up with the network address?
233  Bitcoin / Project Development / Re: BAMT version 0.5 - Easy USB based mining Linux with farm wide management tools on: May 24, 2013, 12:49:44 AM
Anyone have any ideas?

Running an MSI Z77A-GD65 and a Radeon 6950 with a powered x1 to x16 riser cable. BAMT will boot with no PCIe attached, however when I attach the above card via riser cable, I get the "startpar: services(s) returned failure: gdm ... failed!" error. The "failed!" in red is a nice touch...   : )    I've tried plugging into different x1 and x16 ports, and error persists. Again, no problems without the video card attached...

Am really trying to avoid installing Winders -- does anyone know what I might be doing wrong here?

why use a riser?  Connect card to mobo direct.  What happens? Take the riser cable out of the equation.
234  Bitcoin / Hardware / Re: Official Avalon Technical Support Thread on: May 23, 2013, 01:57:00 AM
I've modified the cronjob that checks whether cgminer is running to once every minute (instead of the 5 min).
Hopefully this will increase the effective hashrate by eliminating 5 min of downtime everytime cgminer hangs.

Any ideas why it was set to 5 min and not something shorter?
235  Bitcoin / Hardware / Re: Official Avalon Technical Support Thread on: May 22, 2013, 08:03:35 PM
It appears I have a v1.5 control board.  There is no USB hub.  USB cable goes directly from control board to router.



that p1 connector, check the middle red lead there, looks like that connector is not good?

Good eye Wink

The red lead popped off when I pulled the ribbon cables.  It feeds the red/green LED on the front panel.  I snapped the contact back into the housing after I took the pic.
236  Bitcoin / Hardware / Re: Official Avalon Technical Support Thread on: May 22, 2013, 04:25:32 PM
It appears I have a v1.5 control board.  There is no USB hub.  USB cable goes directly from control board to router.

237  Bitcoin / Hardware / Re: Avalon batch [2] countdown! on: May 22, 2013, 01:19:30 PM
I went on to butterflylabs and told everyone about batch 2..

Oh, this was their response..

Looks like schadenfreude to me. No wonder they got pissy.
* abracadabra mumbles something incoherent about OoC and his big fancy words

 Grin
238  Bitcoin / Hardware / Re: Official Avalon Technical Support Thread on: May 22, 2013, 12:59:21 PM
getting cgminer restarts every 10-60 min.  I believe the longest uptime I've seen is 2hr and 2nd longest uptime is 1hr 17m.

I stopped the cgminer process that was started on bootup, ssh'd in, and ran cgminer from cmdline to watch what was happening.

Noticed the following:

Quote
[2013-05-21 18:47:26] Accepted 02bd534f Diff 93/32 AVA 0
 [2013-05-21 18:47:36] Accepted 07193d6b Diff 36/32 AVA 0
 [2013-05-21 18:47:36] Accepted 02d5c4e6 Diff 90/32 AVA 0
 [2013-05-21 18:47:37] Accepted 054b656e Diff 48/32 AVA 0
 [2013-05-21 18:47:38] Accepted 07370597 Diff 35/32 AVA 0
 [2013-05-21 18:47:40] Accepted 06a76787 Diff 38/32 AVA 0
 [2013-05-21 18:47:42] Accepted 064da8aa Diff 40/32 AVA 0
 [2013-05-21 18:47:46] Accepted 02388552 Diff 115/32 AVA 0
 [2013-05-21 18:47:55] Accepted 009ef78f Diff 412/32 AVA 0
 [2013-05-21 18:47:56] Accepted 06e70c54 Diff 37/32 AVA 0
 [2013-05-21 18:48:01] Accepted 04addbfd Diff 54/32 AVA 0
 [2013-05-21 18:48:02] Accepted 02492f55 Diff 111/32 AVA 0
 [2013-05-21 18:48:04] Accepted 02d765f5 Diff 90/32 AVA 0
 [2013-05-21 18:48:05] Accepted 01d80ffc Diff 138/32 AVA 0
 [2013-05-21 18:48:08] Accepted 02c21d9d Diff 92/32 AVA 0
 [2013-05-21 18:48:10] Accepted 0067bc10 Diff 631/32 AVA 0
 [2013-05-21 18:48:12] Accepted 02a8640a Diff 96/32 AVA 0
 [2013-05-21 18:48:12] Accepted 02249de7 Diff 119/32 AVA 0
 [2013-05-21 18:48:24] Accepted 06387861 Diff 41/32 AVA 0
 [2013-05-21 18:48:28] Accepted 0259ab35 Diff 108/32 AVA 0
 [2013-05-21 18:48:28] Accepted 000ec825 Diff 4.43K/32 AVA 0
 [2013-05-21 18:48:31] Accepted 077780b5 Diff 34/32 AVA 0
 [2013-05-21 18:48:32] AVA0: invalid nonce - HW error
 [2013-05-21 18:49:34] AVA0: Idle for more than 60 seconds, declaring SICK!
 [2013-05-21 18:49:34] AVA0: Attempting to restart
 [2013-05-21 18:49:35] Avalon: Timeout on select in avalon_get_reset
 [2013-05-21 18:49:35] Avalon: Reset failed! not an Avalon? (0: 00 7e 32 e0)
 [2013-05-21 18:50:35] Avalon: Failed to open on /dev/ttyUSB0
 [2013-05-21 18:51:37] Avalon: Failed to open on /dev/ttyUSB0
 [2013-05-21 18:52:39] Avalon: Failed to open on /dev/ttyUSB0
 [2013-05-21 18:53:41] Avalon: Failed to open on /dev/ttyUSB0
 [2013-05-21 18:54:43] Avalon: Failed to open on /dev/ttyUSB0
 [2013-05-21 18:55:45] Avalon: Failed to open on /dev/ttyUSB0
 [2013-05-21 18:56:47] Avalon: Failed to open on /dev/ttyUSB0
 [2013-05-21 18:57:49] Avalon: Failed to open on /dev/ttyUSB0
 [2013-05-21 18:58:33] AVA0: Not responded for more than 10 minutes, declaring DEAD!
 [2013-05-21 18:59:35] Avalon: Failed to open on /dev/ttyUSB0

I have used the latest firmware (20130519) and also another test firmware provided to me by Aseras (050713.bin) with cgminer 3.1

Ambient room temps are about 78F.
Temps shown by Avalon are: Temp1-23   Temp2-40   Temp3-42
I have tried all clocks and I'm currently running at 256 (Normal)

Avalon team, any ideas?

TIA

With all the restarts, effective 24h hashrate is in the vicinity of 52-53GH
239  Economy / Speculation / Re: Heat map 6 months on: May 20, 2013, 10:04:25 PM
Any ideas what's up with the site?  I miss my ferroh heatmap  Sad
240  Bitcoin / Project Development / Re: BAMT version 0.5 - Easy USB based mining Linux with farm wide management tools on: May 20, 2013, 02:56:17 PM
I know it probably seemed like a dumb question  : )  I've tried Centon, Kingston, Sandisk, generic, and even a Transcend SD card, still no luck.

Must be an incompatible board I guess. If anyone has another fix, please let me know.

what mobo?  I know some gigabyte? mobos won't boot a linux partition off usb.
Pages: « 1 2 3 4 5 6 7 8 9 10 11 [12] 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 »
Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!