Bitcoin Forum
October 18, 2019, 12:41:05 AM *
News: Latest Bitcoin Core release: 0.18.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 ... 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 [102] 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 ... 156 »
  Print  
Author Topic: [ANN]Bminer: a fast Equihash/Ethash/Cuckaroo29d miner for AMD/NVIDIA GPUs 15.8.4  (Read 130094 times)
dafky2000
Newbie
*
Offline Offline

Activity: 25
Merit: 0


View Profile
January 24, 2019, 04:58:15 PM
 #2021

Mining Grin on v13.1.0 produces this error often on the grin-server stratum server.

Code:
ERROR grin_servers::mining::stratumserver - (Server ID: 0) Failed to validate share at height 12748, hash 787314f9428c, edge_bits 29, nonce 23765210304776512, job_id 1. Err(Error { inner: Verification Error: endpoints don't match up })
1571359265
Hero Member
*
Offline Offline

Posts: 1571359265

View Profile Personal Message (Offline)

Ignore
1571359265
Reply with quote  #2

1571359265
Report to moderator
1571359265
Hero Member
*
Offline Offline

Posts: 1571359265

View Profile Personal Message (Offline)

Ignore
1571359265
Reply with quote  #2

1571359265
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1571359265
Hero Member
*
Offline Offline

Posts: 1571359265

View Profile Personal Message (Offline)

Ignore
1571359265
Reply with quote  #2

1571359265
Report to moderator
1571359265
Hero Member
*
Offline Offline

Posts: 1571359265

View Profile Personal Message (Offline)

Ignore
1571359265
Reply with quote  #2

1571359265
Report to moderator
1571359265
Hero Member
*
Offline Offline

Posts: 1571359265

View Profile Personal Message (Offline)

Ignore
1571359265
Reply with quote  #2

1571359265
Report to moderator
ks-miner
Newbie
*
Offline Offline

Activity: 2
Merit: 0


View Profile
January 24, 2019, 05:35:05 PM
 #2022

Are you going to make miner for radeon vega ?
my vegas mines less then 1060 on bminer grin
sandinthebones
Sr. Member
****
Offline Offline

Activity: 539
Merit: 321



View Profile
January 24, 2019, 05:43:03 PM
Merited by vapourminer (1)
 #2023

The example of the bat on off website

bminer -uri cuckaroo29://satoshi%40nakamoto%2Ecom%2Fworker:foo@us-east-stratum.grinmint.com:3416

The instruction on mine_grin.bat

REM If you're passing in emails, the '@' characters need to be escaped (%%40)
REM If the pool use / to annoate rigs, the '/' charaactrs need to be escape (%%2F)

So which is right one ?

%40 or %%40

%2F or %%2F

Huh
% in linux, %% in windows
totoy
Hero Member
*****
Offline Offline

Activity: 626
Merit: 500



View Profile
January 24, 2019, 05:51:19 PM
 #2024

The example of the bat on off website

bminer -uri cuckaroo29://satoshi%40nakamoto%2Ecom%2Fworker:foo@us-east-stratum.grinmint.com:3416

The instruction on mine_grin.bat

REM If you're passing in emails, the '@' characters need to be escaped (%%40)
REM If the pool use / to annoate rigs, the '/' charaactrs need to be escape (%%2F)

So which is right one ?

%40 or %%40

%2F or %%2F

Huh

How about someone just give a simple answer to where/how do we put in our workerid in a normal one line startup such as:
bminer -uri cuckaroo29://someone@yahoo.com:SuperGoodPassword@us-east-stratum.grinmint.com:3416 -api 127.0.0.1:1880
So where exactly do I put my workername?

bminer -uri cuckaroo29://someone@yahoo.com/workername:SuperGoodPassword@us-east-stratum.grinmint.com:3416 -api 127.0.0.1:1880

bminer -uri cuckaroo29://someone%%40yahoo.com%%2Fworkername:SuperGoodPassword@us-east-stratum.grinmint.com:3416 -api 127.0.0.1:1880

I tried that, it doesn't work, the cli box just insta closes

https://imgur.com/Fv2lK4A

Works fine, I even use the sample i wrote
hanih
Newbie
*
Offline Offline

Activity: 3
Merit: 0


View Profile
January 24, 2019, 08:54:02 PM
 #2025

13.2 same performance as 12.2 on RTX !!!!!! please tweak it
sky1962
Newbie
*
Offline Offline

Activity: 49
Merit: 0


View Profile
January 24, 2019, 09:38:12 PM
 #2026

13.2 same performance as 12.2 on RTX !!!!!! please tweak it

Also for me and then 10 minutes crash (cpu 100%), with 12.2 -5% hashrate but very stable.  my rig 3x1070 + 1 2080
joseph32
Jr. Member
*
Offline Offline

Activity: 293
Merit: 7


View Profile
January 24, 2019, 10:14:32 PM
 #2027

GTX 1080 TI Rigs with 8 cards, the hashrate per card is decreasing in all newer versions of BMiner.

1...7.2 G/s
2...7.2 G/s
3...7.1 G/s
4...7.1 G/s
5...6.6 G/s
6...6.6 G/s
7...6.5 G/s
8...6.5 G/s

All rigs have identical cards and identical clocks, i7 processor, 16 GB Ram, 200 GB PageFile. Newest Win 10 with all patches, newest driver 417.71. Same picture on every rig.

A single card mines with 7.3+. The more cards, the more decreasing speeds. More than 4 cards you will see a hard break of about 0.5 G/s.

With GMiner all cards have the same speed and nearly 0 rejects. But right now GMiners speed is still a bit less.

UselessGuru
Jr. Member
*
Offline Offline

Activity: 108
Merit: 1


View Profile
January 24, 2019, 10:58:17 PM
 #2028

The example of the bat on off website

bminer -uri cuckaroo29://satoshi%40nakamoto%2Ecom%2Fworker:foo@us-east-stratum.grinmint.com:3416

The instruction on mine_grin.bat

REM If you're passing in emails, the '@' characters need to be escaped (%%40)
REM If the pool use / to annoate rigs, the '/' charaactrs need to be escape (%%2F)

So which is right one ?

%40 or %%40

%2F or %%2F

Huh
% in linux, %% in windows

Nope: Single % in Windows:

Code:
bminer -uri cuckaroo29://someone%40yahoo.com%2Fworkername:SuperGoodPassword@us-east-stratum.grinmint.com:3416 -api 127.0.0.1:1880
[INFO] [2019-01-24T23:57:28+01:00] Bminer: When Crypto-mining Made Fast (v13.2.0-2caa8fc)
[INFO] [2019-01-24T23:57:28+01:00] Watchdog has started.
[INFO] [2019-01-24T23:57:28+01:00] Starting miner on 1 devices
[INFO] [2019-01-24T23:57:28+01:00] Starting the management API at 127.0.0.1:1880
[INFO] [2019-01-24T23:57:28+01:00] Free memory 9171.7 MB available on device (#0). Selecting normal solver.
[INFO] [2019-01-24T23:57:28+01:00] Starting miner on device 0...
[INFO] [2019-01-24T23:57:28+01:00] Connected to us-east-stratum.grinmint.com:3416
[INFO] [2019-01-24T23:57:28+01:00] Authorized with the server
[INFO] [2019-01-24T23:57:29+01:00] Received new job 0
[INFO] [2019-01-24T23:57:29+01:00] Started miner on device 0
[INFO] [2019-01-24T23:57:33+01:00] Accepted share
[INFO] [2019-01-24T23:57:36+01:00] Accepted share
[INFO] [2019-01-24T23:57:38+01:00] Received new job 1
UselessGuru
Jr. Member
*
Offline Offline

Activity: 108
Merit: 1


View Profile
January 24, 2019, 10:59:30 PM
 #2029

What about this problem ?
CUDA error DRIVER: '2' in func 'bminer::cuckoo::CuckooSolverCuda::Initialize' line 127
http://prntscr.com/maqz84

How to fix it ?

Similar to this:

https://bitcointalk.org/index.php?topic=2519271.msg49373992#msg49373992

What GPU and driver version?
UselessGuru
Jr. Member
*
Offline Offline

Activity: 108
Merit: 1


View Profile
January 24, 2019, 11:01:03 PM
 #2030

Code:
BMiner.exe -api 127.0.0.1:4002 -uri stratum://**************************:multipoolminer%2cc%3dBTC@equihash.eu.mine.zpool.ca:2142 -watchdog=false -devices 0
[INFO] [2019-01-23T00:42:08+01:00] Bminer: When Crypto-mining Made Fast (v12.0.1-eab048c)
[INFO] [2019-01-23T00:42:08+01:00] Watchdog has started.
[INFO] [2019-01-23T00:42:08+01:00] Starting miner on 1 devices
[INFO] [2019-01-23T00:42:08+01:00] Starting the management API at 127.0.0.1:4002
[INFO] [2019-01-23T00:42:08+01:00] Starting miner on device 0...
[INFO] [2019-01-23T00:42:08+01:00] Connected to equihash.eu.mine.zpool.ca:2142
[INFO] [2019-01-23T00:42:08+01:00] Started miner on device 0
[INFO] [2019-01-23T00:42:09+01:00] Subscribed to stratum server
[INFO] [2019-01-23T00:42:09+01:00] Set nonce to 81000264
[INFO] [2019-01-23T00:42:09+01:00] Authorized
[INFO] [2019-01-23T00:42:09+01:00] Set target to 00000000000000000000000000000000000000000000000000000000f8ff0700
[INFO] [2019-01-23T00:42:09+01:00] Received new job 6e
[INFO] [2019-01-23T00:42:14+01:00] Accepted share #5

Code:
BMiner.exe -api 127.0.0.1:4002 -uri stratum://**************************:multipoolminer%2cc%3dBTC@equihash.eu.mine.zpool.ca:2142 -watchdog=false -devices 0
[INFO] [2019-01-23T00:42:41+01:00] Bminer: When Crypto-mining Made Fast (v12.2.0-937f19b)
[INFO] [2019-01-23T00:42:42+01:00] Watchdog has started.
[INFO] [2019-01-23T00:42:42+01:00] Starting miner on 1 devices
[INFO] [2019-01-23T00:42:42+01:00] Starting the management API at 127.0.0.1:4002
[INFO] [2019-01-23T00:42:42+01:00] Starting miner on device 0...
[INFO] [2019-01-23T00:42:42+01:00] Connected to equihash.eu.mine.zpool.ca:2142
[INFO] [2019-01-23T00:42:42+01:00] CUDA error DRIVER: '500' in func 'BZSolverCudaImpl::BZSolverCudaImpl' line 186
[FATA] [2019-01-23T00:42:42+01:00] Fatal cuda error in GPU 0. Terminate soon...

Code:
BMiner.exe -api 127.0.0.1:4002 -uri stratum://**************************:multipoolminer%2cc%3dBTC@equihash.eu.mine.zpool.ca:2142 -watchdog=false -devices 0
[INFO] [2019-01-23T00:45:47+01:00] Bminer: When Crypto-mining Made Fast (v13.0.0-6d94ac7)
[INFO] [2019-01-23T00:45:47+01:00] Watchdog has started.
[INFO] [2019-01-23T00:45:47+01:00] Starting miner on 1 devices
[INFO] [2019-01-23T00:45:47+01:00] Starting the management API at 127.0.0.1:4002
[INFO] [2019-01-23T00:45:47+01:00] Starting miner on device 0...
[INFO] [2019-01-23T00:45:47+01:00] Connected to equihash.eu.mine.zpool.ca:2142
[INFO] [2019-01-23T00:45:47+01:00] CUDA error DRIVER: '500' in func 'BZSolverCudaImpl::BZSolverCudaImpl' line 186
[FATA] [2019-01-23T00:45:47+01:00] Fatal cuda error in GPU 0. Terminate soon...

Nvidia driver 417.71 on WIn 10 x64 1809

Bminer version later 12.0.1 throw an error:
Error CUDA error DRIVER: '500' in func 'BZSolverCudaImpl::BZSolverCudaImpl' line 186

Still the same error with 13.2.0

All other miners I've tried word perfectly on my rig.

Any ideas? Silence is not the answer ;-)
ctp9
Jr. Member
*
Offline Offline

Activity: 37
Merit: 4


View Profile
January 25, 2019, 12:09:24 AM
 #2031

Can CONFIRM that mining C29 on Linux with P104-100 4GB GPUs works!

Thank you developer! You did an amazing job of creating compatibility for the 4GB mining cards. Keep up the great work. Smiley

What linux u using? anyone tried p104 with hive os?

Yes, I'm using HIVE OS. Rigs just go offline after some time and hashrate decreases down to 0.
WhyMe
Sr. Member
****
Offline Offline

Activity: 534
Merit: 250


View Profile
January 25, 2019, 12:25:13 AM
 #2032

Anyone has successfully done BEAM on AMD ?
realbminer
Member
**
Offline Offline

Activity: 440
Merit: 44


View Profile WWW
January 25, 2019, 05:57:02 AM
 #2033

We’re pleased to release Bminer 13.2.0.

Improve the performance of Turing GPUs when mining Grin.
Reduced rejected share chance for all cards.

Please see https://www.bminer.me for more details.

Happy mining!

When Crypto-mining Made Fast. @realbminer on TWTR
realbminer
Member
**
Offline Offline

Activity: 440
Merit: 44


View Profile WWW
January 25, 2019, 07:03:59 AM
 #2034

Code:
BMiner.exe -api 127.0.0.1:4002 -uri stratum://**************************:multipoolminer%2cc%3dBTC@equihash.eu.mine.zpool.ca:2142 -watchdog=false -devices 0
[INFO] [2019-01-23T00:42:08+01:00] Bminer: When Crypto-mining Made Fast (v12.0.1-eab048c)
[INFO] [2019-01-23T00:42:08+01:00] Watchdog has started.
[INFO] [2019-01-23T00:42:08+01:00] Starting miner on 1 devices
[INFO] [2019-01-23T00:42:08+01:00] Starting the management API at 127.0.0.1:4002
[INFO] [2019-01-23T00:42:08+01:00] Starting miner on device 0...
[INFO] [2019-01-23T00:42:08+01:00] Connected to equihash.eu.mine.zpool.ca:2142
[INFO] [2019-01-23T00:42:08+01:00] Started miner on device 0
[INFO] [2019-01-23T00:42:09+01:00] Subscribed to stratum server
[INFO] [2019-01-23T00:42:09+01:00] Set nonce to 81000264
[INFO] [2019-01-23T00:42:09+01:00] Authorized
[INFO] [2019-01-23T00:42:09+01:00] Set target to 00000000000000000000000000000000000000000000000000000000f8ff0700
[INFO] [2019-01-23T00:42:09+01:00] Received new job 6e
[INFO] [2019-01-23T00:42:14+01:00] Accepted share #5

Code:
BMiner.exe -api 127.0.0.1:4002 -uri stratum://**************************:multipoolminer%2cc%3dBTC@equihash.eu.mine.zpool.ca:2142 -watchdog=false -devices 0
[INFO] [2019-01-23T00:42:41+01:00] Bminer: When Crypto-mining Made Fast (v12.2.0-937f19b)
[INFO] [2019-01-23T00:42:42+01:00] Watchdog has started.
[INFO] [2019-01-23T00:42:42+01:00] Starting miner on 1 devices
[INFO] [2019-01-23T00:42:42+01:00] Starting the management API at 127.0.0.1:4002
[INFO] [2019-01-23T00:42:42+01:00] Starting miner on device 0...
[INFO] [2019-01-23T00:42:42+01:00] Connected to equihash.eu.mine.zpool.ca:2142
[INFO] [2019-01-23T00:42:42+01:00] CUDA error DRIVER: '500' in func 'BZSolverCudaImpl::BZSolverCudaImpl' line 186
[FATA] [2019-01-23T00:42:42+01:00] Fatal cuda error in GPU 0. Terminate soon...

Code:
BMiner.exe -api 127.0.0.1:4002 -uri stratum://**************************:multipoolminer%2cc%3dBTC@equihash.eu.mine.zpool.ca:2142 -watchdog=false -devices 0
[INFO] [2019-01-23T00:45:47+01:00] Bminer: When Crypto-mining Made Fast (v13.0.0-6d94ac7)
[INFO] [2019-01-23T00:45:47+01:00] Watchdog has started.
[INFO] [2019-01-23T00:45:47+01:00] Starting miner on 1 devices
[INFO] [2019-01-23T00:45:47+01:00] Starting the management API at 127.0.0.1:4002
[INFO] [2019-01-23T00:45:47+01:00] Starting miner on device 0...
[INFO] [2019-01-23T00:45:47+01:00] Connected to equihash.eu.mine.zpool.ca:2142
[INFO] [2019-01-23T00:45:47+01:00] CUDA error DRIVER: '500' in func 'BZSolverCudaImpl::BZSolverCudaImpl' line 186
[FATA] [2019-01-23T00:45:47+01:00] Fatal cuda error in GPU 0. Terminate soon...

Nvidia driver 417.71 on WIn 10 x64 1809

Bminer version later 12.0.1 throw an error:
Error CUDA error DRIVER: '500' in func 'BZSolverCudaImpl::BZSolverCudaImpl' line 186

Still the same error with 13.2.0

All other miners I've tried word perfectly on my rig.

Any ideas? Silence is not the answer ;-)

Seem working for me.

Code:
$ ./bminer -uri stratum://***:multipoolminer%2cc%3dBTC@equihash.eu.mine.zpool.ca:2142
[INFO] [2019-01-25T15:02:19+00:00] Bminer: When Crypto-mining Made Fast (v13.2.0-2caa8fc)
[INFO] [2019-01-25T15:02:20+00:00] Watchdog has started.
[INFO] [2019-01-25T15:02:20+00:00] Starting miner on 5 devices
[INFO] [2019-01-25T15:02:20+00:00] Starting miner on device 0...
[INFO] [2019-01-25T15:02:20+00:00] Started miner on device 0
[INFO] [2019-01-25T15:02:20+00:00] Starting miner on device 1...
[INFO] [2019-01-25T15:02:20+00:00] Connected to equihash.eu.mine.zpool.ca:2142
[INFO] [2019-01-25T15:02:21+00:00] Started miner on device 1
[INFO] [2019-01-25T15:02:21+00:00] Starting miner on device 2...
[INFO] [2019-01-25T15:02:21+00:00] Started miner on device 2
[INFO] [2019-01-25T15:02:21+00:00] Starting miner on device 3...
[INFO] [2019-01-25T15:02:21+00:00] Started miner on device 3
[INFO] [2019-01-25T15:02:21+00:00] Starting miner on device 4...
[INFO] [2019-01-25T15:02:21+00:00] Subscribed to stratum server
[INFO] [2019-01-25T15:02:21+00:00] Set nonce to 81004d23
[INFO] [2019-01-25T15:02:21+00:00] Started miner on device 4
[INFO] [2019-01-25T15:02:22+00:00] Authorized
[INFO] [2019-01-25T15:02:22+00:00] Set target to 00000000000000000000000000000000000000000000000000000000f8ff0700
[INFO] [2019-01-25T15:02:22+00:00] Received new job 281a
[INFO] [2019-01-25T15:02:22+00:00] Accepted share #5

When Crypto-mining Made Fast. @realbminer on TWTR
ctp9
Jr. Member
*
Offline Offline

Activity: 37
Merit: 4


View Profile
January 25, 2019, 07:19:54 AM
 #2035

Running multiple P104-100 rigs on HIVE OS:

Using bminer 13.1.0. All rigs show that they are "mining" - there is progress and it shows that it is receiving jobs and shares are "accepted".

But on Grinmint pool - every single one of the workers goes offline after about 1 hour (requiring a reboot in order to come back online), and graph rate decreases to 0:

Offline workers:


Decreased graph rate:



Any idea what's going on? Grinmint does not receive any shares when this happens, while bminer shows that it is still mining...

sp_
Legendary
*
Offline Offline

Activity: 1806
Merit: 1051

Ccminer developer


View Profile
January 25, 2019, 08:03:45 AM
 #2036

GRIN: Can you add support for 1060 3gb please

https://github.com/tromp/cuckoo/commit/22f7a78b605713dd5e4624acff6b241ee37c2b49



(2.8gb required for cucko-29)
Cryptotourist
Full Member
***
Offline Offline

Activity: 364
Merit: 188


https://youtu.be/snILjFUkk_A


View Profile
January 25, 2019, 08:30:00 AM
 #2037

Running multiple P104-100 rigs on HIVE OS:

Using bminer 13.1.0. All rigs show that they are "mining" - there is progress and it shows that it is receiving jobs and shares are "accepted".

But on Grinmint pool - every single one of the workers goes offline after about 1 hour (requiring a reboot in order to come back online), and graph rate decreases to 0:

Offline workers:
https://i.imgur.com/JuQyDAI.jpg

Decreased graph rate:
https://i.imgur.com/2Pf4Ig4.jpg


Any idea what's going on? Grinmint does not receive any shares when this happens, while bminer shows that it is still mining...



My guess is that you are using the TLS port. Try using the non encrypted one - port 3416.
Also check with another pool (sparkpool for example).
ivcelmik
Sr. Member
****
Offline Offline

Activity: 480
Merit: 250


View Profile WWW
January 25, 2019, 08:42:51 AM
 #2038

GRIN: Can you add support for 1060 3gb please

https://github.com/tromp/cuckoo/commit/22f7a78b605713dd5e4624acff6b241ee37c2b49



(2.8gb required for cucko-29)

+1
ctp9
Jr. Member
*
Offline Offline

Activity: 37
Merit: 4


View Profile
January 25, 2019, 10:18:46 AM
 #2039

Running multiple P104-100 rigs on HIVE OS:

Using bminer 13.1.0. All rigs show that they are "mining" - there is progress and it shows that it is receiving jobs and shares are "accepted".

But on Grinmint pool - every single one of the workers goes offline after about 1 hour (requiring a reboot in order to come back online), and graph rate decreases to 0:

Offline workers:
https://i.imgur.com/JuQyDAI.jpg

Decreased graph rate:
https://i.imgur.com/2Pf4Ig4.jpg


Any idea what's going on? Grinmint does not receive any shares when this happens, while bminer shows that it is still mining...



My guess is that you are using the TLS port. Try using the non encrypted one - port 3416.
Also check with another pool (sparkpool for example).

Nope - I am not using encrypted/TLS port. I will try sparkpool then.
yuzuak
Member
**
Offline Offline

Activity: 574
Merit: 12


View Profile
January 25, 2019, 10:53:25 AM
 #2040

@realbminer  c31 do you have work
Pages: « 1 ... 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 [102] 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 ... 156 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!