Bitcoin Forum
December 07, 2016, 04:39:10 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 [29] 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 »
  Print  
Author Topic: [ANN] [LTC] [PPS] [OTP 2FA] [Stratum only] LTCMine PPS mining pool (3.3%)  (Read 214508 times)
Balthazar
Legendary
*
Offline Offline

Activity: 2002


Post rank racist


View Profile
April 28, 2013, 05:42:11 PM
 #561

What should I do in order to keep reject ratio lower? I'm constantly getting about 3% which is quite a lot from what I read here...
Ping to ltcmine.ru from my miner is about 28-30ms which is really nice, so that shouldn't be a problem. What else can keep my reject ratio that high?

Which type of rejects do you get? Is it "unknown-work" or something another?

yes, unknown-work
There are two working sets - pool's working set and miner's local working set. The "unknown-work" message means that work doesn't exist in pool's working set anymore (or never existed). Pool working set cleanup procedure launched for every new block, received by pool from p2p network. Local working set cleared when miner receives "New work found" message from pool.

So, if miner got reject with "unknown-work" message, this means that local working set wasn't updated properly while pool's working set updated already. This could be caused by network problem, and can be resolved by manual expiry time decreasing. Try -E 30 option for cgminer/bfgminer.

P.S. Minimum shares difficulty border now is fixed at x64.

novaco.in | VMWare VMHGFS driver for 3.19.x kernels | Ukrainian translation for Novacoin [Done]
฿: 1GV8D5SRkA3cPccpYhVc2wMkjwz3UREEpy: 4RgnHWtnJWEyMhqhDdazW3Hdr7cx5ybF6i
1481128750
Hero Member
*
Offline Offline

Posts: 1481128750

View Profile Personal Message (Offline)

Ignore
1481128750
Reply with quote  #2

1481128750
Report to moderator
1481128750
Hero Member
*
Offline Offline

Posts: 1481128750

View Profile Personal Message (Offline)

Ignore
1481128750
Reply with quote  #2

1481128750
Report to moderator
1481128750
Hero Member
*
Offline Offline

Posts: 1481128750

View Profile Personal Message (Offline)

Ignore
1481128750
Reply with quote  #2

1481128750
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481128750
Hero Member
*
Offline Offline

Posts: 1481128750

View Profile Personal Message (Offline)

Ignore
1481128750
Reply with quote  #2

1481128750
Report to moderator
Dehumanizer
Member
**
Offline Offline

Activity: 77



View Profile
April 28, 2013, 06:15:37 PM
 #562

There are two working sets - pool's working set and miner's local working set. The "unknown-work" message means that work doesn't exist in pool's working set anymore (or never existed). Pool working set cleanup procedure launched for every new block, received by pool from p2p network. Local working set cleared when miner receives "New work found" message from pool.

So, if miner got reject with "unknown-work" message, this means that local working set wasn't updated properly while pool's working set updated already. This could be caused by network problem, and can be resolved by manual expiry time decreasing. Try -E 30 option for cgminer/bfgminer.

P.S. Minimum shares difficulty border now is fixed at x64.

Thanks for the hint, I've applied it right now and will let you know if it helped :-)
Dehumanizer
Member
**
Offline Offline

Activity: 77



View Profile
April 28, 2013, 06:46:26 PM
 #563

Great, it looks like it helped a lot. Since I have changed the expiration, I'm getting almost no rejects at all, thanks again.
Dehumanizer
Member
**
Offline Offline

Activity: 77



View Profile
April 28, 2013, 07:58:12 PM
 #564

Well, even though it looked like problem was solved, it was just some short term deviation and now the reject rate is back to 3% :-(
grottenolm
Jr. Member
*
Offline Offline

Activity: 31

Hardware Developer


View Profile
April 28, 2013, 08:05:35 PM
 #565

So, if miner got reject with "unknown-work" message, this means that local working set wasn't updated properly while pool's working set updated already. This could be caused by network problem, and can be resolved by manual expiry time decreasing. Try -E 30 option for cgminer/bfgminer.

Thanks a lot for posting your suggestions here, any knowledge sharing is highly appreciated. Maybe one more hint in case anyone runs into similar issues as I did:

I had ~4% to ~10% rejects on cgminer (a wild mixture of graphics cards on several systems). Setting expiry to 30 unfortunately didn't help. The reason turned out to be connected to the fact that the miners are on a relatively slow internet connection. After I disabled the stratum proxies and CPU miners on two of the systems, reducing network load, everything seems to be fine now Smiley

BC: 1CVREzNBPKsJTK2Ufe9ZFv2vTBr81gHN8j
Balthazar
Legendary
*
Offline Offline

Activity: 2002


Post rank racist


View Profile
April 28, 2013, 08:19:22 PM
 #566

So, if miner got reject with "unknown-work" message, this means that local working set wasn't updated properly while pool's working set updated already. This could be caused by network problem, and can be resolved by manual expiry time decreasing. Try -E 30 option for cgminer/bfgminer.

Thanks a lot for posting your suggestions here, any knowledge sharing is highly appreciated. Maybe one more hint in case anyone runs into similar issues as I did:

I had ~4% to ~10% rejects on cgminer (a wild mixture of graphics cards on several systems). Setting expiry to 30 unfortunately didn't help. The reason turned out to be connected to the fact that the miners are on a relatively slow internet connection. After I disabled the stratum proxies and CPU miners on two of the systems, reducing network load, everything seems to be fine now Smiley
If you have slow connection, it's recommended to run one instance of stratum/ltc proxy and connect all miners (including machines running cgminer) to this instance. This will dramatically reduce traffic usage.

novaco.in | VMWare VMHGFS driver for 3.19.x kernels | Ukrainian translation for Novacoin [Done]
฿: 1GV8D5SRkA3cPccpYhVc2wMkjwz3UREEpy: 4RgnHWtnJWEyMhqhDdazW3Hdr7cx5ybF6i
Listener
Newbie
*
Offline Offline

Activity: 17


View Profile
April 28, 2013, 08:59:17 PM
 #567

I get from time to time the message from cgminer, that the stratum pool could not be reached (last time today 21:20 server time)... cgminer is then still continuing mining, but all shares get rejected. When I restart cgminer then, everything is fine and it starts normally mining again.

Is this a problem from the server-side or should I configure cgminer in another way (e.g. that it tries to reconnect more often, ...)?
Balthazar
Legendary
*
Offline Offline

Activity: 2002


Post rank racist


View Profile
April 28, 2013, 09:26:49 PM
 #568

I received some reports like this. I'm unsure about the reason, but switching to bfgminer usually resolves this issue.

novaco.in | VMWare VMHGFS driver for 3.19.x kernels | Ukrainian translation for Novacoin [Done]
฿: 1GV8D5SRkA3cPccpYhVc2wMkjwz3UREEpy: 4RgnHWtnJWEyMhqhDdazW3Hdr7cx5ybF6i
algorithmic
Jr. Member
*
Offline Offline

Activity: 30



View Profile
April 28, 2013, 09:48:56 PM
 #569

I am unable to set my email address. There error message is "The form is not filled correctly."
Could it be because you are not allowing addresses with a "+" character in the user name?


Balthazar
Legendary
*
Offline Offline

Activity: 2002


Post rank racist


View Profile
April 28, 2013, 10:07:39 PM
 #570

Stats recalculated for 927 users. Other 130 users will be handled later.

novaco.in | VMWare VMHGFS driver for 3.19.x kernels | Ukrainian translation for Novacoin [Done]
฿: 1GV8D5SRkA3cPccpYhVc2wMkjwz3UREEpy: 4RgnHWtnJWEyMhqhDdazW3Hdr7cx5ybF6i
Balthazar
Legendary
*
Offline Offline

Activity: 2002


Post rank racist


View Profile
April 28, 2013, 10:12:53 PM
 #571

I am unable to set my email address. There error message is "The form is not filled correctly."
Could it be because you are not allowing addresses with a "+" character in the user name?



I use this regexp:

Code:
^[_a-z0-9-]+(\.[_a-z0-9-]+)*@[a-z0-9-]+(\.[a-z0-9-]+)*(\.[a-z]{2,3})$

for email address sanity checking.

novaco.in | VMWare VMHGFS driver for 3.19.x kernels | Ukrainian translation for Novacoin [Done]
฿: 1GV8D5SRkA3cPccpYhVc2wMkjwz3UREEpy: 4RgnHWtnJWEyMhqhDdazW3Hdr7cx5ybF6i
Mhash pipe
Member
**
Offline Offline

Activity: 70


View Profile
April 29, 2013, 12:42:15 AM
 #572

Thanks for keeping such a close eye on the pool and helping me reset my password. This pool is amazing!
Duetschpire
Sr. Member
****
Offline Offline

Activity: 366


bitify.com - Bitcoin Marketplace & Auction site


View Profile WWW
April 29, 2013, 12:57:40 AM
 #573

Just looked into the Event Viewer...

At round 1.08.00 am I have "a request to disable windows desktop manager" followed by "faulty application name cgminer.exe..module amdocl.dll" and to top things off   "amdkmdap driver crashed and successfully recovered" 1 sec after that...few hours later fragmentation process starts, finishes and the pc "shuts down ". Have in mind cards fans were working...Anyone  Roll Eyes

EDIT: One worker stopped soon after the upper mentioned findings the other 3 hours after that..

Sorry for the late reply, been away for the day...

It seems like the drivers are crashing which is causing cgminer to crash as well... When this happens and you're infront of the PC you'll notice the screens will turn off then back on and a bubble will pop out saying that the driver has crashed and recovered.

If you're not on version 13.3, update to that version it's more stable, check the OC if you're OCing the card, keep in mind that for scrypt mining the best ratio should be 0.68 e.g: CPU 1000 mem 1,470 if you're OCing the card unofficially through MSIAfterburner.conf, don't add the line manually, it cause my card to crash, just replace the 0 with 1 next to unofficialunlock= 0; this will give you a warning the1st time you launch afterburner, then it will fix itself.

Other things to look at is the intensity and the thread concurrency, lowering them will give you a more stable yet a bit slower mining.

Hope this helps

algorithmic
Jr. Member
*
Offline Offline

Activity: 30



View Profile
April 29, 2013, 01:06:55 AM
 #574

I am unable to set my email address. There error message is "The form is not filled correctly."
Could it be because you are not allowing addresses with a "+" character in the user name?


I use this regexp:

Code:
^[_a-z0-9-]+(\.[_a-z0-9-]+)*@[a-z0-9-]+(\.[a-z0-9-]+)*(\.[a-z]{2,3})$

for email address sanity checking.

Yeah, that won't allow valid addresses like george+jetson@gmail.com.
There's a good Stackoverflow question about validating e-mail with regex:
http://stackoverflow.com/questions/201323/using-a-regular-expression-to-validate-an-email-address

Anyway, no problem. I can work around it. Thanks.
talvivaara
Member
**
Offline Offline

Activity: 104



View Profile
April 29, 2013, 02:18:42 PM
 #575

Weirdness, the TOTP code inquiry gives me "Incorrect code" every time. Doing everything the same as i did after using it last time and at that time it worked fine. I'm clueless of what to try. Ideas?
 Huh

EDIT: I'm on the road now and didn't have time to setup the method in the howtogeek-article. So been using the webapp... http://gauth.apps.gbraad.nl/
...which worked just fine before.

Excuse me, spare a coin for a cyber bum? - BTC: 1KiiToSx5G1ySGrSohvYtTxw5DUjbF7XYc - GET 10% OFF YOUR TRADING FEES FOR A YEAR @ Vircurex (referral link)
Balthazar
Legendary
*
Offline Offline

Activity: 2002


Post rank racist


View Profile
April 29, 2013, 02:49:07 PM
 #576

Weirdness, the TOTP code inquiry gives me "Incorrect code" every time. Doing everything the same as i did after using it last time and at that time it worked fine. I'm clueless of what to try. Ideas?
 Huh

EDIT: I'm on the road now and didn't have time to setup the method in the howtogeek-article. So been using the webapp... http://gauth.apps.gbraad.nl/
...which worked just fine before.
Hm... Did you tried to perform time synchronization?

novaco.in | VMWare VMHGFS driver for 3.19.x kernels | Ukrainian translation for Novacoin [Done]
฿: 1GV8D5SRkA3cPccpYhVc2wMkjwz3UREEpy: 4RgnHWtnJWEyMhqhDdazW3Hdr7cx5ybF6i
talvivaara
Member
**
Offline Offline

Activity: 104



View Profile
April 29, 2013, 03:02:14 PM
 #577

Weirdness, the TOTP code inquiry gives me "Incorrect code" every time. Doing everything the same as i did after using it last time and at that time it worked fine. I'm clueless of what to try. Ideas?
 Huh

EDIT: I'm on the road now and didn't have time to setup the method in the howtogeek-article. So been using the webapp... http://gauth.apps.gbraad.nl/
...which worked just fine before.
Hm... Time synchronization, maybe?
Ping is less than 20ms on all intervals, i usually have +25sec left over from the 30sec. Time & date settings untouched and on the same settings on the same laptop I used last time with the webapp. Undecided

It isn't all that urgent at the moment, as i was only going to check out stats for fun on my spear time. But It's weird enough that i thought to ask is there anything strange going on that you could see. Will report how it goes with jAuth or some other alternative when i get my hands on one. For now being my home server is down because i got too greedy mining with it OC'd. lulz Grin

Excuse me, spare a coin for a cyber bum? - BTC: 1KiiToSx5G1ySGrSohvYtTxw5DUjbF7XYc - GET 10% OFF YOUR TRADING FEES FOR A YEAR @ Vircurex (referral link)
Butters
Jr. Member
*
Offline Offline

Activity: 37


View Profile
April 29, 2013, 03:03:10 PM
 #578

What should I do in order to keep reject ratio lower? I'm constantly getting about 3% which is quite a lot from what I read here...
Ping to ltcmine.ru from my miner is about 28-30ms which is really nice, so that shouldn't be a problem. What else can keep my reject ratio that high?

Which type of rejects do you get? Is it "unknown-work" or something another?


Hey and what do to minimize stales when they are 'prev-hash' type of stales? getting around 2.5% now... Sad

Use the best LTC Pool ever LTC Rabbit - PPS - 2% fee + Altcoin Bonus! - 6.5+ GH/s!
Balthazar
Legendary
*
Offline Offline

Activity: 2002


Post rank racist


View Profile
April 29, 2013, 03:07:39 PM
 #579

Weirdness, the TOTP code inquiry gives me "Incorrect code" every time. Doing everything the same as i did after using it last time and at that time it worked fine. I'm clueless of what to try. Ideas?
 Huh

EDIT: I'm on the road now and didn't have time to setup the method in the howtogeek-article. So been using the webapp... http://gauth.apps.gbraad.nl/
...which worked just fine before.
Hm... Time synchronization, maybe?
Ping is less than 20ms on all intervals, i usually have +25sec left over from the 30sec. Time & date settings untouched and on the same settings on the same laptop I used last time with the webapp. Undecided

It isn't all that urgent at the moment, as i was only going to check out stats for fun on my spear time. But It's weird enough that i thought to ask is there anything strange going on that you could see. Will report how it goes with jAuth or some other alternative when i get my hands on one. For now being my home server is down atm because i got too greedy mining with it OC'd. lulz Grin
Tested web app... It works for me. Smiley

novaco.in | VMWare VMHGFS driver for 3.19.x kernels | Ukrainian translation for Novacoin [Done]
฿: 1GV8D5SRkA3cPccpYhVc2wMkjwz3UREEpy: 4RgnHWtnJWEyMhqhDdazW3Hdr7cx5ybF6i
Balthazar
Legendary
*
Offline Offline

Activity: 2002


Post rank racist


View Profile
April 29, 2013, 03:08:09 PM
 #580

What should I do in order to keep reject ratio lower? I'm constantly getting about 3% which is quite a lot from what I read here...
Ping to ltcmine.ru from my miner is about 28-30ms which is really nice, so that shouldn't be a problem. What else can keep my reject ratio that high?

Which type of rejects do you get? Is it "unknown-work" or something another?


Hey and what do to minimize stales when they are 'prev-hash' type of stales? getting around 2.5% now... Sad
Try -E 30 -s 30

novaco.in | VMWare VMHGFS driver for 3.19.x kernels | Ukrainian translation for Novacoin [Done]
฿: 1GV8D5SRkA3cPccpYhVc2wMkjwz3UREEpy: 4RgnHWtnJWEyMhqhDdazW3Hdr7cx5ybF6i
Pages: « 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 [29] 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!