Bitcoin Forum
November 18, 2017, 02:48:58 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 [59] 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 ... 254 »
  Print  
Author Topic: HoboNickels - HBN - High Fast Stake - Version 2.0! More Secure, Less Intensive  (Read 400102 times)
Frosty45
Jr. Member
*
Offline Offline

Activity: 44


View Profile WWW
April 02, 2014, 08:13:46 PM
 #1161

We need a multipool that pays out in HBN Smiley

ShareCoin Free and Fair Distribution. SRo3UgUWoB3Ar11RXA3uyg7nhCkUVXRA6T
1511016538
Hero Member
*
Offline Offline

Posts: 1511016538

View Profile Personal Message (Offline)

Ignore
1511016538
Reply with quote  #2

1511016538
Report to moderator
1511016538
Hero Member
*
Offline Offline

Posts: 1511016538

View Profile Personal Message (Offline)

Ignore
1511016538
Reply with quote  #2

1511016538
Report to moderator
1511016538
Hero Member
*
Offline Offline

Posts: 1511016538

View Profile Personal Message (Offline)

Ignore
1511016538
Reply with quote  #2

1511016538
Report to moderator
Coinlancer is Disrupting the Freelance marketplace!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Tranz
Legendary
*
Offline Offline

Activity: 1162


May the force bit with you.


View Profile
April 02, 2014, 09:06:49 PM
 #1162


Ok I will try that,

and no it was regular transactions this time.  What can cause this kind of issue ?

I know that if you send a transaction while not synced, or while having networking issues it can cause this to happen. I had this happen with a different coin a few months ago.

I'm still not sure why this happened, as I did make about 10 transactions before sending the 2 that got "stuck".  Maybe they were either too fast, or I had network issues that I wasn't aware of.

The other thing I can say is that I was combining smaller blocks into bigger ones, (I had over 100 blocks sent into one) and the client was a bit laggy while preparing the transaction... Maybe something went wrong during that process.

Anyhow, -salvagewallet cleaned up that mess and I'm all good now. Thanks

EDIT: just did another transaction and never got caught up by the network... I'll redo the -salvagewallet thing but it's a pain and time consuming  Sad

here's the log if that could help

Code:
04/02/14 17:47:48 CommitTransaction:
CTransaction(hash=e62f60d62e, nTime=1396460865, ver=1, vin.size=1, vout.size=1, nLockTime=0)
    CTxIn(COutPoint(1f0f651975, 0), scriptSig=3045022100d53b3d7ec7ca92)
    CTxOut(nValue=1883.598592, scriptPubKey=OP_DUP OP_HASH160 c1deeb3337900432c207e4a0e55c2278e13fcd56 OP_EQUALVERIFY OP_CHECKSIG)
AddToWallet e62f60d62e  new
04/02/14 17:47:49 WalletUpdateSpent found spent coin 1883.599592hbn 1f0f651975818c2e769d370ae02e7df95df505b6e23f887cf9f20f1158d6100d
04/02/14 17:47:49 NotifyTransactionChanged 1f0f651975818c2e769d370ae02e7df95df505b6e23f887cf9f20f1158d6100d status=1
04/02/14 17:47:49 NotifyTransactionChanged e62f60d62e809437dfc8cc19f17aa3a271a3a3ed263c1c2e3955739513ef4a5b status=0
04/02/14 17:47:49 NotifyTransactionChanged 1f0f651975818c2e769d370ae02e7df95df505b6e23f887cf9f20f1158d6100d status=1
04/02/14 17:47:49 CTxMemPool::accept() : accepted e62f60d62e (poolsz 1)
04/02/14 17:47:49 AddToWallet e62f60d62e 
04/02/14 17:47:49 NotifyTransactionChanged e62f60d62e809437dfc8cc19f17aa3a271a3a3ed263c1c2e3955739513ef4a5b status=1
04/02/14 17:47:49 AddToWallet e62f60d62e  new
04/02/14 17:47:49 NotifyTransactionChanged e62f60d62e809437dfc8cc19f17aa3a271a3a3ed263c1c2e3955739513ef4a5b status=0
04/02/14 17:47:49 Relaying wtx e62f60d62e
04/02/14 17:47:49 NotifyAddressBookChanged EzAbwP8XEDByVXLw6rD58gozmvUaiKKQmi  isMine=0 status=0
04/02/14 17:47:50 updateWallet 1f0f651975818c2e769d370ae02e7df95df505b6e23f887cf9f20f1158d6100d 1
04/02/14 17:47:50    inWallet=1 inModel=1 Index=225-226 showTransaction=1 derivedStatus=1
04/02/14 17:47:50 updateWallet e62f60d62e809437dfc8cc19f17aa3a271a3a3ed263c1c2e3955739513ef4a5b 0
04/02/14 17:47:50    inWallet=1 inModel=0 Index=1611-1611 showTransaction=1 derivedStatus=0
04/02/14 17:47:50 updateWallet 1f0f651975818c2e769d370ae02e7df95df505b6e23f887cf9f20f1158d6100d 1
04/02/14 17:47:50    inWallet=1 inModel=1 Index=225-226 showTransaction=1 derivedStatus=1
04/02/14 17:47:50 updateWallet e62f60d62e809437dfc8cc19f17aa3a271a3a3ed263c1c2e3955739513ef4a5b 1
04/02/14 17:47:50    inWallet=1 inModel=1 Index=1611-1612 showTransaction=1 derivedStatus=1
04/02/14 17:47:50 updateWallet e62f60d62e809437dfc8cc19f17aa3a271a3a3ed263c1c2e3955739513ef4a5b 0
04/02/14 17:47:50    inWallet=1 inModel=0 Index=0-0 showTransaction=1 derivedStatus=0
04/02/14 17:47:52 Flushing wallet.dat
04/02/14 17:47:52 Flushed wallet.dat 242ms

Hmm not I am not sure right off hand why it wouldn't get accepted? 
Did you try resendtx? 
After salvage wallet did it work?
Did you use coin control or something different?

HBN: https://bitcointalk.org/index.php?topic=303749.0
hobonickels.info HBN F1TranzWqFGZyFeTMu6iLbtTQgdXuJPsiL
Tranz
Legendary
*
Offline Offline

Activity: 1162


May the force bit with you.


View Profile
April 02, 2014, 09:09:43 PM
 #1163

EDIT: just did another transaction and never got caught up by the network... I'll redo the -salvagewallet thing but it's a pain and time consuming  Sad

here's the log if that could help

From a thread I read on dogecoin subreddit, which uses similar QT, there were problems of the wallet not staying synced properly and causing the type of problems we are seeing. It said the cause of the problem is boost library under version 1.5.5 being used when compiling from source. I am not sure whether this is the problem or not, in the makefile.mingw in the Tranz/HoboNickels repo it is showing boost 1.5.0 - which could be the problem.  But also I don't even know if Tranz uses mingw to compile for windows or not.

I am trying to mess around with compiling for Windows right now, but this will be a learning experience for me because I have only compiled hobonickelsd on Ubuntu.

yeah maybe that is it... I'm using "version" : "v1.3.0.0-g76880ab-hobo" for MAC, maybe that is the problem... I will try to compile the latest version for MAC later tonight... It will be an new experience for me too... let's have fun  Grin

For all my windows compiles I use boost 1.55. I did not compile the Mac. I currently do not own a mac.  This was going to be a project after I complete 1.4. But there maybe bigger fish to fry.


HBN: https://bitcointalk.org/index.php?topic=303749.0
hobonickels.info HBN F1TranzWqFGZyFeTMu6iLbtTQgdXuJPsiL
Tranz
Legendary
*
Offline Offline

Activity: 1162


May the force bit with you.


View Profile
April 02, 2014, 09:11:11 PM
 #1164

I will try that if it does not sync, it is but slow as a snail. Oh! my wallet.dat file was never encrypted.

I just sync'd a few computers last night. The longest took me about 12 hours.  What is your log file saying? 1.3.0.0 will need addnodes manually. But should sync after you get connections.

HBN: https://bitcointalk.org/index.php?topic=303749.0
hobonickels.info HBN F1TranzWqFGZyFeTMu6iLbtTQgdXuJPsiL
unick
Sr. Member
****
Offline Offline

Activity: 378


View Profile
April 02, 2014, 09:36:15 PM
 #1165



Hmm not I am not sure right off hand why it wouldn't get accepted? 
Did you try resendtx? 
After salvage wallet did it work?
Did you use coin control or something different?


yes try resendtx but it didn't return any info and while it seemed to work, nothing happened.
salvagewallet worked, yes.
and yes I used coin control but I'm not sure on that last specific transaction, but the other yes.

Awesome Explorers for Awesome Coins | Show some BTC love here: 1AAYAZgaz2me7hyumexUZzcyGRZEYtCx5C
HoboNickels: hbn.blockx.info | BottleCaps: cap.blockx.info | GrowthCoin: grw.blockx.info
CryptoFunds
Jr. Member
*
Offline Offline

Activity: 48

CryptoFunds.pw Official


View Profile WWW
April 02, 2014, 10:22:27 PM
 #1166

http://cryptofunds.pw HBN market is up! BTC/LTC!

wee have ssmall syncing issue, should be fixed shortly. bear with us.

CryptoFunds.pw - new exchange live! Try us!
unick
Sr. Member
****
Offline Offline

Activity: 378


View Profile
April 02, 2014, 10:30:28 PM
 #1167

Ok I'm trying to compile the QT client for OS X

First error was the icns file.  it was looking for bitcoin.icns but there was hobonickels.icns.  I changed the name to bitcoin.icns and updated to current version of logo.  Maybe changing the reference in the source code for that.
Code:
make: *** No rule to make target `../HoboNickels/src/qt/res/icons/bitcoin.icns', needed by `HoboNickels-Qt.app/Contents/Resources/bitcoin.icns'.  Stop.


then this warning appeared, but the compile moved on... I assume this was not a big deal, but I'm posting it so you can look at it and modify accordingly if it's a bigger issue.
Code:
/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/ranlib:-1: error: file: libleveldb.a(env_win.o) has no symbols

Finally, the compile failed here with this error
Code:
../HoboNickels/src/miner.cpp:475:13: error: no member named 'replace_all' in namespace 'boost'; did you mean 'replace_if'?
            boost::replace_all(strCmd, "%s", hashBlock.GetHex());
            ^~~~~~~~~~~~~~~~~~
            replace_if
/usr/include/c++/4.2.1/bits/stl_algo.h:1022:5: note: 'replace_if' declared here
    replace_if(_ForwardIterator __first, _ForwardIterator __last,
    ^
../HoboNickels/src/miner.cpp:475:13: error: no matching function for call to 'replace_if'
            boost::replace_all(strCmd, "%s", hashBlock.GetHex());
            ^~~~~~~~~~~~~~~~~~
/usr/include/c++/4.2.1/bits/stl_algo.h:1022:5: note: candidate function template not viable: requires 4 arguments, but 3 were provided
    replace_if(_ForwardIterator __first, _ForwardIterator __last,
    ^
2 errors generated.
make: *** [build/miner.o] Error 1

let me know what can I do to complete the compile

Awesome Explorers for Awesome Coins | Show some BTC love here: 1AAYAZgaz2me7hyumexUZzcyGRZEYtCx5C
HoboNickels: hbn.blockx.info | BottleCaps: cap.blockx.info | GrowthCoin: grw.blockx.info
MarketNeutral
Sr. Member
****
Offline Offline

Activity: 364


View Profile
April 02, 2014, 11:00:36 PM
 #1168

Paging Maxpower.....
hyeoam
Full Member
***
Offline Offline

Activity: 182


View Profile
April 02, 2014, 11:01:25 PM
 #1169

Charts here: http://crypto-prices.com/HBN

Donate BTC: 1NRG17fYCNcfQvQHC3G9TUAowNKsM4oTWA
Tranz
Legendary
*
Offline Offline

Activity: 1162


May the force bit with you.


View Profile
April 02, 2014, 11:09:56 PM
 #1170

Guys I just did a normal windows update, nothing out of the ordinary. And then brought back up a wallet that has been very steady for me for sometime. I got the assert failure.

This is now public enemy number 1. I am going in deep. I may not be out for a while. Hopefully I surface with a good solution!

HBN: https://bitcointalk.org/index.php?topic=303749.0
hobonickels.info HBN F1TranzWqFGZyFeTMu6iLbtTQgdXuJPsiL
MarketNeutral
Sr. Member
****
Offline Offline

Activity: 364


View Profile
April 02, 2014, 11:47:22 PM
 #1171

Guys I just did a normal windows update, nothing out of the ordinary. And then brought back up a wallet that has been very steady for me for sometime. I got the assert failure.

This is now public enemy number 1. I am going in deep. I may not be out for a while. Hopefully I surface with a good solution!

Good luck on tackling the assert failure, Tranz. Your hard work and dedication is greatly appreciated.  Smiley

Cheers!
broken_pixel
Hero Member
*****
Offline Offline

Activity: 770



View Profile
April 03, 2014, 12:05:03 AM
 #1172

I will try that if it does not sync, it is but slow as a snail. Oh! my wallet.dat file was never encrypted.

I just sync'd a few computers last night. The longest took me about 12 hours.  What is your log file saying? 1.3.0.0 will need addnodes manually. But should sync after you get connections.

I am using these nodes:

addnode=174.103.158.220:62683   
addnode=68.109.79.96:61187   
addnode=65.24.235.56:33299   
addnode=144.76.9.247:2304   
addnode=75.152.1.226:62062   
addnode=108.83.227.44:51053   
addnode=85.140.75.107:58473   
addnode=94.41.176.140:65508   
addnode=75.138.235.246:7372
addnode=5.249.152.30
addnode=54.201.183.106
addnode=178.33.105.250
addnode=123.176.103.130   

The wallet seems to sync a block every 10-15 min, so far I am on block 2508.

GA-990FXA-UD5, 1x 7970L, 2x S1, AX1200i, RIVBE, 2x R290x, NEX1500, BTC: 1G9cQix8bMgh35MQ9wY3Rb9yNSSCtnoRmK, DGC: DFo9FcKYsutv9Vx5c5xUzkrt7VJdECZWTM, LTC: LaAN33aktPGaimN5ALL9kjHjuJekfmKfTh
Tranz
Legendary
*
Offline Offline

Activity: 1162


May the force bit with you.


View Profile
April 03, 2014, 12:45:28 AM
 #1173

I will try that if it does not sync, it is but slow as a snail. Oh! my wallet.dat file was never encrypted.

I just sync'd a few computers last night. The longest took me about 12 hours.  What is your log file saying? 1.3.0.0 will need addnodes manually. But should sync after you get connections.

I am using these nodes:

addnode=174.103.158.220:62683   
addnode=68.109.79.96:61187   
addnode=65.24.235.56:33299   
addnode=144.76.9.247:2304   
addnode=75.152.1.226:62062   
addnode=108.83.227.44:51053   
addnode=85.140.75.107:58473   
addnode=94.41.176.140:65508   
addnode=75.138.235.246:7372
addnode=5.249.152.30
addnode=54.201.183.106
addnode=178.33.105.250
addnode=123.176.103.130   

The wallet seems to sync a block every 10-15 min, so far I am on block 2508.

No this is not even close. You will never sync. Something is odd with your connection or your computer. 

What does your debug log say?

HBN: https://bitcointalk.org/index.php?topic=303749.0
hobonickels.info HBN F1TranzWqFGZyFeTMu6iLbtTQgdXuJPsiL
broken_pixel
Hero Member
*****
Offline Offline

Activity: 770



View Profile
April 03, 2014, 01:10:22 AM
 #1174

My Growth coin wallet sinks, my Mint coin wallet syncs, all my other wallets work fine.

PM your email so I can send you the debug txt, I can't copy paste it here the text exceeds the character limit for the forums and also pastebin free account.

Currently on block 2503 now. The wallet still producing PoS, I just mined 17 HBN a min ago.

Update:

I took out my wallet.dat file and it is syncing like it is supposed to, is my wallet.dat corrupted?  Cry

Update:

Yay! seems fine now after I synced the wallet and then added my wallet.dat file. The only problem now is the wallet will always go non responsive and freeze if I try to click on an option. This happens with the 1.3.0 and the 1.3.6.0 wallets and only when I have my wallet.dat in my appdata folder.

GA-990FXA-UD5, 1x 7970L, 2x S1, AX1200i, RIVBE, 2x R290x, NEX1500, BTC: 1G9cQix8bMgh35MQ9wY3Rb9yNSSCtnoRmK, DGC: DFo9FcKYsutv9Vx5c5xUzkrt7VJdECZWTM, LTC: LaAN33aktPGaimN5ALL9kjHjuJekfmKfTh
Tranz
Legendary
*
Offline Offline

Activity: 1162


May the force bit with you.


View Profile
April 03, 2014, 02:52:03 AM
 #1175

My Growth coin wallet sinks, my Mint coin wallet syncs, all my other wallets work fine.

PM your email so I can send you the debug txt, I can't copy paste it here the text exceeds the character limit for the forums and also pastebin free account.

Currently on block 2503 now. The wallet still producing PoS, I just mined 17 HBN a min ago.

Update:

I took out my wallet.dat file and it is syncing like it is supposed to, is my wallet.dat corrupted?  Cry

Update:

Yay! seems fine now after I synced the wallet and then added my wallet.dat file. The only problem now is the wallet will always go non responsive and freeze if I try to click on an option. This happens with the 1.3.0 and the 1.3.6.0 wallets and only when I have my wallet.dat in my appdata folder.

I understand now..
You are producing many PoS blocks and it is causing the GUI to become un-responsive.

Yes I have this fixed in 1.3.7+ but i haven't released it yet. For now you can type reservebalance=9999 in your console or when you start up. The 9999 should be 1/2 to 3/4 your coins.  

The coins in reserve won't stake, but as some stake you can lower the reservebalance.  

I am working on a few other fixes here before I release it. including the assert failures and the 22 wallet issues.

Thanks for your patients.

HBN: https://bitcointalk.org/index.php?topic=303749.0
hobonickels.info HBN F1TranzWqFGZyFeTMu6iLbtTQgdXuJPsiL
CryptoFunds
Jr. Member
*
Offline Offline

Activity: 48

CryptoFunds.pw Official


View Profile WWW
April 03, 2014, 02:56:47 AM
 #1176

all working good - enjoy HBN trade at http://cryptofunds.pw

CryptoFunds.pw - new exchange live! Try us!
presstab
Legendary
*
Offline Offline

Activity: 1288


Pivx Core Developer - HyperStake Founder


View Profile
April 03, 2014, 03:41:38 AM
 #1177

Yay! seems fine now after I synced the wallet and then added my wallet.dat file. The only problem now is the wallet will always go non responsive and freeze if I try to click on an option. This happens with the 1.3.0 and the 1.3.6.0 wallets and only when I have my wallet.dat in my appdata folder.

Brokenpixel, I am relieved that you figured out a solution for your dilemma. I have also experienced unresponsive client when I have many blocks staking, because of my VPS having only 666mhz of ram and very low cpu power. In order to prevent this you can use the reserve balance method Tranz suggested, or you can try to combine blocks.

presstab's Block Explorer Service | Only $10/mo for most coins! | Richlist w/ Address Claim | Market Cap Charts | Stake Weight Tracking | PoS % Rate Tracking
PIVX - Private Instant Verified Tx | HyperStake - Fun & Easy High Reward Staking
broken_pixel
Hero Member
*****
Offline Offline

Activity: 770



View Profile
April 03, 2014, 03:51:54 AM
 #1178

My Growth coin wallet sinks, my Mint coin wallet syncs, all my other wallets work fine.

PM your email so I can send you the debug txt, I can't copy paste it here the text exceeds the character limit for the forums and also pastebin free account.

Currently on block 2503 now. The wallet still producing PoS, I just mined 17 HBN a min ago.

Update:

I took out my wallet.dat file and it is syncing like it is supposed to, is my wallet.dat corrupted?  Cry

Update:

Yay! seems fine now after I synced the wallet and then added my wallet.dat file. The only problem now is the wallet will always go non responsive and freeze if I try to click on an option. This happens with the 1.3.0 and the 1.3.6.0 wallets and only when I have my wallet.dat in my appdata folder.

I understand now..
You are producing many PoS blocks and it is causing the GUI to become un-responsive.

Yes I have this fixed in 1.3.7+ but i haven't released it yet. For now you can type reservebalance=9999 in your console or when you start up. The 9999 should be 1/2 to 3/4 your coins.  

The coins in reserve won't stake, but as some stake you can lower the reservebalance.  

I am working on a few other fixes here before I release it. including the assert failures and the 22 wallet issues.

Thanks for your patients.

Thanks for maintaining HBN. 

GA-990FXA-UD5, 1x 7970L, 2x S1, AX1200i, RIVBE, 2x R290x, NEX1500, BTC: 1G9cQix8bMgh35MQ9wY3Rb9yNSSCtnoRmK, DGC: DFo9FcKYsutv9Vx5c5xUzkrt7VJdECZWTM, LTC: LaAN33aktPGaimN5ALL9kjHjuJekfmKfTh
Tranz
Legendary
*
Offline Offline

Activity: 1162


May the force bit with you.


View Profile
April 03, 2014, 05:18:37 AM
 #1179



Thanks for maintaining HBN. 

You are welcome. Hopefully things settle down here soon.


I have been making some headway into the assert failures. Essentially some of the blocks are missing from the index.  I still don't know the root cause for this. As it appears to be somewhat random? But I am continuing investigation into this issue.

Keeping a running backup of the txleveldb folder and blk???.dat files should help.  As you can quickly use a slightly older version, and then re download the missing blocks.

I'll put up weekly zips of the files so others won't have to re download the block chain many times.

Plus after you have a working backup you can always use that to catchup to current quickly.



HBN: https://bitcointalk.org/index.php?topic=303749.0
hobonickels.info HBN F1TranzWqFGZyFeTMu6iLbtTQgdXuJPsiL
otila
Sr. Member
****
Offline Offline

Activity: 336


View Profile
April 03, 2014, 05:56:27 AM
 #1180

Finally, the compile failed here with this error
Code:
../HoboNickels/src/miner.cpp:475:13: error: no member named 'replace_all' in namespace 'boost'; did you mean 'replace_if'?
            boost::replace_all(strCmd, "%s", hashBlock.GetHex());

add into src/miner.cpp:
Code:
#include <boost/algorithm/string/replace.hpp>
Pages: « 1 ... 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 [59] 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 ... 254 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!