Bitcoin Forum
October 21, 2017, 01:49:06 AM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 ... 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 [186] 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 ... 316 »
  Print  
Author Topic: [TEK] TEKcoin Hi-PoS hybrid pos/pow no premine/ipo/ico  (Read 430428 times)
This is a self-moderated topic. If you do not want to be moderated by the person who started this topic, create a new topic.
thundertoe
Legendary
*
Offline Offline

Activity: 938



View Profile
April 19, 2015, 08:51:34 PM
 #3701

Info Bump

Please make sure your wallet is not staking while syncing.

put "reservebalance = 100000000" in the .conf keep staking off until you are ready,

or encrypt the wallet and unlock it for pos only when synced,

Enter the console command "reservebalance false" when you are synced and choose to stake.
1508550546
Hero Member
*
Offline Offline

Posts: 1508550546

View Profile Personal Message (Offline)

Ignore
1508550546
Reply with quote  #2

1508550546
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508550546
Hero Member
*
Offline Offline

Posts: 1508550546

View Profile Personal Message (Offline)

Ignore
1508550546
Reply with quote  #2

1508550546
Report to moderator
1508550546
Hero Member
*
Offline Offline

Posts: 1508550546

View Profile Personal Message (Offline)

Ignore
1508550546
Reply with quote  #2

1508550546
Report to moderator
thundertoe
Legendary
*
Offline Offline

Activity: 938



View Profile
April 19, 2015, 11:14:37 PM
 #3702

somehow i missed this heavy volume going on.... looks like about 10% of total minted Tek and 20+btc? traded on comkort recently
dickwhite
Full Member
***
Offline Offline

Activity: 220


View Profile
April 19, 2015, 11:23:25 PM
 #3703

Info Bump

Please make sure your wallet is not staking while syncing.

put "reservebalance = 100000000" in the .conf keep staking off until you are ready,

or encrypt the wallet and unlock it for pos only when synced,

Enter the console command "reservebalance false" when you are synced and choose to stake.


Hi thundertoe,
No staking while the wallet is syncing. Would it be possible to code this functionality into the wallet for a future update? I realize one could be synced on the wrong fork, but it's less likely with checkpoints. This might help eliminate the trouble people have with unlocked wallets. I know it happened to me in the early days. It shakes your confidence.
 
Which reminds me, I'd like to discuss wallet updates. The wallet is working fabulous. BTW, but I see many nice-to-have features in other coins, which makes me a bit jealous. I'm not sure how wallet development proceeds, but if it requires paying a coder to work more consistently on the wallet, a donation address with reminders could be posted, or better yet add stake for charity feature in the wallet so we can donate from there. I really believe a dynamic, feature-rich wallet will help TEK stay on top. Thanks for your time.
Biomech
Legendary
*
Offline Offline

Activity: 1176


Anarchy is not chaos.


View Profile
April 20, 2015, 01:52:38 AM
 #3704

Info Bump

Please make sure your wallet is not staking while syncing.

put "reservebalance = 100000000" in the .conf keep staking off until you are ready,

or encrypt the wallet and unlock it for pos only when synced,

Enter the console command "reservebalance false" when you are synced and choose to stake.


Hi thundertoe,
No staking while the wallet is syncing. Would it be possible to code this functionality into the wallet for a future update? I realize one could be synced on the wrong fork, but it's less likely with checkpoints. This might help eliminate the trouble people have with unlocked wallets. I know it happened to me in the early days. It shakes your confidence.
 
Which reminds me, I'd like to discuss wallet updates. The wallet is working fabulous. BTW, but I see many nice-to-have features in other coins, which makes me a bit jealous. I'm not sure how wallet development proceeds, but if it requires paying a coder to work more consistently on the wallet, a donation address with reminders could be posted, or better yet add stake for charity feature in the wallet so we can donate from there. I really believe a dynamic, feature-rich wallet will help TEK stay on top. Thanks for your time.

I'm probably speaking out of turn here, but have you considered taking a shot at it yourself? Forking the github repo is a once click thing, and you could play around and see what happens. I'm not a programmer, and I've started doing this as I have time. Which isn't a lot, but it's interesting to try. And if you're successful, you are part of the development.

To my knowledge, we do not have a full time coder in this project, but several who are occasionally willing to help. Defaced, Noise23, and Presstab have all contributed at various times, and Tranz has reviewed code as well. I would personally like to see Coinsolidation have a go at it, and rebase it to BTC core if it can be done. He just did that on a project I'm part of, GameCredits, and it's a very nicely functioning wallet. I'm not sure how well that would work with a coin descended from Novacoin, but I don't know that it wouldn't either.

Buy Bitcoins with Paypal, Credit card, or other methods. Send me a PM or a text to 208-451-2665.
dickwhite
Full Member
***
Offline Offline

Activity: 220


View Profile
April 20, 2015, 01:52:17 PM
 #3705


I'm probably speaking out of turn here, but have you considered taking a shot at it yourself? Forking the github repo is a once click thing, and you could play around and see what happens. I'm not a programmer, and I've started doing this as I have time. Which isn't a lot, but it's interesting to try. And if you're successful, you are part of the development.

To my knowledge, we do not have a full time coder in this project, but several who are occasionally willing to help. Defaced, Noise23, and Presstab have all contributed at various times, and Tranz has reviewed code as well. I would personally like to see Coinsolidation have a go at it, and rebase it to BTC core if it can be done. He just did that on a project I'm part of, GameCredits, and it's a very nicely functioning wallet. I'm not sure how well that would work with a coin descended from Novacoin, but I don't know that it wouldn't either.

No, I haven't much coding experience beyond some basic in the '80s. Maybe I'll have a look at it. What I do have are funds to contribute to development, and your Coinsolidation sounds like an interesting approach. I don't wish to intrude or impose my will upon thundertoe, the community, or the direction of the coin. However, I would like to see more formal structure to the wallet development process. Thanks for the thoughtful reply.
vrm86
Hero Member
*****
Offline Offline

Activity: 680


View Profile
April 21, 2015, 06:25:57 PM
 #3706

Hello, seems that I have a problem: I am no longer staking coins. My last minted coins appeared 27th March. Wallet is sync'ed and up to date, but it keeps saying that I have no mature coins - I am sure I have.
What I have tried so far:
- downloading whole blockchain
- reinstalling wallet on new system
- repairwallet
- rescan
- deleting peers.dat
- withdrawing some coins

I have no idea what is going on  Undecided
thundertoe
Legendary
*
Offline Offline

Activity: 938



View Profile
April 21, 2015, 06:45:58 PM
 #3707

Hello, seems that I have a problem: I am no longer staking coins. My last minted coins appeared 27th March. Wallet is sync'ed and up to date, but it keeps saying that I have no mature coins - I am sure I have.
What I have tried so far:
- downloading whole blockchain
- reinstalling wallet on new system
- repairwallet
- rescan
- deleting peers.dat
- withdrawing some coins

I have no idea what is going on  Undecided


goto settings options display and enable coin control, then hit the send tab and check and see if you have aged blocks. It wont show "mature coins" on the staking icon in the front until after they are 30 days old, and then it resets after they stake.
vrm86
Hero Member
*****
Offline Offline

Activity: 680


View Profile
April 21, 2015, 06:58:23 PM
 #3708

Hello, seems that I have a problem: I am no longer staking coins. My last minted coins appeared 27th March. Wallet is sync'ed and up to date, but it keeps saying that I have no mature coins - I am sure I have.
What I have tried so far:
- downloading whole blockchain
- reinstalling wallet on new system
- repairwallet
- rescan
- deleting peers.dat
- withdrawing some coins

I have no idea what is going on  Undecided


goto settings options display and enable coin control, then hit the send tab and check and see if you have aged blocks. It wont show "mature coins" on the staking icon in the front until after they are 30 days old, and then it resets after they stake.


Interesting - I have one block at age of 56 days, one at 2 days and few hundreds between 26 and 28. So I assume that i have to wait a bit more.
Thanks! Smiley
Biomech
Legendary
*
Offline Offline

Activity: 1176


Anarchy is not chaos.


View Profile
April 21, 2015, 08:36:18 PM
 #3709

Hello, seems that I have a problem: I am no longer staking coins. My last minted coins appeared 27th March. Wallet is sync'ed and up to date, but it keeps saying that I have no mature coins - I am sure I have.
What I have tried so far:
- downloading whole blockchain
- reinstalling wallet on new system
- repairwallet
- rescan
- deleting peers.dat
- withdrawing some coins

I have no idea what is going on  Undecided

If you haven't already, enable coin control and look at the date. March 27th is not yet mature, it's a thirty day cycle. If you have coins that are older than 30 days, look at their weight and how long it's been. It generally can take up to a week to stake, though TEK is usually quicker than that.

Buy Bitcoins with Paypal, Credit card, or other methods. Send me a PM or a text to 208-451-2665.
ryanb
Legendary
*
Offline Offline

Activity: 1134



View Profile
April 23, 2015, 12:36:00 PM
 #3710

Difficulty is skyrocketing today.

https://bitcoinfundingteam.com/ref/SatoshiTeam
turn 0.1 BTC to 80BTC week after week!!!
thundertoe
Legendary
*
Offline Offline

Activity: 938



View Profile
April 23, 2015, 04:59:41 PM
 #3711

Difficulty is skyrocketing today.

yes it spiked a bit,
 i have been watching it here http://blockexperts.com/tek.  atm the last pos block was 0.00044 diff and paid 25.5%, also seeing pow diff climb.
kevin1234a
Legendary
*
Offline Offline

Activity: 1162


Decentralizing Jesus on the Blockchain


View Profile WWW
April 26, 2015, 06:32:27 AM
 #3712

guys need your advise to get daemon comiled on raspberry pi, getting following error

Code:
i@raspberrypi ~/TEK/src $ make -f makefile.unix
g++ -c -O2 -msse2 -pthread -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -g -DBOOST_SPIRIT_THREADSAFE -I/home/pi/TEK/src -I/home/pi/TEK/src/obj -DUSE_UPNP=0 -DUSE_IPV6=1 -DHAVE_BUILD_INFO -fno-stack-protector -fstack-protector-all -Wstack-protector -D_FORTIFY_SOURCE=2  -MMD -MF obj/alert.d -o obj/alert.o alert.cpp
cc1plus: error: unrecognized command line option \u2018-msse2\u2019
makefile.unix:149: recipe for target 'obj/alert.o' failed
make: *** [obj/alert.o] Error 1
pi@raspberrypi ~/TEK/src $



Biomech
Legendary
*
Offline Offline

Activity: 1176


Anarchy is not chaos.


View Profile
April 26, 2015, 08:06:14 AM
 #3713

guys need your advise to get daemon comiled on raspberry pi, getting following error

Code:
i@raspberrypi ~/TEK/src $ make -f makefile.unix
g++ -c -O2 -msse2 -pthread -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -g -DBOOST_SPIRIT_THREADSAFE -I/home/pi/TEK/src -I/home/pi/TEK/src/obj -DUSE_UPNP=0 -DUSE_IPV6=1 -DHAVE_BUILD_INFO -fno-stack-protector -fstack-protector-all -Wstack-protector -D_FORTIFY_SOURCE=2  -MMD -MF obj/alert.d -o obj/alert.o alert.cpp
cc1plus: error: unrecognized command line option \u2018-msse2\u2019
makefile.unix:149: recipe for target 'obj/alert.o' failed
make: *** [obj/alert.o] Error 1
pi@raspberrypi ~/TEK/src $



make sure that src/leveldb/build_detect_platform is executable and recompile. There's something else that will trigger that as well, but I can't recall what. If the above don't fix it, I'll get back to you tomorrow, assuming nobody beats me too it. But I'm pretty sure that will fix it.

EDIT: Remembered the other likely cuplrit. Src might need the obj directory under src.

Buy Bitcoins with Paypal, Credit card, or other methods. Send me a PM or a text to 208-451-2665.
Hilux74
Legendary
*
Offline Offline

Activity: 906



View Profile
April 26, 2015, 09:15:16 AM
 #3714

guys need your advise to get daemon comiled on raspberry pi, getting following error

Code:
i@raspberrypi ~/TEK/src $ make -f makefile.unix
g++ -c -O2 -msse2 -pthread -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -g -DBOOST_SPIRIT_THREADSAFE -I/home/pi/TEK/src -I/home/pi/TEK/src/obj -DUSE_UPNP=0 -DUSE_IPV6=1 -DHAVE_BUILD_INFO -fno-stack-protector -fstack-protector-all -Wstack-protector -D_FORTIFY_SOURCE=2  -MMD -MF obj/alert.d -o obj/alert.o alert.cpp
cc1plus: error: unrecognized command line option \u2018-msse2\u2019
makefile.unix:149: recipe for target 'obj/alert.o' failed
make: *** [obj/alert.o] Error 1
pi@raspberrypi ~/TEK/src $



make sure that src/leveldb/build_detect_platform is executable and recompile. There's something else that will trigger that as well, but I can't recall what. If the above don't fix it, I'll get back to you tomorrow, assuming nobody beats me too it. But I'm pretty sure that will fix it.

EDIT: Remembered the other likely cuplrit. Src might need the obj directory under src.
Edit the makefile.unix and remove the "-msse2".
kevin1234a
Legendary
*
Offline Offline

Activity: 1162


Decentralizing Jesus on the Blockchain


View Profile WWW
April 26, 2015, 03:38:43 PM
 #3715

guys need your advise to get daemon comiled on raspberry pi, getting following error

Code:
i@raspberrypi ~/TEK/src $ make -f makefile.unix
g++ -c -O2 -msse2 -pthread -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -g -DBOOST_SPIRIT_THREADSAFE -I/home/pi/TEK/src -I/home/pi/TEK/src/obj -DUSE_UPNP=0 -DUSE_IPV6=1 -DHAVE_BUILD_INFO -fno-stack-protector -fstack-protector-all -Wstack-protector -D_FORTIFY_SOURCE=2  -MMD -MF obj/alert.d -o obj/alert.o alert.cpp
cc1plus: error: unrecognized command line option \u2018-msse2\u2019
makefile.unix:149: recipe for target 'obj/alert.o' failed
make: *** [obj/alert.o] Error 1
pi@raspberrypi ~/TEK/src $



make sure that src/leveldb/build_detect_platform is executable and recompile. There's something else that will trigger that as well, but I can't recall what. If the above don't fix it, I'll get back to you tomorrow, assuming nobody beats me too it. But I'm pretty sure that will fix it.

EDIT: Remembered the other likely cuplrit. Src might need the obj directory under src.
Edit the makefile.unix and remove the "-msse2".

apology for lack of my linux knowledge but pls have a look to following, i assume my hardware is not compatible with this or there is something else wrong. currently i am having 5 daemons running and currently compiling one another just to make sure things ok. really need your help to figure out where is the wrong

Code:
pi@raspberrypi ~ $ git clone https://github.com/noise23/TEK
Cloning into 'TEK'...
remote: Counting objects: 1039, done.
remote: Total 1039 (delta 0), reused 0 (delta 0), pack-reused 1039
Receiving objects: 100% (1039/1039), 44.56 MiB | 1.00 MiB/s, done.
Resolving deltas: 100% (509/509), done.
Checking out files: 100% (420/420), done.
pi@raspberrypi ~ $ cd TEK/src
pi@raspberrypi ~/TEK/src $ ls
addrman.cpp      irc.cpp               netbase.h              serialize.h
addrman.h        irc.h                 net.cpp                strlcpy.h
alert.cpp        json                  net.h                  sync.cpp
alert.h          kernel.cpp            noui.cpp               sync.h
allocators.h     kernel.h              obj                    tekcoin.cbp
base58.h         key.cpp               pbkdf2.cpp             tekcoinrpc.cpp
bignum.h         key.h                 pbkdf2.h               tekcoinrpc.h
checkpoints.cpp  keystore.cpp          protocol.cpp           ui_interface.h
checkpoints.h    keystore.h            protocol.h             uint256.h
clientversion.h  main.cpp              qt                     util.cpp
coincontrol.h    main.h                rpcblockchain.cpp      util.h
compat.h         makefile.bsd          rpcdump.cpp            version.cpp
crypter.cpp      makefile.linux-mingw  rpcmining.cpp          version.h
crypter.h        makefile.mingw        rpcnet.cpp             wallet.cpp
db.cpp           makefile.osx          rpcrawtransaction.cpp  walletdb.cpp
db.h             makefile.unix         rpcwallet.cpp          walletdb.h
init.cpp         mruset.h              script.cpp             wallet.h
init.h           netbase.cpp           script.h
pi@raspberrypi ~/TEK/src $ cd
pi@raspberrypi ~ $ history -c
pi@raspberrypi ~ $ sudo apt-get install ntp git build-essential libssl-dev libdb-dev libdb++-dev libboost-all-dev libqrencode-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version.
git is already the newest version.
libdb++-dev is already the newest version.
libqrencode-dev is already the newest version.
libssl-dev is already the newest version.
ntp is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libboost-all-dev : Depends: libboost-dev but it is not going to be installed
                    Depends: libboost-chrono-dev but it is not going to be installed
                    Depends: libboost-date-time-dev but it is not going to be installed
                    Depends: libboost-filesystem-dev but it is not going to be installed
                    Depends: libboost-graph-dev but it is not going to be installed
                    Depends: libboost-graph-parallel-dev but it is not going to be installed
                    Depends: libboost-iostreams-dev but it is not going to be installed
                    Depends: libboost-locale-dev but it is not going to be installed
                    Depends: libboost-math-dev but it is not going to be installed
                    Depends: libboost-mpi-dev but it is not going to be installed
                    Depends: libboost-mpi-python-dev but it is not going to be installed
                    Depends: libboost-program-options-dev but it is not going to be installed
                    Depends: libboost-python-dev but it is not going to be installed
                    Depends: libboost-random-dev but it is not going to be installed
                    Depends: libboost-regex-dev but it is not going to be installed
                    Depends: libboost-serialization-dev but it is not going to be installed
                    Depends: libboost-signals-dev but it is not going to be installed
                    Depends: libboost-system-dev but it is not going to be installed
                    Depends: libboost-test-dev but it is not going to be installed
                    Depends: libboost-thread-dev but it is not going to be installed
                    Depends: libboost-timer-dev but it is not going to be installed
                    Depends: libboost-wave-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
pi@raspberrypi ~ $ cd TEK/src
pi@raspberrypi ~/TEK/src $ ls
addrman.cpp      irc.cpp               netbase.h              serialize.h
addrman.h        irc.h                 net.cpp                strlcpy.h
alert.cpp        json                  net.h                  sync.cpp
alert.h          kernel.cpp            noui.cpp               sync.h
allocators.h     kernel.h              obj                    tekcoin.cbp
base58.h         key.cpp               pbkdf2.cpp             tekcoinrpc.cpp
bignum.h         key.h                 pbkdf2.h               tekcoinrpc.h
checkpoints.cpp  keystore.cpp          protocol.cpp           ui_interface.h
checkpoints.h    keystore.h            protocol.h             uint256.h
clientversion.h  main.cpp              qt                     util.cpp
coincontrol.h    main.h                rpcblockchain.cpp      util.h
compat.h         makefile.bsd          rpcdump.cpp            version.cpp
crypter.cpp      makefile.linux-mingw  rpcmining.cpp          version.h
crypter.h        makefile.mingw        rpcnet.cpp             wallet.cpp
db.cpp           makefile.osx          rpcrawtransaction.cpp  walletdb.cpp
db.h             makefile.unix         rpcwallet.cpp          walletdb.h
init.cpp         mruset.h              script.cpp             wallet.h
init.h           netbase.cpp           script.h
pi@raspberrypi ~/TEK/src $ mkdir leveldb
pi@raspberrypi ~/TEK/src $ ls
addrman.cpp      irc.cpp               netbase.cpp            script.h
addrman.h        irc.h                 netbase.h              serialize.h
alert.cpp        json                  net.cpp                strlcpy.h
alert.h          kernel.cpp            net.h                  sync.cpp
allocators.h     kernel.h              noui.cpp               sync.h
base58.h         key.cpp               obj                    tekcoin.cbp
bignum.h         key.h                 pbkdf2.cpp             tekcoinrpc.cpp
checkpoints.cpp  keystore.cpp          pbkdf2.h               tekcoinrpc.h
checkpoints.h    keystore.h            protocol.cpp           ui_interface.h
clientversion.h  leveldb               protocol.h             uint256.h
coincontrol.h    main.cpp              qt                     util.cpp
compat.h         main.h                rpcblockchain.cpp      util.h
crypter.cpp      makefile.bsd          rpcdump.cpp            version.cpp
crypter.h        makefile.linux-mingw  rpcmining.cpp          version.h
db.cpp           makefile.mingw        rpcnet.cpp             wallet.cpp
db.h             makefile.osx          rpcrawtransaction.cpp  walletdb.cpp
init.cpp         makefile.unix         rpcwallet.cpp          walletdb.h
init.h           mruset.h              script.cpp             wallet.h
pi@raspberrypi ~/TEK/src $ chmod 755 leveldb/build_detect_platform && make -f makefile.unix
chmod: cannot access `leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK/src $ sudo chmod 755 leveldb/build_detect_platform && make -f makefile.unix
chmod: cannot access `leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK/src $ sudo chmod 755 leveldb
pi@raspberrypi ~/TEK/src $ sudo chmod 755 leveldb/build_detect_platform && make -f makefile.unix
chmod: cannot access `leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK/src $ make -f makefile.unixg++ -c -O2 -msse2 -pthread -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -g -DBOOST_SPIRIT_THREADSAFE -I/home/pi/TEK/src -I/home/pi/TEK/src/obj -DUSE_UPNP=0 -DUSE_IPV6=1 -DHAVE_BUILD_INFO -fno-stack-protector -fstack-protector-all -Wstack-protector -D_FORTIFY_SOURCE=2  -MMD -MF obj/alert.d -o obj/alert.o alert.cpp
cc1plus: error: unrecognized command line option \u2018-msse2\u2019
makefile.unix:149: recipe for target 'obj/alert.o' failed
make: *** [obj/alert.o] Error 1
pi@raspberrypi ~/TEK/src $ cd ..
pi@raspberrypi ~/TEK $ sudo chmod 755 src/leveldb/build_detect_platform
chmod: cannot access `src/leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK $



Biomech
Legendary
*
Offline Offline

Activity: 1176


Anarchy is not chaos.


View Profile
April 26, 2015, 03:54:25 PM
 #3716

guys need your advise to get daemon comiled on raspberry pi, getting following error

Code:
i@raspberrypi ~/TEK/src $ make -f makefile.unix
g++ -c -O2 -msse2 -pthread -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -g -DBOOST_SPIRIT_THREADSAFE -I/home/pi/TEK/src -I/home/pi/TEK/src/obj -DUSE_UPNP=0 -DUSE_IPV6=1 -DHAVE_BUILD_INFO -fno-stack-protector -fstack-protector-all -Wstack-protector -D_FORTIFY_SOURCE=2  -MMD -MF obj/alert.d -o obj/alert.o alert.cpp
cc1plus: error: unrecognized command line option \u2018-msse2\u2019
makefile.unix:149: recipe for target 'obj/alert.o' failed
make: *** [obj/alert.o] Error 1
pi@raspberrypi ~/TEK/src $



make sure that src/leveldb/build_detect_platform is executable and recompile. There's something else that will trigger that as well, but I can't recall what. If the above don't fix it, I'll get back to you tomorrow, assuming nobody beats me too it. But I'm pretty sure that will fix it.

EDIT: Remembered the other likely cuplrit. Src might need the obj directory under src.
Edit the makefile.unix and remove the "-msse2".

apology for lack of my linux knowledge but pls have a look to following, i assume my hardware is not compatible with this or there is something else wrong. currently i am having 5 daemons running and currently compiling one another just to make sure things ok. really need your help to figure out where is the wrong

Code:
pi@raspberrypi ~ $ git clone https://github.com/noise23/TEK
Cloning into 'TEK'...
remote: Counting objects: 1039, done.
remote: Total 1039 (delta 0), reused 0 (delta 0), pack-reused 1039
Receiving objects: 100% (1039/1039), 44.56 MiB | 1.00 MiB/s, done.
Resolving deltas: 100% (509/509), done.
Checking out files: 100% (420/420), done.
pi@raspberrypi ~ $ cd TEK/src
pi@raspberrypi ~/TEK/src $ ls
addrman.cpp      irc.cpp               netbase.h              serialize.h
addrman.h        irc.h                 net.cpp                strlcpy.h
alert.cpp        json                  net.h                  sync.cpp
alert.h          kernel.cpp            noui.cpp               sync.h
allocators.h     kernel.h              obj                    tekcoin.cbp
base58.h         key.cpp               pbkdf2.cpp             tekcoinrpc.cpp
bignum.h         key.h                 pbkdf2.h               tekcoinrpc.h
checkpoints.cpp  keystore.cpp          protocol.cpp           ui_interface.h
checkpoints.h    keystore.h            protocol.h             uint256.h
clientversion.h  main.cpp              qt                     util.cpp
coincontrol.h    main.h                rpcblockchain.cpp      util.h
compat.h         makefile.bsd          rpcdump.cpp            version.cpp
crypter.cpp      makefile.linux-mingw  rpcmining.cpp          version.h
crypter.h        makefile.mingw        rpcnet.cpp             wallet.cpp
db.cpp           makefile.osx          rpcrawtransaction.cpp  walletdb.cpp
db.h             makefile.unix         rpcwallet.cpp          walletdb.h
init.cpp         mruset.h              script.cpp             wallet.h
init.h           netbase.cpp           script.h
pi@raspberrypi ~/TEK/src $ cd
pi@raspberrypi ~ $ history -c
pi@raspberrypi ~ $ sudo apt-get install ntp git build-essential libssl-dev libdb-dev libdb++-dev libboost-all-dev libqrencode-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version.
git is already the newest version.
libdb++-dev is already the newest version.
libqrencode-dev is already the newest version.
libssl-dev is already the newest version.
ntp is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libboost-all-dev : Depends: libboost-dev but it is not going to be installed
                    Depends: libboost-chrono-dev but it is not going to be installed
                    Depends: libboost-date-time-dev but it is not going to be installed
                    Depends: libboost-filesystem-dev but it is not going to be installed
                    Depends: libboost-graph-dev but it is not going to be installed
                    Depends: libboost-graph-parallel-dev but it is not going to be installed
                    Depends: libboost-iostreams-dev but it is not going to be installed
                    Depends: libboost-locale-dev but it is not going to be installed
                    Depends: libboost-math-dev but it is not going to be installed
                    Depends: libboost-mpi-dev but it is not going to be installed
                    Depends: libboost-mpi-python-dev but it is not going to be installed
                    Depends: libboost-program-options-dev but it is not going to be installed
                    Depends: libboost-python-dev but it is not going to be installed
                    Depends: libboost-random-dev but it is not going to be installed
                    Depends: libboost-regex-dev but it is not going to be installed
                    Depends: libboost-serialization-dev but it is not going to be installed
                    Depends: libboost-signals-dev but it is not going to be installed
                    Depends: libboost-system-dev but it is not going to be installed
                    Depends: libboost-test-dev but it is not going to be installed
                    Depends: libboost-thread-dev but it is not going to be installed
                    Depends: libboost-timer-dev but it is not going to be installed
                    Depends: libboost-wave-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
pi@raspberrypi ~ $ cd TEK/src
pi@raspberrypi ~/TEK/src $ ls
addrman.cpp      irc.cpp               netbase.h              serialize.h
addrman.h        irc.h                 net.cpp                strlcpy.h
alert.cpp        json                  net.h                  sync.cpp
alert.h          kernel.cpp            noui.cpp               sync.h
allocators.h     kernel.h              obj                    tekcoin.cbp
base58.h         key.cpp               pbkdf2.cpp             tekcoinrpc.cpp
bignum.h         key.h                 pbkdf2.h               tekcoinrpc.h
checkpoints.cpp  keystore.cpp          protocol.cpp           ui_interface.h
checkpoints.h    keystore.h            protocol.h             uint256.h
clientversion.h  main.cpp              qt                     util.cpp
coincontrol.h    main.h                rpcblockchain.cpp      util.h
compat.h         makefile.bsd          rpcdump.cpp            version.cpp
crypter.cpp      makefile.linux-mingw  rpcmining.cpp          version.h
crypter.h        makefile.mingw        rpcnet.cpp             wallet.cpp
db.cpp           makefile.osx          rpcrawtransaction.cpp  walletdb.cpp
db.h             makefile.unix         rpcwallet.cpp          walletdb.h
init.cpp         mruset.h              script.cpp             wallet.h
init.h           netbase.cpp           script.h
pi@raspberrypi ~/TEK/src $ mkdir leveldb
pi@raspberrypi ~/TEK/src $ ls
addrman.cpp      irc.cpp               netbase.cpp            script.h
addrman.h        irc.h                 netbase.h              serialize.h
alert.cpp        json                  net.cpp                strlcpy.h
alert.h          kernel.cpp            net.h                  sync.cpp
allocators.h     kernel.h              noui.cpp               sync.h
base58.h         key.cpp               obj                    tekcoin.cbp
bignum.h         key.h                 pbkdf2.cpp             tekcoinrpc.cpp
checkpoints.cpp  keystore.cpp          pbkdf2.h               tekcoinrpc.h
checkpoints.h    keystore.h            protocol.cpp           ui_interface.h
clientversion.h  leveldb               protocol.h             uint256.h
coincontrol.h    main.cpp              qt                     util.cpp
compat.h         main.h                rpcblockchain.cpp      util.h
crypter.cpp      makefile.bsd          rpcdump.cpp            version.cpp
crypter.h        makefile.linux-mingw  rpcmining.cpp          version.h
db.cpp           makefile.mingw        rpcnet.cpp             wallet.cpp
db.h             makefile.osx          rpcrawtransaction.cpp  walletdb.cpp
init.cpp         makefile.unix         rpcwallet.cpp          walletdb.h
init.h           mruset.h              script.cpp             wallet.h
pi@raspberrypi ~/TEK/src $ chmod 755 leveldb/build_detect_platform && make -f makefile.unix
chmod: cannot access `leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK/src $ sudo chmod 755 leveldb/build_detect_platform && make -f makefile.unix
chmod: cannot access `leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK/src $ sudo chmod 755 leveldb
pi@raspberrypi ~/TEK/src $ sudo chmod 755 leveldb/build_detect_platform && make -f makefile.unix
chmod: cannot access `leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK/src $ make -f makefile.unixg++ -c -O2 -msse2 -pthread -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -g -DBOOST_SPIRIT_THREADSAFE -I/home/pi/TEK/src -I/home/pi/TEK/src/obj -DUSE_UPNP=0 -DUSE_IPV6=1 -DHAVE_BUILD_INFO -fno-stack-protector -fstack-protector-all -Wstack-protector -D_FORTIFY_SOURCE=2  -MMD -MF obj/alert.d -o obj/alert.o alert.cpp
cc1plus: error: unrecognized command line option \u2018-msse2\u2019
makefile.unix:149: recipe for target 'obj/alert.o' failed
make: *** [obj/alert.o] Error 1
pi@raspberrypi ~/TEK/src $ cd ..
pi@raspberrypi ~/TEK $ sudo chmod 755 src/leveldb/build_detect_platform
chmod: cannot access `src/leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK $




I see two things going on. Not sure how to solve one of them, and the other is my fault. I forgot, TEK doesn't use leveldb. Most coins do Tongue So you can pretty much ignore that part.

However, it's not getting the boost libraries for some reason. I'm mostly familiar with Ubuntu 14.04, which I'm guessing uses different package names from what you're after. try sudo apt search libboost and see what you find. I've never used a rapspberry pi, so I have to be somewhat generic here. It appears that you do have the other necessary dependencies, so I *think* that boost is your problem.

Buy Bitcoins with Paypal, Credit card, or other methods. Send me a PM or a text to 208-451-2665.
kevin1234a
Legendary
*
Offline Offline

Activity: 1162


Decentralizing Jesus on the Blockchain


View Profile WWW
April 26, 2015, 04:00:46 PM
 #3717

guys need your advise to get daemon comiled on raspberry pi, getting following error

Code:
i@raspberrypi ~/TEK/src $ make -f makefile.unix
g++ -c -O2 -msse2 -pthread -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -g -DBOOST_SPIRIT_THREADSAFE -I/home/pi/TEK/src -I/home/pi/TEK/src/obj -DUSE_UPNP=0 -DUSE_IPV6=1 -DHAVE_BUILD_INFO -fno-stack-protector -fstack-protector-all -Wstack-protector -D_FORTIFY_SOURCE=2  -MMD -MF obj/alert.d -o obj/alert.o alert.cpp
cc1plus: error: unrecognized command line option \u2018-msse2\u2019
makefile.unix:149: recipe for target 'obj/alert.o' failed
make: *** [obj/alert.o] Error 1
pi@raspberrypi ~/TEK/src $



make sure that src/leveldb/build_detect_platform is executable and recompile. There's something else that will trigger that as well, but I can't recall what. If the above don't fix it, I'll get back to you tomorrow, assuming nobody beats me too it. But I'm pretty sure that will fix it.

EDIT: Remembered the other likely cuplrit. Src might need the obj directory under src.
Edit the makefile.unix and remove the "-msse2".

apology for lack of my linux knowledge but pls have a look to following, i assume my hardware is not compatible with this or there is something else wrong. currently i am having 5 daemons running and currently compiling one another just to make sure things ok. really need your help to figure out where is the wrong

Code:
pi@raspberrypi ~ $ git clone https://github.com/noise23/TEK
Cloning into 'TEK'...
remote: Counting objects: 1039, done.
remote: Total 1039 (delta 0), reused 0 (delta 0), pack-reused 1039
Receiving objects: 100% (1039/1039), 44.56 MiB | 1.00 MiB/s, done.
Resolving deltas: 100% (509/509), done.
Checking out files: 100% (420/420), done.
pi@raspberrypi ~ $ cd TEK/src
pi@raspberrypi ~/TEK/src $ ls
addrman.cpp      irc.cpp               netbase.h              serialize.h
addrman.h        irc.h                 net.cpp                strlcpy.h
alert.cpp        json                  net.h                  sync.cpp
alert.h          kernel.cpp            noui.cpp               sync.h
allocators.h     kernel.h              obj                    tekcoin.cbp
base58.h         key.cpp               pbkdf2.cpp             tekcoinrpc.cpp
bignum.h         key.h                 pbkdf2.h               tekcoinrpc.h
checkpoints.cpp  keystore.cpp          protocol.cpp           ui_interface.h
checkpoints.h    keystore.h            protocol.h             uint256.h
clientversion.h  main.cpp              qt                     util.cpp
coincontrol.h    main.h                rpcblockchain.cpp      util.h
compat.h         makefile.bsd          rpcdump.cpp            version.cpp
crypter.cpp      makefile.linux-mingw  rpcmining.cpp          version.h
crypter.h        makefile.mingw        rpcnet.cpp             wallet.cpp
db.cpp           makefile.osx          rpcrawtransaction.cpp  walletdb.cpp
db.h             makefile.unix         rpcwallet.cpp          walletdb.h
init.cpp         mruset.h              script.cpp             wallet.h
init.h           netbase.cpp           script.h
pi@raspberrypi ~/TEK/src $ cd
pi@raspberrypi ~ $ history -c
pi@raspberrypi ~ $ sudo apt-get install ntp git build-essential libssl-dev libdb-dev libdb++-dev libboost-all-dev libqrencode-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version.
git is already the newest version.
libdb++-dev is already the newest version.
libqrencode-dev is already the newest version.
libssl-dev is already the newest version.
ntp is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libboost-all-dev : Depends: libboost-dev but it is not going to be installed
                    Depends: libboost-chrono-dev but it is not going to be installed
                    Depends: libboost-date-time-dev but it is not going to be installed
                    Depends: libboost-filesystem-dev but it is not going to be installed
                    Depends: libboost-graph-dev but it is not going to be installed
                    Depends: libboost-graph-parallel-dev but it is not going to be installed
                    Depends: libboost-iostreams-dev but it is not going to be installed
                    Depends: libboost-locale-dev but it is not going to be installed
                    Depends: libboost-math-dev but it is not going to be installed
                    Depends: libboost-mpi-dev but it is not going to be installed
                    Depends: libboost-mpi-python-dev but it is not going to be installed
                    Depends: libboost-program-options-dev but it is not going to be installed
                    Depends: libboost-python-dev but it is not going to be installed
                    Depends: libboost-random-dev but it is not going to be installed
                    Depends: libboost-regex-dev but it is not going to be installed
                    Depends: libboost-serialization-dev but it is not going to be installed
                    Depends: libboost-signals-dev but it is not going to be installed
                    Depends: libboost-system-dev but it is not going to be installed
                    Depends: libboost-test-dev but it is not going to be installed
                    Depends: libboost-thread-dev but it is not going to be installed
                    Depends: libboost-timer-dev but it is not going to be installed
                    Depends: libboost-wave-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
pi@raspberrypi ~ $ cd TEK/src
pi@raspberrypi ~/TEK/src $ ls
addrman.cpp      irc.cpp               netbase.h              serialize.h
addrman.h        irc.h                 net.cpp                strlcpy.h
alert.cpp        json                  net.h                  sync.cpp
alert.h          kernel.cpp            noui.cpp               sync.h
allocators.h     kernel.h              obj                    tekcoin.cbp
base58.h         key.cpp               pbkdf2.cpp             tekcoinrpc.cpp
bignum.h         key.h                 pbkdf2.h               tekcoinrpc.h
checkpoints.cpp  keystore.cpp          protocol.cpp           ui_interface.h
checkpoints.h    keystore.h            protocol.h             uint256.h
clientversion.h  main.cpp              qt                     util.cpp
coincontrol.h    main.h                rpcblockchain.cpp      util.h
compat.h         makefile.bsd          rpcdump.cpp            version.cpp
crypter.cpp      makefile.linux-mingw  rpcmining.cpp          version.h
crypter.h        makefile.mingw        rpcnet.cpp             wallet.cpp
db.cpp           makefile.osx          rpcrawtransaction.cpp  walletdb.cpp
db.h             makefile.unix         rpcwallet.cpp          walletdb.h
init.cpp         mruset.h              script.cpp             wallet.h
init.h           netbase.cpp           script.h
pi@raspberrypi ~/TEK/src $ mkdir leveldb
pi@raspberrypi ~/TEK/src $ ls
addrman.cpp      irc.cpp               netbase.cpp            script.h
addrman.h        irc.h                 netbase.h              serialize.h
alert.cpp        json                  net.cpp                strlcpy.h
alert.h          kernel.cpp            net.h                  sync.cpp
allocators.h     kernel.h              noui.cpp               sync.h
base58.h         key.cpp               obj                    tekcoin.cbp
bignum.h         key.h                 pbkdf2.cpp             tekcoinrpc.cpp
checkpoints.cpp  keystore.cpp          pbkdf2.h               tekcoinrpc.h
checkpoints.h    keystore.h            protocol.cpp           ui_interface.h
clientversion.h  leveldb               protocol.h             uint256.h
coincontrol.h    main.cpp              qt                     util.cpp
compat.h         main.h                rpcblockchain.cpp      util.h
crypter.cpp      makefile.bsd          rpcdump.cpp            version.cpp
crypter.h        makefile.linux-mingw  rpcmining.cpp          version.h
db.cpp           makefile.mingw        rpcnet.cpp             wallet.cpp
db.h             makefile.osx          rpcrawtransaction.cpp  walletdb.cpp
init.cpp         makefile.unix         rpcwallet.cpp          walletdb.h
init.h           mruset.h              script.cpp             wallet.h
pi@raspberrypi ~/TEK/src $ chmod 755 leveldb/build_detect_platform && make -f makefile.unix
chmod: cannot access `leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK/src $ sudo chmod 755 leveldb/build_detect_platform && make -f makefile.unix
chmod: cannot access `leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK/src $ sudo chmod 755 leveldb
pi@raspberrypi ~/TEK/src $ sudo chmod 755 leveldb/build_detect_platform && make -f makefile.unix
chmod: cannot access `leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK/src $ make -f makefile.unixg++ -c -O2 -msse2 -pthread -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -g -DBOOST_SPIRIT_THREADSAFE -I/home/pi/TEK/src -I/home/pi/TEK/src/obj -DUSE_UPNP=0 -DUSE_IPV6=1 -DHAVE_BUILD_INFO -fno-stack-protector -fstack-protector-all -Wstack-protector -D_FORTIFY_SOURCE=2  -MMD -MF obj/alert.d -o obj/alert.o alert.cpp
cc1plus: error: unrecognized command line option \u2018-msse2\u2019
makefile.unix:149: recipe for target 'obj/alert.o' failed
make: *** [obj/alert.o] Error 1
pi@raspberrypi ~/TEK/src $ cd ..
pi@raspberrypi ~/TEK $ sudo chmod 755 src/leveldb/build_detect_platform
chmod: cannot access `src/leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK $




I see two things going on. Not sure how to solve one of them, and the other is my fault. I forgot, TEK doesn't use leveldb. Most coins do Tongue So you can pretty much ignore that part.

However, it's not getting the boost libraries for some reason. I'm mostly familiar with Ubuntu 14.04, which I'm guessing uses different package names from what you're after. try sudo apt search libboost and see what you find. I've never used a rapspberry pi, so I have to be somewhat generic here. It appears that you do have the other necessary dependencies, so I *think* that boost is your problem.

haha in my last 6 hr study i figuered it out Smiley

well i missed another suggestion here but after following it seems it started to compile will update here should any prob comes up thanks guys

[/quote]
Edit the makefile.unix and remove the "-msse2".
[/quote]

Biomech
Legendary
*
Offline Offline

Activity: 1176


Anarchy is not chaos.


View Profile
April 26, 2015, 05:05:39 PM
 #3718

guys need your advise to get daemon comiled on raspberry pi, getting following error

Code:
i@raspberrypi ~/TEK/src $ make -f makefile.unix
g++ -c -O2 -msse2 -pthread -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -g -DBOOST_SPIRIT_THREADSAFE -I/home/pi/TEK/src -I/home/pi/TEK/src/obj -DUSE_UPNP=0 -DUSE_IPV6=1 -DHAVE_BUILD_INFO -fno-stack-protector -fstack-protector-all -Wstack-protector -D_FORTIFY_SOURCE=2  -MMD -MF obj/alert.d -o obj/alert.o alert.cpp
cc1plus: error: unrecognized command line option \u2018-msse2\u2019
makefile.unix:149: recipe for target 'obj/alert.o' failed
make: *** [obj/alert.o] Error 1
pi@raspberrypi ~/TEK/src $



make sure that src/leveldb/build_detect_platform is executable and recompile. There's something else that will trigger that as well, but I can't recall what. If the above don't fix it, I'll get back to you tomorrow, assuming nobody beats me too it. But I'm pretty sure that will fix it.

EDIT: Remembered the other likely cuplrit. Src might need the obj directory under src.
Edit the makefile.unix and remove the "-msse2".

apology for lack of my linux knowledge but pls have a look to following, i assume my hardware is not compatible with this or there is something else wrong. currently i am having 5 daemons running and currently compiling one another just to make sure things ok. really need your help to figure out where is the wrong

Code:
pi@raspberrypi ~ $ git clone https://github.com/noise23/TEK
Cloning into 'TEK'...
remote: Counting objects: 1039, done.
remote: Total 1039 (delta 0), reused 0 (delta 0), pack-reused 1039
Receiving objects: 100% (1039/1039), 44.56 MiB | 1.00 MiB/s, done.
Resolving deltas: 100% (509/509), done.
Checking out files: 100% (420/420), done.
pi@raspberrypi ~ $ cd TEK/src
pi@raspberrypi ~/TEK/src $ ls
addrman.cpp      irc.cpp               netbase.h              serialize.h
addrman.h        irc.h                 net.cpp                strlcpy.h
alert.cpp        json                  net.h                  sync.cpp
alert.h          kernel.cpp            noui.cpp               sync.h
allocators.h     kernel.h              obj                    tekcoin.cbp
base58.h         key.cpp               pbkdf2.cpp             tekcoinrpc.cpp
bignum.h         key.h                 pbkdf2.h               tekcoinrpc.h
checkpoints.cpp  keystore.cpp          protocol.cpp           ui_interface.h
checkpoints.h    keystore.h            protocol.h             uint256.h
clientversion.h  main.cpp              qt                     util.cpp
coincontrol.h    main.h                rpcblockchain.cpp      util.h
compat.h         makefile.bsd          rpcdump.cpp            version.cpp
crypter.cpp      makefile.linux-mingw  rpcmining.cpp          version.h
crypter.h        makefile.mingw        rpcnet.cpp             wallet.cpp
db.cpp           makefile.osx          rpcrawtransaction.cpp  walletdb.cpp
db.h             makefile.unix         rpcwallet.cpp          walletdb.h
init.cpp         mruset.h              script.cpp             wallet.h
init.h           netbase.cpp           script.h
pi@raspberrypi ~/TEK/src $ cd
pi@raspberrypi ~ $ history -c
pi@raspberrypi ~ $ sudo apt-get install ntp git build-essential libssl-dev libdb-dev libdb++-dev libboost-all-dev libqrencode-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version.
git is already the newest version.
libdb++-dev is already the newest version.
libqrencode-dev is already the newest version.
libssl-dev is already the newest version.
ntp is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libboost-all-dev : Depends: libboost-dev but it is not going to be installed
                    Depends: libboost-chrono-dev but it is not going to be installed
                    Depends: libboost-date-time-dev but it is not going to be installed
                    Depends: libboost-filesystem-dev but it is not going to be installed
                    Depends: libboost-graph-dev but it is not going to be installed
                    Depends: libboost-graph-parallel-dev but it is not going to be installed
                    Depends: libboost-iostreams-dev but it is not going to be installed
                    Depends: libboost-locale-dev but it is not going to be installed
                    Depends: libboost-math-dev but it is not going to be installed
                    Depends: libboost-mpi-dev but it is not going to be installed
                    Depends: libboost-mpi-python-dev but it is not going to be installed
                    Depends: libboost-program-options-dev but it is not going to be installed
                    Depends: libboost-python-dev but it is not going to be installed
                    Depends: libboost-random-dev but it is not going to be installed
                    Depends: libboost-regex-dev but it is not going to be installed
                    Depends: libboost-serialization-dev but it is not going to be installed
                    Depends: libboost-signals-dev but it is not going to be installed
                    Depends: libboost-system-dev but it is not going to be installed
                    Depends: libboost-test-dev but it is not going to be installed
                    Depends: libboost-thread-dev but it is not going to be installed
                    Depends: libboost-timer-dev but it is not going to be installed
                    Depends: libboost-wave-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
pi@raspberrypi ~ $ cd TEK/src
pi@raspberrypi ~/TEK/src $ ls
addrman.cpp      irc.cpp               netbase.h              serialize.h
addrman.h        irc.h                 net.cpp                strlcpy.h
alert.cpp        json                  net.h                  sync.cpp
alert.h          kernel.cpp            noui.cpp               sync.h
allocators.h     kernel.h              obj                    tekcoin.cbp
base58.h         key.cpp               pbkdf2.cpp             tekcoinrpc.cpp
bignum.h         key.h                 pbkdf2.h               tekcoinrpc.h
checkpoints.cpp  keystore.cpp          protocol.cpp           ui_interface.h
checkpoints.h    keystore.h            protocol.h             uint256.h
clientversion.h  main.cpp              qt                     util.cpp
coincontrol.h    main.h                rpcblockchain.cpp      util.h
compat.h         makefile.bsd          rpcdump.cpp            version.cpp
crypter.cpp      makefile.linux-mingw  rpcmining.cpp          version.h
crypter.h        makefile.mingw        rpcnet.cpp             wallet.cpp
db.cpp           makefile.osx          rpcrawtransaction.cpp  walletdb.cpp
db.h             makefile.unix         rpcwallet.cpp          walletdb.h
init.cpp         mruset.h              script.cpp             wallet.h
init.h           netbase.cpp           script.h
pi@raspberrypi ~/TEK/src $ mkdir leveldb
pi@raspberrypi ~/TEK/src $ ls
addrman.cpp      irc.cpp               netbase.cpp            script.h
addrman.h        irc.h                 netbase.h              serialize.h
alert.cpp        json                  net.cpp                strlcpy.h
alert.h          kernel.cpp            net.h                  sync.cpp
allocators.h     kernel.h              noui.cpp               sync.h
base58.h         key.cpp               obj                    tekcoin.cbp
bignum.h         key.h                 pbkdf2.cpp             tekcoinrpc.cpp
checkpoints.cpp  keystore.cpp          pbkdf2.h               tekcoinrpc.h
checkpoints.h    keystore.h            protocol.cpp           ui_interface.h
clientversion.h  leveldb               protocol.h             uint256.h
coincontrol.h    main.cpp              qt                     util.cpp
compat.h         main.h                rpcblockchain.cpp      util.h
crypter.cpp      makefile.bsd          rpcdump.cpp            version.cpp
crypter.h        makefile.linux-mingw  rpcmining.cpp          version.h
db.cpp           makefile.mingw        rpcnet.cpp             wallet.cpp
db.h             makefile.osx          rpcrawtransaction.cpp  walletdb.cpp
init.cpp         makefile.unix         rpcwallet.cpp          walletdb.h
init.h           mruset.h              script.cpp             wallet.h
pi@raspberrypi ~/TEK/src $ chmod 755 leveldb/build_detect_platform && make -f makefile.unix
chmod: cannot access `leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK/src $ sudo chmod 755 leveldb/build_detect_platform && make -f makefile.unix
chmod: cannot access `leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK/src $ sudo chmod 755 leveldb
pi@raspberrypi ~/TEK/src $ sudo chmod 755 leveldb/build_detect_platform && make -f makefile.unix
chmod: cannot access `leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK/src $ make -f makefile.unixg++ -c -O2 -msse2 -pthread -Wall -Wextra -Wformat -Wformat-security -Wno-unused-parameter -g -DBOOST_SPIRIT_THREADSAFE -I/home/pi/TEK/src -I/home/pi/TEK/src/obj -DUSE_UPNP=0 -DUSE_IPV6=1 -DHAVE_BUILD_INFO -fno-stack-protector -fstack-protector-all -Wstack-protector -D_FORTIFY_SOURCE=2  -MMD -MF obj/alert.d -o obj/alert.o alert.cpp
cc1plus: error: unrecognized command line option \u2018-msse2\u2019
makefile.unix:149: recipe for target 'obj/alert.o' failed
make: *** [obj/alert.o] Error 1
pi@raspberrypi ~/TEK/src $ cd ..
pi@raspberrypi ~/TEK $ sudo chmod 755 src/leveldb/build_detect_platform
chmod: cannot access `src/leveldb/build_detect_platform': No such file or directory
pi@raspberrypi ~/TEK $




I see two things going on. Not sure how to solve one of them, and the other is my fault. I forgot, TEK doesn't use leveldb. Most coins do Tongue So you can pretty much ignore that part.

However, it's not getting the boost libraries for some reason. I'm mostly familiar with Ubuntu 14.04, which I'm guessing uses different package names from what you're after. try sudo apt search libboost and see what you find. I've never used a rapspberry pi, so I have to be somewhat generic here. It appears that you do have the other necessary dependencies, so I *think* that boost is your problem.

haha in my last 6 hr study i figuered it out Smiley

well i missed another suggestion here but after following it seems it started to compile will update here should any prob comes up thanks guys

Edit the makefile.unix and remove the "-msse2".
[/quote]
[/quote]

Well, if you do get it working, post up a guide for us Cheesy One of these days I'm gonna get a pi for my staking coins Cheesy

Buy Bitcoins with Paypal, Credit card, or other methods. Send me a PM or a text to 208-451-2665.
kevin1234a
Legendary
*
Offline Offline

Activity: 1162


Decentralizing Jesus on the Blockchain


View Profile WWW
April 26, 2015, 05:25:12 PM
 #3719

pretty much i followed this guide http://www.reddit.com/r/reddCoin/comments/2b8wqm/tutorial_compiling_and_running_the_reddcoin/
and from step 5 followed each coin instructions and get assistance from relevant coin thread. however for TEK i just removed that part from makefile.unix in src

NB: due to the limitations of Raspberry pi memory and storage what i did:

transfer my filesystem to external USB powered HDD by following this guide
https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=44177

increase swapfile to max 1000

use tight vnc to get display on my laptop by following this
https://www.raspberrypi.org/forums/viewtopic.php?f=49&t=50698

and thats it Smiley

easy pezy lemon freezy




elgimpo
Sr. Member
****
Offline Offline

Activity: 260


View Profile
April 27, 2015, 12:43:36 PM
 #3720

Staking less than 25% with 0.00005 difficulty..

hmmm.. why you no make me rich tek?

Pages: « 1 ... 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 [186] 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 ... 316 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!